Xshell简介

Xshell 4 Help / Xshell简介
Xshell简介

Xshell 是在Windows环境下使用的强大的SSH、TELNET、RLOGIN终端仿真软件。Windows用户通过 Xshell 可以便捷安全地登陆UNIX/Linux主机。SSH (Secure Shell)协议支持加密及用户身份验证功能以安全连接网络并可替代TELNET、RLOGIN等原协议。

See Also

主要功能
推荐配置
安装及删除

Copyright© 2013 Netsarang Computer, Inc. All rights reserved.


主要功能

Xshell 4 Help / 主要功能
主要功能

该部分说明 Xshell 的主要功能。

常规

l 支持SSH1、 SSH2、 SFTP、 TELNET、 RLOGIN及SERIAL协议

l 支持Windows 2000/XP/2003/Vista/2008/7/8

l 支持OpenSSH及ssh.com服务器

l 多用户设置

l 保持连接选项

l SOCKS4/5、 HTTP代理连接

l 支持多个会话 (会话选项卡、会话栏)

l 用户按键对应

l VB脚本

l 新链接栏

l 断开连接时自动进行连接

会话管理

l 创建及管理其他主机有关的会话文件

l 提供连接会话用的会话对话框、 地址栏、 本地提示、 会话快捷方式及链接栏功能

l 提供快速连接用的默认会话

l 多会话同时连接

l 地址栏支持URL命令，可登陆不使用会话的远程主机

l 通过Xactivator连接会话

l 自动登录、自动输入功能

l 会话对话框的文件夹及树视图

安全

l RSA/DSA 公钥、 密码及 Keyboard Interactive用户身份验证方法

l RSA/DSA 密钥生成向导及导入/导出功能

l 利用Xagent (SSH用户身份验证代理)进行用户身份验证

l AES128/192/256、 3DES、 BLOWFISH、 CAST128、 ARCFOUR 及RIJNDAEL加密算法

l SHA1、 SHA1-96、 MD5、 MD5-96及RIPEMD160 MAC 算法

l Zlib压缩

l 主机密钥管理对话框

l 用户密钥管理对话框

终端

l 基于Unicode的终端缓冲区

l VT100、 VT220、 VT320、 XTERM、 LINUX、 SCOANSI 及ANSI 终端

l 多国语输出编码 (UTF-8)

l 可以同时给所有会话发送字符的撰写栏

l 可以保存到2,147,483,647Line的滚动缓冲区

l 利用正则表达式查找字符串

l 选择Column单位文本

l 复制/粘贴时支持Multi-byte字符串

l 在终端窗口双击选择单词及指定分隔符

l 点击三次鼠标按钮时选择一行

l 突出字体及ANSI颜色代码

l Xterm 终端鼠标

l Xterm 256色模式

l Liunx Meta键仿真

l 打印终端屏幕

l 终端窗口的行距及边距设置

l 用ESC键切换韩->英文 (仅限韩文Windows系统)

隧道

l TCP/IP及 X11转发

l 利用SOCKS4/5的动态端口转发

l 通过隧道窗口可查看当前激活的的转发渠道，在当前会话中添加新的转发规则

外观

l 简单而强大的用户界面

l 切换到自定义布局

l 可移动工具栏

l 配色方案的编辑/导入/导出

l 游标颜色变更及闪烁设置

l 利用字体按钮轻松变更字体

l 把常用字符串指定为快速命令

l 自定义工具栏的标准按钮

l 状态栏上显示安全-锁、会话选择、网络up/down流量信息

l 全屏查看(Alt+Enter)

l 透明度调节选项

本地指令

l 为高级用户提供本地Shell提示

l open、 ssh、 telnet、 rlogin及sftp、 ftp等本地指令

l ping、 ipconfig、 netstat及nslookup等本地Windows指令

l 在连接远程主机时转出本地提示

互通性

l 与Xmanager程序联动的X11转发

l 与Xagent程序联动的代理转发

l 与Xftp联动轻松登陆FTP站点

l 在记事本编辑滚动缓冲区

l 通过菜单指令依次选择Xshell窗口

文件管理

l 发送及接收SFTP

l 发送及接收ZMODEM

l 发送ASCII文件

l 自动记录会话(也保存终端代码)

l 页面设置及打印预览

See Also

Xshell简介


推荐配置

Xshell 4 Help / 推荐配置
推荐配置

l 处理器 : Intel®兼容机

l 运行环境: Microsoft Windows®2000 SP4以上

l 存 储 器: 50MB以上的剩余空间

l 网 络: TCP/IP 网络

l 程 序: Internet Explorer®6.0以上

See Also

Xshell简介


安装及删除

Xshell 4 Help / 安装及删除
安装及删除

Xshell 安装程序采用InstallShield®，在安装过程中可变更多种安装选项。但在大部分情况下，点击[下一步]安装即可。
删除 Xshell 时使用Windows的标准添加/删除功能。在控制面板中打开[添加/删除程序]后，在目录中选择删除 Xshell 或 Xmanager Enterprise。删除 Xmanager Enterprise 时除了 Xshell 外其他程序也会被删除，需多加注意。

删除程序时并不会删除用户创建的注册表信息、 日志文件及资料文件。重新安装程序时可继续使用这些信息及文件。如要全部删除这些注册表信息和文件，请删除下列位置的注册表信息和文件：

注册表信息:

· \HKEY_CURRENT_USER\Software\NetSarang\Xshell

· \HKEY_CURRENT_USER\Software\NetSarang\Xmanager Enterprise

文件及文件夹:

· %APPDATA%\NetSarang\Xshell

· %APPDATA%\NetSarang\Xmanager Enterprise

See Also

Xshell简介


启动

Xshell 4 Help / 启动
启动

此部分对Telnet/Rlogin或SSH会话的创建方法和UNIX/Linux主机的登陆方法进行说明。Telnet会话非常简单，SSH会话则在连接服务器之前有时要在服务器上注册用户秘钥。如需注册用户密钥请参阅“公钥用户身份验证”。

See Also

创建会话
连接远程主机
退出Xshell


创建会话

Xshell 4 Help / 创建会话
创建会话

1. 在[文件]菜单选择[新建]， 出现新建会话属性对话框。

图1: 新建会话属性对话框

2. 在[名称]中输入会话名。

3. 在[协议]目录选择适用协议。

4. [主机]上输入服务器的主机名称或IP地址。

5. 在[端口号]输入远程服务器使用的端口号。

6. 点击[确定]。

See Also

启动


连接远程主机

Xshell 4 Help / 连接远程主机
连接远程主机

以下是连接SSH会话的过程。如还没有创建会话请参阅“创建会话”部分。

1. 在[文件]菜单选择[打开]。

2. 在会话目录中选择可连接会话后点击[连接]即出现 SSH用户名对话框。

图2: SSH用户名对话框

3. 输入用户名后点击[确定]即出现 SSH用户身份验证对话框。

图3: SSH用户身份验证对话框

4. 如要进行 Password 验证，请在[密码]项输入密码后点击[确定]。

5. 如要进行 Public Key 验证，请先在目录中选择用户秘钥后在[密码]项输入所选用户密钥后点击[确定]。

* 注释

如还没有设置用户秘钥请参阅“公钥用户身份验证”部分。

6. 如要进行 Keyboard Interactive 验证，请点击[确定]后回答在连接过程中出现的提问。

See Also

启动


退出Xshell

Xshell 4 Help / 退出Xshell
退出Xshell

如需断开会话连接，请在终端屏幕的提示中输入“exit”或在[文件]菜单中选择[断开连接]。

* 注释

如在选择‘终止连接时还原为本地Shell’选项的状态下断开连接即以本地Shell状态保持会话选项卡。在本地Shell会话中在终端屏幕上显示 Xshell 提示，可执行open、telnet、ssh、ping等本地指令。

如要退出 Xshell 请在[文件]菜单中选择[退出]。

See Also

启动


会话管理

Xshell 4 Help / 会话管理
会话管理

会话保存远程主机相关设置的文件。通过创建会话，用户可对不同的远程主机设置不同的选项。会话对话框显示创建的所有会话，也可创建和编辑会话。

用户也能在不创建会话的状态下登陆远程计算机，因为 Xshell 在安装的同时提供可使用的默认会话。

See Also

会话管理
会话属性
导出
导入


会话管理

Xshell 4 Help / 会话管理
会话管理

如何新建会话:

1. 选择[文件]菜单项的[新建]以打开新建会话属性对话框。

2. 输入连接信息。

3. 点击[确定]。

如何打开会话对话框:

· 在[文件]菜单项选择[打开]。

· 点击标准按钮的[打开]。

如何编辑会话:

1. 打开会话对话框。

2. 选择拟要编辑的会话。

3. 点击标准按钮的[属性]。

4. 编辑会话后点击[确定]。

如何重命名会话:

1. 打开会话对话框。

2. 选择拟要重命名的会话后点击鼠标右键。

3. 选择菜单项的[重命名]。

* 注释

会话名称应为有效的文件名。

如何另存会话:

1. 打开会话对话框。

2. 选择另存操作的会话。

3. 点击标准按钮的[另存为]。

如何删除会话:

1. 打开会话对话框。

2. 选择拟要删除的会话。

3. 点击标准按钮的[删除]。

如何创建会话快捷方式:

1. 打开会话对话框。

2. 选择拟创建快捷方式的会话。

3. 点击标准按钮的[创建快捷方式]。

4. 选择保存快捷方式的文件夹。

5. 点击[确定]。

如何变更默认会话的设置:

采用如下方法之一来打开默认会话的会话属性对话框:

· 在本地Shell状态下选择[文件]菜单的[属性]。

· 点击主窗口标准按钮的[属性]按钮旁的箭头后在目录中选择[默认会话]。

* 注释

默认会话在使用本地提示或地址栏连接ssh, telnet, rlogin, sftp时使用。

如要在本地提示使用连接指令请参阅“Xshell本地指令”内容。如要利用地址栏进行连接请参阅“地址栏”部分。

如何新建会话文件夹:

1. 打开会话对话框。

2. 点击标准按钮的[新建]按钮旁的箭头后在目录中选择[文件夹]。

3. 输入文件夹名称。

如何把会话文件复制到其他电脑:

1. 打开会话对话框。

2. 点击标准按钮的[打开会话文件夹]。

3. 找出相关会话文件(*.xsh)后进行复制或发送邮件。

4. 在下面的文件夹中保存会话文件:
”%APPDATA%\NetSarang\Xshell\Sessions”

See Also

会话管理


会话属性

Xshell 4 Help / 会话属性
会话属性

新建会话或编辑会话时打开会话属性对话框。

如何打开会话属性对话框:

· 在[文件]菜单选择[新建]。

· 在[文件]菜单选择[属性]。

· 点击标准按钮的[属性]。

See Also

会话管理
连接
连接:用户身份验证
连接:用户身份验证: 登录提示
连接: 登录脚本
连接: SSH
连接: SSH: 安全
连接: SSH: 隧道
连接: SSH: SFTP
连接: TELNET
连接: RLOGIN
连接: SERIAL
连接: 代理
终端
终端: 键盘
终端: VT模式
终端: 高级
外观
外观: 边距
高级
高级: 跟踪
高级: 日志记录
ZMODEM


连接

Xshell 4 Help / 连接
连接

在连接设置项可设置会话连接相关信息。大部分情况下用户仅设置这一部分后即可登陆远程主机。

名称

输入该会话的固有名称。该名称是会话文件的名称，因此应使用有效的文字命名文件名。

协议

选择连接远程计算机使用的连接协议。支持的协议有SSH、SFTP、TELNET、RLOGI及SERIAL。

主机

输入远程计算机的主机名称或IP地址。

端口号

输入上面所选协议的端口号。在协议目录中选择协议时自动输入该协议的默认端口号。如远程计算机使用其他端口号，则需由用户直接输入端口号。各协议的默认值是SSH/SFTP为22，TELNET为23，RLOGIN为513。

连接会话期间发送保持活动状态消息

给远程计算机发送保持活动状态消息。该功能是在不使用Xshel时连接意外被断开时有效。在各个网络环境下网关Gateway)或防火墙(Firewall)系统会强行断开在一定时间内没有传输数据的连接。

连接被意外断开时进行自动连接

在不是用户断开连接的状态下网络被断开时自动进行连接。

See Also

会话属性


连接:用户身份验证

Xshell 4 Help / 连接:用户身份验证
连接:用户身份验证

通过用户身份验证设置可指定验证方法和用户名、加密用户秘钥等。

方法

选择验证方法。可在Password、Public Key、Keyboard Interactive中选一，如SSH服务器不支持所选验证方法则在连接时出现询问用户身份验证方法的对话框。

用户名

输入登录用户名。用户名是远程计算机的登录账户，如未输入则在连接时出现询问用户名的对话框。

密码

输入远程计算机用户账户的密码，且在选择Password验证时有效。如未输入密码则在连接时出现询问用户身份验证的对话框。密码经加密后保存到用户的PC上。为安全起见请空出密码。

用户秘钥

选择公钥验证时选择拟要使用的用户秘钥。如未输入密钥则在连接时出现询问用户身份验证的对话框。如果在目录没有用户秘钥，需在生成密钥后登录远程SSH服务器。

密码

输入所选用户秘钥的密码。输入的密码经加密后保存到用户的PC上。为安全起见请空出密码。

See Also

会话属性


连接:用户身份验证: 登录提示

Xshell 4 Help / 连接:用户身份验证: 登录提示
连接:用户身份验证: 登录提示

选用TELNET或RLOGIN协议时为自动执行登录过程，Xshell需识别服务器的用户名/密码提示，一般情况下使用默认值即可。

TELNET

输入自动完成TELNET登录过程的用户名和密码提示。空白文字同样有效，需多加注意。

RLOGIN

输入RLOGIN协议用的密码提示。根据rlogin服务器的设置有时也不需要密码。空白文字同样有效，需多加注意。

See Also

会话属性


连接: 登录脚本

Xshell 4 Help / 连接: 登录脚本
连接: 登录脚本

通过录脚本设置可定义自动输入到终端的指令，成功登录远程服务器后依次执行目录中出现的命令，该功能在首次登录后以其他服务器重新进行登录时非常有效。

执行下一次待机及发送规则

可选择该选项以使用待机及发送规则。

添加

打开待机及发送规则对话框。规则编辑完毕后添加到目录。

编辑

打开待机及发送规则对话框来编辑所选规则。

连接会话时运行脚本

可指定连接会话后运行的脚本文件。

See Also

会话属性


连接: SSH

Xshell 4 Help / 连接: SSH
连接: SSH

可设置SSH协议的常规选项。

协议版本

选择拟使用的SSH协议版本。相比SSH1，SSH2更加安全且提供更多功能。

使用密码处理的Xagent(SSH代理)

如要使用Xagent可选择该项。使用Xagent可在进行公钥用户身份验证时减少输入用户秘钥的繁琐。

自动启动Xagent

必要时自动启动Xagent。选择该项在使用Xagent时用户无需提前启用Xagent。

使用ZLIB压缩

压缩算法用来压缩所有SSH连接数据。网速慢时使用压缩可提高网速。

不分配终端

不使用终端时选择该项。该功能在只使用Xshell的隧道功能时有效。

See Also

会话属性


连接: SSH: 安全

Xshell 4 Help / 连接: SSH: 安全
连接: SSH: 安全

加密

加密算法用来给通过网络传输的数据进行加密。用户可从目录中选择必要的加密算法。如在目录中选择<Cipher List>可尝试多种算法。如需对<Cipher List>进行编辑请点击[编辑]。

MAC (消息验证代码)

MAC是为保障数据的完整性，为进一步确保安全而在SSH2添加的。如在目录中选择<MAC List>可尝试多种算法。如需对<MAC List>进行编辑请点击[编辑]。

See Also

会话属性


连接: SSH: 隧道

Xshell 4 Help / 连接: SSH: 隧道
连接: SSH: 隧道

隧道设置项提供对TCP/IP、Dynamic及X11转发规则进行设置的功能。这些设置在连接设置项中选择SSH协议时有效。

详细的隧道设置方法请参阅“隧道服务”内容。

See Also

会话属性


连接: SSH: SFTP

Xshell 4 Help / 连接: SSH: SFTP
连接: SSH: SFTP

设置与SFTP协议有关的选项。

开始文件夹

设置通过SFTP协议成功登录后开始作业的本地及远程文件夹。

See Also

会话属性


连接: TELNET

Xshell 4 Help / 连接: TELNET
连接: TELNET

设置与TELNET协议有关的选项。

使用XDISPLOC Telnet选项

通过XDISPLOC Telnet选项登录时向服务器发送显示(PC X 服务器的信息)内容。使用Xmanager等的PC X 服务器时选用该选项可非常轻松地在用户电脑上使用远程服务器的X11应用程序，非常方便。

显示

输入登录时拟要发送的显示内容。$PCADDR关键词在发送到服务器之前自动变换为PC的IP地址值。

See Also

会话属性


连接: RLOGIN

Xshell 4 Help / 连接: RLOGIN
连接: RLOGIN

设置与RLOGIN协议有关的选项。

终端速度

定义发送到rlogin服务器的终端速度。

See Also

会话属性


连接: SERIAL

Xshell 4 Help / 连接: SERIAL
连接: SERIAL

通过SERIAL设置项可对SERIAL连接选项进行设置。在UNIX系统上没有显卡或无法直接登陆控制器时RS232C SERIAL连接可替代原有的终端机利用PC进行连接，非常方便。如要通过Xshell使用SERIAL连接应在主机系统上安装串行接口（SERIAL Interface）。

SERIAL设置方法请参阅“SERIAL连接”内容。

See Also

会话属性


连接: 代理

Xshell 4 Help / 连接: 代理
连接: 代理

代理服务器

选择连接时拟要使用的代理服务器设置。

代理服务器相关的详细内容请参阅“代理服务器设置”。

See Also

会话属性


终端

Xshell 4 Help / 终端
终端

通过终端设置选项可设置与终端类型不同的其他终端相关选项。

终端类型

选择拟要使用的终端类型。Xshell支持VT100、VT102、VT220、VT320、ANSI、SCOANSI、LINUX及XTERM终端。

连接后使用以下终端大小

如需指定该会话的终端大小可选择该选项。选择后，连接会话时以水平和垂直值变更终端大小。如未选择该项，即使连接会话也不会改变终端大小。

行

输入终端的行宽。在连接会话后才会调整终端大小。

列

输入终端的列数。在连接会话后才会调整终端大小。

滚动缓冲区

以行单位指定滚动缓冲区的大小。

将清除的屏幕推到滚动缓冲区

即使因clear命令等清除了终端作业屏幕，但滚动缓冲区仍保留着清除的内容，因此可利用鼠标滚动键查看之前屏幕。

编码

选择终端的输出编码，这一值应为远程服务器使用的语言。选择默认语言时，Xshell使用用户Windows的默认编码。该选项不会更改键盘输入值，必要时应安装Windows提供的IME (Input Method Editor)。

韩中日语言中的不确定字符处理为宽字符

把韩中日语言中的模糊字符识别为宽字符。

See Also

会话属性


终端: 键盘

Xshell 4 Help / 终端: 键盘
终端: 键盘

键盘设置对用户PC的键盘发送到服务器的字符串进行设置。

功能键仿真

根据终端类型设置功能键。选择<默认>则按照“终端”设置指定的终端类型自动设置功能键。

请指定要替换的按键对应文件

使用用户定义的按键对应文件，在按各功能键(F1~F20)时可直接指定发送到服务器的字符串。

Delete键序列，Backspace键序列

选择用户按Delete键或Backspace键时发送的字符串。

元(Meta)键仿真

为使用Emacs等Meta键的应用程序提供Meta键仿真设置功能。

See Also

会话属性


终端: VT模式

Xshell 4 Help / 终端: VT模式
终端: VT模式

设置各终端模式的初始值。

Auto Wrap Mode (DECAWM)

启用自动换行功能时被激活。

Origin Mode (DECOM)

激活Origin Mode。激活该选项时游标以服务器指定的位置为基准移动。

Reverse Video Mode (DECSCNM)

启用Reverse Video Mode时被激活。激活该选项时屏幕的前景色和背景色会颠倒。

New Line Mode (NLM)

启用New Line Mode时被激活。激活该选项时按ENTER键即显示CR和LF。如未选择该选项，按ENTER键时只显示CR。

Insert Mode (IRM)

启用Insert Mode时被激活。激活该选项时在光标位置插入服务器发送的字符而不删除已经存在的字符串。

Echo Mode (SRM)

激活该选项时在屏幕上显示发送的字符串并发送到服务器。

初始光标键模式(DECCKM)

设置光标键模式的初始值。

初始数字键盘模式(DECNKM)

设置终端类型的功能键。

See Also

会话属性


终端: 高级

Xshell 4 Help / 终端: 高级
终端: 高级

设置终端相关的高级选项。

用SHIFT 键限制在终端中使用鼠标

像vi等部分应用程序有时需要把点击鼠标或拖动操作用作变更区域或选择文件、移动目录的功能。此时按住Shift键后使用鼠标即能用作Xshell使用鼠标进行文件选择等功能。

以背景色清除屏幕

用当前终端的背景色清除屏幕而不使用在非配色方案设置的背景色。

用 CR+LF 接收LF

从服务器接收LF时在终端屏幕都显示CR和LF。

按键滚动到底部

用户使用按键时滚动到终端屏幕底部。

输入/输出终端时滚动到底部

在终端屏幕上显示字符时滚动到屏幕的最底部。

启用析构性BACKSPACE

按Backspace键时删除游标左侧字符，并把游标移动到其字符所在位置。

禁用闪烁文本

闪烁文字被固定而不闪烁。

禁用更改终端标题

不更改Xshell标题栏的终端标题，在大部分情况下标题栏根据远程计算机的要求显示作业文件夹和主机名称。

禁用终端打印功能

接到服务器的终端印刷申请时不进行打印而显示到屏幕上。

禁用终端替换屏幕 (Alternate Screen) 切换

不使用像vi等部分应用程序适用的替换屏幕。在使用替换屏幕时退出该应用程序后终端区域被替换成运行该应用程序前的屏幕。

忽略终端大小变更申请

忽略服务器的终端大小变更信号。

See Also

会话属性


外观

Xshell 4 Help / 外观
外观

在外观设置项下可设置终端窗口的颜色和字体。

配色方案

选择会话使用的配色方案。Xshell提供几个默认配色方案，可添加新配色方案或在配色方案对话框对原有配色方案进行编辑。

字体名

选择会话使用的字体，只显示固定宽度的字体。也可按标准按钮的字体图标选择字体。

字体大小

选择字体大小。

突出文本

选择拟要突出显示的方法。

游标

指定游标的颜色或模样、闪烁等。

See Also

会话属性


外观: 边距

Xshell 4 Help / 外观: 边距
外观: 边距

在边距设置项下可设置Xshell终端窗口的边距及间距。

边距

设置终端窗口的边距。

间距

设置终端窗口的行距和字符间距。

See Also

会话属性


高级

Xshell 4 Help / 高级
高级

在高级设置项下可设置快速命令集和跟踪及日志选项。

快速命令集

选择会话中使用的默认快速命令集。启用相关会话时选择的快速命令集显示在快速命令栏。

禁用快速命令快捷方式键

不把Ctrl+F1、Ctrl+F2等键用作快速命令快捷方式键，而把相应的按键值发送到服务器。

See Also

会话属性


高级: 跟踪

Xshell 4 Help / 高级: 跟踪
高级: 跟踪

在跟踪设置项下可设置协议跟踪选项。该功能在解决特定问题时有效。跟踪信息将显示于终端屏幕上。

SSH版本、算法交换及用户身份验证

在屏幕上显示版本交换、加密算法、压缩方法、服务器及用户身份验证等信息。

SSH TCP/IP及X11隧道

在屏幕上显示端口转发相关信息。

TELNET选项模式

在屏幕上显示Xshell和telnet服务器之间的TELNET选项交换过程。

See Also

会话属性


高级: 日志记录

Xshell 4 Help / 高级: 日志记录
高级: 日志记录

在日志记录设置项下设置与创建日志有关的选项。

连接时开始日志记录

当会话连接到远程主机时自动开始记录日志。日志记录方法可从下列方法中选择其一。

· 仅记录可打印文本。

· 记录可打印的文本和终端代码

在日志文件夹自动创建新文件

在程序指定的默认文件夹中创建新文件后记录日志消息。自动匹配文件名。

使用以下文件

在用户指定的文件夹中衣用户指定的格式保存日志消息。

文件路径

指定日志文件的路径。创建文件时%n、%d、%t转换为名称、日期、时间。

浏览器按钮([…])

打开另存为对话框以选择记录日志内容的文件。

覆盖指定文件已存在的路径

上面指定的文件已经存在时用日志内容覆盖相应文件。如未选择该选项，在文件名后附加顺序号后创建具有固有名称的文件。

启动会话日志记录时询问

启用日志时打开保存对话框以选择用户保留日志的文件。

See Also

会话属性


ZMODEM

Xshell 4 Help / ZMODEM
ZMODEM

在ZMODEM设置项下设置与发送ZMODEM文件有关的各种选项。

自动激活ZMODEM

远程ZMODEM程序开始发送/接收作业时自动进行文件的接收/发送。如未选择该选项，需选择文件菜单下文件发送项的ZMODEM接收/发送功能以接收文件。

下载前始终询问

每次下载时可变更接收的文件夹。

使用下列下载路径

接收文件时无需询问保存路径而保存到指定的文件夹中。保存的文件名与远程文件的名称相同。如已经存在相同的文件名则在文件名中附加序列号。

自动重命名

通过ZMODEM接收文件时如已存在相同的文件名则自动进行重命名。例)变更前: abc.txt, 变更后: abc (2).txt

覆盖

通过ZMODEM接收文件时如已存在相同的文件名则覆盖原有文件。

See Also

会话属性


导出

Xshell 4 Help / 导出
导出

从Xshell导出的会话被创建成一个便捷的会话集文件。把这些文件导入到已安装Xshell的其他电脑时无需另行设置就能使用相同的会话。

如何导出会话:

1. 选择[文件]菜单的[导出]。

2. 选择保存导出会话集文件的位置后点击[下一步]。
结果: 显示会话导出结果。

3. 点击[完成]结束会话导出。

See Also

会话管理


导入

Xshell 4 Help / 导入
导入

Xshell可导入从其他计算机导出的会话文件。

如何导入会话:

1. 选择[文件]菜单的[导入]。

2. 直接输入拟要保存从其他计算机中导出的会话集文件的位置或点击[…]按钮选择会话集文件后点击[下一步]。

3. 点击[完成]以结束会话导入。

See Also

会话管理


连接

Xshell 4 Help / 连接
连接

Xshell 提供会话对话框、本地提示、地址栏、链接栏和会话快捷方式等多种连接方法。

See Also

无会话连接
通过会话连接
SERIAL连接
以Xactivator进行连接
代理服务器设置


无会话连接

Xshell 4 Help / 无会话连接
无会话连接

如和在本地提示进行连接:

1. 在本地提示中输入下列命令之一:

· Xshell:\> telnet hostname

· Xshell:\> ssh hostname

· Xshell:\> rlogin hostname

* 注释

如远程主机不使用默认端口号则需指定端口号。各指令相关信息请参阅“Xshell本地指令”。

如何通过地址栏进行连接:

1. 在地址栏中输入下列命令之一:

· telnet://hostname

· ssh://hostname

· rlogin://hostname

2. 按Enter键或点击[连接]。

* 注释

在地址栏中也能输入用户名和端口号。具体内容请参阅“地址栏”部分。

See Also

连接


通过会话连接

Xshell 4 Help / 通过会话连接
通过会话连接

如何利用会话对话框进行连接:

1. 打开会话对话框。

2. 选择拟进行连接的会话。

3. 点击[连接]。

* 注释

如已登陆远程主机，会出现建立新连接的新选项卡或运行新的 Xshell。

如何通过本地提示进行连接:

1.   在 Xshell 本地提示中输入如下命令。
Xshell:\> open session

如何通过快捷方式进行连接:

1. 双击会话快捷方式图标。

* 注释

如需了解会话快捷方式相关内容请参阅“会话管理”部分。

See Also

连接


SERIAL连接

Xshell 4 Help / SERIAL连接
SERIAL连接

UNIX系统上没有显卡或无法直接登陆控制器时RS232C SERIAL连接可替代原有的终端机以利用PC进行连接，非常方便。如要通过Xshell使用SERIAL连接应在主机系统上安装串行接口（SERIAL Interface）。

如何进行SERIAL连接:

1. 选择[文件]菜单的[新建]。出现新建会话属性对话框。

2. 在[名称]中输入会话名。

3. 在[协议]目录下选择SERIAL。

4. [类别]中选择[SERIAL]。

5. 在[Port]项选择连接到已安装有Xshell的PC上的RS232C串行端口号。

6. 在[Baud Rate]项下选择通讯速度，应与服务器的值保持一致，一般使用9600。

7. 在[Data Bits]项下选择发送数据单位的位数，应与服务器的值保持一致。

8. 在[Stop Bits]项下选择显示发送数据单位结尾的位数。按照服务器设置进行选择。

9. [Parity]用于验证发送资料的错误，按照服务器设置在None、Odd、Even、Mark和Space中选一。

10. 点击[确定]以新建会话。

11. 如“通过会话连接”单元的说明，可用创建的会话建立连接。

See Also

连接


以Xactivator进行连接

Xshell 4 Help / 以Xactivator进行连接
以Xactivator进行连接

Xactivator在系统托盘以图标形态运行。利用Xactivator可打开新的Xshell窗口或可以简便地进行新的会话连接，在选择和关闭Xshell窗口时也非常方便。

如何开始Xactivator:

1. 在[工具]菜单下选择[运行Xactivator]。运行Xactivator时在系统托盘出现图标。

如何在Xactivator上启用新的会话连接:

1. 用鼠标右键点击Xactivator系统托盘图标。

2. 在弹出的菜单中把鼠标置于[会话]位置以在子菜单罗列所有会话。

3. 选择拟进行连接的会话。

See Also

连接


代理服务器设置

Xshell 4 Help / 代理服务器设置
代理服务器设置

代理服务器是在用户所属的网络和拟要连接的外部网络之间起到中介作用的服务器。
在代理目录对话框中可添加、编辑、删除代理服务器。

如何添加代理服务器:

1. 在会话属性对话框的[连接: 代理]的[代理服务器]中点击[浏览]。

2. 在代理目录对话框中点击[添加]。结果:出现代理设置对话框。

3. 输入代理服务器的名称、代理服务器的类型及主机信息和用户信息。

4. 点击[确定]进行添加。

See Also

连接


安全

Xshell 4 Help / 安全
安全

Xshell提供公钥用户身份验证。

Xshell创建的主机密钥和用户秘钥数据库可在Xmanager和Xftp程序中使用，用户一经创建公钥即无需另行设置可在全部程序中使用。

See Also

公钥用户身份验证
主机密钥管理


公钥用户身份验证

Xshell 4 Help / 公钥用户身份验证
公钥用户身份验证

如要启用公钥用户身份验证，用户应创建由公钥和密钥组成的用户密钥对。在进行公钥验证时，由 Xshell 用密钥来创建用户签名，SSH服务器则用公钥来确认其签名。

SSH服务器和 Xshell 均能创建用户密钥，如在服务器上创建密钥，用户需利用 Xshell 的导入功能把密钥注册到 Xshell 密钥保存位置。如在 Xshell 上创建密钥用户应把公钥注册到服务器。

如何创建用户秘钥:

1. 在[工具]菜单选择[用户秘钥生成向导]。

2. 按照用户秘钥生成向导的提示创建用户秘钥。

* 注释

可在生成密钥的最后阶段把公钥注册到服务器上。注册方法随服务器的类型而不同。

· SSH1: 把公钥复制到$HOME/.ssh/authorized_keys文件。为删除设置文件和目录写入权限执行如下指令。
$ cd
$ chmod go-w . .ssh .ssh/authorized_keys

· SSH2-OpenSSH: OpenSSH服务器使用该格式。把公钥复制到$HOME/.ssh/authorized_keys2文件。为删除设置文件和目录写入权限执行如下指令。
$ cd
$ chmod go-w . .ssh .ssh/authorized_keys2

· SSH2-IETF SECSH: 像ssh.com的服务器，几个常用SSH服务器使用该格式。像mypublickey.pub等以固有名称保存公钥后复制到$HOME/.ssh2目录。在$HOME/.ssh2/authorization文件上添加如下Line:
Key mypublickey.pub
为删除设置文件和目录写入权限执行如下指令。
$ cd
$ chmod go-w . .ssh2
$ chmod go-w .ssh2/authorization .ssh2/mypublickey.pub

如何在服务器上注册公钥:

1. 在[工具]菜单选择[用户密钥管理者]以打开用户秘钥对话框。

2. 选择拟要注册的用户密钥。

3. 点击[属性]，出现用户秘钥属性对话框。

4. 点击[公钥]选项卡。

5. 在[公钥类型]目录中选择适用类型。

6. 点击[保存为文件]进行保存或复制密钥内容后按照上述公钥注册方法注册到服务器。

如何变更用户秘钥的密码:

1. 打开用户秘钥对话框。

2. 选择拟变更密码的用户秘钥。

3. 点击[属性]，出现用户秘钥属性对话框。

4. 点击[常规]选项卡。

5. 点击[更改密码]。

* 注释

利用“用户秘钥对话框”可进行导出、导入、重命名、删除、生成用户秘钥等作业。.

See Also

安全
用户秘钥对话框


用户秘钥对话框

Xshell 4 Help / 用户秘钥对话框
用户秘钥对话框

通过用户秘钥对话框可生成和管理用户秘钥。选择[工具]菜单的[用户密钥管理者]来打开对话框。

导入

打开‘打开对话框’来选择和导入用户秘钥文件。目前，Xshell 可读取SSH1协议的RSA密钥和OpenSSH SSH2协议的RSA/DSA密钥、SSH.COM密钥及Netsarang用户秘钥类型。

导出

打开保存对话框来保存所选用户秘钥文件。导出的文件类型有Netsarang用户秘钥类型和OpenSSH SSH2 类型。Netsarang用户秘钥类型的文件可在Netsarang Computer开发的程序中使用，无法用于其他公司的应用程序。

删除

从数据库中删除选择的用户秘钥。

重命名

重命名选择的用户秘钥。密钥名应为有效的文件名。

属性

显示用户秘钥的属性信息。可查看类型、长度、指纹和公钥等，也能更改密钥密码。

生成

打开用户秘钥生成向导。

See Also

公钥用户身份验证


主机密钥管理

Xshell 4 Help / 主机密钥管理
主机密钥管理

主机密钥是远程主机的公钥，用户可通过密钥指纹对主机进行验证。

远程主机在建立连接时把自己的公钥发送到 Xshell。第一次连接主机或数据库上并未保存主机密钥时连接时将发出 SSH安全警告对话框。主机密钥有效且可信时用户可把主机密钥保存到 Xshell 主机密钥数据库。

See Also

安全
SSH安全警告对话框
主机密钥对话框


SSH安全警告对话框

Xshell 4 Help / SSH安全警告对话框
SSH安全警告对话框

SSH安全警告对话框在远程主机的主机密钥并没有保存在主机密钥数据库或远程主机密钥和保存的主机密钥指纹有差异时出现。

接受一次

仅在本次连接中接受主机密钥，也不会保存主机密钥，下次连接时还会出现相同的对话框。经常更换服务器的主机密钥或不经常连接该服务器时使用。

接收及保存

保存主机密钥并继续进行连接。下次连接时不会出现 SSH安全警告对话框。指纹验证明确，经常连接该主机时使用。

取消

不接受主机密钥并取消连接。

See Also

主机密钥管理


主机密钥对话框

Xshell 4 Help / 主机密钥对话框
主机密钥对话框

主机密钥对话框用来管理允许连接的主机密钥。选择[工具]菜单的[主机密钥管理者]来打开对话框。

导入

通过打开对话框来导入主机密钥。导入的主机密钥被保存到主机密钥数据库并出现在主机密钥对话框。可以导入保存为SECSH公钥格式的文件。

导出

打开保存对话框后导出选择的主机密钥。导出的密钥被保存为SECSH公钥格式，也能在其他程序中使用。

删除

从数据库删除选择的主机密钥。

查看

打开用记事本选择的主机密钥文件。

See Also

主机密钥管理


隧道服务

Xshell 4 Help / 隧道服务
隧道服务

Xshell 提供的TCP/IP及X11转发功能可以给通过不受信任的网络环境连接的用户PC和其他计算机生成安全隧道以安全发送数据。

See Also

TCP/IP端口转发
X11转发
SOCKS4/5 动态端口转发
Instant隧道


TCP/IP端口转发

Xshell 4 Help / TCP/IP端口转发
TCP/IP端口转发

为使用通过加密隧道的端口转发服务，应定义各个应用程序的端口转发规则。

* 注释

如果是Local转发，会发送到通过本地PC的侦听端口进行连接的目标主机的特定端口。

Remote转发会发送到通过远程主机的侦听端口进行连接的目标主机的特定端口。此时目标主机大部分是‘localhost’。

Dynamic转发虽然采用与Local转发相同的方法，但不指定特定的目标主机。Dynamic转发使用SOCKS代理协议，SOCKS协议的默认端口号是1080号。

如何在会话上添加新端口转发规则:

1. 打开会话对话框。

2. 选择拟要编辑端口转发规则的会话。

3. 点击标准按钮的[属性]。

4. 在[类别]中选择[连接: SSH: 隧道]。

5. 点击[添加]打开转发规则对话框。

6. 在[类型]目录选择连接类型。

7. 在[源主机]中输入localhost或IP地址。

8. 在[侦听端口]中输入端口号或选择服务名称。

9. 在[目标主机]中输入启动服务器程序的主机名称或输入IP地址。

10. 在[目标端口]中输入服务器程序等待的端口号。

11. 在[说明]中输入转发规则相关说明。

12. 点击[确定]。

如何更改转发规则:

1. 打开会话对话框。

2. 选择拟要编辑端口转发规则的会话。

3. 点击标准按钮的[属性]。

4. 在[类别]中选择[连接: SSH: 隧道]。

5. 选择拟要更改的转发规则。

6. 点击[编辑]。

如何删除端口转发规则:

1. 打开会话对话框。

2. 选择拟要删除端口转发规则的会话。

3. 点击标准按钮的[属性]。

4. 在[类别]中选择[连接: SSH: 隧道]。

5. 选择拟要删除的转发规则。

6. 点击[删除]。

See Also

隧道服务


X11转发

Xshell 4 Help / X11转发
X11转发

X11转发是TCP/IP端口转发服务的特殊情况。X11协议由PC X 服务器软件使用，从远程主机到用户PC建立连接，可以说是与电子邮件或Telnet等的其他客户端程序相反的情况。利用X11转发功能，无需进行复杂的端口转发设置，通过安全的加密隧道在用户PC上使用远程的X11 应用程序。

如要使用X11转发服务，需对 Xshell 和SSH服务器进行设置。

如何在Xshell激活X11转发功能:

1. 打开会话对话框。

2. 选择拟要激活X11转发功能的会话。

3. 点击标准按钮的[属性]。

4. 在[类别]中选择[连接: SSH: 隧道]。

5. 选择[转发X11连接到]。

6. 如用户的PC上已安装Xmanager®，请选择[Xmanager]。
 如使用其他PC X 服务器，选择[X DISPLAY]后输入适用的DISPLAY。

7. 点击[确定]。

* 注释

Xmanager 会把X DISPLAY选项自动查找为 Xshell。其他 PC X 服务器程序需由用户进行设置。如果PC X 服务器使用TCP 6000号端口，DISPLAY设置为“localhost:0.0”。

如何在OpenSSH服务器上激活X11转发功能:

1. 打开/etc/ssh/sshd_config文件。

2. 把X11Forwarding选项值设置如下:
 X11Forwarding         yes

3. 重启SSH服务器。

如何在ssh.com服务器上激活X11转发功能:

1. 打开/etc/ssh2/sshd2_config文件。

2. 把AllowX11Forwarding选项值设置如下:
 AllowX11Forwarding             yes

3. 重启SSH服务器。

See Also

隧道服务


SOCKS4/5 动态端口转发

Xshell 4 Help / SOCKS4/5 动态端口转发
SOCKS4/5 动态端口转发

动态端口转发是把本地网络的连接发送到SSH服务器的转发方式之一，通过SOCKS协议自动指定发送的目标主机和端口。使用动态端口转发可把Xshell用作SOCKS代理服务器。

如何在会话中添加新的动态端口转发规则:

1. 打开会话对话框。

2. 选择拟要编辑端口转发规则的会话。

3. 点击标准按钮的[属性]。

4. 在[类别]中选择[连接: SSH: 隧道]。

5. 点击[添加]打开转发规则对话框。

6. 在[类型]目录中选择 Dynamic (SOCKS4/5)。

7. 在[侦听端口]上输入端口号或选择服务名称。SOCKS代理服务器的默认端口号为1080号。

8. 点击[确定]。

* 注释

动态端口转发无需输入目标主机和端口。

See Also

隧道服务


Instant隧道

Xshell 4 Help / Instant隧道
Instant隧道

Instant隧道功能是在连接会话的状态下添加、删除、暂停、继续转发规则的功能。当前会话的隧道状态可在 Xshell 终端窗口下方的隧道窗口进行确认。如要显示隧道窗口，在[查看]菜单选择[隧道窗口]。

如何在隧道窗口添加端口转发规则:

1. 在隧道窗口点击[转发规则]选项卡。

2. 用鼠标右键点击目录。

3. 在菜单中选择[添加]，出现转发规则对话框。

* 注释

新添加的规则在不保存的状态下仅适用于当前连接，断开连接后即被清除。

如何在隧道窗口删除端口转发规则:

1. 在隧道窗口点击[转发规则]选项卡。

2. 在[转发规则]目录用鼠标右键点击拟要删除的规则。

3. 在菜单中选择[删除]。

如何暂停端口转发规则:

1. 在隧道窗口点击[转发规则]选项卡。

2. 在[转发规则]目录用鼠标右键点击拟要暂停的规则。

3. 在菜单中选择[暂停]。

如何继续端口转发规则:

1. 在隧道窗口点击[转发规则]选项卡。

2. 在[转发规则]目录用鼠标右键点击拟要继续的规则。

3. 在菜单中点击[继续]。

* 注释

继续作业仅限之前暂停的规则。

See Also

隧道服务


终端窗口作业

Xshell 4 Help / 终端窗口作业
终端窗口作业

Xshell 提供便捷而又强大的终端窗口以便同时使用远程主机命令行Interface和本地提示。此外还提供复制和粘贴、查看文字、更换字体及颜色、高级终端选项等多样而便利的功能。

See Also

复制和粘贴
查找字符串
更换字体
字体色和背景色设置
变更游标设置
Xshell窗口操作
多会话操作
快速命令集设置
更改编码
高级终端选项设置
布局管理


复制和粘贴

Xshell 4 Help / 复制和粘贴
复制和粘贴

如何选择字符串:

1. 可从以下方法中选择其一:

· 用鼠标左键点击所选内容的起始点。在按住鼠标键的状态下移动鼠标到所选内容的结束点后松开鼠标，所选字符串显示为颠倒色。

· 在拟要选择的字符串起始点按鼠标左键。移动鼠标到内容的结束点后按住Shift键的状态下再点击一次左键。

· 双击拟要选择的单词即可选择相关单词。

· 点击三次拟要选择的行即可选择整行。

如何以Column单位选择字符串:

1. 按住Alt键。

2. 在拟选内容的起始点按鼠标左键。在按住鼠标键的状态下移动鼠标到选定内容的结束点后松开鼠标。

如何把所选字符串复制到Windows的剪贴板:

1. 选择拟要复制的字符串。

2. 从以下方法中选择其一:

· 点击[智能选择]按钮后选择[复制]。

· 在[编辑]菜单选择[复制]。

· 点击标准按钮的[复制]。

· 按Ctrl+Insert键。

· 在选项中设置[将选定的文本自动复制到剪贴板]时所选文本就会被自动复制。

如何把所选字符串复制到记事本:

1. 选择拟要复制的字符串。

2. 从以下方法中选择其一:

· 点击[智能选择]按钮后选择[记事本]。

· 把鼠标移动到[编辑]菜单的[记事本]后选择[选择内容]。

* 注释

不仅是选定的字符串，也可复制当前画面或滚动缓冲区。记事本窗口随复制的文本会自动显示。该功能不会把字符串复制到剪贴板。

如何把剪贴板的内容粘贴到终端画面:

1. 从以下方法中选择其一:

  • 在[编辑]菜单选择[粘贴]。
  • 点击标准按钮的[粘贴]。
  • 同时按Shift+Insert键。
  • 把鼠标中间键或右键的动作设为[粘贴剪贴板的内容]后点击相关鼠标键。

如何设置xterm程序的复制及粘贴:

1. 打开选项对话框。

2. 点击[键盘和鼠标]选项卡。

3. 把[鼠标 - 中间键]的动作设为[粘贴剪贴板的内容]。

4. 选择[将选定的文本自动复制到剪贴板]。

5. 点击[确定]。

* 注释

xterm程序会把选定的所有字符串复制到剪贴板，按鼠标的中间按钮即粘贴到终端画面。

See Also

终端窗口作业


查找字符串

Xshell 4 Help / 查找字符串
查找字符串

利用特定关键词或正则表达式可搜索滚动缓冲区。

如何用关键词查找:

1. 在[编辑]菜单选择[查找]。

2. 在查找对话框中输入搜索的关键词。

3. 点击[查找下一处]。

如何用正则表达式查找:

1. 在[编辑]菜单选择[查找]。

2. 在查找对话框中输入搜索的关键词。

3. 选择[正则表达式]。

4. 点击[查找下一处]。

* 注释

正则表达式有关详情请参阅“正则表达式”部分。

See Also

终端窗口作业


更换字体

Xshell 4 Help / 更换字体
更换字体

终端屏幕的特点是根据行和列显示文字，因此在 Xshell 程序只能选择固定宽度的字体。

如何更改终端字体及其大小:

1. 从以下方法中选择其一:

· 点击标准按钮的字体图标后选择字体和大小。

· 在会话属性对话框选择[外观]类别后按需选择字体和大小。

如何变更文字的突出显示方式:

1. 打开会话属性对话框。

2. 在[类别]中选择[外观]。

3. 在[突出显示]部分选择选项。

* 注释

突出显示可使用凸显色、加粗字体或同时使用凸显色和加粗字体。

See Also

终端窗口作业


字体色和背景色设置

Xshell 4 Help / 字体色和背景色设置
字体色和背景色设置

配色方案保存字体色和背景色、ANSI 16色等信息。Xshell 可在使用过程中随时选择/更改配色方案，且能立即适用选定的配色方案。

如何更改终端色:

1. 从以下方法中选择其一:

· 点击标准按钮的[配色方案]即出现配色方案选择对话框。在对话框中选择配色方案后点击[确定]。

· 在会话属性对话框的[类别]中选择[外观]后，在[配色方案]目录中选择配色方案后点击[确定]。

* 注释

Xshell 提供几个默认配色方案。用户可编辑原有的配色方案或创建新的配色方案。

如何新建配色方案:

1. 打开配色方案选择对话框。

2. 点击[新建]，在目录中添加新的配色方案。

3. 选择创建的配色方案。

4. 点击[编辑]，出现配色方案编辑对话框。

如何编辑配色方案:

1. 打开配色方案选择对话框。

2. 选择拟要编辑的配色方案。

3. 点击[编辑]，出现配色方案编辑对话框。

4. 在[普通文本]选择普通文字使用的颜色。

5. 在[加粗文本]选择加粗文字使用的颜色。一般来讲，加粗文本与普通文本相比使用更亮的颜色。

6. [ANSI颜色]是在终端显示ANSI颜色代码时使用的颜色。上面是 black、red、green、yellow、blue、magenta、cyan 及 white 色的普通文本颜色，下面是各加粗文本的字体色。

如何导出配色方案:

1. 打开配色方案选择对话框。

2. 选择拟要导出的配色方案。

3. 点击[导出]，出现保存对话框。

4. 指定文件夹后输入拟要保存的文件名。

5. 点击[保存]。

* 注释

导出的文件是“.xcs”类型，仅可在 Xshell 下使用。可以在一个文件上保存多个配色方案，配色方案的名称也会保存到文件上。

如何导入配色方案:

1. 打开配色方案选择对话框。

2. 点击[导入]，出现打开对话框。

3. 选择拟要导入的配色方案文件(.xcs)。

4. 点击[打开]。

See Also

终端窗口作业


变更游标设置

Xshell 4 Help / 变更游标设置
变更游标设置

如何变更游标颜色:

1. 打开会话属性对话框。

2. 在[类别]中选择[外观]。

3. 选择[游标颜色]值。

4. 选择[文本颜色]值。

5. 点击[确定]。

如何更改游标闪烁与否:

1. 打开会话属性对话框。

2. 在[类别]中选择[外观]。

3. 选择或取消[使用闪烁光标]选项。

4. 点击[确定]。

如何更改光标的闪烁速度:

1. 打开会话属性对话框。

2. 在[类别]中选择[外观]。

3. 选择[使用闪烁光标]。

4. 在[速度]中输入毫秒单位的速度。

5. 点击[确定]。

See Also

终端窗口作业


Xshell窗口操作

Xshell 4 Help / Xshell窗口操作
Xshell窗口操作

如何最小化到系统托盘:

1. 打开选项对话框。

2. 选择[高级]选项卡。

3. 选择[最小化到系统托盘]。

4. 点击[确定]以保存更改。

如何在开始时最小化到系统托盘:

1. 打开选项对话框。

2. 点击[高级]选项卡。

3. 选择[启动Xshell时最小化到系统托盘]。

4. 点击[确定]以保存更改。

终止所有连接时如何退出Xshell:

1. 打开选项对话框。

2. 点击[高级]选项卡。

3. 选择[全部连接退出时关闭Xshell]。

4. 点击[确定]。

如何在终止连接时转出到本地Shell:

1. 打开选项对话框。

2. 点击[高级]选项卡。

3. 选择[连接终止时还原为本地Shell]。

4. 点击[确定]。

如何新建Xshell窗口:

1. 在[窗口]菜单选择[新建窗口]。

如何移动到其他Xshell窗口:

1. 在[窗口]菜单选择[下一个]或[上一个]。

* 注释

利用Alt+Right和Alt+Left键也能执行相同功能。

如何同时关闭所有Xshell窗口:

1. 在[窗口]菜单选择[全部关闭]。

如何关闭除了当前窗口之外的所有Xshell窗口:

1. 在[窗口]菜单选择[除此之外全部关闭]。

See Also

终端窗口作业


多会话操作

Xshell 4 Help / 多会话操作
多会话操作

利用多会话功能可以在一个 Xshell 窗口保持多重连接，可以通过会话选项卡或会话栏在移动会话的同时进行作业。

如何在一个Xshell窗口打开多个会话:

1. 打开选项对话框。

2. 点击[高级]选项卡。

3. 在[选项]区域选择[在单一Xshell窗口中打开多个会话]。

4. 点击[确定]以保存更改。

如何在会话选项卡创建新的连接:

1. 点击会话选项卡的选项卡添加按钮。

2. 在会话目录中选择其一。
结果: 在新的选项卡中出现选定的会话。

如何在会话栏创建新的连接:

1. 点击会话栏最左侧的图标。

2. 在会话目录中选择其一。

结果: 在新的选项卡中出现选定的会话。

* 注释

新建连接时如“会话管理”部分说明的，可以使用通过会话或无会话连接的方法。

如何在本地Shell输入指令以连接远程计算机:

1. 点击会话选项卡的选项卡添加按钮选择[本地Shell]或双击会话选项卡的空白空间以生成本地Shell会话。

2. 在命令行提示状态下利用ssh、telnet、sftp等命令登陆远程计算机。为使用详细的命令行使用方法输入‘?’。

如何在多会话连接状态下进行会话之间的移动:

1. 如要移动会话从下列方法中选择其一。

· 选择会话选项卡。

· 选择会话栏中罗列的会话名。

· 利用Ctrl+Tab、Shift+Tab或Ctrl+Shift+Tab。

· 以Alt+会话编号移动。

如何在新的Xshell窗口连接会话:

1. 选择[窗口]菜单的[新建终端]或点击标准按钮的[新建终端]。结果: 出现新 Xshell窗口，试图连接到与当前会话相同的会话信息。

See Also

终端窗口作业


快速命令集设置

Xshell 4 Help / 快速命令集设置
快速命令集设置

如果把常用字符串指定为快速命令，可点击使用快速命令以替代反复的键盘输入操作。如要显示快速命令栏勾选[查看]菜单的[快速命令]即可。

如何添加快速命令集:

1. 在[工具]菜单选择[快速命令集]。结果: 出现快速命令集对话框。

2. 点击[新建]。

3. 输入新建快速命令集的名称。

* 注释

在快速命令栏点击[快速命令集]按钮后在目录中选择[浏览]以打开快速命令集对话框。

如何把快速命令添加到快速命令栏:

1. 点击快速命令栏的未定义快速命令按钮。
或点击快捷方式键(Ctrl+F1等)。
结果: 出现快速命令编辑对话框。

2. 在[标签]中输入快速命令名称，在[文本]上输入常用命令或字符串。

3. 点击[确定]。

如何把快速命令添加到快速命令集:

1. 在[工具]菜单选择[快速命令集]。结果: 出现快速命令集对话框。

2. 选择拟要添加快速命令的快速命令集。

3. 点击[编辑]。结果: 出现快速命令集编辑对话框。

4. 选择快速命令后点击[编辑]。 结果: 出现快速命令编辑对话框。

5. 在[标签]中输入快速命令名称，在[文本]上输入常用命令或字符串。

6. 点击[确定]。

7. 如要添加快速命令，重复4-6的过程。

8. 在快速命令集编辑对话框点击[确定]。

* 注释

如要编辑当前的快速命令栏中显示的快速命令集，点击快速命令栏的[快速命令集]按钮后在目录中选择[编辑]以打开快速命令集编辑对话框。

利用快速命令集编辑对话框可添加、删除、编辑快速命令，也能变更在快速命令栏显示的顺序。

如何在快速命令栏显示其他快速命令集:

1. 在快速命令栏点击[快速命令集]按钮后在目录中选择快速命令集。结果: 出现所选快速命令集的快速命令列表。

如何选择开始会话时显示的快速命令集:

1. 打开会话的会话属性对话框。

2. 选择[类别]的[高级]选项。

3. 选择会话使用的快速命令集。

4. 点击[浏览]在快速命令集对话框变更或新建快速命令集。

5. 点击[确定]。

See Also

终端窗口作业


更改编码

Xshell 4 Help / 更改编码
更改编码

基本上 Xshell 使用Windows系统的用户默认语言。也可按照远程主机的编码选择使用与Windows系统不同的各种编码。

如何更改会话编码:

1. 从以下方法中选择其一:

· 点击标准按钮的[编码]后选择拟要使用的编码。

· 打开会话属性对话框选择[类别]的[终端]后在[编码]目录中选择适用的编码。

2. 输出UTF-8 编码:

· 远程计算机支持Unicode(UTF-8)且设为使用UTF-8时编码应使用‘Unicode(UTF-8)’。UTF-8 编码可同时输出多个语言的字符集。

* 注释

为准确显示选定的编码，应安装该Windows系统选定编码的语言包。

编码选项不会改变键盘输入值，必要时应安装Windows提供的IME (Input Method Editor)。

See Also

终端窗口作业


高级终端选项设置

Xshell 4 Help / 高级终端选项设置
高级终端选项设置

如何变更滚动缓冲区的大小:

1. 打开会话属性对话框。

2. 在[类别]中选择[终端]。

3. 在[滚动缓冲区]中输入拟要使用的Line数。

4. 点击[确定]。

* 注释

滚动缓冲区的大小是0 ~ 2,147,483,647之间的值。0表示不使用滚动缓冲区。

如何变更终端类型:

1. 打开会话属性对话框。

2. 在[类别]中选择[终端]。

3. 在[终端类型]项下选择终端类型。

4. 点击[确定]。

如何变更启动终端时的大小:

1. 打开会话属性对话框。

2. 在[类别]中选择[终端]。

3. 在[仿真]区域选择[连接后使用以下终端大小]。

4. 在[行]项输入行大小。

5. 在[列]项输入列大小。

6. 点击[确定]。

如何变更键盘模式:

1. 打开会话属性对话框。

2. 在[类别]中选择[终端: VT模式]。

3. 在[初始数字小键盘模式]选择[常规]或[应用程序]。

4. 点击[确定]。

See Also

终端窗口作业


布局管理

Xshell 4 Help / 布局管理
布局管理

布局管理功能是根据用户的作业环境或习惯保存 Xshell 窗口布局的功能。在布局管理对话框可删除或重命名已保存的布局。

如何保存当前Xshell窗口的布局:

1. 在[查看]菜单选择[布局]后选择[另存为]。

2. 在另存为对话框输入[新名称]。

3. 点击[确定]。

如何以其他布局变更Xshell窗口:

· 在[查看]菜单选择[布局]后在布局目录中选择其一。

· 按Alt+L键在布局目录中选择其一。

如何管理已注册的布局目录:

1. 在[查看]菜单选择[布局]后再选择[管理]。

2. 在布局管理对话框下删除或重命名布局。

See Also

终端窗口作业


选项设置

Xshell 4 Help / 选项设置
选项设置

选项对话框可以设置适用于所有会话的选项。选择[工具]菜单的[选项]来打开对话框。

See Also

会话文件夹及启动会话
清除历史记录及连接日志
按键对应设置
鼠标设置
透明度设置
高级选项


会话文件夹及启动会话

Xshell 4 Help / 会话文件夹及启动会话
会话文件夹及启动会话

可更改Xshell会话文件夹路径。会话对话框显示更改后路径下的所有会话。选择网络文件夹即可与其他用户共享会话。

如何更改会话文件夹:

1. 打开选项对话框。

2. 在[常规]选项卡中输入[会话文件夹路径]。

如何注册启动时打开的会话:

1. 打开选项对话框。

2. 在[常规]选项卡下点击[启动时打开的会话]目录下的[添加]。

3. 在打开对话框选择会话文件。

See Also

选项设置


清除历史记录及连接日志

Xshell 4 Help / 清除历史记录及连接日志
清除历史记录及连接日志

清除历史记录对话框可选择地址栏、撰写栏、搜索关键词、本地Shell和连接日志的历史记录后进行删除。在记录设置对话框下可定义连接日志相关设置或保存日志的文件。

如何清除历史记录:

1. 打开选项对话框。

2. 点击[常规]选项卡的[清除]历史记录。

3. 在清除历史记录对话框中选择拟要清除的内容。

4. 点击[清除]。

如何保存连接日志:

1. 打开选项对话框。

2. 点击[常规]选项卡的记录[设置]。

3. 在记录置对话框中选择[将连接详细信息记录到下一个文件中]。

4. 输入拟要保存连接服务器、连接协议、连接日期、终止日期及连接时间相关信息的文件。

See Also

选项设置


按键对应设置

Xshell 4 Help / 按键对应设置
按键对应设置

通过用户按键对应对话框可确认当前设置的快捷方式键组合，用户也能添加、删除、编辑组合键。

如何更改按键对应设置:

1. 打开选项对话框。

2. 点击[键盘和鼠标]选项卡。

3. 点击[按键对应]的[编辑]。结果:出现用户按键对应对话框。

4. 在[当前键设置]目录下选择拟要变更的组合键后点击[编辑]。结果: 出现编辑对话框。

5. 在[类型]的菜单、发送字符串、运行脚本、启动应用程序中选择其一。

6. 在[操作]中输入选定的各类型菜单或字符串。

7. 点击[确定]。

See Also

选项设置


鼠标设置

Xshell 4 Help / 鼠标设置
鼠标设置

可设置鼠标的中间和右键动作，也能指定通过双击选择词语时使用的分隔符。

如何变更鼠标键的动作:

1. 打开选项对话框。

2. 在[键盘和鼠标]选项卡的鼠标中间键功能中选择其一。

· 不进行任何动作。

· 打开弹出菜单。

· 粘贴剪贴板的内容。(默认值)

· 打开属性窗口。

3. 在右键功能中选择其一，右键的默认功能是[打开弹出菜单]。

如何变更双击选择时的分隔符:

1. 打开选项对话框。

2. 输入在[键盘和鼠标]选项卡的[选择]区域选择词语时使用的分隔符。

See Also

选项设置


透明度设置

Xshell 4 Help / 透明度设置
透明度设置

Xshell提供窗口的透明度设置功能。

如何令窗口变得更透明:

1. 选择[查看]菜单的[透明]。

2. 打开选项对话框。

3. 在[查看]选项卡设置透明度。

4. 设置[不透明度]值。不透明度值越小 Xshell窗口越透明。

5. 选择[鼠标悬停在窗口时不透明显示]选项时在设置为透明显示Xshell窗口的状态下把鼠标置于窗口位置时也能不透明显示Xshell窗口。

6. 选择[透明时前端显示]选项时，在使用透明显示功能的时间内把Xshell窗口置于所有窗口之上。

See Also

选项设置


高级选项

Xshell 4 Help / 高级选项
高级选项

高级选项是可在选项对话框的[高级]选项卡进行设置的选项。

按ESC键切换到英文输入

像vi, vim 等部分应用程序在输入韩文时按ESC键转到命令模式时自动切换为英文输入状态。

禁用铃声

设置成不使用铃声。

利用智能选择键以进行便捷的复制、文件下载操作

用鼠标选择终端内容时显示或屏蔽智能选择按钮。

最小化到系统托盘

把Xshell最小化到系统托盘。

全屏模式下显示会话选项卡

在全屏模式下显示会话选项卡。

全屏模式下显示卷动条

在全屏模式下显示卷动条。

按当前窗口大小排列层叠窗口

在[窗口]菜单选择层叠排列时按照当前Xshell窗口大小进行排列。

启动Windows时运行Xshell

启动Windows时自动运行Xshell。

启动Xshell时最小化到系统托盘

启动Xshell时会最小化到系统托盘。

启动Xshell时打开会话对话框

启动Xshell时打开会话对话框。

在菜单访问中使用Alt键

按Alt键来打开菜单。

在单一Xshell窗口中打开多个会话

在一个Xshell窗口打开多个会话，利用会话选项卡和会话栏可在会话之间移动。

退出Xshell时确认断开连接

在关闭程序时询问是否断开连接中的会话。

终止会话时确认断开连接

终止会话时询问是否断开连接。

终止连接时还原为本地Shell

终止连接时以本地Shell状态保持会话选项卡。在本地Shell会话状态下终端屏幕显示Xshell提示，可执行open、telnet、ssh、ping等本地命令。如需查看指令目录请在Xshell提示执行help或?。

退出全部连接时关闭Xshell

在退出所有会话连接时关闭Xshell程序。

See Also

选项设置


文件传输

Xshell 4 Help / 文件传输
文件传输

Xshell 可利用SFTP和ZMODEM协议发送和接收文件。

See Also

利用SFTP传输文件
利用ZMODEM传输文件
与Xftp联动的文件传输


利用SFTP传输文件

Xshell 4 Help / 利用SFTP传输文件
利用SFTP传输文件

SFTP是基于SSH的文件传输协议，与ZMODEM相比具有更加安全且更为快速的文件传输功能。

如何利用SFTP接收文件:

1. 在本地提示以 sftp 命令登陆拟要接收文件的主机。
Xshell:\> sftp hostname

2. 在 sftp 提示下以 get 命令接收需要的文件。
sftp:/home/user21> get filename

如何利用SFTP发送文件:

1. 在本地提示下以 sftp 命令登陆拟要发送文件的主机。
Xshell:\> sftp hostname

2. 在 sftp 提示下以 put 命令发送需要的文件。
sftp:/home/user21> put filename

See Also

文件传输


利用ZMODEM传输文件

Xshell 4 Help / 利用ZMODEM传输文件
利用ZMODEM传输文件

通过ZMODEM接收的文件被保存到用户指定的文件夹，用户也可以在每次接收时指定其他文件夹。

如何利用ZMODEM接收文件:

1. 在远程主机的提示下执行如下命令:
$ sz file1 file2 …

2. 选择[文件]菜单的[传输]。

3. 选择[用ZMODEM接收]。

* 注释

如远程主机上不存在 sz 命令则需由用户进行安装，大部分情况下存在类似的命令。

如何在终端用ZMODEM接收文件:

1. 在Xshell终端窗口选择拟要下载的文件名。
结果: 所选文件名周围出现智能选择按钮。

2. 点击智能选择按钮。

3. 选择[用ZMODEM下载]。

如何利用ZMODEM发送文件:

1. 在远程提示下执行如下命令:
$ rz

2. 选择[文件]菜单的[传输]。

3. 选择[用ZMODEM发送]。

4. 选择拟要发送的文件。

5. 如需以ASCII类型发送文件，选择[发送文件到ASCII]。

6. 点击[打开]。

如何利用拖放以ZMODEM发送文件:

1. 选择拟要上传的Windows文件。

2. 拖放文件到 Xshell 终端窗口。
结果:自动传输文件。

如何变更保存文件的默认文件夹:

1. 打开会话属性对话框。

2. 在[类别]中选择[ZMODEM]。

3. 在[接收文件夹]区域内选择[使用下列下载路径]。

4. 打开浏览文件夹对话框后选择拟要保存已接收文件的文件夹。

5. 点击[确定]。

如何浏览已接收文件:

1. 打开会话属性对话框。

2. 在[类别]中选择[ZMODEM]。

3. 点击[接收文件夹]区域的[打开]。

See Also

文件传输


与Xftp联动的文件传输

Xshell 4 Help / 与Xftp联动的文件传输
与Xftp联动的文件传输

Xshell提供与(株)Netsarang Computer的文件传输程序即 Xftp联动的功能，通过当前 Xshell与登陆中的主机建立快速便捷的FTP/SFTP连接。

Xshell与连接中的主机创建Xftp连接:

1. 登陆以Xshell传输文件的主机。

2. 在[窗口]菜单下选择[传输新文件]或点击标准按钮的[传输新文件]。

* 注释

如Xshell使用SSH协议，Xftp尝试建立SFTP连接，如果是TELNET、RLOGIN等协议则利用FTP进行连接。

See Also

文件传输


会话日志记录和跟踪

Xshell 4 Help / 会话日志记录和跟踪
会话日志记录和跟踪

利用 Xshell 的日志功能可以以文件形式保留通过会话收发的所有文字，也能以Debugging为目的使用跟踪功能。

See Also

会话日志记录
会话跟踪


会话日志记录

Xshell 4 Help / 会话日志记录
会话日志记录

如何仅对字符串进行记录:

1. 用鼠标锁定[文件]菜单的[日志]。

2. 选择[开始]，出现另存为对话框。

3. 输入拟要保存日志数据的文件名。

4. 取消[记录普通文本和终端代码]的勾选。

5. 点击[保存]。

* 注意

日志记录会一直保持到会话结束，如在不关闭会话的状态下终止日志记录，请在[文件]菜单的[日志]项下选择[停止]。

如何同时记录字符串和终端代码:

1. 用鼠标锁定[文件]菜单的[日志]。

2. 选择[开始]，出现另存为对话框。

3. 输入拟要保存日志数据的文件名。

4. 选择[记录普通文本和终端代码]。

5. 点击[保存]。

如何在连接会话时开始日志记录:

1. 打开会话属性对话框。

2. 在[类别]中选择[日志记录]。

3. 选择[连接时开始日志记录]。

4. 可指定保存日志的文件夹或文件名。

5. 点击[确定]。

See Also

会话日志记录和跟踪


会话跟踪

Xshell 4 Help / 会话跟踪
会话跟踪

利用跟踪选项可跟踪与远程主机进行收发的协议管理数据。

SSH协议可在终端屏幕显示算法交换和用户身份验证的具体内容；TELNET协议可跟踪各种选项交换动作。该功能在远程主机的连接出现问题时非常有效。

如何启用或关闭跟踪功能:

1. 打开会话属性对话框。

2. 在[类别]中选择[跟踪]。

3. 选择适用选项。

4. 点击[确定]。

See Also

会话日志记录和跟踪


打印

Xshell 4 Help / 打印
打印

Xshell 提供用本地打印机打印终端窗口文本的功能。在 Xshell 打印时可以沿用终端窗口使用的字体及颜色。且在页面设置对话框可以设置打印纸的边距。

如何设置打印纸的大小和方向:

1. 在[文件]菜单选择[页面设置]。

2. 选择纸张大小和方向。

3. 输入边距。

4. 点击[确定]以保存更改。

如何进行打印:

1. 在[文件]菜单选择[打印]。

2. 在[名称]目录选择打印机。

3. 点击[确定]。


使用Xagent

Xshell 4 Help / 使用Xagent
使用Xagent

Xagent 是SSH的验证代理(authentication agent)。Xagent 在保存公钥用户身份验证使用的用户秘钥后在 Xshell 需要用户秘钥时帮助 Xshell 使用相应密钥。

Xagent 具有 Xshell 用户秘钥的所有目录，必要时要求用户输入密码。用户输入密钥后 Xagent 对其进行解密并保存到存储器。因此使用 Xagent 用户只需输入一次密码即能多次使用相关密钥。

Xagent 同时还具有SSH的代理转发功能所需的SSH验证服务器的功能。SSH代理转发功能在从首次登陆的服务器连接到其他服务器时使用。基本上，用户秘钥仅保存在用户PC上，从首次登陆的服务器连接到其他服务器时无法使用该密钥。SSH代理转发功能可以在远程服务器的SSH客户端程序下使用PC的 Xagent 管理的用户秘钥。

* 注释

运行 Xagent 时在系统托盘上生成 Xagent 图标。即使关闭 Xagent 对话框也不会保持 Xagent 运行。退出 Xagent 或打开 Xagent 对话框时请使用系统托盘图标上的菜单。

See Also

通过Xagent登陆服务器
在远程主机使用Xagent的用户秘钥


通过Xagent登陆服务器

Xshell 4 Help / 通过Xagent登陆服务器
通过Xagent登陆服务器

如何在Xshell设置使用Xagent:

1. 打开会话属性对话框。

2. 在[类别]中选择[连接: SSH]。

3. 选择[用密码处理的 Xagent (SSH代理)]。

4. 点击[确定]。

如何通过Xagent登陆SSH服务器:

1. 在 Xshell 进行设置以启用 Xagent。

2. 如未运行 Xagent 则运行 Xagent。

3. 登陆SSH服务器。
此时，SSH服务器需支持公钥用户身份验证，且在服务器上注册有拟要使用的用户秘钥的公钥。

4. 出现用户秘钥密码对话框。输入所选用户秘钥的密码。

* 注释

连接: 在SSH设置项下选择[自动启动Xagent]时可省略第2项的过程。用户秘钥密码对话框在所选密钥在Close状态时出现。用户秘钥的状态可在 Xagent 的用户秘钥目录进行确认。

See Also

使用Xagent


在远程主机使用Xagent的用户秘钥

Xshell 4 Help / 在远程主机使用Xagent的用户秘钥
在远程主机使用Xagent的用户秘钥

启用 Xagent 时远程主机上的ssh客户端可以使用 Xshell 使用的用户秘钥即 Xagent 所持有的用户秘钥。如需在远程主机使用 Xagent 的用户秘钥，Xshell 和远程主机的SSH服务器应支持代理转发功能。

如何在ssh.com服务器激活带来转发功能:

1. 打开/etc/ssh2/sshd2_config文件。

2. 以如下值设置AllowAgentForwarding选项:
AllowAgentForwarding      yes

3. 重启SS服务器。

* 注释

OpenSSH服务器只要不指定no-agent-forwarding选项，其代理转发功能始终处在激活状态。

远程主机如何使用Xagent的密钥:

1. 在 Xshell 进行设置以启用 Xagent。

2. 如未运行 Xagent 则运行 Xagent。

3. 连接并登录SSH服务器。

* 注释

服务器支持代理转发功能时，登录时会对代理转发用的环境参数(SSH_AUTH_SOCK 或 SSH2_AUTH_SOCK)进行合理设置。

4. 在远程服务器登陆进行公钥验证的其他服务器。

5. 出现用户秘钥密码对话框时输入选定的用户秘钥密码。

* 注释

[用户秘钥密码]对话框在所选密钥在Close状态时出现。用户秘钥的状态可在 Xagent 的用户秘钥目录进行确认。

See Also

使用Xagent


使用脚本

Xshell 4 Help / 使用脚本
使用脚本

脚本是把一次执行的命令集合在一起的一个文件，把重复性的作业制作成文件，无需一一输入命令，使用起来非常方便， 采用Visual Basic脚本格式。

See Also

脚本的运行和结束
脚本API


脚本的运行和结束

Xshell 4 Help / 脚本的运行和结束
脚本的运行和结束

如何启用脚本文件:

1. 在[工具]菜单锁定[脚本]를后选择[运行]。
结果: 出现打开对话框。

2. 选择脚本文件。

3. 点击[确定]。

脚本文件运行过程中退出脚本

1. 在[工具]菜单锁定[脚本]后选择[取消]。

See Also

使用脚本


脚本API

Xshell 4 Help / 脚本API
脚本API

Xshell提供如下脚本API。利用该API可实现重复作业的自动化。

See Also

使用脚本
xsh.Session
xsh.Screen
Script例示


xsh.Session

Xshell 4 Help / xsh.Session
xsh.Session

Xshell会话可使用下列函数和参数。为使用这些函数和参数，需同时运行xsh.Session。例如在使用‘sleep’函数时同时启用‘xsh.Session.sleep(1000)’。

Functions
返回值 | 函数 | 参数 | 说明
Void | OpenSession(LPCTSTR lpszSession) | lpszSession 是字符串，指Xshell会话路径或Xshell使用的URL类型。 | 打开新会话或URL。 为打开会话把 /s选项置于字符串的前端。例)在打开A.xsh 会话时使用‘/s $PATH/A.xsh’。
Void | CloseSession() |  | 退出当前连接的会话。
Void | Sleep(long timeout) | Timeout 毫秒单位的时间值 | Xshell按照指定时间进行待机。
Void | LogFilePath(LPCTSTR lpszNewFilePath) | lpszNewFilePath 包括路径在内的文件名 | 指定日志文件。
void | StartLog() |  | 开始会话的日志记录。日志将被保存到LogFilePath()指定的路径。如未指定日志文件路径则使用默认路径。
void | StopLog() |  | 停止日志记录。

参数
名称 | 类型 | 说明
Connected | BOOL | 是否连接当前会话。
LocalAddress | BSTR | 导入本地地址。
Path | BSTR | 导入当前会话文件的路径。
RemoteAddress | BSTR | 导入远程地址。
RemotePort | long | 导入远程端口号。
Logging | BOOL | 确认当前会话是否记录日志。

See Also

脚本API


xsh.Screen

Xshell 4 Help / xsh.Screen
xsh.Screen

在操作Xshell的终端屏幕时可使用下列函数和参数。 为使用这些函数和参数，需同时运行xsh.Screen。例如要使用‘Clear()’函数应同时启用‘xsh.Session.Clear()’。

Functions
返回值 | 函数 | 参数 | 说明
void | Clear() |  | 清除终端屏幕。
void | Send(LPCTSTR lpszStrToSend) | lpszStrToSend 用户拟要发送的字符串 | 向终端发送消息。
BSTR | Get(long nBegRow, long nBegCol, long nEndRow, long nEndCol) | nBegRow 终端的行起始位置 nBegCol 终端的列起始位置 nEndRow 终端的行末端位置 nEndCol 终端的列末端位置 | 读入终端规定区域的字符串后返回值。
void | WaitForString(LPCTSTR lpszString) | lpszString 终端中出现的字符串 | 等待消息。
Long | WaitForStrings(VARIANT FAR* strArray, long nTimeout) | strArray 终端中出现的字符串 nTimeout 等候时间的毫秒值 返回值 发现的字符数 | 等待消息直至到时。
void | Synchronous(BOOL bSync) | bSync 1(True): 使用画面同步化 0(False) : 禁用画面同步化 | 定义画面的同步化。

参数
名称 | 类型 | 说明
CurrentColumn | long | 返回当前值。
CurrentRow | long | 返回当前行。
Columns | long | 返回与终端的列宽相同的列数。
Rows | long | 返回与终端的行高相同的行数。

See Also

脚本API


Script例示

Xshell 4 Help / Script例示
Script例示

Script file

Sub Main

' *** Connect the session ***

xsh.Session.Open "ssh://192.168.1.17"

' "/s C:\Users\Administor\AppData\Roaming\NetSarang\Xshell\Sessions\example.xsh"

xsh.Screen.Synchronous = true

xsh.Screen.WaitForString "login: "

xsh.Screen.Send "username"

xsh.Screen.Send VbCr

xsh.Session.Sleep 100

xsh.Screen.WaitForString "Password: "

xsh.Screen.Send "password"

xsh.Screen.Send VbCr

xsh.Session.Sleep 100

' *** Wait for Prompt Message ***

xsh.Screen.WaitForString "username@password"

' *** Set File Format ***

Dim app, wb, ws

Set app = CreateObject("Excel.Application")

Set wb   = app.Workbooks.Add

set ws   = wb.Worksheets(1)

xsh.Session.LogFilePath = "c:\example.log"

xsh.Session.StartLog

Dim waitStrs

waitStrs = Array(Chr(10), "username@password")' make wait message as array

Dim row, screenrow, readline, itmes

row = 1

' *** Send Command ***

xsh.Screen.Send "cat /etc/passwd"

xsh.Screen.Send VbCr

xsh.Session.Sleep 100

Dim result

' *** Read Data and Save it as an EXCEL File ***

Do

While true

        result = xsh.Screen.WaitForStrings(waitStrs, 1000)

        If result = 2 Then

               Exit Do

        End If

        screenrow = xsh.Screen.CurrentRow - 1

        readline  = xsh.Screen.Get(screenrow, 1, screenrow, 40)

        items     = Split(readline, ":", -1)

        ws.Cells(row,1).Value = items(0)

        ws.Cells(row,2).Value = items(2)

        row = row + 1

Wend

Loop

wb.SaveAs("C:\chart.xls")                    ' save file path

wb.Close

app.Quit

Set ws  = nothing

Set wb  = nothing

Set app = nothing

xsh.Screen.Synchronous = false

xsh.Session.StopLog

End Sub

See Also

脚本API


参考

Xshell 4 Help / 参考
参考

该部分包括Xshell使用有关的参考信息。

See Also

标准按钮
地址栏
Xshell本地指令
Xshell命令行选项
SFTP指令
正则表达式
已定义的快捷方式键


标准按钮

Xshell 4 Help / 标准按钮
标准按钮

Xshell提供常用作业和命令有关的标准按钮。

以下是标准按钮相关说明。

按钮 | 名称 | 说明
 | 新建 | 打开新建会话属性对话框以创建新的会话。
 | 打开 | 打开会话对话框。
 | 断开连接 | 断开当前会话的连接。
 | 重新连接 | 重新连接当前选项卡的会话。
 | 属性 | 显示当前会话的属性。如打不开会话则显示默认会话的属性
 | 复制 | 把选择内容复制到剪贴板。
 | 粘贴 | 粘贴剪贴板的内容。
 | 查找 | 打开查找对话框。
 | 打印 | 当前打印对话框。
 | 配色方案 | 选择配色方案。
 | 编码 | 罗列可输出语言的编码。
 | 字体 | 罗列可使用的字体名称和大小，可更改目前打开的会话的字体，如要更改各会话的字体，在会话属性对话框选择会话的字体。
toolbarnewterminal | 新建终端 | 打开新的Xshell窗口。在连接状态下点击该按钮可使用相关会话的连接信息试图建立连接。
toolbarfiletransfer | 新文件传输 | 已安装Xftp™时运行Xftp。在连接状态下点击该按钮用相关会话的连接信息开始新的文件传输会话。如未安装Xftp，开始Xshell自己的文件传输会话。
 | 全屏 | 切换到全屏模式。按Alt+Enter键即变回一般窗口模式。
 | 锁定屏幕 | 切换到锁屏模式。在输入密码之前用户输入的动作均无效。
 | 按键对应 | 打开用户按键对应对话框。
 | 脚本 | 运行Xshell脚本文件。
 | 启动日志记录 | 开始记录日志。
 | 停止日志记录 | 停止记录日志。
cog | 选项 | 打开选项对话框。
 | 用户密钥管理者 | 打开用户秘钥对话框。
 | 主机密钥管理者 | 打开主机密钥对话框。
 | Xagent | 运行 Xagent程序。
 | Xactivator | 运行 Xactivator程序。
 | 帮助 | 打开Xshell帮助。

See Also

参考


地址栏

Xshell 4 Help / 地址栏
地址栏

地址栏的语法格式如下:

        [protocol://][user[:password]@]hostname[:port][/]

可使用协议有 ssh、sftp、telnet、rlogin 及 serial。默认协议是默认会话选择的协议。各协议的默认端口号定义如下:

· ssh:            22

· sftp:           22

· telnet:         23

· rlogin:         513

· ftp:            21

下面例示供参考。

例示 | 说明
foobar.com | 以默认会话指定的协议和端口号登陆foobar.com 。
ssh://kay@foobar.com/ | 以ssh协议登陆foobar.com。用户账户为kay并使用默认端口号。
ssh://kay@foobar.com:12345/ | 以ssh协议登陆foobar.com的12345号端口。用户账户为kay。
telnet://foobar.com/ | 通过telnet协议登陆foobar.com，并未指定用户账户，连接到默认端口即23号端口。
rlogin://kay@foobar.com/ | 以rlogin协议登陆foobar.com，用户账户为kay，连接到默认端口即513号端口。
sftp://kay@foobar.com/ | 以sftp协议登陆foobar.com，用户账户为kay并使用默认端口号。
ftp://foobar.com/test.zip | 以ftp协议登陆foobar.com，下载test.zip文件。

See Also

参考


Xshell本地指令

Xshell 4 Help / Xshell本地指令
Xshell本地指令

Xshell 提供熟悉终端环境的高级用户使用的本地指令。

一般来讲，Xshell 提示在未连接远程主机的状态下出现在终端屏幕上。连接会话后可按“Ctrl+Alt+]”以转出本地提示。如要返回到远程主机模式输入“exit”或按“Ctrl+D”即可。

可使用如下指令。

指令 | 说明
help ? | 在终端窗口显示指令目录。
new | 打开新建会话属性对话框。
open [session] | 已指定“session”时连接到相应会话，未指定时打开会话对话框。
edit [session] | 已指定“session”时打开相应会话的会话属性对话框，未指定时打开默认会话的会话属性对话框。
list | 显示当前作业directory可使用的会话相关信息和directory目录。
cd | 更改当前作业的directory。
clear | 清除画面、地址栏的历史记录、本地Shell命令提示的命令历史记录。
exit quit | 退出 Xshell 会话或返回到远程主机。
ssh [user@]host [port] | 以ssh协议进行连接。
sftp [user@]host [port] | 以sftp协议进行连接。
telnet [user@]host [port] | 以telnet协议进行连接。
rlogin [user@]host [port] | 以rlogin协议进行连接。
ftp [user@]host [port] | 以ftp协议进行连接。
ipconfig | 执行Windows的ipconfig命令。
ping host | 执行Windows的ping命令。
tracert host | 显示至host的数据包路径。
netstat | 执行Windows의netstat命令。
nslookup | 执行Windows의 nslookup 命令。

See Also

参考


Xshell命令行选项

Xshell 4 Help / Xshell命令行选项
Xshell命令行选项

是Xshell识别的命令行参数选项，这些参数可以从Windows控制台程序或其他应用程序执行时使用。

选项、参数 | 说明
“会话文件” | 运行相应会话。“会话文件”有可能包括路径。
-folder “会话文件夹” | 运行相关文件夹的所有会话。
-url [protocol://][user[:password]@]host[:port] | 直接输入URL而进行登陆而不用保存的会话文件。可使用协议是SSH、SFTP、TELNET、RLOGIN和FTP。 如省略协议则使用选项对话框的[常规]选项卡中定义的默认协议。 如省略用户(user)、密码(password)则出现验证用的窗口。 如未指定连接端口(port)则使用连接协议的默认端口。
-open | 打开会话对话框。
-register | 打开产品注册用的对话框。
-about | 打开可查看产品版本、许可证信息等的Xshell信息对话框。
-prop “会话文件” | 打开相应会话的会话属性对话框。“会话文件”有可能包括路径。
-create “会话文件” | 新建会话。
-folder “会话文件夹” | 运行“会话文件夹”的所有会话。
-newwin | 打开新 Xshell窗口。
-newtab “选项卡名称” | “选项卡名称”，新建一个选项卡。

例示:

Xshell “c:\users\zoo\AppData\Roaming\NetSarang\Xshell\Sessions\xdev.xsh” xdev.xsh会话文件的运行。

Xshell -url foobar.com 以默认协议登陆foobar.com。

Xshell -url ssh://foobar.com 以ssh登陆foobar.com。

Xshell –url ssh://test:testpasswd@foobar.com 以ssh登陆foobar.com，用户名和密码各为“test”和“testpasswd”。

Xshell –url telnet://foobar.com:2300 使用telnet协议，2300号端口连接foobar.com。

Xshell -newwin -url foobar.com 运行新的xshell窗口登陆foobar.com而不使用原窗口的会话选项卡。

* 注释

在启用选项对话框[高级]选项卡的[一个Xshell窗口上打开多个会话]选项时，在最后的Xshell窗口运行除了“-newwin”选项之外的所有选项或用选项卡运行会话。 “-newwin”选项可与其他选项一起使用，用该选项运行新的Xshell窗口。

See Also

参考


SFTP指令

Xshell 4 Help / SFTP指令
SFTP指令

Xshell 提供熟悉终端环境的高级用户使用的与UNIX/Linux的FTP相类似的指令。各指令说明内容如下，具体使用方法请用SFTP提示的help命令进行确认。

指令 | 说明
getfile1 [file2] [file3] … | 把远程主机的指定文件导入到本地主机。
putfile1 [file2] [file3] … | 把本地主机的指定文件发送到远程主机。
mv path1path2 renamepath1path2 | 把特定文件或Directory转移到其他路径或进行更名。
mkdirdirectory | 创建远程主机指定的Directory。
rmdir directory | 删除远程主机指定的Directory。
rmfile | 删除远程主机指定的文件。
pwd | 显示远程主机的作业Directory。
lpwd | 显示本地主机的作业Directory。
cddirectory | 更改远程主机的作业Directory。
lcddirectory | 更改本地主机的作业Directory。
ls [directory] | 显示远程主机的文件目录。
lls[directory] | 显示本地主机的文件目录。
explore [directory] | 利用Windows资源管理器浏览当前(或指定的)Directory。
help [command] | 显示SFTP指令目录或指定指令的使用方法。
bye exit quit | 终止SFTP连接。

See Also

参考


正则表达式

Xshell 4 Help / 正则表达式
正则表达式

此部分说明查找对话框使用的正则表达式。

See Also

参考
Pattern匹配
字符集的缩写
POSIX 字符集
例示


Pattern匹配

Xshell 4 Help / Pattern匹配
Pattern匹配
Pattern | 说明
. | 除了换行符之外的汉子
[abc] | a, b, c 之间的汉子
[a-z] | a 和z之间的汉子
[^ac] | a 和c之外的汉子
(x) | x, 此时 x有可能是正则表达式。
x* | X重复0次以上。此时 x有可能是正则表达式。
x+ | X重复1次以上。此时 x有可能是正则表达式。
x{n,m} | X重复n次以上，m次以下。此时 x有可能是正则表达式。
x{n} | X准备重复n次以上。此时 x有可能是正则表达式。
x{n,} | X重复n次以上。此时 x有可能是正则表达式。
x|y | x或y， 此时x, y有可能是正则表达式。
xy | xy, 此时x, y有可能是正则表达式。
^ | 行头
\A | 行头
$ | 行端
\z | 行端
\Z | 行端
\< | 单词的开头
\b | 单词的开头
\> | 单词的末端
\B | 单词的末端

See Also

正则表达式


字符集的缩写

Xshell 4 Help / 字符集的缩写
字符集的缩写
Class | 说明
\w | 组成单词的字符，与[a-zA-Z0-9_]相同。
\W | 不组成单词的字符，与[^a-zA-Z0-9_]相同。
\s | 空白符
\S | 空白符之外的字符
\d | 数字，与[0-9]相同。
\D | 数字之外的字符，与[^0-9]相同。

See Also

正则表达式


POSIX 字符集

Xshell 4 Help / POSIX 字符集
POSIX 字符集
Class | 说明
[:alnum:] | 罗马字母和数字，与[a-zA-Z0-9]相同
[:alpha:] | 罗马字母，与[a-zA-Z]相同
[:blank:] | 空白符
[:cntrl:] | 控制符
[:digit:] | 数字，与[0-9]相同
[:graph:] | 可输出字符(空白符除外)
[:lower:] | 小写字母，与[a-z]相同
[:print:] | 非控制符的字符
[:punct:] | 标点符号
[:space:] | 空白符
[:upper:] | 大写字母，与[A-Z]相同
[:xdigit:] | 用来表示16进制的字符，与[0-9a-fA-F]相同

See Also

正则表达式


例示

Xshell 4 Help / 例示
例示
表达式 | 说明
[0-9]+ | 数字重复1次以上的Pattern
(foo)|(bar) | "foo" 或 "bar"
\.html$ | 以".html"结束的字符串
^\. | 以"."开始的字符串

See Also

正则表达式


已定义的快捷方式键

Xshell 4 Help / 已定义的快捷方式键
已定义的快捷方式键

下列目录对 Xshell 已定义的快捷方式键进行说明。

快捷方式键 | 说明
Alt + N | 与文件菜单的新建相同
Alt + O | 与文件菜单的打开相同
Alt + C | 与文件菜单的断开相同
Alt + Enter | 切换到全屏模式
Alt + D | 把键盘焦点移动到地址栏
Alt + L | 更改布局
Alt + 1~9 | 移动会话选项卡
Alt + Right | 与窗口菜单的前进相同
Alt + Left | 与窗口菜单的后退相同
Ctrl + D | 退出本地提示的本地 Shell
Ctrl + Alt + ] | 连接时转出本地提示
Ctrl + Alt + T | 与窗口菜单的新建终端相同
Ctrl + Alt + F | 与窗口菜单的发送新建文件相同
Ctrl + Tab | 从一个 Xshell 窗口移动到下一会话
Shift + Tab | 从一个 Xshell 窗口移动到最近使用的会话
Shift + Home | 顶部
Shift + End | 底部
Shift + PgUp | 向上翻页
Shift + PgDn | 向下翻页
Shift + Up Arrow | 向上滚动
Shift + Down Arrow | 向下滚动

* 注释

变更菜单的快捷方式键时使用对应功能。通过用户按键对应对话框可变更快捷方式键的组合键，也可在组合键上分配菜单、发送字符串、运行脚本、运行程序等动作。

See Also

参考