Xshellの紹介

Xshell 4 Help / Xshellの紹介
Xshellの紹介

Xshell はWindowsプラットフォームで動作する強力なSSH、TELNET、RLOGINターミナルエミュレーションソフトウェアです。WindowsユーザーはXshellを通じてUNIX/Linuxホストに容易で安全にアクセスできます。SSH(Secure Shell)プロトコルはインターネット上で安全な接続のための暗号化およびユーザー認証をサポートし、TELNET、RLOGINのような既存のプロトコルを代替できます。

See Also

主な機能
推奨仕様
インストールおよび削除

Copyright© 2013 Netsarang Computer, Inc. All rights reserved.


主な機能

Xshell 4 Help / 主な機能
主な機能

このセクションではXshellの主な機能を記述します。

全般

l SSH1、SSH2、SFTP、TELNET、RLOGINおよびSERIALプロトコルサポート

l Windows 2000/XP/2003/Vista/2008/7/8サポート

l OpenSSHおよびssh.comサーバーサポート

l 複数ユーザー設定

l Keep Aliveオプション

l SOCKS4/5、HTTPプロキシ接続

l マルチセッションサポート(セッションタブ、セッションバー)

l ユーザー指定キーマッピング

l VBスクリプト

l 新しいリンクバー

l 切断された接続を自動で再接続

セッション管理

l 他のホストに対するセッションファイルの生成および管理

l セッションを開くためのセッションダイアログボックス、アドレスバー、ローカルプロンプト、セッションショートカットおよびリンクバーサポート

l 早い接続のための既定セッション提供

l 複数セッション同時接続

l アドレスバーはURLコマンドをサポートし、セッションを使用しないリモートホストに接続サポート

l Xactivatorを通じたセッション接続

l 自動ログイン、自動入力機能

l セッションダイアログボックスでフォルダおよびツリービュー

セキュリティ

l RSA/DSA公開キー、パスワードおよびKeyboard Interactiveユーザー認証方法

l RSA/DSAキーウィザードおよびインポート/エクスポート機能

l Xagent(SSHユーザー認証エージェント)を利用したユーザー認証

l AES128/192/256、3DES、BLOWFISH、CAST128、ARCFOURおよびRIJNDAEL暗号化アルゴリズム

l SHA1、SHA1-96、MD5、MD5-96およびRIPEMD160 MACアルゴリズム

l zlib圧縮

l ホストキーの管理ダイアログボックス

l ユーザーキーの管理ダイアログボックス

ターミナル

l ユニコード基盤のターミナルバッファー

l VT100、VT220、VT320、XTERM、LINUX、SCOANSIおよびANSIターミナル

l 多国語出力エンコード(UTF-8)

l すべてのセッションに同時に文字転送できる作成バー

l 2,147,483,647ラインまで保存可能なスクロールバッファー

l 正規表現を利用した文字列の検索

l カラム単位のテキスト選択

l コピー/貼り付け時にMulti-byte文字列サポート

l ターミナルウィンドウで2回クリックして単語選択および区切り記号を指定

l マウスボタン3回クリック時に1行選択

l 太字およびANSIカラーコード

l Xtermターミナルマウス

l Xterm 256カラーモード

l Liunx Metaキーエミュレーション

l ターミナル画面の印刷

l ターミナルウィンドウの行間および余白の設定

l ESCキーを押せば韓->英変換 (ハングルWindowsの場合のみ該当)

トンネリング

l TCP/IPおよびX11フォワーディング

l SOCKS4/5を利用した動的ポートフォワーディング

l トンネリングペインを通じて現在活性化されたフォワーディングチャネルを観察することができ、現在のセッションに新しいフォワーディングルールを追加

表示

l 容易で強力なユーザーインターフェイス

l ユーザー指定のレイアウトに転換

l 移動可能なツールバー

l 配色編集/インポート/エクスポート

l カーソルカラーの変更および点滅設定

l フォントボタンを通じて容易にフォント変更

l しばしば使用する文字列をクイックコマンドに指定

l ツールバーの標準ボタンユーザー指定

l ステータスバーにセキュリティロック、セッション、選択、ネットワークup/downトラフィック情報を表示

l フルスクリーン表示 (Alt+Enter)

l 透明度調節オプション

ローカルコマンド

l 詳細ユーザーのためのローカルセルプロンプト

l open、ssh、telnet、rloginおよびsftp、ftpなどのようなローカルコマンド

l ping、ipconfig、netstatおよびnslookupのようなローカルWindowsコマンド

l リモートホスト接続中にローカルプロンプトに出る

相互運用性

l Xmanagerプログラムと連動するX11フォワーディング

l Xagentプログラムと連動するエージェントフォワーディング

l Xftpと連動して容易にFTPサイトに接続

l スクロールバッファーをメモ帳で編集

l メニューコマンドを通じてXshellウィンドウを順に選択

ファイル管理

l SFTPエクスポートおよび受信

l ZMODEMエクスポートおよび受信

l ASCIIファイル送信

l セッション自動ログ(ターミナルコードも保存)

l ページ設定および印刷プレビュー

See Also

Xshellの紹介


推奨仕様

Xshell 4 Help / 推奨仕様
推奨仕様

l プロセッサ：Intel®互換

l オペレーティングシステム：Microsoft Windows® 2000 SP4以上

l 保存空間：50MB以上の余裕空間

l ネットワーク：TCP/IPネットワーク

l プログラム：Internet Explorer® 6.0以上

See Also

Xshellの紹介


インストールおよび削除

Xshell 4 Help / インストールおよび削除
インストールおよび削除

Xshell インストールプログラムは InstallShield®を使用してつくられ、インストール過程で多様なインストールオプションを変更できます。しかし、大部分の場合、単純に[次へ]をクリックするだけのものです。

Xshell を削除するためには、Windowsの標準追加/削除機能を利用します。コントロールパネルで[プログラムの追加/削除]を実行した後、一覧でXshellまたはXmanager Enterpriseを選択して削除します。Xmanager Enterprise を削除するとXshellと他のプログラムも一緒に削除されるので注意してください。

プログラムを削除してもユーザーによって生成されたレジストリ情報、ログファイルおよび資料ファイルは削除されません。プログラムを再びインストールすればこのような情報およびファイルを再使用できます。もし、レジストリ情報とファイルをすべて削除したければ、次の位置のレジストリ情報とファイルをすべて削除します：

レジストリ情報：

· \HKEY_CURRENT_USER\Software\NetSarang\Xshell

· \HKEY_CURRENT_USER\Software\NetSarang\Xmanager Enterprise

ファイルおよびフォルダ：

· %APPDATA%\NetSarang\Xshell

· %APPDATA%\NetSarang\Xmanager Enterprise

See Also

Xshellの紹介


開始

Xshell 4 Help / 開始
開始

このセクションではTelnet/RloginまたはSSHセッションを生成する方法とUNIX/Linuxホストに接続するための方法を説明します。Telnetセッションは非常に簡単ですが、SSHセッションはサーバーに接続する前にユーザーキーをサーバーに登録しなければならない場合があります。もし、ユーザーキー登録が必要ならば、“ 公開キーユーザー認証 ”を参照してください。

See Also

セッションの生成
リモートホストに接続
Xshell終了


セッションの生成

Xshell 4 Help / セッションの生成
セッションの生成

1. [ファイル]メニューで、[新規]を選択します。新しいセッションのプロパティダイアログボックスが現れます。

図1: 新しいセッションのプロパティダイアログボックス

2. [名前]にセッション名を入力します。

3. [プロトコル]一覧で適切なプロトコルを選択します。

4. [ホスト]にサーバーのホスト名またはIPアドレスを入力します。

5. [ポート番号]にリモートサーバーによって使われるポート番号を入力します。

6. [OK]をクリックします。

See Also

開始


リモートホストに接続

Xshell 4 Help / リモートホストに接続
リモートホストに接続

次はSSHセッションに接続する過程です。もし、生成されたセッションがなければ、“ セッションの生成 ”セクションを参照してください。

1. [ファイル]メニューで[開く]を選択します。

2. セッション一覧の中から接続するセッションを選択して[接続]をクリックすれば、SSHユーザー名ダイアログボックスが現れます。

図2: SSHユーザー名ダイアログボックス

3. ユーザー名を入力して[OK]をクリックすれば、SSHユーザー認証ダイアログボックスが現れます。

図3: SSHユーザー認証ダイアログボックス

4. Password 認証を試行するには、[パスワード]にパスワードを入力した後[OK]をクリックします。

5. Public Key 認証を試行するには、まず一覧でユーザーキーを選択します。選択されたユーザーキーのパスフレーズを[パスフレーズ]に入力した後[OK]をクリックします。

* 参考

もし、ユーザーキーがなければ、“ 公開キーユーザー認証 ”セクションを参照してください。

6. Keyboard Interactive 認証を試行するには、[OK]をクリックした後、接続過程で提示される質問に答えてください。

See Also

開始


Xshell終了

Xshell 4 Help / Xshell終了
Xshell終了

セッションの接続を切断するには、ターミナル画面のプロンプトで“exit”を入力するか[ファイル]メニューで[切断]を選択してください。

* 参考

[接続終了時にローカルシェルへ復帰]オプションが選択された状態で接続を切断すれば、ローカルシェル状態でセッションタブが維持されます。ローカルシェルセッションではターミナル画面にXshellプロンプトが現れ、open、telnet、ssh、pingなどのようなローカルコマンドを実行できます。

Xshell を終了するには、[ファイル]メニューで[終了]を選択してください。

See Also

開始


セッション管理

Xshell 4 Help / セッション管理
セッション管理

セッションはリモートホストの接続に関する設定を含んでいるファイルです。セッションを生成することによってユーザーはそれぞれ異なるリモートホストに対するそれぞれ異なるオプションを設定できます。セッションダイアログボックスは生成されたすべてのセッションを表示し、セッションを生成して編集できるようにします。

ユーザーはセッションを生成しないでリモートコンピュータに接続することもできます。このような目的でXshellはインストールと同時に使用可能な既定のセッションをサポートしています。

See Also

セッション管理
セッションのプロパティ
エクスポート
インポート


セッション管理

Xshell 4 Help / セッション管理
セッション管理

新しいセッションを生成するには：

1. [ファイル]メニューで、[新規]を選択します。新しいセッションのプロパティダイアログボックスが開きます。

2. 接続情報を入力します。

3. [OK]をクリックします。

セッション ダイアログボックスを開くには：

· [ファイル]メニューで[開く]を選択します。

· 標準ボタンの[開く]をクリックします。

セッションを編集するには：

1. セッションダイアログボックスを開きます。

2. 編集するセッションを選択します。

3. 標準ボタンで[プロパティ]をクリックします。

4. セッションを編集した後[OK]をクリックします。

セッションの名前を変更するには：

1. セッションダイアログボックスを開きます。

2. 名前を変更するセッションを選択した後、マウス右ボタンをクリックします。

3. メニューで[名前の変更]を選択します。

* 参考

セッションの名前は有効なファイル名でなければなりません。

名前を付けてコピーするには：

1. セッションダイアログボックスを開きます。

2. 名前を付けてコピーするセッションを選択します。

3. 標準ボタンで[名前をつけて保存]をクリックします。

セッションを削除するには：

1. セッションダイアログボックスを開きます。

2. 削除するセッションを選択します。

3. 標準ボタンで[削除]をクリックします。

セッションショートカットを作成するには：

1. セッションダイアログボックスを開きます。

2. ショートカットを作成するセッションを選択します。

3. 標準ボタンで[ショートカットの作成 ]をクリックします。

4. ショートカットを保存するフォルダを選択します。

5. [OK]をクリックします。

既定のセッションの設定を変更するには：

既定のセッションのセッションプロパティダイアログボックスを開くには次のうち一つの方法を使用します：

· ローカルシェル状態で[ファイル]メニューの[プロパティ]を選択します。

· メインウィンドウの標準ボタンで[プロパティ]ボタンの横にある矢印をクリックした後、一覧で[既定のセッション]を選択します。

* 参考

既定のセッションはローカルプロンプトやアドレスバーを使用してssh、telnet、rlogin、sftpに接続をする時に使われます。

ローカルプロンプトで接続コマンドを使用するには、“ Xshellローカルコマンド ”を参照してください。アドレスバーを利用して接続するには、“ アドレスバー ”セクションを参照してください。

新しいセッションフォルダを生成するには：

1. セッションダイアログボックスを開きます。

2. 標準ボタンで[新規]ボタンの横にある矢印をクリックした後、一覧で[フォルダ]を選択します。

3. フォルダ名を入力します。

セッションファイルを他のコンピュータにコピーするには：

1. セッションダイアログボックスを開きます。

2. 標準ボタンで[セッションフォルダを開く]をクリックします。

3. 該当セッションファイル(*.xsh)を探してコピーしたりメールで送信して他のコンピュータにエクスポートします。

4. 次のフォルダにセッションファイルを保存します：
”%APPDATA%\NetSarang\Xshell\Sessions”

See Also

セッション管理


セッションのプロパティ

Xshell 4 Help / セッションのプロパティ
セッションのプロパティ

新しいセッションを生成したりセッションを編集するには、セッションのプロパティダイアログボックスを開きます。

セッションのプロパティダイアログボックスを開くには：

· [ファイル]メニューで[新規]を選択します。

· [ファイル]メニューで[プロパティ]を選択します。

· 標準ボタンで[プロパティ]をクリックします。

See Also

セッション管理
接続
接続：ユーザー認証
接続：ユーザー認証：ログインプロンプト
接続：ログインスクリプト
接続：SSH
接続：SSH：セキュリティ
接続：SSH：トンネリング
接続：SSH：SFTP
接続：TELNET
接続：RLOGIN
接続：SERIAL
接続：プロキシ
ターミナル
ターミナル：キーボード
ターミナル：VTモード
ターミナル：詳細
表示
表示：余白
詳細
詳細：トレース
詳細：ログ記録
ZMODEM


接続

Xshell 4 Help / 接続
接続

接続設定ではセッションの接続に関する情報を設定できます。多くの場合、ユーザーはこの部分だけを設定してリモートホストに接続できます。

名前

このセッションの固有な名前を入力します。名前はセッションファイルの名前になるので、ファイル名として有効な文字でなければなりません。

プロトコル

リモートコンピュータに接続する時に使用する接続プロトコルを選択します。サポートされるプロトコルはSSH、SFTP、TELNET、RLOGINおよびSERIALです。

ホスト

リモートコンピュータのホスト名やIPアドレスを入力します。

ポート番号

上で選択したプロトコルのポート番号を入力します。プロトコル一覧でプロトコルが選択されれば、該当プロトコルの既定のポート番号が自動で入力されます。もし、リモートコンピュータが異なるポート番号を使っていれば、ユーザーがポート番号を直接入力しなければなりません。各プロトコル別の既定値はSSH/SFTPは22、TELNETは23、そしてRLOGINは513です。

セッションが接続されている間、Keep Aliveメッセージを送信

リモートコンピュータにKeep Aliveメッセージを送信します。この機能はXshellを使用しない間、接続が突然切断される場合に役立ちます。いくつかのネットワーク環境ではゲートウェイ(Gateway)またはファイアウォール(Firewall)システムが一定時間の間データ転送がない接続を強制的に切断する場合があります。

予期しない接続が切断されたときに自動で再接続

ユーザーが直接接続を終了していない状況でネットワーク接続が切断されたときに自動で再接続します。

See Also

セッションのプロパティ


接続：ユーザー認証

Xshell 4 Help / 接続：ユーザー認証
接続：ユーザー認証

ユーザー認証設定では認証方法とユーザー名、パスワードユーザーキーなどを指定できます。

方法

認証方法を選択します。Password、Public Key、Keyboard Interactiveのうち一つ選択することができます。もし、選択した認証方法をSSHサーバーがサポートしなければ、接続中にユーザー認証方法を尋ねるダイアログボックスが現れます。

ユーザー名

ログインするユーザー名を入力します。ユーザー名はリモートコンピュータのログインアカウントです。空けておけば接続時にユーザー名を尋ねるダイアログボックスが現れます。

パスワード

リモートコンピュータユーザーアカウントのパスワードを入力します。この値はPassword認証が選択された場合に有効です。もし、この値を空けておけば、接続中にユーザー認証を尋ねるダイアログボックスが現れます。パスワードは暗号化されてユーザーのPCに保存されます。より良いセキュリティのためにはこの値を空けておきます。

ユーザーキー

公開キー認証が選択された場合、使用するユーザーキーを選択します。もし、この値を空けておけば、接続中にユーザー認証を尋ねるダイアログボックスが現れます。もし。一覧にユーザーキーがなければ、キーを生成した後リモートSSHサーバーに登録しなければなりません。

パスフレーズ選択したユーザーキーのパスフレーズを入力します。入力したキーパスフレーズは暗号化されてユーザーのPCに保存されます。より良いセキュリティのためにはこの値を空けておきます。

See Also

セッションのプロパティ


接続：ユーザー認証：ログインプロンプト

Xshell 4 Help / 接続：ユーザー認証：ログインプロンプト
接続：ユーザー認証：ログインプロンプト

TELNETまたはRLOGINプロトコルを使用する場合、ログイン過程を自動で遂行するためにXshellがサーバーのユーザー名/パスワードプロンプトを認識する必要があります。一般的な場合には、既定値をそのまま使用すれば良いです。

TELNET

TELNETログイン過程を自動化するためのユーザー名とパスワードプロンプトを入力します。空白文字も有効なので注意してください。

RLOGIN

RLOGINプロトコルのためのパスワードプロンプトを入力します。rloginサーバーの設定によりパスワードが必要でないこともあります。空白文字も有効なので注意してください。

See Also

セッションのプロパティ


接続：ログインスクリプト

Xshell 4 Help / 接続：ログインスクリプト
接続：ログインスクリプト

ログインスクリプト設定ではターミナルに自動で入力されるコマンドを定義することができます。リモートサーバーに正常にログインした後、一覧に現れた順序に従ってコマンドが順に実行されます。この機能は最初のログイン後、他のサーバーで再びログインしなければならない場合に非常に役立ちます。

次の待機および送信ルールを実行します。

待機および送信ルールを使用するにはこのオプションを選択します。

追加

待機および送信ルールダイアログボックスを開きます。ルールの編集が終われば一覧に追加されます。

編集

待機および送信ルールダイアログボックスを開いて選択されたルールを編集します。

セッション接続時にスクリプトを実行します。

セッション接続後、実行するスクリプト ファイルを決めることができます。

See Also

セッションのプロパティ


接続：SSH

Xshell 4 Help / 接続：SSH
接続：SSH

SSHプロトコルの一般的なオプションを設定できます。

プロトコルバージョン

使用するSSHプロトコルのバージョンを選択します。SSH1に比べてSSH2がより安全で多くの機能を提供します。

パスフレーズ処理にXagent(SSHエージェント)を使用する

Xagentを利用する場合に選択します。Xagentを利用すれば公開キーユーザー認証を遂行する時、ユーザーキーパスフレーズを入力する手間を省くことができます。

Xagent自動起動

必要な場合、Xagentを自動で実行します。このオプションを選択すれば、ユーザーがXagentをあらかじめ実行しなくても良いです。

ZLIB圧縮使用

圧縮アルゴリズムはSSH接続のすべてのデータを圧縮するために使われます。ネットワーク速度が遅い環境では圧縮を使用すれば速度向上の効果が得られます。

ターミナルの非割当

ターミナルを使用しない場合、このオプションを選択します。この機能はXshellのトンネリング機能だけを使用する時に役立ちます。

See Also

セッションのプロパティ


接続：SSH：セキュリティ

Xshell 4 Help / 接続：SSH：セキュリティ
接続：SSH：セキュリティ

暗号化

暗号化アルゴリズムはネットワークに転送されるデータを暗号化するために使われます。ユーザーは一覧で望む暗号化アルゴリズムを選択できます。もし、一覧で<Cipher List>を選択すれば、複数のアルゴリズムを試行することができます。<Cipher List>を編集するには、[編集]をクリックします。

MAC (メッセージン認証コード)

MACはデータの整合性を保障し、より良いセキュリティのためにSSH2で追加されたのです。もし、一覧で<MAC List>を選択すれば、複数のアルゴリズムを試行することができます。<MAC List>を編集するには、[編集]をクリックします。

See Also

セッションのプロパティ


接続：SSH：トンネリング

Xshell 4 Help / 接続：SSH：トンネリング
接続：SSH：トンネリング

トンネリング設定ではTCP/IP、DynamicおよびX11フォワーディングルールを設定できます。この設定は接続設定でプロトコルをSSHプロトコルを選択した場合のみ有効です。

詳しいトンネリング設定方法は“ トンネリングサービス ”を参照してください。

See Also

セッションのプロパティ


接続：SSH：SFTP

Xshell 4 Help / 接続：SSH：SFTP
接続：SSH：SFTP

SFTPプロトコルに関連したオプションを設定します。

スタートアップフォルダ

SFTPプロトコルを使用して正常にログインした後、作業を始めるローカルおよびリモートフォルダを設定します。

See Also

セッションのプロパティ


接続：TELNET

Xshell 4 Help / 接続：TELNET
接続：TELNET

TELNETプロトコルに関連したオプションを設定します。

XDISPLOC Telnetオプションを使用

XDISPLOCテルネットオプションを使用してログイン時にサーバーにディスプレイ(PC Xサーバーの情報)を伝達します。XmanagerなどのPC Xサーバーを使用する場合、このオプションを使用すれば、リモートサーバーのX11アプリケーションを容易にユーザーのコンピュータで使用できて非常に便利です。

ディスプレイ

ログイン時に伝達するディスプレイを入力します。$PCADDRキーワードはサーバーに伝えられる直前にPCのIPアドレス値に自動で変換されます。

See Also

セッションのプロパティ


接続：RLOGIN

Xshell 4 Help / 接続：RLOGIN
接続：RLOGIN

RLOGINプロトコルに関連したオプションを設定します。

ターミナル速度

rloginサーバーに伝達するターミナル速度を指定します。

See Also

セッションのプロパティ


接続：SERIAL

Xshell 4 Help / 接続：SERIAL
接続：SERIAL

SERIAL設定ではSERIAL接続のためのオプションを設定できます。RS232C SERIAL接続はUNIXシステムにビデオカードがなかったりコンソールに直接アクセスできない場合、既存の端末の代わりにPCを利用して接続できて便利です。Xshellを通じたSERIAL接続を使用するには、ホストシステムにSERIALインターフェイスがインストールされていなければなりません。

詳しいSERIAL設定方法は“ SERIAL接続 ”を参照してください。

See Also

セッションのプロパティ


接続：プロキシ

Xshell 4 Help / 接続：プロキシ
接続：プロキシ

プロキシサーバー

接続時に使用するプロキシサーバー設定を選択します。

プロキシ設定に関する詳しい内容は、“ プロキシ設定 ”を参照してください。

See Also

セッションのプロパティ


ターミナル

Xshell 4 Help / ターミナル
ターミナル

ターミナル設定ではターミナルの種類とその他ターミナル関連のオプションを設定できます。

ターミナルの種類

使用するターミナルの種類を選択します。XshellはVT100、VT102、VT220、VT320、ANSI、SCOANSI、LINUXおよびXTERMターミナルをサポートします。

接続すると次のターミナルサイズの使用

このセッションのターミナルサイズを指定したければ、このオプションを選択します。選択された場合、セッションが接続した時、縦と横の値でターミナルサイズが変更されます。選択されなかった場合、セッションに接続してもターミナルサイズは変更されません。

行

ターミナルの行の幅を入力します。ターミナルサイズはセッションが接続した時に調整できます。

列

ターミナルの列の個数を入力します。ターミナルサイズはセッションが接続した時に調整できます。

スクロールバッファー

スクロールバッファーのサイズを行単位で指定します。

消去されたスクリーンをスクロールバッファーに押します。

clearコマンドなどでターミナル作業画面を消した場合にも、スクロールバッファーに消された内容が残ってマウススクロールなどを利用して前の画面を再び見ることができます。

エンコード

ターミナルの出力エンコードを選択します。この値はリモートサーバーが使用する言語でなければなりません。既定の言語が選択された場合、XshellはユーザーWindowsの既定のエンコードを使用します。このオプションはキーボード入力値を変更せず、必要な場合、Windowsで提供するIME(Input Method Editor)を適切にインストールしなければなりません。

日中韓の不明な文字をワイド文字で処理

日中韓の不明な文字をワイド文字で認識します。

See Also

セッションのプロパティ


ターミナル：キーボード

Xshell 4 Help / ターミナル：キーボード
ターミナル：キーボード

キーボード設定ではユーザーPCのキーボードがサーバーに伝達する文字列を設定できます。

ファンクションキーエミュレーション

ターミナルの種類にともなうファンクションキーを設定します。<Default(既定)>を選択すれば、“ ターミナル ”設定で指定したターミナルの種類によって自動でファンクションキーが設定されます。

代替するキーマッピングファイルを指定してください。

ユーザーが定義したキーマッピングファイルを使用すれば、各ファンクションキー(F1～F20)が押された時、サーバーに送る文字列を直接指定できます。

Deleteキーシーケンス、Backspaceキーシーケンス

ユーザーがDeleteキーまたはBackspaceキーを押した時に送る文字列を選択します。

メタ(Meta)キーエミュレーション

EmacsなどのようにMetaキーを使用するアプリケーションのためにMetaキーエミュレーションを設定できるようにします。

See Also

セッションのプロパティ


ターミナル：VTモード

Xshell 4 Help / ターミナル：VTモード
ターミナル：VTモード

各ターミナルモードの初期値を設定します。

Auto Wrap Mode (DECAWM)

自動改行機能を始める時にアクティブ化します。

Origin Mode (DECOM)

Origin Modeをアクティブ化します。このオプションがアクティブ化すれば、サーバーが指定した位置を基準としてカーソルが移動します。

Reverse Video Mode (DECSCNM)

Reverse Video Modeを始める時にアクティブ化します。このオプションがアクティブ化すれば、画面の前景色と背景色が反転します。

New Line Mode (NLM)

New Line Modeを始める時にアクティブ化します。このオプションがアクティブ化すれば、ENTERキーが押された時にCRとLFを両方送ります。このオプションが選択されていない場合、ENTERキーはCRだけ送ります。

Insert Mode (IRM)

Insert Modeを始める時にアクティブ化します。このオプションがアクティブ化すれば、サーバーが送った文字をカーソル位置に既に存在する文字列を削除しないで挿入します。

Echo Mode (SRM)

このオプションがアクティブ化すれば、サーバーに送る文字列を画面に出力した後サーバーに転送します。

初期方向キーモード(DECCKM)

方向キーモードの初期値を設定します。

初期テンキーモード(DECNKM)

ターミナルの種類にともなうファンクションキーを設定します。

See Also

セッションのプロパティ


ターミナル：詳細

Xshell 4 Help / ターミナル：詳細
ターミナル：詳細

ターミナルに関連した詳細オプションを設定します。

Shiftキーでターミナルでマウス使用を制限する

viなど一部アプリケーションがマウスのクリックやドラッグを領域変更やファイル選択、ディレクトリ移動などの機能で使用する場合があります。このような場合にも、Shiftキーを押してマウスを使用すれば、Xshellがマウス入力を直接使ってテキスト選択などの機能で利用できます。

背景色でスクリーンを消去

画面を消す時、配色に設定された背景色でない現在のターミナルの背景色を使用します。

LFをCR+LFで受信

サーバーからLFを受信した時、ターミナル画面にCRとLFを両方出力します。

キーを押すと一番下にスクロール

ユーザーのキー入力時、ターミナル画面を一番下にスクロールします。

ターミナルで入出力する時に一番下にスクロール

ターミナル画面に文字が出力される時、画面を一番下にスクロールします。

破棄用のBACKSPACEの有効

Backspaceキーが押されれば、カーソル左の文字を消して、カーソルをその文字があった所に移動します。

点滅する文字の無効化

点滅する文字が点滅しないで固定されて現れます。

ターミナルタイトル変更の無効化

Xshellのタイトルバーのターミナルタイトルを変更しません。多くの場合、タイトルバーはリモートコンピュータの要求により作業フォルダとホスト名を表示することになります。

ターミナル印刷機能の無効化

サーバーからターミナル印刷要求を受けた場合、印刷しないで画面に出力します。

ターミナル代替スクリーン(Alternate Screen)転換を無効化

viのような一部アプリケーションのための代替スクリーンを使用しません。代替スクリーンを使用する場合、該当アプリケーションが終了すれば、ターミナル領域には該当アプリケーションを実行する前のスクリーンに代替されます。

ターミナルサイズ変更要求の無効化

サーバーのターミナルサイズ変更信号を無視します。

See Also

セッションのプロパティ


表示

Xshell 4 Help / 表示
表示

表示設定ではターミナルウィンドウのカラーとフォントを設定できます。

配色

セッションで使用する配色を選択します。Xshellはいくつかの既定の配色を提供し、新しい配色を追加したり、既存の配色を配色ダイアログボックスで編集できます。

フォント名

セッションに使われるフォントを選択します。固定幅フォントだけ羅列されます。標準ボタンのフォント アイコンを押してフォントを選択することもできます。

フォントサイズ

望むフォントのサイズを 選択 します。

太字

太字を表現する方法を選択します。

カーソル

カーソルの色と表示点滅などを指定します。

See Also

セッションのプロパティ


表示：余白

Xshell 4 Help / 表示：余白
表示：余白

余白設定ではXshellターミナルウィンドウの余白および間隔を設定できます。

余白

ターミナルウィンドウの余白を設定します。

間隔

ターミナルウィンドウの行間と文字幅と間隔を設定します。

See Also

セッションのプロパティ


詳細

Xshell 4 Help / 詳細
詳細

詳細設定でクイックコマンドセットとトレースおよびログのオプションを設定できます。

クイックコマンドセット

セッションで使用する既定のクイックコマンドセットを選択できます。該当セッションが起動する時に選択したクイックコマンドセットがクイックコマンドバーに表示されます。

クイックコマンドショートカットキーの無効化

Ctrl+F1、Ctrl+F2などのキーをクイックコマンドショートカットキーで使わず、該当キー値をサーバーに送ります。

See Also

セッションのプロパティ


詳細：トレース

Xshell 4 Help / 詳細：トレース
詳細：トレース

トレース設定ではプロトコルトレースオプションを設定できます。この機能は特定の問題状況を解決する時に役立ちます。トレースメッセージはターミナル画面に出力されます。

SSHバージョン、アルゴリズム交換およびユーザー認証

バージョン交換、暗号化アルゴリズム、圧縮方法、サーバーおよびユーザー認証などの情報を画面に出力します。

SSH TCP/IP および X11トンネリング

ポートフォワーディング関連の情報を画面に出力します。

TELNETオプションのネゴシエーション

Xshellとtelnetサーバー間のTELNETオプション交換過程を画面に出力します。

See Also

セッションのプロパティ


詳細：ログ記録

Xshell 4 Help / 詳細：ログ記録
詳細：ログ記録

ログ設定ではログ生成に関連したオプションを設定します。

接続時のログの開始

セッションがリモートホストに接続されれば自動でログを始めます。ログの記録方法で次の中から一つ選択できます。

· 印刷可能なテキストだけの記録

· 印刷可能なテキストのみならずターミナルコードも記録

ログのフォルダに自動で新しいファイルを作成します。

プログラムで基本で指定したフォルダに新しいファイルを生成してログメッセージを記録します。ファイル名は自動で与えられます。

次のファイルを使用します。

ユーザーが指定したフォルダにユーザーが指定した形式でログ メッセージを保存します。

ファイルパス

ログファイルのパスを指定します。ファイル生成時、%n、%d、%tはそれぞれ名前、日、時間に変換されます。

ブラウザボタン([…])

新しい名前で保存ダイアログボックスを開いてログ内容を記録するファイルを選択します。

指定したファイルが既に存在する場合に上書きします。

上で指定されたファイルが既に存在する場合、ログ内容を該当ファイルに上書きします。このオプションが選択されていない場合には、ファイル名の後に順次番号を付与して固有な名前のファイルを生成します。

セッション ログ記録を開始するときに問い合わせします。

ログが始まる時、保存ダイアログボックスを開いてユーザーがログを残すファイルを選択できるようにします。

See Also

セッションのプロパティ


ZMODEM

Xshell 4 Help / ZMODEM
ZMODEM

ZMODEM設定ではZMODEMファイル転送に関連した各種オプションを設定します。

自動でZMODEMをアクティブ化

リモートZMODEMプログラムが送信/受信を始める時、自動でファイル受信/送信を実行します。このオプションが選択されていなければ、ファイルメニューのファイル転送でZMODEM受信/送信を選択してファイルを受信しなければなりません。

ダウンロード前に常に確認

ダウンロードするたびに受信するフォルダを変更できます。

次のダウンロードパスを使用

ファイルを受信する時、保存するフォルダを尋ねないで指定されたフォルダに保存します。保存されるファイルの名前はリモートファイルの名前と同じく保存されます。もし、同じ名前のファイルが既に存在すれば、ファイル名に一連番号を付けます。

自動で名前の変更

ZMODEMを通じて受信しようとするファイルと同じ名前のファイルが既に存在する場合、ファイル名を自動で変更します。例)変更前：abc.txt,変更後：abc (2).txt

上書き

ZMODEMを通じて受信しようとするファイルと同じ名前のファイルが既に存在する場合、既にあったファイルに上書きします。

See Also

セッションのプロパティ


エクスポート

Xshell 4 Help / エクスポート
エクスポート

Xshellでエクスポートしたセッションは一つの簡便なセッションファイルに生成されます。このファイルをXshellがインストールされた他のコンピュータからインポートすれば、別途の設定なしで同じセッションを使用できます。

セッションをエクスポートするには：

1. [ファイル]メニューで[エクスポート]を選択します。

2. エクスポートしたセッションファイルを保存する位置を選択して[次へ]をクリックします。
結果：セッションエクスポートの結果が出力されます。

3. [完了]をクリックしてセッションエクスポートを終了します。

See Also

セッション管理


インポート

Xshell 4 Help / インポート
インポート

Xshellは他のコンピュータでエクスポートしたセッションファイルをインポートすることができます。

セッションをインポートするには：

1. [ファイル]メニューで[インポート]を選択します。

2. 他のコンピュータでエクスポートしたセッションファイルが保存された位置を直接入力するか、[…]ボタンをクリックしてセッションファイルを選択した後、[次へ]をクリックします。

3. [完了]をクリックしてセッションのインポートを終了します。

See Also

セッション管理


接続

Xshell 4 Help / 接続
接続

Xshell はセッションダイアログボックス、ローカルプロンプト、リンクバー、接続バー、そしてセッションショートカットなどの多様な接続方法を提供します。

See Also

セッションなしで接続
セッションを通じた接続
SERIAL接続
Xactivatorで接続
プロキシ設定


セッションなしで接続

Xshell 4 Help / セッションなしで接続
セッションなしで接続

ローカルプロンプトで接続するには：

1. 次のコマンドのうち一つをローカルプロンプトに入力してください：

· Xshell:\> telnet hostname

· Xshell:\> ssh hostname

· Xshell:\> rlogin hostname

* 参考

もし、リモートホストが既定のポート番号を使用しない場合、ポート番号を指定する必要があります。コマンドに関する情報は“ Xshellローカルコマンド ”を参照してください。

アドレスバーを通じて接続するには：

1. 次のコマンドのうち一つをアドレスバーに入力してください：

· telnet://hostname

· ssh://hostname

· rlogin://hostname

2. Enterキーを押すか[接続]をクリックしてください。

* 参考

アドレスバーでもユーザー名とポート番号を入力できます。詳しい情報は“ アドレスバー ” セクションを参照してください。

See Also

接続


セッションを通じた接続

Xshell 4 Help / セッションを通じた接続
セッションを通じた接続

セッションダイアログボックスを通じて接続するには：

1. セッションダイアログボックスを開きます。

2. 接続するセッションを選択します。

3. [接続]をクリックします。

* 参考

もし、既にリモートホストに接続された場合には、新しい接続のための新しいタブが開くか新しいXshellが実行されます。

ローカルプロンプトを通じて接続するには：

1.   次のコマンドを Xshell ローカルプロンプトに入力します。
Xshell:\> open session

ショートカットを通じて接続するには：

1. セッションのショートカットアイコンを2回クリックします。

* 参考

セッションショートカットに関する情報を見るには“ セッション管理 ”セクションを参照してくください。

See Also

接続


SERIAL接続

Xshell 4 Help / SERIAL接続
SERIAL接続

RS232C SERIAL接続はUNIXシステムにビデオカードがなかったりコンソールに直接アクセスできない場合、既存の端末の代わりにPCを利用して接続できて便利です。Xshellを通じたSERIAL接続を使用するには、ホストシステムにSERIALインターフェイスがインストールされていなければなりません。

SERIALで接続するには：

1. [ファイル]メニューで[新規]を選択します。新しいセッションのプロパティダイアログボックスが現れます。

2. [名前]にセッション名を入力します。

3. [プロトコル]一覧でSERIALを選択します。

4. [カテゴリ]で[SERIAL]を選択します。

5. [Port]にXshellがインストールされたPCに接続されたRS232Cシリアルポートの番号を選択します。

6. [Baud Rate]で通信速度を選択します。サーバーの値と一致するようにしなければなりません。一般的に9600を使用します。

7. [Data Bits]で転送されるデータ単位のビット数を選択します。サーバーの値と一致するようにしなければなりません。

8. [Stop Bits]に転送されるデータ単位の終わりを現わすためのビット数を選択します。サーバー設定に従って選択します。

9. [Parity]は転送資料のエラーを検証するためのもので、サーバー設定によりNone、Odd、Even、Mark、Spaceのうち一つを選択します。

10. [OK]をクリックして新しいセッションを生成します。

11. 生成されたセッションで“ セッションを通じた接続 ”で説明したように接続できます。

See Also

接続


Xactivatorで接続

Xshell 4 Help / Xactivatorで接続
Xactivatorで接続

Xactivatorはシステムトレイにアイコンの形態で実行されます。Xactivatorを利用すれば、新しいXshellウィンドウを開いたり新しいセッション接続を簡単に始めることができ、Xshellウィンドウを選択したり閉じる時にも便利です。

Xactivatorを起動するには：

1. [ツール]メニューで[Xactivator実行]を選択します。Xactivatorが実行されてシステムトレイにアイコンが生成されます。

Xactivatorで新しいセッション接続を開始するには：

1. Xactivatorシステムトレイアイコンでマウス右ボタンをクリックします。

2. ポップアップメニューで[セッション]にマウスを位置させて、すべてのセッションをサブメニューに羅列します。

3. 接続するセッションを選択します。

See Also

接続


プロキシ設定

Xshell 4 Help / プロキシ設定
プロキシ設定

プロキシサーバーはユーザーが属したネットワークと接続しようとする外部ネットワークの間で仲介役割をするサーバーです。

プロキシの一覧ダイアログボックスでプロキシサーバーを追加、編集、削除できます。

プロキシサーバーを追加するには：

1. セッションのプロパティダイアログボックスの[接続 > プロキシ]の[プロキシサーバー]で[参照]をクリックします。

2. プロキシの一覧ダイアログボックスで[追加]をクリックします。結果：プロキシ設定ダイアログボックスが現れます。

3. プロキシサーバーの名前とプロキシサーバーの種類およびホスト情報とユーザー情報を入力します。

4. [OK]を押して追加します。

See Also

接続


セキュリティ

Xshell 4 Help / セキュリティ
セキュリティ

Xshellは公開キーユーザー認証を提供します。

Xshellで生成したホストキーとユーザーキーデータベースはXmanagerとXftpプログラムで使用できるので、ユーザーが一度公開キーを生成すれば、追加的な設定過程なしですべてのプログラムで使用できます。

See Also

公開キーユーザー認証
ホストキーの管理


公開キーユーザー認証

Xshell 4 Help / 公開キーユーザー認証
公開キーユーザー認証

公開キーユーザー認証を使用するために、ユーザーは公開キーと秘密キーから成るユーザーキーペアを生成しなければなりません。公開キー認証が進行する時、秘密キーはユーザーの署名を作成するためにXshellが使用し、公開キーはその署名を確認するためにSSHサーバーが使用します。

ユーザーキーはSSHサーバー、Xshell両方で生成が可能です。もし、サーバー側で生成されたとすれば、ユーザーは秘密キーをXshellのインポート機能を利用してXshellの秘密キー保存場所に登録しなければなりません。もし、Xshellで生成されたとすれば、ユーザーは公開キーをサーバーに登録しなければなりません。

ユーザーキーを生成するには：

1. [ツール]メニューで、[新しいユーザーキーウィザード]を選択します。

2. 新しいユーザーキーウィザードの案内に従ってユーザーキーを生成します。

* 参考

キー生成の最後の段階で公開キーをサーバーに登録できます。登録方法はサーバーの種類によって異なります。

· SSH1：公開キーを$HOME/.ssh/authorized_keysファイルにコピーして入れます。設定ファイルとディレクトリの書き込み権限をなくすために次のコマンドを実行します。
$ cd
$ chmod go-w . .ssh .ssh/authorized_keys

· SSH2-OpenSSH: OpenSSHサーバーはこの形式を使用します。公開キーを$HOME/.ssh/authorized_keys2ファイルにコピーして入れます。設定ファイルとディレクトリの書き込み権限をなくすために次のコマンドを実行します。
$ cd
$ chmod go-w . .ssh .ssh/authorized_keys2

· SSH2-IETF SECSH：ssh.comのサーバーのようにいくつかの商用SSHサーバーはこの形式を使用します。公開キーをmypublickey.pubのように固有な名前で保存して$HOME/.ssh2ディレクトリにコピーします。$HOME/.ssh2/authorizationファイルに次のラインを追加します：
Key mypublickey.pub
設定ファイルとディレクトリの書き込み権限をなくすために次のコマンドを実行します。
$ cd
$ chmod go-w . .ssh2
$ chmod go-w .ssh2/authorization .ssh2/mypublickey.pub

公開キーをサーバーに登録するには：

1. [ツール]メニューで[ユーザーキーマネージャ]を選択してユーザーキーダイアログボックスを開きます。

2. 登録するユーザーキーを選択します。

3. [プロパティ]をクリックします。ユーザーキーのプロパティダイアログボックスが現れます。

4. [公開キー]タブをクリックします。

5. [公開キーの形式]一覧で、適切な形式を選択します。

6. [ファイルに保存]をクリックして保存するか、キーの内容をコピーして上の公開キー登録方法に従ってサーバーに登録します。

ユーザーキーのパスフレーズを変更するには：

1. ユーザーキーダイアログボックスを開きます。

2. パスフレーズを変更するユーザーキーを選択します。

3. [プロパティ]をクリックします。ユーザーキーのプロパティダイアログボックスが現れます。

4. [全般]タブをクリックします。

5. [パスフレーズの変更]をクリックします。

* 参考

“ ユーザーキーダイアログボックス ”でユーザーキーのエクスポート、インポート、名前の変更、削除、生成などの操作ができます。

See Also

セキュリティ
ユーザーキーダイアログボックス


ユーザーキーダイアログボックス

Xshell 4 Help / ユーザーキーダイアログボックス
ユーザーキーダイアログボックス

ユーザーキーダイアログボックスはユーザーキーを生成および管理できるようにします。[ツール]メニューの[ユーザーキーマネージャ]を選択して開くことができます。

インポート

オープンダイアログボックスを開いてユーザーキーファイルを選択し、インポートできます。現在、XshellはSSH1プロトコルのRSAキーと、OpenSSH SSH2プロトコルのRSA/DSAキー、SSH.COMキーおよびNetSarangユーザーキーの形式を読み込むことができます。

エクスポート

保存ダイアログボックスを開いて選択されたユーザーキーファイルを保存します。エクスポートするファイルの形式はNetSarangユーザーキー形式とOpenSSH SSH2形式です。NetSarang User Key Files(ユーザーキー形式)のファイルはNetSarang Computer, Inc.で開発したプログラムで使用することができ、他社のアプリケーションでは使用できません。

削除

選択されたユーザーキーをデータベースから削除します。

名前の変更

選択されたユーザーキーの名前を変更します。キー名はファイル名として有効なものでなければなりません。

プロパティ

ユーザーキーのプロパティを表示します。種類、長さ、拇印、公開キーなどを見ることができ、キーパスフレーズを変更することができます。

生成

新しいユーザーキーウィザードを開きます。

See Also

公開キーユーザー認証


ホストキーの管理

Xshell 4 Help / ホストキーの管理
ホストキーの管理

ホストキーはリモートホストの公開キーであり、ユーザーはキーの拇印を通じてホストを検証できます。

リモートホストは接続が成り立つ時、自身の公開キーを Xshell に送ります。初めて接続するホストやホストキーがデータベースに保存されていなければ、接続する時SSHセキュリティ警告ダイアログボックスが現れます。ホストキーが有効で信頼できるならば、ユーザーはホストキーをXshellホストキーのデータベースに保存します。

See Also

セキュリティ
SSHセキュリティ警告ダイアログボックス
ホストキーダイアログボックス


SSHセキュリティ警告ダイアログボックス

Xshell 4 Help / SSHセキュリティ警告ダイアログボックス
SSHセキュリティ警告ダイアログボックス

SSHセキュリティ警告ダイアログボックスはリモートホストのホストキーがホストキーのデータベースに保存されていなかったり、リモートホストキーと保存されているホストキーの拇印が異なる時に現れます。

一度受理

ホストキーを今回の接続のみ受け入れます。ホストキーは保存されず、次に接続する時同じダイアログボックスが現れます。サーバーのホストキーが頻繁に変化したり、該当サーバーにあまり接続しない場合に役立ちます。

受理および保存

ホストキーを保存して接続を続けます。次に接続する時にはSSHセキュリティ警告ダイアログボックスが現れません。拇印が確実で、このホストにしばしば接続する場合に役立ちます。

キャンセル

ホストキーを受け入れないで接続をキャンセルします。.

See Also

ホストキーの管理


ホストキーダイアログボックス

Xshell 4 Help / ホストキーダイアログボックス
ホストキーダイアログボックス

ホストキーダイアログボックスは接続が許されたホストに対するホストキーを管理できるようにします。[ツール]メニューの[ホストキーマネージャ]を選択して開くことができます。

インポート

オープンダイアログボックスを開いてホストキーをインポートします。インポートしたホストキーはホストキーのデータベースに保存され、ホストキーダイアログボックスに現れます。SECSH公開キー形式で保存されたファイルをインポートできます。

エクスポート

保存ダイアログボックスを開いて選択されたホストキーをエクスポートします。エクスポートしたキーはSECSHの公開キー形式で保存され、他のプログラムでも使用できます。

削除

選択されたホストキーをデータベースから削除します。

表示

メモ帳に選択されたホストキーファイルを開きます。

See Also

ホストキーの管理


トンネリングサービス

Xshell 4 Help / トンネリングサービス
トンネリングサービス

Xshell は信頼できないネットワーク環境を通じて接続されたユーザーのPCと他のコンピュータにセキュリティトンネルを生成して安全にデータを転送するTCP/IPおよびX11フォワーディング機能を提供します。

See Also

TCP/IPポートフォワーディング
X11フォワーディング
SOCKS4/5動的ポートフォワーディング
インスタントトンネリング


TCP/IPポートフォワーディング

Xshell 4 Help / TCP/IPポートフォワーディング
TCP/IPポートフォワーディング

暗号化トンネルを通じたポートフォワーディングサービスを利用するためには、それぞれのアプリケーションに対するポートフォワーディングルールを定義しなければなりません。

* 参考

Localフォワーディングの場合、ローカルPCのリッスンするポートを通じた接続を対象ホストの特定ポートに伝達します。

Remoteフォワーディングの場合、リモートホストのリッスンするポートを通じた接続を対象ホストの特定ポートに伝達します。この場合、対象ホストは大部分‘localhost’です。

DynamicフォワーディングはLocalフォワーディングと同じ方法で動作するが特定対象ホストを決めません。参考に、DynamicフォワーディングはSOCKSプロキシプロトコルを使用し、SOCKSプロトコルの既定のポート番号は1080番です。

セッションに新しいポートフォワーディングルールを追加するには：

1. セッションダイアログボックスを開きます。

2. ポートフォワーディングルールを編集するセッションを選択します。

3. 標準ボタンで[プロパティ]をクリックします。

4. [カテゴリ]で[接続：SSH：トンネリング]を選択します。

5. [追加]をクリックしてフォワーディングルールダイアログボックスを開きます。

6. [種類]一覧で接続の種類を選択します。

7. [ソースホスト]にlocalhostまたはIPアドレスを入力します。

8. [リッスンするポート]にポート番号を入力したりサービス名を選択します。

9. [対象ホスト]にサーバープログラムが駆動されているホストの名前やIPアドレスを入力してください。

10. [宛先ポート]にサーバープログラムが待機しているポート番号を入力してください。

11. [説明]に該当フォワーディングルールに関する説明を入力できます。

12. [OK]をクリックします。

フォワーディングルールを変更するには：:

1. セッションダイアログボックスを開きます。

2. ポートフォワーディングルールを編集するセッションを選択します。

3. 標準ボタンで[プロパティ]をクリックします。

4. [カテゴリ]で[接続：SSH：トンネリング]を選択します。

5. 変更するフォワーディングルールを選択します。

6. [変更]をクリックします。

ポートフォワーディングルールを削除するには：

1. セッションダイアログボックスを開きます。

2. ポートフォワーディングルールを削除するセッションを選択します。

3. 標準ボタンで[プロパティ]をクリックします。

4. [カテゴリ]で[接続：SSH：トンネリング]を選択します。

5. 削除するフォワーディングルールを選択します。

6. [削除]をクリックします。

See Also

トンネリングサービス


X11フォワーディング

Xshell 4 Help / X11フォワーディング
X11フォワーディング

X11フォワーディングはTCP/IPポートフォワーディングの特別な場合です。X11プロトコルはPC Xサーバーソフトウェアが使用し、接続がリモートホストからユーザーPCで成立するので、Eメールやテルネットのような他のクライアントプログラムと反対の場合ということができます。X11フォワーディングを利用すれば、複雑なポートフォワーディング設定なしでリモートのX11アプリケーションを安全な暗号化トンネルを通じてユーザーPCで使用できます。

X11フォワーディングサービスを使用するためには、XshellとSSHサーバーの両方を設定しなければなりません。

XshellでX11フォワーディングをアクティブ化するには：

1. セッションダイアログボックスを開きます。

2. X11フォワーディングをアクティブ化するセッションを選択します。

3. 標準ボタンで[プロパティ]をクリックします。

4. [カテゴリ]で[接続：SSH：トンネリング]を選択します。

5. [X11 接続を次にフォワードします]を選択します。

6. もし、ユーザーのPCにXmanager®がインストールされていれば、[Xmanager]を選択します。
もし、他のPC Xサーバーを使用するならば、[X DISPLAY]を選択して適切なDISPLAYを入力します。

7. [OK]をクリックします。

* 参考

Xmanager の場合、X DISPLAYオプションをXshellが自動で探します。他のPC Xサーバープログラムはユーザーが直接設定しなければなりません。もし、PC XサーバーがTCP 6000番ポートを使用しているならば、DISPLAYは“localhost:0.0”で設定します。

OpenSSHサーバーでX11フォワーディングをアクティブ化するには：

1. /etc/ssh/sshd_configファイルを開きます。

2. X11Forwardingオプションの値を下のように設定します:
X11Forwarding             yes

3. SSHサーバーを再開します。

ssh.comサーバーでX11フォワーディングをアクティブ化するには：

1. /etc/ssh2/sshd2_configファイルを開きます。

2. AllowX11Forwardingオプションの値を下のように設定します：
AllowX11Forwarding        yes

3. SSHサーバーを再開します。

See Also

トンネリングサービス


SOCKS4/5動的ポートフォワーディング

Xshell 4 Help / SOCKS4/5動的ポートフォワーディング
SOCKS4/5動的ポートフォワーディング

動的ポートフォワーディングはローカルネットワークにある接続をSSHサーバーに伝達するフォワーディング方法の一つで、伝えられる対象ホストとポートがSOCKSプロトコルによって自動で決定される方式です。動的ポートフォワーディングを使用すれば、XshellをSOCKSプロキシサーバーで使用できるようになります。

セッションに新しい動的ポートフォワーディングルールを追加するには：

1. セッションダイアログボックスを開きます。

2. ポートフォワーディングルールを編集するセッションを選択します。

3. 標準ボタンで[プロパティ]をクリックします。

4. [カテゴリ]で[接続：SSH：トンネリング]を選択します。

5. [追加]をクリックしてフォワーディングルールダイアログボックスを開きます。

6. [種類]一覧でDynamic(SOCKS4/5)を選択します。

7. [リッスンするポート]にポート番号を入力したりサービス名を選択します。SOCKSプロキシサーバーの既定のポートは1080番です。

8. [OK]をクリックします。

* 参考

動的ポートフォワーディングの場合には、対象ホストとポートを入力する必要がありません。

See Also

トンネリングサービス


インスタントトンネリング

Xshell 4 Help / インスタントトンネリング
インスタントトンネリング

インスタントトンネリング機能はセッションが接続されている状態でフォワーディングルールを追加、除去、一時停止、再開できるようにする機能です。現在のセッションのトンネリング状態はXshellターミナルウィンドウの下方にあるトンネリングペインで確認できます。トンネリングペインを表示するには、[表示]メニューで[トンネリングペイン]を選択してください。

トンネリングペインでポートフォワーディングルールを追加するには：

1. トンネリングペインで[フォワーディングルール]タブをクリックします。

2. 一覧でマウス右ボタンをクリックします。

3. メニューで[追加]を選択します。フォワーディングルールダイアログボックスが現れます。

* 参考

新しく追加されたルールは保存しない限り現在の接続にのみ適用され、接続が終われば削除されます。

トンネリングペインでポートフォワーディングルールを削除するには：

1. トンネリングペインで[フォワーディングルール]タブをクリックします。

2. [フォワーディングルール]一覧で削除したいルールでマウス右ボタンをクリックします。

3. メニューで[削除]を選択します。

ポートフォワーディングルールを中断するには：

1. トンネリングペインで[フォワーディングルール]タブをクリックします。

2. [フォワーディングルール]一覧で中断したいルールでマウス右ボタンをクリックします。

3. メニューで[中断]を選択します。

ポートフォワーディングルールを再開するには：

1. トンネリングペインで[フォワーディングルール]タブをクリックします。

2. [フォワーディングルール]一覧で再開するルールでマウス右ボタンをクリックします。

3. メニューで[再開]を選択します。

* 参考

再開は以前に中断したルールに対してのみ実行できます。

See Also

トンネリングサービス


ターミナルウィンドウ作業

Xshell 4 Help / ターミナルウィンドウ作業
ターミナルウィンドウ作業

Xshell はリモートホストのコマンドラインインターフェイスとローカルプロンプトを同時に使用できるようにする簡潔ながらも強力なターミナルウィンドウを提供します。また、ターミナルウィンドウはコピーと貼り付け、文字列の検索、フォントおよび色の変更、詳細ターミナルオプションなど多様で便利な機能を提供します。

See Also

コピーと貼り付け
文字列の検索
フォントの変更
文字色と背景色の設定
カーソルの設定を変更する
Xshellウィンドウを扱う
マルチセッションを扱う
クイックコマンドセットの設定
エンコードの変更
詳細ターミナルオプションの設定
レイアウト管理


コピーと貼り付け

Xshell 4 Help / コピーと貼り付け
コピーと貼り付け

文字列を選択するには：

1. 次の中から一つの方法を選択します：

  • 選択する領域の始点でマウス左ボタンを押します。ボタンを押したままマウスを動かして選択する領域の終点でマウス ボタンを置きます。選択された文字列は反転した色で表示されます。
  • 選択する文字列の始点でマウス左ボタンを押します。マウスを動かして選択する領域の終点に移動します。Shiftキーを押したまま左ボタンをもう一度押します。
  • 選択する単語を2回クリックします。2回クリックされた単語が選択されます。
  • 選択する行を早く3回クリックします。該当行全体が選択されます。

カラム単位で文字列を選択するには：

1. Altキーを押します。

2. 選択する領域の始点でマウス左ボタンを押します。ボタンを押したままマウスを動かして選択する領域の終点でマウスボタンを置きます。

選択された文字列をWindowsクリップボードにコピーするには：

1. コピーする文字列を選択します。

2. 次の中から一つの方法を選択します：

· [スマート選択]ボタンをクリックした後、[コピー]を選択します。

· [編集]メニューで[コピー]を選択します。

· 標準ボタンで[コピー]をクリックします。

· Ctrl+Insertキーを押します。

· オプションで[選択したテキストを自動でクリップボードにコピー]を設定すれば、選択したテキストが自動でコピーされます。

選択された文字列をメモ帳にコピーするには：

1. コピーする文字列を選択します。

2. 次の中から一つの方法を選択します：

· [スマート選択]ボタンをクリックした後、[メモ帳へ]を選択します。

· [編集]メニューで[メモ帳へ]を指した後、[選択した範囲]を選択します。

* 参考

選択された文字列だけでなく現在の画面やスクロールバッファーをコピーすることもできます。メモ帳ウィンドウはコピーされたテキストとともに自動で現れます。この機能は文字列をクリップボードにコピーしません。

クリップボードの内容をターミナル画面に貼り付けるには：

1. 次の中から一つの方法を選択します：

  • [編集]メニューで[貼り付け]を選択します。
  • 標準ボタンで[貼り付け]をクリックします。
  • Shift+Insertキーを押します。
  • マウス中央ボタンや右ボタンの動作を[Paste the clipboard contents (クリップボードの内容を貼り付けます。)]に選択した場合、該当マウスボタンをクリックします。

xtermスタイルのコピーおよび貼り付けを設定するには：

1. オプションダイアログボックスを開きます。

2. [キーボードとマウス]タブをクリックします。

3. [マウス-中央ボタン]の動作を[Paste the clipboard contents (クリップボードの内容を貼り付けます。)]に選択します。

4. [選択したテキストを自動でクリップボードにコピー]を選択します。

5. [OK]をクリックします。

* 参考

xtermプログラムは文字列を選択する時クリップボードにコピーし、中央ボタンを押す時ターミナル画面に貼り付けます。

See Also

ターミナルウィンドウ作業


文字列の検索

Xshell 4 Help / 文字列の検索
文字列の検索

スクロールバッファーを特定キーワードや正規表現を利用して検索できます。

キーワードで検索するには：

1. [編集]メニューで[検索]を選択します。

2. 検索ダイアログボックスで検索するキーワードを入力します。

3. [次の検索]をクリックします。

正規表現で検索するには：

1. [編集]メニューで[検索]を選択します。

2. 検索ダイアログボックスで検索するキーワードを入力します。

3. [正規表現]を選択します。

4. [次の検索]をクリックします。

* 参考

正規表現に関する詳しい情報は“ 正規表現 ”セクションを参照してください。

See Also

ターミナルウィンドウ作業


フォントの変更

Xshell 4 Help / フォントの変更
フォントの変更

ターミナル画面はその特性上行と列に合わせて文字を現わさなければならないので、Xshellでは固定幅フォントだけが選択できます。

ターミナルフォントとそのサイズを変更するには：

1. 次の中から一つの方法を選択します：

· 標準ボタンでフォントアイコンをクリックして望むフォントとサイズを選択します。

· セッションのプロパティダイアログボックスで[表示]カテゴリを選択した後、望むフォントとサイズを選択します。

太字表現方法を変更するには：

1. セッションのプロパティダイアログボックスを開きます。

2. [カテゴリ]で[表示]を選択します。

3. [太字]領域で望むオプションを選択します。

* 参考

太字は太字カラー、太字フォントまたは太字カラーと太字フォントすべてを使用できます。

See Also

ターミナルウィンドウ作業


文字色と背景色の設定

Xshell 4 Help / 文字色と背景色の設定
文字色と背景色の設定

配色には文字色と背景色、ANSI 16色などの情報が保存されます。Xshellは使用中いつでも配色を選択/変更できるようにし、選択された配色はすぐに適用されます。

ターミナルカラーを変更するには：

1. 次の中から一つの方法を選択します：

· 標準ボタンで[配色]をクリックすれば、配色選択ダイアログボックスが現れます。ダイアログボックスで望む配色を選択した後、[OK]をクリックします。

· セッションのプロパティダイアログボックスの[カテゴリ]で[表示]を選択した後、[配色]一覧で望む配色を選択して[OK]をクリックします。

* 参考

Xshell はいくつかの既定の配色を提供します。ユーザーは既存の配色を編集したり新しい配色を生成することができます。

新しい配色を生成するには：

1. 配色の選択ダイアログボックスを開きます。

2. [新規]をクリックします。新しい配色が一覧に追加されます。

3. 生成された配色を選択します。

4. [編集]をクリックします。配色編集ダイアログボックスが現れます。

配色を編集するには：

1. 配色の選択ダイアログボックスを開きます。

2. 編集する配色を選択します。

3. [編集]をクリックします。配色編集ダイアログボックスが現れます。

4. [標準テキスト]には標準文字に使われる色を選択します。

5. [太字]には太字に使われる色を選択します。一般的に太字の色は標準文字より明るい色を使用します。

6. [ANSIカラー]はターミナルでANSIカラーコードを表現するために使われる色です。上の色はblack、red、green、yellow、blue、magenta、cyanおよびwhiteの標準文字色で、下の色はそれぞれの太字の色です。

配色をエクスポートするには：

1. 配色の選択ダイアログボックスを開きます。

2. エクスポートする配色を選択します。

3. [エクスポート]をクリックします。保存ダイアログボックスが現れます。

4. フォルダを決めて保存するファイル名を入力します。

5. [保存]をクリックします。

* 参考

エクスポートしたファイルは“.xcs”という形式で、Xshellでのみ使用可能です。複数の配色が一個のファイルに保存されることがあります。配色の名前もファイルに一緒に保存されます。

配色をインポートするには：

1. 配色選択ダイアログボックスを開きます。

2. [インポート]をクリックします。オープンダイアログボックスが現れます。

3. インポートする配色ファイル(.xcs)を選択します。

4. [開く]をクリックします。

See Also

ターミナルウィンドウ作業


カーソルの設定を変更する

Xshell 4 Help / カーソルの設定を変更する
カーソルの設定を変更する

カーソルの色を変更するには：

1. セッションのプロパティダイアログボックスを開きます。

2. [カテゴリ]で[表示]を選択します。

3. [カーソルの色]の値を選択します。

4. [テキストの色]の値を選択します。

5. [OK]をクリックします。

カーソルの点滅有無を変更するには：

1. セッションのプロパティダイアログボックスを開きます。

2. [カテゴリ]で[表示]を選択します。

3. [点滅するカーソルの使用]を選択したり選択を解除します。

4. [OK]をクリックします。

カーソルの点滅速度を変更するには：

1. セッションのプロパティダイアログボックスを開きます。

2. [カテゴリ]で[表示]を選択します。

3. [点滅するカーソルの使用]を選択します。

4. [速度]にカーソルの点滅速度をミリ秒単位で入力します。

5. [OK]をクリックします。

See Also

ターミナルウィンドウ作業


Xshellウィンドウを扱う

Xshell 4 Help / Xshellウィンドウを扱う
Xshellウィンドウを扱う

システムトレイに最小化するには：

1. オプションダイアログボックスを開きます。

2. [詳細]タブをクリックします。

3. [システムトレイに最小化]を選択します。

4. [OK]をクリックして変更事項を保存します。

スタートアップ時にシステムトレイに最小化するには：

1. オプションダイアログボックスを開きます。

2. [詳細]タブをクリックします。

3. [Xshell スタートアップ時にシステムトレイに最小化]を選択します。

4. [OK]をクリックして変更事項を保存します。

すべての接続の終了時にXshellを終了するには：

1. オプションダイアログボックスを開きます。

2. [詳細]タブをクリックします。

3. [すべての接続の終了時に Xshell の終了]を選択します。

4. [OK]をクリックします。

接続終了時にローカルシェルへ復帰 するには：

1. オプションダイアログボックスを開きます。

2. [詳細]タブをクリックします。

3. [接続終了時にローカルシェルへ復帰]を選択します。

4. [OK]をクリックします。

新しいXshellウィンドウを生成するには：

1. [ウィンドウ]メニューで[新しいウィンドウ]を選択します。

他のXshellウィンドウに移動するには：

1. [ウィンドウ]メニューで[次へ]または[戻る]を選択します。

* 参考

Alt+RightとAlt+Leftキーを通じて同じ機能を遂行できます。

すべてのXshellウィンドウを同時に終了するには：

1. [ウィンドウ]メニューで[すべて閉じる]を選択します。

現在のウィンドウを除いたすべてのXshellウィンドウを終了するには：

1. [ウィンドウ]メニューで[このウィンドウ以外すべて閉じる]を選択します。

See Also

ターミナルウィンドウ作業


マルチセッションを扱う

Xshell 4 Help / マルチセッションを扱う
マルチセッションを扱う

マルチセッション機能は一つのXshellウィンドウで複数接続を維持してセッションタブやセッションバーを利用してセッションを移動しながら作業できるようにします。

一つの Xshell ウィンドウに複数のセッションを開くには：

1. オプションダイアログボックスを開きます。

2. [詳細]タブをクリックします。

3. [オプション]領域で[一つのXshellウィンドウに複数のセッションを開く]を選択します。

4. [OK]をクリックして変更事項を保存します。

セッションタブで新しい接続を生成するには：

1. セッションタブのタブ追加ボタンをクリックします。

2. セッションの一覧で一つ選択します。
結果：新しいタブに選択されたセッションが開きます。

セッションバーで新しい接続を生成するには：

1. セッションバーの一番左のアイコンをクリックします。

2. セッションの一覧で一つ選択します。

結果：新しいタブに選択されたセッションが開きます。

* 参考

新しい接続を生成するには、“ 接続 ”で説明するようにセッションを利用したりセッションなしで接続する方法を使ってもかまいません。

ローカルシェルでコマンドを入力してリモートコンピュータに接続するには：

1. セッションタブのタブ追加ボタンをクリックして[ローカルシェル]を選択するか、セッション タブの空いている空間を2回クリックしてローカルシェルセッションを生成します。

2. コマンドラインプロンプト状態でssh、telnet、sftpなどのコマンドを利用してリモートコンピュータに接続します。詳しいコマンドライン使用法のためには‘?’を入力します。

マルチセッション接続でセッション間を移動するには：

1. セッションを移動するには、次のうち一つの方法を使います。

· セッションタブを選択します。

· セッションバーに羅列されたセッション名を選択します。

· Ctrl+Tab、Shift+TabまたはCtrl+Shift+Tabを利用します。

· Alt+セッション番号で移動します。

新しいXshellウィンドウにセッション接続するには：

1. [ウィンドウ]メニューの[新しいターミナル]を選択するか、標準ボタンの[新しいターミナル]をクリックします。結果：新しいXshellウィンドウが開いて現在接続されているセッションと同じセッション情報に接続を試行します。

See Also

ターミナルウィンドウ作業


クイックコマンドセットの設定

Xshell 4 Help / クイックコマンドセットの設定
クイックコマンドセットの設定

しばしば使用する文字列をクイックコマンドで指定して使用すれば、繰り返されるキーボード入力をクイックコマンドクリックに代えることができます。クイックコマンドバーを表示するには[表示]メニューの[クイックコマンド]をチェックすれば良いです。

クイックコマンドセットを追加するには：

1. [ツール]メニューで[クイックコマンドセット]を選択します。結果：クイックコマンドセットダイアログボックスが現れます。

2. [新規]をクリックします。

3. 新しいクイックコマンドセットの名前を入力します。

* 参考

また、クイックコマンドセットダイアログボックスを開くために、クイックコマンドバーで[クイックコマンドセット]ボタンをクリックした後、一覧で[参照]を選択します。

クイックコマンドバーでクイックコマンドを追加するには：

1. クイックコマンドバーで定義されていないクイックコマンドボタンをクリックします。
また、ショートカットキー(Ctrl+F1など)を押すこともできます。
結果：クイック コマンドの編集ダイアログボックスが現れます。

2. [ラベル]にクイックコマンド名を、[テキスト]にしばしば使用するコマンドや文字列を入力します。

3. [OK]をクリックします。

クイックコマンドセットにクイックコマンドを追加するには：

1. [ツール]メニューで[クイックコマンドセット]を選択します。結果：クイックコマンドセットダイアログボックスが現れます。

2. クイックコマンドを追加するクイックコマンドセットを選択します。

3. [編集]をクリックします。結果：クイックコマンドセット編集ダイアログボックスが現れます。

4. クイックコマンドを選択した後[編集]をクリックします。結果：クイック コマンドの編集ダイアログボックスが現れます。

5. [ラベル]にクイックコマンド名を、[テキスト]にしばしば使用するコマンドや文字列を入力します。

6. [OK]をクリックします。

7. クイックコマンドをさらに追加するには4-6の過程を繰り返します。

8. クイックコマンドセット編集ダイアログボックスで[OK]をクリックします。

* 参考

また、現在クイックコマンドバーに表示されているクイックコマンドセットを編集するには、クイックコマンドバーで[クイックコマンドセット]ボタンをクリックした後、一覧で[編集]を選択してクイックコマンドセット編集ダイアログボックスを開きます。

クイックコマンドセット編集ダイアログボックスではクイックコマンドの追加、削除、編集が可能です。また、クイックコマンドバーに表示される順序を変更できます。

クイックコマンドバーに他のクイックコマンドセットを表示するには：

1. クイックコマンドバーで[クイックコマンドセット]ボタンをクリックした後、一覧でクイックコマンドセットを選択します。結果：選択されたクイックコマンドセットのクイックコマンドが羅列されます。

セッションを開始する時に表示されるクイックコマンドセットを選択するには：

1. セッションのセッションプロパティダイアログボックスを開きます。

2. [カテゴリ]の[詳細]を選択します。

3. セッションで使用するクイックコマンドセットを選択します。

4. [参照]を押してクイックコマンドセットダイアログボックスでクイックコマンドセットを変更したり新しく生成することができます。

5. [OK]をクリックします。

See Also

ターミナルウィンドウ作業


エンコードの変更

Xshell 4 Help / エンコードの変更
エンコードの変更

基本的に Xshell はWindowsシステムのユーザー既定の言語を使用します。ユーザーはリモートホストのエンコードによりWindowsシステムと異なる多様なエンコードを選択して使用できます。

セッションのエンコードを変更するには：

1. 次の中から一つの方法を選択します：

· 標準ボタンで[エンコード]をクリックして使用するエンコードを選択します。

· セッションのプロパティダイアログボックスを開いて[カテゴリ]の[ターミナル]を選択した後、[エンコード]一覧で望むエンコードを選択します。

2. UTF-8エンコード出力：

· リモートコンピュータがユニコード(UTF-8)をサポートし、UTF-8を使用するように設定されていれば、エンコードを‘ユニコード(UTF-8)’を使用しなければなりません。UTF-8エンコードは複数の言語の文字セットを同時に出力できます。

* 参考

選択されたエンコードを正しく表示するためには、該当Windowsシステムに選択されたエンコードの言語パックがインストールされていなければなりません。

エンコードオプションはキーボードの入力値を変更せず、必要な場合、Windowsで提供するIME (Input Method Editor)を適切にインストールしなければなりません。

See Also

ターミナルウィンドウ作業


詳細ターミナルオプションの設定

Xshell 4 Help / 詳細ターミナルオプションの設定
詳細ターミナルオプションの設定

スクロールバッファーのサイズを変更するには：

1. セッションのプロパティダイアログボックスを開きます。

2. [カテゴリ]で[ターミナル]を選択します。

3. [スクロールバッファー]に使用するライン数を入力します。

4. [OK]をクリックします。

* 参考

スクロールバッファーのサイズは0～2,147,483,647の間の値です。0はスクロールバッファーを使用しないという意味です。

ターミナルの種類を変更するには：

1. セッションのプロパティダイアログボックスを開きます。

2. [カテゴリ]で[ターミナル]を選択します。

3. [ターミナルの種類]でターミナルの種類を選択します。

4. [OK]をクリックします。

ターミナルを開始する時のサイズを変更するには：

1. セッションのプロパティダイアログボックスを開きます。

2. [カテゴリ]で[ターミナル]を選択します。

3. [エミュレーション]領域で[接続すると次のターミナルサイズの使用]を選択します。

4. [行]に行のサイズを入力します。

5. [列]に列のサイズを入力します。

6. [OK]をクリックします。

キーパッドモードを変更するには：

1. セッションのプロパティダイアログボックスを開きます。

2. [カテゴリ]で[ターミナル：VTモード]を選択します。

3. [初期テンキーモード]で[標準]または[アプリケーション]を選択します。

4. [OK]をクリックします。

See Also

ターミナルウィンドウ作業


レイアウト管理

Xshell 4 Help / レイアウト管理
レイアウト管理

レイアウト管理機能はユーザーの作業環境や記号にともなう Xshell ウィンドウのレイアウトを保存できる機能です。レイアウト管理ダイアログボックスで保存したレイアウトを削除したり名前を変更できます。

現在のXshellウィンドウのレイアウトを保存するには：

1. [表示]メニューで[レイアウト]を選択した後、[名前を付けて保存]を選択します。

2. 名前を付けて保存ダイアログボックスで[新しい名前]を入力します。

3. [OK]をクリックします。

他のレイアウトにXshellウィンドウを変更するには：

· [表示]メニューで[レイアウト]を選択した後、レイアウト一覧から一つ選択します。

· Alt+Lを押してレイアウト一覧から一つ選択します。

登録されたレイアウト一覧を管理するには：

1. [表示]メニューで[レイアウト]を選択した後、[管理]を選択します。

2. レイアウト管理ダイアログボックスでレイアウトを削除したり名前を変更します。

See Also

ターミナルウィンドウ作業


オプション設定

Xshell 4 Help / オプション設定
オプション設定

オプションダイアログボックスはすべてのセッションに適用されるオプションを設定できるようにします。[ツール]メニューの[オプション]を選択して開くことができます。

See Also

セッションフォルダおよび起動セッション
履歴のクリアおよび接続ログ
キーマッピングの設定
マウスの設定
透明度の設定
詳細オプション


セッションフォルダおよび起動セッション

Xshell 4 Help / セッションフォルダおよび起動セッション
セッションフォルダおよび起動セッション

Xshellセッションフォルダパスを変更できます。セッションダイアログボックスには変更したパスの下のすべてのセッションが表示されます。ネットワークフォルダを選択すれば、他のユーザーとセッションを共有できます。

セッションフォルダを変更するには：

1. オプションダイアログボックスを開きます。

2. [全般]タブで[セッションフォルダパス]を入力します。

起動時に開くセッションを登録するには：

1. オプションダイアログボックスを開きます。

2. [全般]タブで[起動時に開くセッション]一覧の下の[追加]をクリックします。

3. オープンダイアログボックスでセッションファイルを選択します。

See Also

オプション設定


履歴のクリアおよび接続ログ

Xshell 4 Help / 履歴のクリアおよび接続ログ
履歴のクリアおよび接続ログ

履歴のクリアダイアログボックスではアドレスバー、作成バー、検索キーワード、ローカルシェル、そして接続ログのヒストリーを選択して削除できます。履歴設定ダイアログボックスでは接続ログに関する設定やログを保存するファイルを指定できます。

履歴をクリアするには：

1. オプションダイアログボックスを開きます。

2. [全般]タブで履歴[クリア]をクリックします。

3. 履歴のクリアダイアログボックスでクリアする内容を選択します。

4. [クリア]をクリックします。

接続ログを保存するには：

1. オプションダイアログボックスを開きます。

2. [全般]タブで履歴[設定]をクリックします。

3. 履歴設定ダイアログボックスで[接続情報を次のファイルに記録します。]を選択します。

4. 接続サーバー、接続プロトコル、接続日時、終了日時および接続時間に関する情報を保存するファイルを入力します。

See Also

オプション設定


キーマッピングの設定

Xshell 4 Help / キーマッピングの設定
キーマッピングの設定

ユーザー指定キーマッピングダイアログボックスでは現在設定されているショートカットキーび組み合わせを確認することができ、ユーザーがキーの組み合わせを追加、削除、編集できます。

キーマッピングを変更するには：

1. オプションダイアログボックスを開きます。

2. [キーボードとマウス]タブをクリックします。

3. [キーマッピング]の[編集]をクリックします。結果：カスタムキーマッピングダイアログボックスが現れます。

4. [現在のキー設定]一覧で変更するキーの組み合わせを選択した後、[編集]をクリックします。結果：編集ダイアログボックスが現れます。

5. [種類]のメニュー、文字列の送信、スクリプトの実行、アプリケーションの起動の中から一つ選択します。

6. [アクション]に選択した種類別メニューや文字列を入力します。

7. [OK]をクリックします。

See Also

オプション設定


マウスの設定

Xshell 4 Help / マウスの設定
マウスの設定

マウスの中央と右ボタンの動作をそれぞれ選択できます。また、2回クリックで単語を選択する時に使われる区切り記号を指定できます。

マウスボタンの動作を変更するには：

1. オプションダイアログボックスを開きます。

2. [キーボードとマウス]タブでマウス中央ボタンの機能の中から一つ選択します。

· Do nothing. (何もしません。)

· Open the popup menu. (ポップアップメニューを開きます。)

· Paste the clipboard contents. (クリップボードの内容を貼り付けます。)(既定値)

· Open Properties dialog. (プロパティウィンドウを開きます。)

3. 右ボタンの機能の中から一つ選択します。右ボタンの基本機能は[Open the popup menu (ポップアップメニューを開きます。)]です。

2回クリック選択時に区切り記号を変更するには：

1. オプションダイアログボックスを開きます。

2. [キーボードとマウス]タブの[選択]領域で単語を選択する時に使用する区切り記号を入力します。

See Also

オプション設定


透明度の設定

Xshell 4 Help / 透明度の設定
透明度の設定

Xshellはウィンドウの透明度設定機能を提供します。

ウィンドウが透明に見えるように設定するには：

1. [表示]メニューの[透明]を選択します。

2. オプションダイアログボックスを開きます。

3. [ビュー]タブで透明度を設定します。

4. [不透明度]値を設定します。不透明度値が小さいほどXshellウィンドウが透明になります。

5. [マウスポイント上のウィンドウを不透明で表示 ]オプションを選択すれば、Xshellウィンドウを透明に表示で設定された場合にも、マウスがウィンドウ上に位置する間はXshellウィンドウを不透明に表示します。

6. [透明の場合、いつも上に表示]オプションを選択すれば、Xshellウィンドウを透明に使用する間すべてのウィンドウ上に表示します。

See Also

オプション設定


詳細オプション

Xshell 4 Help / 詳細オプション
詳細オプション

詳細オプションはオプションダイアログボックスの[詳細]タブで設定できるオプションです。

ESCキーを 押すと英文の入力に転換

vi,vimなどのような一部アプリケーションでハングルを入力してコマンドモードに行くためにESCキーを押した場合、自動で英文入力状態に転換されます。

ベルの無効

ベルを使用しないように設定します。

簡単なコピー、ファイルダウンロードのためのスマート選択ボタンを使用

ターミナル領域をマウスで選択時、スマート選択ボタンを表示したり見えないように設定します。

システムトレイに最小化

Xshellが最小化される時にシステムトレイに最小化します。

全画面表示モードでセッションタブの表示

全画面表示モードでセッションタブを表示します。

全画面表示モードでスクロール バーの表示

全画面表示モードでスクロール バーを表示します。

現在のウィンドウサイズで重ねて表示

[ウィンドウ]メニューで重ねて表示を選択すれば、現在のXshellウィンドウサイズで配列されます。

Windowsスタートアップ時にXshellを実行

Windowsスタートアップ時にXshellを自動で駆動します。

Xshellスタートアップ時にシステムトレイに最小化

Xshellがスタートアップ時にシステムトレイに最小化されます。

Xshellスタートアップ時にセッションダイアログボックスを開く

Xshellがスタートアップ時にセッションダイアログボックスを開きます。

メニューアクセスにAltキーの使用

Altキーを押せばメニューが開きます。

一つのXshellウィンドウに複数のセッションを開く

一つのXshellウィンドウに複数のセッションが開くようにします。セッションタブとセッションバーを利用してセッション間で移動できます。

Xshell終了時に接続を切断するかを確認

プログラム終了時に接続中のセッションの終了可否を尋ねます。

セッションが中断された際に接続を切断するかを確認

セッション中断時に接続の切断可否を尋ねます。

接続終了時にローカルシェルへ復帰

接続終了時にローカルシェル状態にセッションタブが維持されます。ローカルシェルセッションではターミナル画面にXshellプロンプトが現れ、open、telnet、ssh、pingなどのようなローカルコマンドを実行できます。コマンド一覧を見るには、Xshellプロンプトでhelpまたは？を実行してください。

すべての接続の終了時にXshellの終了

すべてのセッション接続が終了すれば、Xshellプログラムを終了します。

See Also

オプション設定


ファイル転送

Xshell 4 Help / ファイル転送
ファイル転送

Xshell はSFTPとZMODEMプロトコルを利用してファイルを送信したり受信できるようにします。

See Also

SFTPを利用したファイル転送
ZMODEMを利用したファイル転送
Xftpと連動したファイル転送


SFTPを利用したファイル転送

Xshell 4 Help / SFTPを利用したファイル転送
SFTPを利用したファイル転送

SFTPはSSH基盤のファイル転送プロトコルで、ZMODEMと比べてより安全で速いファイル転送をサポートします。

SFTPでファイルを受信するには：

1. ローカルプロンプトでsftpコマンドでファイルを受信するホストに接続します。
Xshell:\> sftp hostname

2. sftp プロンプトでgetコマンドで望むファイルを受信します。
sftp:/home/user21> get filename

SFTPでファイルを送信するには：

1. ローカルプロンプトでsftpコマンドでファイルを送信するホストに接続します。
Xshell:\> sftp hostname

2. sftp プロンプトでputコマンドで望むファイルを送信します。
sftp:/home/user21> put filename

See Also

ファイル転送


ZMODEMを利用したファイル転送

Xshell 4 Help / ZMODEMを利用したファイル転送
ZMODEMを利用したファイル転送

ZMODEMを通じて転送されたファイルはユーザーが指定したフォルダに保存され、受信するたびに他のフォルダをユーザーが指定することもできます。

ZMODEMでファイルを受信するには：

1. 次のようなコマンドをリモートホストのプロンプトで実行します：
$ sz file1 file2 …

2. [ファイル]メニューで[転送]を指します。

3. [ZMODEMで受信]を選択します。

* 参考

もし、リモートホストにszコマンドが存在しない場合、ユーザーが直接インストールしなければなりません。多くの場合、それと類似したコマンドが存在します。

ターミナルでZMODEMでファイルを受信するには：

1. Xshellターミナルウィンドウでダウンロードするファイル名を選択します。
結果：スマート選択ボタンが選択されたファイル名の周辺に現れます。

2. スマート選択ボタンをクリックします。

3. [ZMODEMでダウンロード]を選択します。

ZMODEMでファイルを送信するには：

1. 次のようなコマンドをリモートプロンプトで実行します：
$ rz

2. [ファイル]メニューで[転送]を指します。

3. [ZMODEM で送信]を選択します。

4. 送信するファイルを選択します。

5. もし、ASCII形式で送信したければ、[ファイルをASCIIで送信]を選択します。

6. [開く]をクリックします。

ドラッグ＆ドロップを利用してZMODEMでファイル送信するには：

1. アップロードするWindowsファイルを選択します。

2. ファイルをドラッグしてXshellターミナルウィンドウにドロップします。
結果：ファイル転送が自動で進行します。

既定のファイル保存フォルダを変更するには：

1. セッションのプロパティダイアログボックスを開きます。

2. [カテゴリ]で[ZMODEM]を選択します。

3. [受信フォルダ]領域内で[次のダウンロード パスを使用]を選択します。

4. フォルダ参照ダイアログボックスを開いた後、受信したファイルを保存するフォルダを選択します。

5. [OK]をクリックします。

受信したファイルを閲覧するには：

1. セッションのプロパティダイアログボックスを開きます。

2. [カテゴリ]で[ZMODEM]を選択します。

3. [受信フォルダ]領域内の[開く]をクリックします。

See Also

ファイル転送


Xftpと連動したファイル転送

Xshell 4 Help / Xftpと連動したファイル転送
Xftpと連動したファイル転送

XshellはNetSarang Computer, Inc.のファイル転送プログラムであるXftpと連動して現在Xshellで接続中のホストに早くて容易にFTP/SFTP接続ができるようにします。

Xshellが接続中のホストにXftp接続を生成する：

1. Xshellでファイルを転送するホストに接続します。

2. [ウィンドウ]メニューで[新しいファイル転送]を選択します。または、標準ボタンで[新しいファイルを転送]をクリックします。

* 参考

Xshellが使用するプロトコルがSSHである場合、XftpはSFTP接続を試行し、その他にTELNET、RLOGINなどのプロトコルである場合、FTPを使用して接続します。

See Also

ファイル転送


セッションログとトレース

Xshell 4 Help / セッションログとトレース
セッションログとトレース

Xshell のログ機能を利用すればセッションを通じてやり取りしたすべての文字をファイルに残すことができます。また、デバッグ目的でトレース機能を利用することもできます。

See Also

セッションログ
セッショントレース


セッションログ

Xshell 4 Help / セッションログ
セッションログ

文字列だけをログするには：

1. [ファイル]メニューで[ログ]を指します。

2. [開始]を選択します。名前を付けて保存ダイアログボックスが現れます。

3. ログデータが保存されるファイル名を入力します。

4. [標準テキストのみならずターミナルコードも記録]の選択を解除します。

5. [保存]をクリックします。

* 注意

ログはセッションが終了する時まで続きます。セッションを終了しないでログを中断するには、[ファイル]メニューの[ログ]で[停止]を選択してください。

文字列とターミナル ードを一緒にログするには：

1. [ファイル]メニューで[ログ]を指します。

2. [開始]を選択します。名前を付けて保存ダイアログボックスが現れます。

3. ログデータが保存されるファイル名を入力します。

4. [標準テキストのみならずターミナルコードも記録] を選択します。

5. [保存]をクリックします。

セッション接続時にログを開始するには：

1. セッションのプロパティダイアログボックスを開きます。

2. [カテゴリ]で[ログ記録]を選択します。

3. [接続時のログの開始]を選択します。

4. ログを保存するフォルダまたはファイル名を指定できます。

5. [OK]をクリックします。

See Also

セッションログとトレース


セッショントレース

Xshell 4 Help / セッショントレース
セッショントレース

トレースオプションでリモートホストとやり取りするプロトコルコントロールデータをトレースできます。

SSHプロトコルの場合にはアルゴリズム交換とユーザー認証の細部事項をターミナル画面に出力することができ、TELNETプロトコルの場合には多様なオプション交換をトレースできます。この機能はリモートホストに接続する時に問題が発生した場合に有用に使用できます。

トレース機能を有効/無効にするには：

1. セッションのプロパティダイアログボックスを開きます。

2. [カテゴリ]で[トレース]を選択します。

3. オプションを適切に選択します。

4. [OK]をクリックします。

See Also

セッションログとトレース


印刷

Xshell 4 Help / 印刷
印刷

Xshell はターミナルウィンドウのテキストをローカルプリンタで印刷できる機能を提供します。Xshellはターミナルウィンドウで使われるフォントおよびカラーを印刷する時にもそのまま使用します。また、ページ設定ダイアログボックスで印刷される用紙の余白を設定できます。

用紙のサイズと方向を設定するには：

1. [ファイル]メニューで[ページ設定]を選択します。

2. 適切な用紙のサイズと方向を選択します。

3. 余白を入力します。

4. [OK]をクリックして変更事項を保存します。

印刷するには：

1. [ファイル]メニューで[印刷]を選択します。

2. [プリンター名]一覧でプリンタを選択します。

3. [OK]をクリックします。


Xagent使用

Xshell 4 Help / Xagent使用
Xagent使用

Xagent はSSH認証エージェント(authentication agent)です。Xagentは公開キーユーザー認証に使われるユーザーキーを有していてXshellでユーザーキーが必要な場合に、Xshellが該当キーを使用できるようにします。

Xagent はXshellユーザーキーのすべての一覧を維持し、必要な場合、ユーザーにキーパスフレーズの入力を要求します。ユーザーがキーパスフレーズを入力した場合、Xagentはユーザーキーを解除してメモリーに保存します。したがって、Xagentを使用すれば、ユーザーは同じキーに対して一度のキーパスフレーズの入力で該当キーを何度も使用できます。

Xagent はまたSSHのエージェントフォワーディング機能のためのSSH認証サーバーで動作します。SSHエージェントフォワーディング機能は初めて接続したサーバーから他のサーバーに接続する場合に必要です。基本的にユーザーキーはユーザーのPCにのみ保存されていて、初めて接続したサーバーから他のサーバーに接続を試行する場合にはそのキーの使用は不可能です。SSHエージェントフォワーディング機能はリモートサーバーのSSHクライアントプログラムが自分のPCのXagentが管理するユーザーキーを使用できるようにします。

* 参考

Xagent を実行すればXagentアイコンがシステムトレイに生成されます。Xagentダイアログボックスを閉じてもXagentは終了しないでずっと実行されます。Xagentを終了したりXagentダイアログボックスを開くには、システムトレイアイコン上のメニューを利用します。

See Also

Xagentを通じてサーバーに接続する
リモートホストでXagentのユーザーキーを使用する


Xagentを通じてサーバーに接続する

Xshell 4 Help / Xagentを通じてサーバーに接続する
Xagentを通じてサーバーに接続する

XshellがXagentを使用するように設定するには：

1. セッションのプロパティダイアログボックスを開きます。

2. [カテゴリ]で[接続：SSH]を選択します。

3. [パスフレーズ処理にXagent(SSH エージェント)を使用]を選択します。

4. [OK]をクリックします。

Xagentを通じてSSHサーバーに接続するには：

1. Xagent を使用するようにXshellを設定します。

2. Xagent が実行中でない場合、Xagentを実行します。

3. SSHサーバーに接続します。
この時、SSHサーバーは公開キーユーザー認証をサポートし、使用するユーザーキーの公開キーの部分がサーバーに登録されていなければなりません。

4. ユーザーキーパスフレーズダイアログボックスが現れます。選択されたユーザーキーのパスフレーズを入力します。

* 参考

接続：SSH設定で[Xagent自動起動]を選択した場合、2番の過程を省略できます。ユーザーキーパスフレーズダイアログボックスは選択されたキーの状態がCloseの時のみ現れます。ユーザーキーの状態はXagentのユーザーキー一覧で確認できます。

See Also

Xagent使用


リモートホストでXagentのユーザーキーを使用する

Xshell 4 Help / リモートホストでXagentのユーザーキーを使用する
リモートホストでXagentのユーザーキーを使用する

Xagent を使用すればリモートホストにあるsshクライアントがXshellが使用するユーザーキー、すなわちXagentが持っているユーザーキーを使用できます。リモートホストでXagentのユーザーキーを使用するには、XshellとリモートホストのSSHサーバーがエージェントフォワーディング機能をサポートしなければなりません。

ssh.comサーバーでエージェントフォワーディングをアクティブ化するには：

1. /etc/ssh2/sshd2_configファイルを開きます。

2. AllowAgentForwardingオプションの値を下のように設定します：
AllowAgentForwarding      yes

3. SSHサーバーを再起動します。

* 参考

OpenSSHサーバーはno-agent-forwardingオプションを指定しない限りエージェントフォワーディング機能が常にアクティブ化しています。

Xagentのキーをリモートホストで利用するには：

1. Xagent を使用するようにXshellを設定します。

2. Xagent が実行中でない場合、Xagentを実行します。

3. SSHサーバーに接続してログインします。

* 参考

サーバーがエージェントフォワーディングをサポートすれば、ログインした時にエージェントフォワーディングのための環境変数(SSH_AUTH_SOCKあるいはSSH2_AUTH_SOCK)が適切に設定されます。

4. リモートサーバーで公開キー認証をする他のサーバーに接続します。

5. ユーザーキーパスフレーズダイアログボックスが現れれば、選択されたユーザーキーのパスフレーズを入力します。

* 参考

[ユーザーキーパスフレーズ]ダイアログボックスは選択されたキーの状態がCloseの時のみ現れます。ユーザーキーの状態はXagentのユーザーキー一覧で確認できます。

See Also

Xagent使用


スクリプト使用

Xshell 4 Help / スクリプト使用
スクリプト使用

スクリプトは一度に実行するコマンドを集めた一つのファイルです。繰り返された作業をファイルで生成してコマンドをいちいちタイピングしないで一括的に実行できて便利で、Visual Basicスクリプトで作成されます。

See Also

スクリプトの開始と終了
スクリプトAPI


スクリプトの開始と終了

Xshell 4 Help / スクリプトの開始と終了
スクリプトの開始と終了

スクリプトファイルを開始するには：

1. [ツール]メニューで[スクリプト]を指した後、[実行]を選択します。
結果：オープンダイアログボックスが現れます。

2. スクリプトファイルを選択します。

3. [OK]をクリックします。

スクリプトファイルを実行中に終了する

1. [ツール]メニューで[スクリプト]を指した後、[キャンセル]を選択します。

See Also

スクリプト使用


スクリプトAPI

Xshell 4 Help / スクリプトAPI
スクリプトAPI

Xshellは次のスクリプトAPIを提供します。このAPIを利用すれば反復的な作業の自動化に使用できます。

See Also

スクリプト使用
xsh.Session
xsh.Screen
Script例題


xsh.Session

Xshell 4 Help / xsh.Session
xsh.Session

次の関数と変数はXshellセッションで使用できます。この関数と変数を使用するためにはxsh.Sessionと一緒に実行します。例えば‘sleep’関数を使用するには、‘xsh.Session.sleep(1000)’のように使用します。

Functions
戻り値 | 関数 | パラメータ | 説明
Void | OpenSession(LPCTSTR lpszSession) | lpszSession 文字列でXshellセッションパスやXshellが使用するURL形式です。 | 新しいセッションやURLを開きます。 セッションを開くためには/sオプションを文字列の一番前に置きます。例)A.xshセッションを開くためには‘/s $PATH/A.xsh’を使います。
Void | CloseSession() |  | 現在接続中のセッションを終了します。
Void | Sleep(long timeout) | Timeout ミリ秒単位の時間値 | 指定した時間だけXshellが待機するようにします。
Void | LogFilePath(LPCTSTR lpszNewFilePath) | lpszNewFilePath パスを含むファイル名 | ログファイルを保存します。
void | StartLog() |  | セッションに対するログ記録を始めます。ログはLogFilePath()で決めたパスに保存します。ログ ファイルパスを指定していなければ既定のパスを使います。
void | StopLog() |  | ログ記録を中止します。

変数
名前 | 種類 | 説明
Connected | BOOL | 現在のセッションの接続可否
LocalAddress | BSTR | ローカルアドレスをインポートします。
Path | BSTR | 現在のセッションファイルのパスをインポートします。
RemoteAddress | BSTR | リモートアドレスをインポートします。
RemotePort | long | リモートポート番号をインポートします。
Logging | BOOL | 現在のセッションがログを記録しているのか確認します。

See Also

スクリプトAPI


xsh.Screen

Xshell 4 Help / xsh.Screen
xsh.Screen

次の関数と変数はXshellのターミナル画面を扱う時に使用できます。この関数と変数を使用するためにはxsh.Screenと一緒に実行します。例えば‘Clear()’関数を使用するには‘xsh.Session.Clear()’のように使用します。

Functions
戻り値 | 関数 | パラメータ | 説明
void | Clear() |  | ターミナル画面をクリアします。
void | Send(LPCTSTR lpszStrToSend) | lpszStrToSend ユーザーが送ろうとする文字列 | ターミナルにメッセージを送ります。
BSTR | Get(long nBegRow, long nBegCol, long nEndRow, long nEndCol) | nBegRow ターミナルで行の開始位置 nBegCol ターミナルで列の開始位置 nEndRow ターミナルで行の終了位置 nEndCol ターミナルで列の終了位置 | ターミナルの決まった領域の文字列を読み込んでその値を返します。
void | WaitForString(LPCTSTR lpszString) | lpszString ターミナルに現れる文字列 | メッセージを待ちます。
Long | WaitForStrings(VARIANT FAR* strArray, long nTimeout) | strArray ターミナルに現れる文字列 nTimeout 待機時間のミリ秒値 戻り値 発見した文字の数字 | タイムアウトが発生する前までメッセージを待ちます。
void | Synchronous(BOOL bSync) | bSync 1(True) : 画面を同期化します。 0(False) : 画面を同期化しません。 | 画面の同期化を決めます。

変数
名前 | 種類 | 説明
CurrentColumn | long | 現在の列を返します。
CurrentRow | long | 現在の行を返します。
Columns | long | ターミナルの幅と同じ列の数を返します。
Rows | long | ターミナルの高さと同じ行の数を返します。

See Also

スクリプトAPI


Script例題

Xshell 4 Help / Script例題
Script例題

Script file

Sub Main

' *** Connect the session ***

xsh.Session.Open "ssh://192.168.1.17"

' "/s C:\Users\Administor\AppData\Roaming\NetSarang\Xshell\Sessions\example.xsh"

xsh.Screen.Synchronous = true

xsh.Screen.WaitForString "login: "

xsh.Screen.Send "username"

xsh.Screen.Send VbCr

xsh.Session.Sleep 100

xsh.Screen.WaitForString "Password: "

xsh.Screen.Send "password"

xsh.Screen.Send VbCr

xsh.Session.Sleep 100

' *** Wait for Prompt Message ***

xsh.Screen.WaitForString "username@password"

' *** Set File Format ***

Dim app, wb, ws

Set app = CreateObject("Excel.Application")

Set wb   = app.Workbooks.Add

set ws   = wb.Worksheets(1)

xsh.Session.LogFilePath = "c:\example.log"

xsh.Session.StartLog

Dim waitStrs

waitStrs = Array(Chr(10), "username@password") ' make wait message as array

Dim row, screenrow, readline, itmes

row = 1

' *** Send Command ***

xsh.Screen.Send "cat /etc/passwd"

xsh.Screen.Send VbCr

xsh.Session.Sleep 100

Dim result

' *** Read Data and Save it as an EXCEL File ***

Do

While true

        result = xsh.Screen.WaitForStrings(waitStrs, 1000)

        If result = 2 Then

               Exit Do

        End If

        screenrow = xsh.Screen.CurrentRow - 1

        readline  = xsh.Screen.Get(screenrow, 1, screenrow, 40)

        items     = Split(readline, ":", -1)

        ws.Cells(row,1).Value = items(0)

        ws.Cells(row,2).Value = items(2)

        row = row + 1

Wend

Loop

wb.SaveAs("C:\chart.xls")                    ' save file path

wb.Close

app.Quit

Set ws  = nothing

Set wb  = nothing

Set app = nothing

xsh.Screen.Synchronous = false

xsh.Session.StopLog

End Sub

See Also

スクリプトAPI


レファレンス

Xshell 4 Help / レファレンス
レファレンス

このセクションはXshell使用に関するレファレンス情報を含んでいます。

See Also

標準ボタン
アドレスバー
Xshellローカルコマンド
Xshellコマンドラインオプション
SFTPコマンド
正規表現
予め定義されたショートカットキー


標準ボタン

Xshell 4 Help / 標準ボタン
標準ボタン

Xshellはしばしば使われる作業とコマンドに関する標準ボタンを提供します。

下は標準ボタンの説明です。

ボタン | 名前 | 説明
 | 新規 | 新しいセッションのプロパティダイアログボックスを開いて新しいセッションを生成します。
 | 開く | セッションダイアログボックスを開きます。
 | 切断 | 現在のセッションの接続を切断します。
 | 再接続 | 現在のタブのセッションを再接続します。
 | プロパティ | 現在のセッションのプロパティを表示します。セッションが開かなかった場合には既定のセッションのプロパティを表示します。
 | コピー | 選択領域をクリップボードにコピーします。
 | 貼り付け | クリップボードの内容を貼り付けます。
 | 検索 | 検索ダイアログボックスを開きます。
 | 印刷 | 印刷ダイアログボックスを開きます。
 | 配色 | 配色を選択します。
 | エンコード | 出力言語で可能なエンコードを羅列します。
 | フォント | 使用可能なフォントの名前とサイズを羅列します。現在開いているセッションのフォントを変更することができます。各セッションのフォントを変更するには、セッションのプロパティダイアログボックスで該当セッションのフォントを選択できます。
Description: toolbarnewterminal | 新しいターミナル | 新しいXshellウィンドウを開きます。接続された状態でこのボタンをクリックすれば、該当セッションの接続情報を使って接続を試行します。
Description: toolbarfiletransfer | 新しいファイル転送 | Xftp™がインストールされた場合Xftpを実行します。接続された状態でこのボタンをクリックすれば、該当セッションの接続情報で新しいファイル転送セッションを開始します。Xftpがインストールされていなければ、Xshell自らファイル転送セッションを開始します。
 | 全画面 | 全画面モードに切り替えます。Alt+Enterを入力すれば、標準ウィンドウモードに切り替わります。
 | スクリーンロック | スクリーンロックモードに切り替えます。パスワードを入力する時までユーザー入力を受け入れません。
 | キーマッピング | ユーザー指定キーマッピングダイアログボックスを開きます。
 | スクリプト | Xshellスクリプトファイルを開始します。
 | ログの開始 | ログを開始します。
 | ログの停止 | ログを停止します。
Description: cog | オプション | オプションダイアログボックスを開きます。
 | ユーザーキーマネージャ | ユーザーキーダイアログボックスを開きます。
 | ホストキーマネージャ | ホストキーダイアログボックスを開きます。
 | Xagent | Xagentプログラムを実行します。
 | Xactivator | Xactivatorプログラムを実行します。
 | ヘルプ | Xshellヘルプを開きます。

See Also

レファレンス


アドレスバー

Xshell 4 Help / アドレスバー
アドレスバー

アドレスバーの文法は次のとおりです：

        [protocol://][user[:password]@]hostname[:port][/]

使用可能なプロトコルはssh、sftp、telnet、rloginおよびserialです。既定のプロトコルは既定のセッションに選択されたプロトコルです。プロトコル別既定のポート番号は下のように定義されています：

· ssh:            22

· sftp:           22

· telnet:         23

· rlogin:         513

· ftp:            21

下でいくつかの例題を見ることができます。

例題 | 説明
foobar.com | 既定のセッションに指定されたプロトコルとポート番号でfoobar.comに接続します。
ssh://kay@foobar.com/ | sshプロトコルでfoobar.comに接続します。ユーザーアカウントはkayで、既定のポート番号が使われます。
ssh://kay@foobar.com:12345/ | foobar.comの12345番ポートにsshプロトコルで接続します。ユーザーアカウントはkayです。
telnet://foobar.com/ | telnetプロトコルを通じてfoobar.comに接続します。ユーザーアカウントは指定されていません。既定のポートである23番ポートに接続されます。
rlogin://kay@foobar.com/ | rloginプロトコルでfoobar.comに接続します。ユーザーアカウントはkayで、既定のポートである513番ポートに接続されます。
sftp://kay@foobar.com/ | sftpプロトコルでfoobar.comに接続します。ユーザーアカウントはkayで、既定のポート番号が使われます。
ftp://foobar.com/test.zip | ftpプロトコルでfoobar.comに接続してtest.zipファイルをダウンロードします。

See Also

レファレンス


Xshellローカルコマンド

Xshell 4 Help / Xshellローカルコマンド
Xshellローカルコマンド

Xshell はターミナル環境に慣れた詳細ユーザーのためのローカルコマンドを提供します。

基本的にXshellプロンプトはリモートホストに接続されていない時にターミナル画面に現れます。セッションが接続された時は“Ctrl+Alt+]”を押してローカルプロンプトに出ることができます。再びリモートホストモードに戻るためには“exit”を入力するか“Ctrl+D”を押せば良いです。

次のコマンドが使用可能です。

コマンド | 説明
help ? | ターミナルウィンドウにコマンド一覧を表示
new | 新しいセッションのプロパティダイアログボックスを開く
open [session] | “session”が指定された場合該当セッションに接続、指定されていない場合セッションダイアログボックスを開く
edit [session] | “session”が指定された場合該当セッションのセッションプロパティダイアログボックスを、指定されていない場合既定セッションのセッションプロパティダイアログボックスを開く
list | 現在作業ディレクトリの使用可能なセッションに関する情報とディレクトリ一覧を表示
cd | 現在の作業ディレクトリを変更
clear | 画面、アドレスバーのヒストリー、ローカルシェルコマンドプロンプトのコマンドヒストリーをクリア
exit quit | Xshell セッションを終了したりリモートホストに戻る
ssh [user@]host [port] | sshプロトコルで接続
sftp [user@]host [port] | sftpプロトコルで接続
telnet [user@]host [port] | telnetプロトコルで接続
rlogin [user@]host [port] | rloginプロトコルで接続
ftp [user@]host [port] | ftpプロトコルで接続
ipconfig | Windowsのipconfigコマンドを実行
ping host | Windowsのpingコマンドを実行
tracert host | hostまでのパケットパスを表示する。
netstat | Windowsのnetstatコマンドを実行
nslookup | Windowsのnslookupコマンドを実行

See Also

レファレンス


Xshellコマンドラインオプション

Xshell 4 Help / Xshellコマンドラインオプション
Xshellコマンドラインオプション

Xshellが認識するコマンドラインパラメータオプションです。Windowsコンソールまたは他のアプリケーションプログラムからXshellを実行するときに我々は、これらのパラメータを使用することができます。

オプション、パラメータ | 説明
“セッションファイル” | 該当セッションを実行します。“セッション ファイル”はパスを含むことができます。
-folder “セッションフォルダ” | 該当フォルダのすべてのセッションを実行します。
-url [protocol://][user[:password]@]host[:port] | 保存したセッションファイルでないURLを直接入力して接続します。使用可能なプロトコルはSSH、SFTP、TELNET、RLOGIN、そしてFTPです。 プロトコルを省略した場合はオプションダイアログボックスの[全般]タブで決めた既定のプロトコルを使用します。 ユーザー(user)、パスワード(password)を省略した場合、これを認証するためのウィンドウが現れます。 接続ポート(port)を指定しなかった場合、接続プロトコルの既定ポートを使います。
-open | セッションダイアログボックスを開きます。
-register | 製品登録をするためのダイアログボックスを開きます。
-about | 製品のバージョン、ライセンス情報などが分かるXshell のバージョン情報を開きます。
-prop “セッションファイル” | 該当セッションのセッションプロパティダイアログボックスを開きます。“セッションファイル”はパスを含むことができます。
-create “セッションファイル” | 新しいセッションを生成します。
-folder “セッションフォルダ” | “セッションフォルダ”にあるすべてのセッションを実行します。
-newwin | 新しいXshellウィンドウを開きます。
-newtab “タブ名” | “タブ名”で新しいタブを生成します。

例題：

Xshell “c:\users\zoo\AppData\Roaming\NetSarang\Xshell\Sessions\xdev.xsh” xdev.xsh セッションファイルを実行します。

Xshell -url foobar.com foobar.comに既定のプロトコルで接続します。

Xshell -url ssh://foobar.com foobar.comにsshで接続します。

Xshell –url ssh://test:testpasswd@foobar.com foobar.comにsshで接続します。ユーザー名とパスワードはそれぞれ “test”と“testpasswd”です。

Xshell –url telnet://foobar.com:2300 foobar.comにtelnetプロトコルを使用、2300番ポートで接続します。

Xshell -newwin -url foobar.com foobar.comに既存ウィンドウのセッションタブではない新しいxshellウィンドウを実行して接続します。

* 参考

“-newwin”オプションを除いたすべてのオプションはオプションダイアログボックスの[詳細]タブで[一つのXshellウィンドウに複数のセッションを開く]が有効な場合、最後にXshellウィンドウで実行したり、タブでセッションを実行するようにします。“-newwin”オプションは他のオプションのように使用できて、このオプションで新しいXshellウィンドウを実行します。

See Also

レファレンス


SFTPコマンド

Xshell 4 Help / SFTPコマンド
SFTPコマンド

Xshell はターミナル環境に慣れた詳細ユーザーのためにUNIX/LinuxのFTPと似たコマンドを提供します。各コマンドの説明は下のとおりで、詳しい使用法はSFTPプロンプトでhelpコマンドを通じて確認してください。

コマンド | 説明
get file1 [file2] [file3] … | リモートホストの指定されたファイルをローカルホストにインポートします。
put file1 [file2] [file3] … | ローカルホストの指定されたファイルをリモートホストにエクスポートします。
mv path1 path2 rename path1 path2 | 特定ファイルまたはディレクトリを他のパスに移動したり名前を変更します。
mkdir directory | リモートホストで指定されたディレクトリを生成します。
rmdir directory | リモートホストで指定されたディレクトリを削除します。
rm file | リモートホストで指定されたファイルを削除します。
pwd | リモートホストの作業ディレクトリを表示します。
lpwd | リモートホストの作業ディレクトリを表示します。
cd directory | リモートホストの作業ディレクトリを変更します。
lcd directory | ローカルホストの作業ディレクトリを変更します。
ls [directory] | リモートホストのファイル一覧を表示します。
lls [directory] | ローカルホストのファイル一覧を表示します。
explore [directory] | Windowsエクスプローラーを利用して現在(あるいは指定された)ディレクトリを閲覧します。
help [command] | SFTPコマンド一覧または指定されたコマンドの使用法を表示します。
bye exit quit | SFTP接続を終了します。

See Also

レファレンス


正規表現

Xshell 4 Help / 正規表現
正規表現

このセクションでは検索ダイアログボックスで使われる正規表現について説明します。

See Also

レファレンス
パターンマッチ
文字集合の縮約型
POSIX文字集合
例題


パターンマッチ

Xshell 4 Help / パターンマッチ
パターンマッチ
パターン | 説明
. | 改行文字を除いた一文字
[abc] | A、b、c中の一文字
[a-z] | aからzまでに属している一文字
[^ac] | aとcを除いた一文字
(x) | x, このとき xは正規表現の場合がある
x* | xが0回以上反復される、このとき xは正規表現の場合がある
x+ | xが1回以上反復される、このとき xは正規表現の場合がある
x{n,m} | xがn回以上 m回以下で反復される、このとき xは正規表現の場合がある
x{n} | xが正確に n回反復される、このとき xは正規表現の場合がある
x{n,} | xが n回以上反復される、このとき xは正規表現の場合がある
x|y | x であったり y, このとき x, yは正規表現の場合がある
xy | xy, このとき x, yは正規表現の場合がある
^ | 行の開始
\A | 行の開始
$ | 行の終了
\z | 行の終了
\Z | 行の終了
\< | 単語の開始
\b | 単語の開始
\> | 単語の終了
\B | 単語の終了

See Also

正規表現


文字集合の縮約型

Xshell 4 Help / 文字集合の縮約型
文字集合の縮約型
クラス | 説明
\w | 単語を構成する文字、[a-zA-Z0-9_]と同じ
\W | 単語を構成しない文字、[^a-zA-Z0-9_]と同じ
\s | 空白文字
\S | 空白文字を除いた文字
\d | 数字、[0-9]と同じ
\D | 数字を除いた文字、[^0-9]と同じ

See Also

正規表現


POSIX文字集合

Xshell 4 Help / POSIX文字集合
POSIX文字集合
クラス | 説明
[:alnum:] | アルファベットと数字、[a-zA-Z0-9]と同じ
[:alpha:] | アルファベット、[a-zA-Z]と同じ
[:blank:] | 空白文字
[:cntrl:] | 制御文字
[:digit:] | 数字、[0-9]と同じ
[:graph:] | 出力できる文字 (空白文字除外)
[:lower:] | 小文字、[a-z]と同じ
[:print:] | 制御文字 でない文字
[:punct:] | 句読点
[:space:] | 空白文字
[:upper:] | 大文字、[A-Z]と同じ
[:xdigit:] | 16進数の表記に使われる文字、[0-9a-fA-F]と同じ

See Also

正規表現


例題

Xshell 4 Help / 例題
例題
表現式 | 説明
[0-9]+ | 数字が1回以上反復されるパターン
(foo)|(bar) | "foo" や "bar"
\.html$ | ".html"で終わる文字列
^\. | "." で始まる文字列

See Also

正規表現


予め定義されたショートカットキー

Xshell 4 Help / 予め定義されたショートカットキー
予め定義されたショートカットキー

下の一覧はXshellに定義されたショートカットキーの説明です。

ショートカットキー | 説明
Alt + N | ファイルメニューの新規と同じ
Alt + O | ファイルメニューの開くと同じ
Alt + C | ファイルメニューの切断と同じ
Alt + Enter | 全画面表示モードに転換
Alt + D | アドレスバーにキーボードフォーカスを移動
Alt + L | レイアウトの変更
Alt + 1~9 | セッションタブの移動
Alt + Right | ウィンドウメニューの次へと同じ
Alt + Left | ウィンドウメニューの戻ると同じ
Ctrl + D | ローカルプロンプトでローカルシェル終了
Ctrl + Alt + ] | 接続中にローカルプロンプトに出る
Ctrl + Alt + T | ウィンドウメニューの新しいターミナルと同じ
Ctrl + Alt + F | ウィンドウメニューの新しいファイル転送と同じ
Ctrl + Tab | 一つのXshellウィンドウで次のセッションに移動
Shift + Tab | 一つのXshellウィンドウで最近使用したセッションに移動
Shift + Home | 一番上
Shift + End | 一番下
Shift + PgUp | 前のページ
Shift + PgDn | 次のページ
Shift + Up Arrow | 上にスクロール
Shift + Down Arrow | 下にスクロール

* 参考

メニューのショートカットキーを変更するには、キーマッピング機能を利用します。ユーザー指定キーマッピングダイアログボックスではユーザーがショートカットキーのキー組み合わせを変更することができ、メニュー、文字列の送信、スクリプトの実行、プログラムの実行などの動作をキーの組み合わせに割り当てることができます。

See Also

レファレンス