Xshell 소개

Xshell 4 도움말 / Xshell 소개
Xshell 소개

Xshell 은 Windows 플랫폼에서 동작하는 강력한 SSH, TELNET, RLOGIN 터미널 에뮬레이션 소프트웨어입니다. Windows 사용자는 Xshell 을 통해 UNIX/Linux 호스트에 쉽고 안전하게 접근할 수 있습니다. SSH (Secure Shell) 프로토콜은 인터넷 상에서 안전한 연결을 위한 암호화 및 사용자 인증을 지원하며 TELNET, RLOGIN과 같은 기존의 프로토콜을 대체할 수 있습니다.

관련 정보

주요 기능
권장 사양
설치 및 제거

Copyright© 2013 Netsarang Computer, Inc. All rights reserved.


주요 기능

Xshell 4 도움말 / 주요 기능
주요 기능

이 섹션에서는 Xshell 의 주요 기능을 기술합니다.

일반

l SSH1, SSH2, SFTP, TELNET, RLOGIN 및 SERIAL 프로토콜 지원

l Windows 2000/XP/2003/Vista/2008/7/8 지원

l OpenSSH 및 ssh.com 서버 지원

l 다중 사용자 설정

l 연결 유지 옵션

l SOCKS4/5, HTTP 프록시 연결

l 멀티 세션 지원 (세션 탭, 세션 표시줄)

l 사용자 지정 키 매핑

l VB 스크립팅

l 새로운 연결 모음

l 끊어진 연결 자동으로 다시 연결

세션 관리

l 다른 호스트들에 대한 세션 파일 생성 및 관리

l 세션을 열기 위한 세션 대화 상자, 주소 표시줄, 로컬 프롬프트, 세션 바로가기 및 연결 모음 지원

l 빠른 연결을 위한 기본 세션 제공

l 다중 세션 동시 접속

l 주소 표시줄은 URL 명령을 지원하며, 세션을 사용하지 않은 원격 호스트에 접속 지원

l Xactivator를 통한 세션 연결

l 자동 로그인, 자동 입력 기능

l 세션 대화 상자에서 폴더 및 트리 뷰

보안

l RSA/DSA 공개 키, 암호 및 Keyboard Interactive 사용자 인증 방법

l RSA/DSA 키 생성 마법사 및 가져오기/내보내기 기능

l Xagent (SSH 사용자 인증 에이전트)를 이용한 사용자 인증

l AES128/192/256, 3DES, BLOWFISH, CAST128, ARCFOUR 및 RIJNDAEL 암호화 알고리즘

l SHA1, SHA1-96, MD5, MD5-96 및 RIPEMD160 MAC 알고리즘

l zlib 압축

l 호스트 키 관리 대화 상자

l 사용자 키 관리 대화 상자

터미널

l 유니코드 기반의 터미널 버퍼

l VT100, VT220, VT320, XTERM, LINUX, SCOANSI 및 ANSI 터미널

l 다국어 출력 인코딩 (UTF-8)

l 모든 세션에 동시에 문자 전송 가능한 작성 창

l 2,147,483,647라인까지 저장 가능한 스크롤 버퍼

l 정규식을 이용한 문자열 찾기

l 컬럼 단위 텍스트 선택

l 복사/붙여넣기 시 Multi-byte 문자열 지원

l 터미널 창에서 두 번 클릭으로 단어 선택 및 구분 기호 지정

l 마우스 단추 세번 클릭 시 한줄 선택

l 강조 글꼴 및 ANSI 컬러 코드

l Xterm 터미널 마우스

l Xterm 256 컬러 모드

l Liunx Meta 키 에뮬레이션

l 터미널 화면 인쇄

l 터미널 창의 줄 간격 및 여백 설정

l ESC 키 누르면 한->영 변환 (한글 Windows인 경우만 해당)

터널링

l TCP/IP 및 X11 포워딩

l SOCKS4/5를 이용한 동적 포트 포워딩

l 터널링 창을 통해 현재 활성화된 포워딩 채널을 관찰할 수 있으며 현재 세션에 새 포워딩 규칙을 추가

모양

l 쉽고 강력한 사용자 인터페이스

l 사용자 지정 레이아웃 전환

l 이동 가능한 도구 모음

l 색 구성표 편집/가져오기/내보내기

l 커서 색 변경 및 깜박임 설정

l 글꼴 단추를 통해 쉽게 글꼴 변경

l 자주 사용하는 문자열을 빠른 명령으로 지정

l 도구 모음의 표준 단추 사용자 지정

l 상태 표시줄에 보안-자물쇠, 세션 선택, 네트워크 up/down 트래픽 정보 표시

l 전체화면 보기 (Alt+Enter)

l 투명도 조절 옵션

로컬 명령어

l 고급 사용자를 위한 로컬 셸 프롬프트

l open, ssh, telnet, rlogin 및 sftp, ftp 등과 같은 로컬 명령어

l ping, ipconfig, netstat 및 nslookup과 같은 로컬 Windows 명령어

l 원격 호스트 연결 중 로컬 프롬프트로 빠져 나오기

상호 운용성

l Xmanager 프로그램과 연동되는 X11 포워딩

l Xagent 프로그램과 연동되는 에이전트 포워딩

l Xftp와 연동하여 쉽게 FTP 사이트에 접속

l 스크롤 버퍼를 메모장에서 편집

l 메뉴 명령을 통해 Xshell 창을 순차적으로 선택

파일 관리

l SFTP 보내기 및 받기

l ZMODEM 보내기 및 받기

l ASCII 파일 보내기

l 세션 자동 로깅 (터미널 코드도 저장)

l 페이지 설정 및 인쇄 미리 보기

관련 정보

Xshell 소개


권장 사양

Xshell 4 도움말 / 권장 사양
권장 사양

l 프로세서: Intel® 호환

l 운영체제: Microsoft Windows® 2000 SP4 이상

l 저장 공간: 50MB 이상의 여유 공간

l 네트워크: TCP/IP 네트워크

l 프로그램: Internet Explorer® 6.0 이상

관련 정보

Xshell 소개


설치 및 제거

Xshell 4 도움말 / 설치 및 제거
설치 및 제거

Xshell 설치 프로그램은 InstallShield®를 사용하여 만들어졌으며, 설치 과정에서 다양한 설치 옵션을 변경할 수 있습니다. 그러나 대부분의 경우에는 단순히 [다음]을 클릭하는 것으로도 충분합니다.

Xshell 을 제거하기 위해서는, Windows의 표준 추가/제거 기능을 이용합니다. 제어판에서 [프로그램 추가/제거]를 실행한 후, 목록에서 Xshell 또는 Xmanager Enterprise 를 선택하여 제거합니다. Xmanager Enterprise를 제거하면 Xshell 외 다른 프로그램도 함께 제거되므로 유의하십시오.

프로그램을 제거하더라도 사용자에 의해 생성된 레지스트리 정보, 로그 파일 및 자료 파일은 제거되지 않습니다. 프로그램을 다시 설치하면 이러한 정보 및 파일을 재사용할 수 있습니다. 만약 레지스트리 정보와 파일을 모두 지우고 싶다면 다음 위치의 레지스트리 정보와 파일을 모두 삭제합니다:

레지스트리 정보:

· \HKEY_CURRENT_USER\Software\NetSarang\Xshell

· \HKEY_CURRENT_USER\Software\NetSarang\Xmanager Enterprise

파일 및 폴더:

· %APPDATA%\NetSarang\Xshell

· %APPDATA%\NetSarang\Xmanager Enterprise

관련 정보

Xshell 소개


시작

Xshell 4 도움말 / 시작
시작

이 섹션에서는 Telnet/Rlogin 또는 SSH 세션을 생성하는 방법과 UNIX/Linux 호스트에 접속하기 위한 방법을 설명합니다. Telnet 세션은 매우 간단하지만 SSH 세션은 서버에 연결하기 전에 사용자 키를 서버에 등록해야 할 경우가 있습니다. 만약 사용자 키 등록이 필요하다면 “ 공개 키 사용자 인증 ”을 참조하십시오.

관련 정보

세션 만들기
원격 호스트에 연결
Xshell 끝내기


세션 만들기

Xshell 4 도움말 / 세션 만들기
세션 만들기

1. [파일] 메뉴에서, [새로 만들기]를 선택합니다. 새 세션 등록 정보 대화 상자가 나타납니다.

그림 1: 새 세션 등록 정보 대화 상자

2. [이름]에 세션 이름을 입력합니다.

3. [프로토콜] 목록에서 적절한 프로토콜을 선택합니다.

4. [호스트]에 서버의 호스트 이름 또는 IP 주소를 입력합니다.

5. [포트 번호]에 원격 서버에 의해 사용되는 포트 번호를 입력합니다.

6. [확인]을 클릭합니다.

관련 정보

시작


원격 호스트에 연결

Xshell 4 도움말 / 원격 호스트에 연결
원격 호스트에 연결

다음은 SSH 세션으로 연결하는 과정입니다. 만약 생성된 세션이 없다면 “ 세션 만들기 ” 섹션을 참조하십시오.

1. [파일] 메뉴에서 [열기]를 선택합니다.

2. 세션 목록 중에서 연결할 세션을 선택하고 [연결]을 클릭하면 SSH 사용자 이름 대화 상자가 나타납니다.

그림 2: SSH 사용자 이름 대화 상자

3. 사용자 이름을 입력하고 [확인]을 클릭하면 SSH 사용자 인증 대화 상자가 나타납니다.

그림 3: SSH 사용자 인증 대화 상자

4. Password 인증을 시도하려면 [암호]에 암호를 입력한 후 [확인]을 클릭합니다.

5. Public Key 인증을 시도하려면 먼저 목록에서 사용자 키를 선택합니다. 선택된 사용자 키의 암호를 [암호]에 입력한 후 [확인]을 클릭합니다.

* 참고

만약 사용자 키가 없다면 “ 공개 키 사용자 인증 ” 섹션을 참조하십시오.

6. Keyboard Interactive 인증을 시도하려면 [확인]을 클릭한 후, 접속 과정에서 제시되는 질문에 답하십시오.

관련 정보

시작


Xshell 끝내기

Xshell 4 도움말 / Xshell 끝내기
Xshell 끝내기

세션의 연결을 끊으려면 터미널 화면의 프롬프트에서 “exit”을 치거나 [파일] 메뉴에서 [연결 끊기]를 선택하십시오.

* 참고

연결 종료 시 로컬 셸로 복귀 옵션이 선택된 상태에서 연결을 끊으면 로컬 셸 상태로 세션 탭이 유지됩니다. 로컬 셸 세션에서는 터미널 화면에 Xshell 프롬프트가 나타나며, open, telnet, ssh, ping 등과 같은 로컬 명령어를 실행할 수 있습니다.

Xshell 을 끝내려면 [파일] 메뉴에서 [끝내기]를 선택하십시오.

관련 정보

시작


세션 관리

Xshell 4 도움말 / 세션 관리
세션 관리

세션은 원격 호스트 연결에 관한 설정을 담고 있는 파일입니다. 세션을 생성함으로써 사용자는 각기 다른 원격 호스트에 대한 각각 다른 옵션을 설정할 수 있습니다. 세션 대화 상자는 생성된 모든 세션을 보여 주며, 세션을 생성하고 편집할 수 있게 해줍니다.

사용자는 세션을 생성하지 않고 원격 컴퓨터에 접속할 수도 있습니다. 이런 목적으로 Xshell 은 설치와 동시에 사용 가능한 기본 세션을 지원하고 있습니다.

관련 정보

세션 관리
세션 등록 정보
내보내기
가져오기


세션 관리

Xshell 4 도움말 / 세션 관리
세션 관리

새로운 세션을 만들려면:

1. [파일] 메뉴에서 [새로 만들기]를 선택하여 새 세션 등록 정보 대화 상자를 엽니다.

2. 연결 정보를 입력합니다.

3. [확인]을 클릭합니다.

세션 대화 상자를 열려면:

· [파일] 메뉴에서 [열기]를 선택합니다.

· 표준 단추의 [열기]를 클릭합니다.

세션을 편집하려면:

1. 세션 대화 상자를 엽니다.

2. 편집하고자 하는 세션을 선택합니다.

3. 표준 단추에서 [등록 정보]를 클릭합니다.

4. 세션을 편집한 후 [확인]을 클릭합니다.

세션의 이름을 바꾸려면:

1. 세션 대화 상자를 엽니다.

2. 이름을 변경하고자 하는 세션을 선택한 후 마우스 오른쪽 단추를 클릭합니다.

3. 메뉴에서 [이름 바꾸기]를 선택합니다.

* 참고

세션의 이름은 유효한 파일 이름이어야 합니다.

다른 이름으로 복사하려면:

1. 세션 대화 상자를 엽니다.

2. 다른 이름으로 복사할 세션을 선택합니다.

3. 표준 단추에서 [다른 이름으로 저장]을 클릭합니다.

세션을 삭제하려면:

1. 세션 대화 상자를 엽니다.

2. 삭제할 세션을 선택합니다.

3. 표준 단추에서 [삭제]를 클릭합니다.

세션 바로 가기를 만들려면:

1. 세션 대화 상자를 엽니다.

2. 바로 가기를 만들 세션을 선택합니다.

3. 표준 단추에서 [바로 가기 만들기]를 클릭합니다.

4. 바로 가기를 저장할 폴더를 선택합니다.

5. [확인]을 클릭합니다.

기본 세션의 설정을 변경하려면:

기본 세션의 세션 등록 정보 대화 상자를 열려면 다음 중 한 가지 방법을 사용합니다:

· 로컬 셸 상태에서 [파일] 메뉴의 [등록 정보]를 선택합니다.

· 메인 창의 표준 단추에서 [등록 정보] 단추 옆에 있는 화살표를 클릭한 다음 목록에서 [기본 세션]을 선택합니다.

* 참고

기본 세션은 로컬 프롬프트나 주소 표시줄을 사용하여 ssh, telnet, rlogin, sftp 연결을 할 때 사용됩니다.

로컬 프롬프트에서 연결 명령어를 사용하려면 “ Xshell 로컬 명령어 ”를 참조하십시오. 주소 표시줄을 이용하여 연결하려면 “ 주소 표시줄 ” 섹션을 참조하십시오.

새로운 세션 폴더를 만들려면:

1. 세션 대화 상자를 엽니다.

2. 표준 단추에서 [새로 만들기] 단추 옆에 있는 화살표를 클릭한 다음 목록에서 [폴더]를 선택합니다.

3. 폴더의 이름을 입력합니다.

세션 파일을 다른 컴퓨터로 복사하려면:

1. 세션 대화 상자를 엽니다.

2. 표준 단추에서 [세션 폴더 열기]를 클릭합니다.

3. 해당 세션 파일(*.xsh)을 찾아서 복사하거나 메일로 전송하여 다른 컴퓨터로 가져갑니다.

4. 다음 폴더에 세션 파일을 저장합니다:
”%APPDATA%\NetSarang\Xshell\Sessions”

관련 정보

세션 관리


세션 등록 정보

Xshell 4 도움말 / 세션 등록 정보
세션 등록 정보

새로운 세션을 생성하거나 세션을 편집하려면 세션 등록 정보 대화 상자를 엽니다.

세션 등록 정보 대화 상자를 열려면:

· [파일] 메뉴에서 [새로 만들기]를 선택합니다.

· [파일] 메뉴에서 [등록 정보]를 선택합니다.

· 표준 단추의 [등록 정보]를 클릭합니다.

관련 정보

세션 관리
연결
연결: 사용자 인증
연결: 사용자 인증: 로그인 프롬프트
연결: 로그인 스크립트
연결: SSH
연결: SSH: 보안
연결: SSH: 터널링
연결: SSH: SFTP
연결: TELNET
연결: RLOGIN
연결: SERIAL
연결: 프록시
터미널
터미널: 키보드
터미널: VT 모드
터미널: 고급
모양
모양: 여백
고급
고급: 추적
고급: 로깅
ZMODEM


연결

Xshell 4 도움말 / 연결
연결

연결 설정에서는 세션의 연결에 대한 정보를 설정할 수 있습니다. 대부분의 경우 사용자는 이 부분만을 설정하여 원격 호스트에 접속할 수 있습니다.

이름

이 세션의 고유한 이름을 입력합니다. 이름은 세션 파일의 이름이 되므로 파일명으로 유효한 문자들로 이루어져야 합니다.

프로토콜

원격 컴퓨터에 연결할 때 사용할 연결 프로토콜을 선택합니다. 지원되는 프로토콜은 SSH, SFTP, TELNET, RLOGIN 및 SERIAL입니다.

호스트

원격 컴퓨터의 호스트 이름이나 IP 주소를 입력합니다.

포트 번호

위에서 선택한 프로토콜의 포트 번호를 입력합니다. 프로토콜 목록에서 프로토콜이 선택되면 해당 프로토콜의 기본 포트 번호가 자동으로 입력됩니다. 만약 원격 컴퓨터가 다른 포트 번호를 사용하고 있다면, 사용자가 포트 번호를 직접 입력해야 합니다. 각 프로토콜별 기본값은 SSH/SFTP는 22, TELNET은 23 그리고 RLOGIN은 513입니다.

세션이 연결되어 있는 동안 연결 유지 메시지를 보냄

원격 컴퓨터에 연결 유지 메시지를 보냅니다. 이 기능은 Xshell을 사용하지 않는 동안 연결이 예상치 않게 끊어지는 경우에 유용합니다. 몇몇 네트워크 환경에서는 게이트웨이(Gateway) 또는 방화벽(Firewall) 시스템이 일정 시간 동안 데이터 전송이 없는 연결을 강제로 끊는 경우가 있습니다.

예기치 않게 연결이 끊겼을 때 자동으로 다시 연결

사용자가 직접 연결을 종료하지 않은 상황에서 네트워크 연결이 끊겼을 때 자동으로 다시 연결합니다.

관련 정보

세션 등록 정보


연결: 사용자 인증

Xshell 4 도움말 / 연결: 사용자 인증
연결: 사용자 인증

사용자 인증 설정에서는 인증 방법과 사용자 이름, 암호 또는 사용자 키 등을 지정할 수 있습니다.

방법

인증 방법을 선택합니다. Password, Public Key, Keyboard Interactive 중 하나를 선택할 수 있으며 만약 선택한 인증 방법을 SSH 서버가 지원하지 않으면 연결 중 사용자 인증 방법을 묻는 대화 상자가 나타납니다.

사용자 이름

로그인할 사용자 이름을 입력합니다. 사용자 이름은 원격 컴퓨터의 로그인 계정입니다. 비워 두면 연결 시에 사용자 이름을 묻는 대화 상자가 나타납니다.

암호

원격 컴퓨터 사용자 계정의 암호를 입력합니다. 이 값은 Password 인증이 선택된 경우에 유효합니다. 만약 이 값을 비워 두면 연결 중 사용자 인증을 묻는 대화 상자가 나타납니다. 암호는 암호화되어 사용자의 PC에 저장됩니다. 더 나은 보안을 위해서는 이 값을 비워 둡니다.

사용자 키

공개 키 인증이 선택된 경우 사용할 사용자 키를 선택합니다. 만약 이 값을 비워 두면 연결 중 사용자 인증을 묻는 대화 상자가 나타납니다. 만약 목록에 사용자 키가 없다면, 키를 생성한 후 원격 SSH 서버에 등록해야 합니다.

암호

선택한 사용자 키의 암호를 입력합니다. 입력한 키 암호는 암호화되어 사용자의 PC에 저장됩니다. 더 나은 보안을 위해서는 이 값을 비워 둡니다.

관련 정보

세션 등록 정보


연결: 사용자 인증: 로그인 프롬프트

Xshell 4 도움말 / 연결: 사용자 인증: 로그인 프롬프트
연결: 사용자 인증: 로그인 프롬프트

TELNET 또는 RLOGIN 프로토콜을 사용하는 경우 로그인 과정을 자동으로 수행하기 위해 Xshell이 서버의 사용자 이름/암호 프롬프트를 인식할 필요가 있습니다. 일반적인 경우에는 기본값을 그대로 사용하면 됩니다.

TELNET

TELNET 로그인 과정을 자동화하기 위한 사용자 이름과 암호 프롬프트를 입력합니다. 공백 문자도 유효하므로 주의하십시오.

RLOGIN

RLOGIN 프로토콜을 위한 암호 프롬프트를 입력합니다. rlogin 서버의 설정에 따라 암호가 필요하지 않을 수도 있습니다. 공백 문자도 유효하므로 주의하십시오.

관련 정보

세션 등록 정보


연결: 로그인 스크립트

Xshell 4 도움말 / 연결: 로그인 스크립트
연결: 로그인 스크립트

로그인 스크립트 설정에서는 터미널에 자동으로 입력될 명령어를 정의할 수 있습니다. 원격 서버에 성공적으로 로그인한 후, 목록에 나타난 순서에 따라 명령들이 차례로 실행됩니다. 이 기능은 첫번째 로그인 후 다른 서버로 다시 로그인해야 할 경우에 매우 유용합니다.

다음 대기 및 보내기 규칙을 실행합니다.

대기 및 보내기 규칙을 사용하려면 이 옵션을 선택합니다.

추가

대기 및 보내기 규칙 대화 상자를 엽니다. 규칙의 편집이 끝나면 목록에 추가됩니다.

편집

대기 및 보내기 규칙 대화 상자를 열어 선택된 규칙을 편집합니다.

세션 연결 시 스크립트를 실행합니다.

세션 접속 후 실행할 VB 스크립트 파일을 정할 수 있습니다.

관련 정보

세션 등록 정보


연결: SSH

Xshell 4 도움말 / 연결: SSH
연결: SSH

SSH 프로토콜의 일반적인 옵션을 설정할 수 있습니다.

프로토콜 버전

사용할 SSH 프로토콜의 버전을 선택합니다. SSH1에 비해 SSH2가 보다 안전하며 많은 기능을 제공합니다.

암호 처리에 Xagent(SSH 에이전트)를 사용함

Xagent를 이용할 경우 선택합니다. Xagent를 이용하면 공개 키 사용자 인증을 수행할 때 사용자 키 암호를 입력하는 수고를 줄일 수 있습니다.

Xagent 자동 시작

필요한 경우 Xagent를 자동으로 실행합니다. 이 옵션을 선택하면 Xagent를 미리 실행시키지 않아도 됩니다.

ZLIB 압축 사용함

압축 알고리즘은 SSH 연결의 모든 데이터를 압축하기 위해 사용됩니다. 네트워크 속도가 느린 환경에서는 압축을 사용하면 속도 향상의 효과를 볼 수 있습니다.

터미널 할당 안 함

터미널을 사용하지 않을 경우 이 옵션을 선택합니다. 이 기능은 Xshell의 터널링 기능만을 사용하고자 할 때 유용합니다.

관련 정보

세션 등록 정보


연결: SSH: 보안

Xshell 4 도움말 / 연결: SSH: 보안
연결: SSH: 보안

암호화

암호화 알고리즘은 네트워크로 전송되는 데이터를 암호화하기 위해 사용됩니다. 사용자는 목록에서 원하는 암호화 알고리즘을 선택할 수 있습니다. 만약 목록에서 <Cipher List>를 선택하면 복수의 알고리즘을 시도할 수 있습니다. <Cipher List>를 편집하려면 [편집]을 클릭합니다.

MAC (메시지 인증 코드)

MAC은 데이터의 무결성을 보장하며 더 나은 보안을 위해 SSH2에서 추가된 것입니다. 만약 목록에서 <MAC List>를 선택하면 복수의 알고리즘을 시도할 수 있습니다. <MAC List>를 편집하려면 [편집]을 클릭합니다.

관련 정보

세션 등록 정보


연결: SSH: 터널링

Xshell 4 도움말 / 연결: SSH: 터널링
연결: SSH: 터널링

터널링 설정에서는 TCP/IP, Dynamic 및 X11 포워딩 규칙을 설정할 수 있습니다. 이 설정들은 연결 설정에서 프로토콜을 SSH 프로토콜을 선택한 경우에만 유효합니다.

자세한 터널링 설정 방법은 “ 터널링 서비스 ”를 참조하십시오.

관련 정보

세션 등록 정보


연결: SSH: SFTP

Xshell 4 도움말 / 연결: SSH: SFTP
연결: SSH: SFTP

SFTP 프로토콜과 관련된 옵션을 설정합니다.

시작 폴더

SFTP 프로토콜을 사용하여 성공적으로 로그인한 후 작업을 시작할 로컬 및 원격 폴더를 설정합니다.

관련 정보

세션 등록 정보


연결: TELNET

Xshell 4 도움말 / 연결: TELNET
연결: TELNET

TELNET 프로토콜과 관련된 옵션을 설정합니다.

XDISPLOC Telnet 옵션 사용

XDISPLOC 텔넷 옵션을 사용하여 로그인 시 서버에 디스플레이(PC X 서버의 정보)를 전달합니다. Xmanager 등의 PC X 서버를 사용하는 경우, 이 옵션을 사용하면 원격 서버의 X11 응용 프로그램을 쉽게 사용자의 컴퓨터에서 사용할 수 있어 매우 편리합니다.

디스플레이

로그인 시 전달할 디스플레이를 입력합니다. $PCADDR 키워드는 서버에 전달되기 직전에 PC의 IP 주소 값으로 자동으로 변환됩니다.

관련 정보

세션 등록 정보


연결: RLOGIN

Xshell 4 도움말 / 연결: RLOGIN
연결: RLOGIN

RLOGIN 프로토콜과 관련된 옵션을 설정합니다.

터미널 속도

rlogin 서버에 전달할 터미널 속도를 지정합니다.

관련 정보

세션 등록 정보


연결: SERIAL

Xshell 4 도움말 / 연결: SERIAL
연결: SERIAL

SERIAL 설정에서는 SERIAL 연결을 위한 옵션들을 설정할 수 있습니다. RS232C SERIAL 연결은 UNIX 시스템에 비디오 카드가 없거나 콘솔에 직접 접근할 수 없는 경우 기존의 단말기 대신 PC를 이용하여 연결할 수 있어 편리합니다. Xshell을 통한 SERIAL 연결을 사용하려면 호스트 시스템에 SERIAL 인터페이스가 설치되어 있어야 합니다.

자세한 SERIAL 설정 방법은 “ SERIAL 연결 ”을 참조하십시오.

관련 정보

세션 등록 정보


연결: 프록시

Xshell 4 도움말 / 연결: 프록시
연결: 프록시

프록시 서버

연결 시 사용할 프록시 서버 설정을 선택합니다.

프록시 설정에 대한 자세한 내용은 “ 프록시 설정 ”을 참조하십시오.

관련 정보

세션 등록 정보


터미널

Xshell 4 도움말 / 터미널
터미널

터미널 설정에서는 터미널의 종류와 기타 터미널 관련 옵션들을 설정할 수 있습니다.

터미널 종류

사용하고자 하는 터미널 종류를 선택합니다. Xshell은 VT100, VT102, VT220, VT320, ANSI, SCOANSI, LINUX 및 XTERM 터미널을 지원합니다.

연결되면 다음 터미널 크기 사용

이 세션의 초기 터미널 크기를 지정하고 싶으면 이 옵션을 선택합니다. 선택된 경우, 세션이 연결되었을 때 행과 열의 값으로 터미널 크기가 변경됩니다. 선택되지 않은 경우, 세션으로 연결하여도 터미널 크기는 변경되지 않습니다.

행

터미널의 행의 개수를 입력합니다. 터미널의 크기는 세션이 연결되었을 때 조정됩니다.

열

터미널의 열의 너비를 입력합니다. 터미널의 크기는 세션이 연결되었을 때 조정됩니다.

스크롤 버퍼

스크롤 버퍼의 크기를 줄 단위로 지정합니다.

지워진 화면을 스크롤 버퍼에 넣습니다.

clear 명령 등으로 터미널 작업 화면을 지웠을 경우에도 스크롤 버퍼에 지워진 내용이 남아 마우스 스크롤 등을 이용하여 이전 화면을 다시 볼 수 있습니다.

인코딩

터미널의 출력 인코딩을 선택합니다. 이 값은 원격 서버가 사용하는 언어이어야 합니다. 기본 언어가 선택된 경우, Xshell은 사용자 Windows의 기본 인코딩을 사용합니다. 이 옵션은 키보드 입력 값을 바꾸지는 않으며 필요한 경우 Windows에서 제공하는 IME (Input Method Editor)를 적절히 설치해야 합니다.

한중일 언어의 모호한 문자를 와이드 문자로 처리

한중일 언어의 모호한 문자를 와이드 문자로 인식합니다.

관련 정보

세션 등록 정보


터미널: 키보드

Xshell 4 도움말 / 터미널: 키보드
터미널: 키보드

키보드 설정에서는 사용자 PC의 키보드가 서버에 전달하는 문자열을 설정할 수 있습니다.

기능 키 에뮬레이션

터미널 종류에 따른 기능 키를 설정합니다. <기본>을 선택하면 “ 터미널 ” 설정에서 지정한 터미널 종류에 따라 자동으로 기능 키가 설정됩니다.

대체할 키 매핑 파일을 지정하십시오.

사용자가 정의한 키 매핑 파일을 사용하면 각 기능 키(F1~F20)가 눌렸을 때 서버로 보낼 문자열을 직접 지정할 수 있습니다.

Delete 키 시퀀스, Backspace 키 시퀀스

사용자가 Delete 키 또는 Backspace 키를 눌렀을 때 보낼 문자열을 선택합니다.

메타(Meta) 키 에뮬레이션

Emacs 등과 같이 Meta 키를 사용하는 응용 프로그램들을 위해 Meta 키 에뮬레이션을 설정할 수 있게 합니다.

관련 정보

세션 등록 정보


터미널: VT 모드

Xshell 4 도움말 / 터미널: VT 모드
터미널: VT 모드

각 터미널 모드의 초기값을 설정합니다.

Auto Wrap Mode (DECAWM)

자동 줄 바꾸기 기능을 시작할 때 활성화합니다.

Origin Mode (DECOM)

Origin Mode를 활성화합니다. 이 옵션이 활성화되면 서버가 지정한 위치를 기준으로 커서가 이동합니다.

Reverse Video Mode (DECSCNM)

Reverse Video Mode를 시작할 때 활성화합니다. 이 옵션이 활성화되면 화면의 전경색과 배경색이 반전됩니다.

New Line Mode (NLM)

New Line Mode를 시작할 때 활성화합니다. 이 옵션이 활성화되면 ENTER 키가 눌렸을 때 CR과 LF를 모두 보냅니다. 이 옵션이 선택되지 않은 경우, ENTER 키는 CR만을 보냅니다.

Insert Mode (IRM)

Insert Mode를 시작할 때 활성화합니다. 이 옵션이 활성화되면 서버가 보낸 문자를 커서 위치에 이미 존재하는 문자열을 삭제하지 않고 삽입합니다.

Echo Mode (SRM)

이 옵션이 활성화되면 서버로 보낼 문자열을 화면에 출력한 후 서버로 전송합니다.

초기 커서 키 모드(DECCKM)

커서 키 모드의 초기값을 설정합니다.

초기 숫자 키패드 모드(DECNKM)

숫자 키패드 모드의 초기값을 설정합니다.

관련 정보

세션 등록 정보


터미널: 고급

Xshell 4 도움말 / 터미널: 고급
터미널: 고급

터미널 관련된 고급 옵션을 설정합니다.

Shift 키로 터미널에서 마우스 사용을 제한함

vi 등 일부 응용프로그램이 마우스 클릭이나 드래그를 영역 변경이나 파일 선택, 디렉토리 이동 등의 기능으로 사용하는 경우가 있습니다. 이러한 경우에도 Shift 키를 누르고 마우스를 사용하면 Xshell이 마우스 입력을 직접 사용하여 텍스트 선택 등의 기능으로 이용할 수 있습니다.

배경색으로 화면을 지움

화면을 지울 때 색 구성표에 설정된 배경색이 아닌 현재 터미널의 배경색을 사용합니다.

LF를 CR+LF로 받음

서버로부터 LF를 받았을 때 터미널 화면에 CR과 LF를 모두 출력합니다.

키를 누르면 맨 아래로 스크롤

사용자의 키 입력 시 터미널 화면을 맨 아래로 스크롤합니다.

터미널 입출력 시 맨 아래로 스크롤

터미널 화면에 문자가 출력될 때 화면을 맨 아래로 스크롤합니다.

BACKSPACE 신호 시 강제로 글자 삭제

Backspace 키가 눌리면 커서 왼쪽의 문자를 지우고 커서를 그 문자가 있던 곳으로 이동합니다.

깜박이는 문자 사용 안 함

깜박임 문자가 깜박이지 않고 고정되어 나타납니다.

터미널 제목 변경 사용 안 함

Xshell의 타이틀 바의 터미널 제목을 변경하지 않습니다. 대부분의 경우, 타이틀 바는 원격 컴퓨터의 요청에 따라 작업 폴더와 호스트 이름을 표시하게 됩니다.

터미널 인쇄 기능 사용 안 함

서버로부터 터미널 인쇄 요청을 받은 경우 인쇄하지 않고 화면에 출력합니다.

터미널 대체 화면(Alternate Screen) 전환 사용 안 함

vi와 같은 일부 응용프로그램을 위한 대체 화면을 사용하지 않습니다. 대체 화면을 사용할 경우 해당 응용프로그램이 종료되면 터미널 영역에는 해당 응용프로그램을 실행하기 전 화면으로 대체됩니다.

터미널 크기 변경 요청을 처리하지 않음

서버의 터미널 크기 변경 신호를 무시합니다.

관련 정보

세션 등록 정보


모양

Xshell 4 도움말 / 모양
모양

모양 설정에서는 터미널 창의 색과 글꼴을 설정할 수 있습니다.

색 구성표

세션에서 사용할 색 구성표를 선택합니다. Xshell은 몇 개의 기본 색 구성표를 제공하며, 새 색 구성표를 추가하거나 기존의 색 구성표를 색 구성표 대화 상자에서 편집할 수 있습니다.

글꼴 이름

세션에 사용될 글꼴을 선택합니다. 고정 폭 글꼴들만 나열됩니다. 표준 단추의 글꼴 아이콘을 눌러 글꼴을 선택할 수도 있습니다.

글꼴 크기

원하는 글꼴의 크기를 선택합니다.

강조 스타일

강조 문자를 표현하는 방법을 선택합니다.

커서

커서의 색과 모양, 깜박임 등을 지정합니다.

관련 정보

세션 등록 정보


모양: 여백

Xshell 4 도움말 / 모양: 여백
모양: 여백

여백 설정에서는 Xshell 터미널 창의 여백 및 간격을 설정할 수 있습니다.

여백

터미널 창의 여백을 설정합니다.

간격

터미널 창의 줄 간격과 문자 간격을 설정합니다.

관련 정보

세션 등록 정보


고급

Xshell 4 도움말 / 고급
고급

고급 설정에서는 빠른 명령 모음과 추적 및 로그 옵션을 설정할 수 있습니다.

빠른 명령 모음

세션에서 사용할 기본 빠른 명령 모음을 선택할 수 있습니다. 해당 세션이 시작할 때 선택한 빠른 명령 모음이 빠른 명령 표시줄에 표시됩니다.

빠른 명령 바로 가기 키를 사용하지 않음

Ctrl+F1, Ctrl+F2 등의 키를 빠른 명령 바로 가기 키로 사용하지 않고 해당 키값을 서버에 보냅니다.

관련 정보

세션 등록 정보


고급: 추적

Xshell 4 도움말 / 고급: 추적
고급: 추적

추적 설정에서는 프로토콜 추적 옵션을 설정할 수 있습니다. 이 기능은 특정한 문제 상황을 해결할 때 유용합니다. 추적 메시지는 터미널 화면에 출력됩니다.

SSH 버전, 알고리즘 교환 및 사용자 인증

버전 교환, 암호화 알고리즘, 압축 방법, 서버 및 사용자 인증 등의 정보를 화면에 출력합니다.

SSH TCP/IP 및 X11 터널링

포트 포워딩 관련 정보를 화면에 출력합니다.

TELNET 옵션 협상

Xshell과 telnet 서버 간의 TELNET 옵션 교환 과정을 화면에 출력합니다.

관련 정보

세션 등록 정보


고급: 로깅

Xshell 4 도움말 / 고급: 로깅
고급: 로깅

로깅 설정에서는 로그 생성과 관련된 옵션을 설정합니다.

연결 시 로깅 시작

세션이 원격 호스트에 접속되면 자동으로 로깅를 시작합니다. 로그 기록 방법으로 다음 중 한 가지를 선택할 수 있습니다.

· 인쇄 가능한 텍스트만 기록

· 인쇄 가능한 텍스트 뿐 아니라 터미널 코드도 기록

로그 폴더에 자동으로 새 파일을 만듭니다.

프로그램에서 기본으로 지정한 폴더에 새 파일을 생성하고 로그 메시지를 기록합니다. 파일명은 자동으로 주어집니다.

다음 파일을 사용합니다.

사용자가 지정한 폴더에 사용자가 지정한 형식으로 로그 메시지를 저장합니다.

파일 경로

로그 파일의 경로를 지정합니다. 파일 생성시 %n, %d, %t는 각각 이름, 날짜, 시간으로 변환됩니다.

브라우저 단추([…])

새 이름으로 저장 대화 상자를 열어 로그 내용을 기록할 파일을 선택합니다.

지정한 파일이 이미 존재하는 경우 덮어씁니다.

위에서 지정된 파일이 이미 존재하는 경우 로그 내용을 해당 파일에 덮어씁니다. 이 옵션이 선택되지 않은 경우에는, 파일 명 뒤에 순차번호를 부여하여 고유한 이름의 파일을 생성합니다.

세션 로깅을 시작할 때 물어봅니다.

로그가 시작될 때 저장 대화 상자를 열어서 사용자가 로그를 남길 파일을 선택할 수 있도록 합니다.

관련 정보

세션 등록 정보


ZMODEM

Xshell 4 도움말 / ZMODEM
ZMODEM

ZMODEM 설정에서는 ZMODEM 파일 전송과 관련된 각종 옵션을 설정합니다.

자동으로 ZMODEM 활성화

원격 ZMODEM 프로그램이 보내기/받기를 시작할 때 자동으로 파일 받기/보내기를 실행합니다. 이 옵션이 선택되지 않으면 파일 메뉴의 파일 전송에서 ZMODEM 받기/보내기를 선택하여 파일을 보내거나 받아야 합니다.

다운로드 전에 항상 확인

다운로드할 때마다 받을 폴더를 변경할 수 있습니다.

다음 다운로드 경로를 사용함

파일을 받을 때 저장할 폴더를 묻지 않고 지정된 폴더에 저장합니다. 저장되는 파일의 이름은 원격 파일의 이름과 동일하게 저장됩니다. 만약 같은 이름의 파일이 이미 존재하면 파일 이름에 일련 번호를 붙입니다.

자동으로 이름 바꾸기

ZMODEM을 통해 받으려는 파일과 동일한 이름의 파일이 이미 존재하는 경우 파일 이름을 자동으로 변경합니다. 예)변경 전: abc.txt, 변경 후: abc (2).txt

덮어쓰기

ZMODEM을 통해 받으려는 파일과 동일한 이름의 파일이 이미 존재하는 경우 기존에 있던 파일에 덮어씁니다.

관련 정보

세션 등록 정보


내보내기

Xshell 4 도움말 / 내보내기
내보내기

Xshell에서 내보내기한 세션들은 하나의 간편한 세션 모음 파일로 만들어집니다. 이 파일을 Xshell이 설치된 다른 컴퓨터에서 가져오기하면 별도의 설정 없이 동일한 세션을 사용할 수 있습니다.

세션을 내보내려면:

1. [파일] 메뉴에서 [내보내기]를 선택합니다.

2. 내보낸 세션 모음 파일을 저장할 위치를 선택하고 [다음]을 클릭합니다.
결과: 세션 내보내기의 결과가 출력됩니다.

3. [마침]을 클릭하여 세션 내보내기를 종료합니다.

관련 정보

세션 관리


가져오기

Xshell 4 도움말 / 가져오기
가져오기

Xshell은 다른 컴퓨터에서 내보내기한 세션 파일을 가져올 수 있습니다.

세션을 가져오려면:

1. [파일] 메뉴에서 [가져오기]를 선택합니다.

2. 다른 컴퓨터에서 내보낸 세션 모음 파일이 저장된 위치를 직접 입력하거나 […] 단추를 클릭하여 세션 모음 파일을 선택한 후 [다음]을 클릭합니다.

3. [마침]을 클릭하여 세션 가져오기를 종료합니다.

관련 정보

세션 관리


연결

Xshell 4 도움말 / 연결
연결

Xshell 은 세션 대화 상자, 로컬 프롬프트, 주소 표시줄, 연결 모음 그리고 세션 바로 가기 등의 다양한 연결 방법을 제공합니다.

관련 정보

세션 없이 연결
세션을 통한 연결
SERIAL 연결
Xactivator로 연결
프록시 설정


세션 없이 연결

Xshell 4 도움말 / 세션 없이 연결
세션 없이 연결

로컬 프롬프트에서 연결하려면:

1. 다음 명령 중 하나를 로컬 프롬프트에 입력하십시오:

· Xshell:\> telnet hostname

· Xshell:\> ssh hostname

· Xshell:\> rlogin hostname

* 참고

만약 원격 호스트가 기본 포트 번호를 사용하지 않는 경우, 포트 번호를 지정할 필요가 있습니다. 명령어들에 대한 정보는 “ Xshell 로컬 명령어 ”를 참조하십시오.

주소 표시줄을 통해 연결하려면:

1. 다음 명령 중 하나를 주소 표시줄에 입력하십시오:

· telnet://hostname

· ssh://hostname

· rlogin://hostname

2. Enter 키를 치거나 [연결]을 클릭하십시오.

* 참고

주소 표시줄에서도 사용자 이름과 포트 번호를 입력할 수 있습니다. 자세한 정보는 “ 주소 표시줄 ” 섹션을 참조하십시오.

관련 정보

연결


세션을 통한 연결

Xshell 4 도움말 / 세션을 통한 연결
세션을 통한 연결

세션 대화 상자를 통해 연결하려면:

1. 세션 대화 상자를 엽니다.

2. 연결하고자 하는 세션을 선택합니다.

3. [연결]을 클릭합니다.

* 참고

만약 이미 원격 호스트에 접속된 경우에는 새 연결을 위한 새 탭이 열리거나 새 Xshell 이 실행됩니다.

로컬 프롬프트를 통해 연결하려면:

1.   다음 명령을 Xshell 로컬 프롬프트에 입력합니다.
Xshell:\> open session

바로 가기를 통해 연결하려면:

1. 세션의 바로 가기 아이콘을 두 번 클릭 합니다.

* 참고

세션 바로 가기에 대한 정보를 얻으시려면 “ 세션 관리 ” 섹션을 참조하십시오.

관련 정보

연결


SERIAL 연결

Xshell 4 도움말 / SERIAL 연결
SERIAL 연결

RS232C SERIAL 연결은 UNIX 시스템에 비디오 카드가 없거나 콘솔에 직접 접근할 수 없는 경우 기존의 단말기 대신 PC를 이용하여 연결할 수 있어 편리합니다. Xshell을 통한 SERIAL 연결을 사용하려면 호스트 시스템에 SERIAL 인터페이스가 설치되어 있어야 합니다.

SERIAL로 연결하려면:

1. [파일] 메뉴에서 [새로 만들기]를 선택합니다. 새 세션 등록 정보 대화 상자가 나타납니다.

2. [이름]에 세션 이름을 입력합니다.

3. [프로토콜] 목록에서 SERIAL을 선택합니다.

4. [범주]에서 [SERIAL]을 선택합니다.

5. [Port]에 Xshell이 설치된 PC에 연결된 RS232C 직렬포트의 번호를 선택합니다.

6. [Baud Rate]에서 통신속도를 선택합니다. 서버의 값과 일치하도록 해야 합니다. 일반적으로 9600을 사용합니다.

7. [Data Bits]에서 전송되는 데이터 단위의 비트 수를 선택합니다. 서버의 값과 일치하도록 해야 합니다.

8. [Stop Bits]에 전송되는 데이터 단위의 끝을 나타내기 위한 비트 수를 선택합니다. 서버 설정에 따라 선택합니다.

9. [Parity]는 전송 자료의 에러를 검증하기 위한 것으로 서버 설정에 따라 None, Odd, Even, Mark 그리고 Space 중 하나를 선택합니다.

10. [확인]을 클릭하여 새 세션을 생성합니다.

11. 생성된 세션으로 “ 세션을 통한 연결 ”에서 설명한 바와 같이 연결할 수 있습니다.

관련 정보

연결


Xactivator로 연결

Xshell 4 도움말 / Xactivator로 연결
Xactivator로 연결

Xactivator는 알림 영역에 아이콘의 형태로 실행됩니다. Xactivator를 이용하면 새로운 Xshell 창을 열거나 새로운 세션 연결을 간단히 시작할 수 있으며 Xshell 창들을 선택하거나 닫을 때에도 편리합니다.

Xactivator를 시작하려면:

1. [도구] 메뉴에서 [Xactivator 시작]를 선택합니다. Xactivator가 실행되어 알림 영역에 아이콘이 생성됩니다.

Xactivator에서 새로운 세션 연결을 시작하려면:

1. Xactivator 알림 영역 아이콘에서 마우스 오른쪽 단추를 클릭합니다.

2. 팝업 메뉴에서 [세션]으로 마우스를 위치시켜 모든 세션을 서브 메뉴에 나열합니다.

3. 연결하려는 세션을 선택합니다.

관련 정보

연결


프록시 설정

Xshell 4 도움말 / 프록시 설정
프록시 설정

프록시 서버는 사용자 PC와 연결하고자 하는 외부 장비 사이에서 중개 역할을 하는 서버입니다.

프록시 목록 대화 상자에서 프록시 서버를 추가, 편집, 제거할 수 있습니다.

프록시 서버를 추가하려면:

1. 세션 등록 정보 대화 상자의 [연결: 프록시] 범주를 열어 [프록시 서버]의 [찾아보기]를 클릭합니다.

2. 프록시 목록 대화 상자에서 [추가]를 클릭합니다. 결과: 프록시 설정 대화 상자가 나타납니다.

3. 프록시 서버의 이름과 프록시 서버의 종류 및 호스트 정보와 사용자 정보를 입력합니다.

4. [확인]을 눌러 추가합니다.

5.

관련 정보

연결


보안

Xshell 4 도움말 / 보안
보안

Xshell은 공개 키 사용자 인증을 제공합니다.

Xshell에서 생성한 호스트 키와 사용자 키 데이터베이스는 Xmanager와 Xftp 프로그램에서 사용할 수 있으므로 사용자가 한번 공개 키를 만들면 추가적인 설정 과정 없이 모든 프로그램에서 사용할 수 있습니다.

관련 정보

공개 키 사용자 인증
호스트 키 관리


공개 키 사용자 인증

Xshell 4 도움말 / 공개 키 사용자 인증
공개 키 사용자 인증

공개 키 사용자 인증을 사용하기 위해, 사용자는 공개 키와 비밀 키로 이루어진 사용자 키 쌍을 생성해야 합니다. 공개 키 인증이 진행될 때, 비밀 키는 사용자 서명을 만들기 위해 Xshell 이 사용하며, 공개 키는 그 서명을 확인하기 위해 SSH 서버가 사용합니다.

사용자 키는 SSH 서버, Xshell 양쪽에서 생성이 가능합니다. 만약 서버 쪽에서 생성되었다면, 사용자는 비밀 키를 Xshell 의 가져오기 기능을 이용하여 Xshell 비밀 키 저장소에 등록해야 합니다. 만약 Xshell 에서 생성되었다면, 사용자는 공개 키를 서버에 등록하여야 합니다.

사용자 키를 생성하려면:

1. [도구] 메뉴에서 [사용자 키 생성 마법사]를 선택합니다.

2. 사용자 키 생성 마법사 의 안내에 따라 사용자 키를 생성합니다.

* 참고

키 생성의 마지막 단계에서 공개 키를 서버에 등록할 수 있습니다. 등록 방법은 서버의 종류에 따라 다릅니다.

· SSH1: 공개 키를 $HOME/.ssh/authorized_keys 파일에 복사해 넣습니다. 설정 파일과 디렉터리의 쓰기 권한을 없애기 위해 다음 명령어를 실행합니다.
$ cd
$ chmod go-w . .ssh .ssh/authorized_keys

· SSH2-OpenSSH: OpenSSH 서버들은 이 형식을 사용합니다. 공개 키를 $HOME/.ssh/authorized_keys2 파일에 복사해 넣습니다. 설정 파일과 디렉터리의 쓰기 권한을 없애기 위해 다음 명령어를 실행합니다.
$ cd
$ chmod go-w . .ssh .ssh/authorized_keys2

· SSH2-IETF SECSH: ssh.com의 서버와 같이 몇몇 상용 SSH 서버들은 이 형식을 사용합니다. 공개 키를 mypublickey.pub과 같이 고유한 이름으로 저장하여 $HOME/.ssh2 디렉토리에 복사합니다. $HOME/.ssh2/authorization 파일에 다음 라인을 추가합니다:
Key mypublickey.pub
설정 파일과 디렉터리의 쓰기 권한을 없애기 위해 다음 명령어를 실행합니다.
$ cd
$ chmod go-w . .ssh2
$ chmod go-w .ssh2/authorization .ssh2/mypublickey.pub

공개 키를 서버에 등록하려면:

1. [도구] 메뉴에서 [사용자 키 관리자]를 선택하여 사용자 키 대화 상자를 엽니다.

2. 등록할 사용자 키를 선택합니다.

3. [등록 정보]를 클릭합니다. 사용자 키 속성 대화 상자가 나타납니다.

4. [공개 키] 탭을 클릭합니다.

5. [공개 키 형식] 목록에서 적절한 형식을 선택합니다.

6. [파일로 저장]을 클릭하여 저장하거나 키의 내용을 복사하여 위의 공개 키 등록 방법에 따라 서버에 등록합니다.

사용자 키의 암호를 변경하려면:

1. 사용자 키 대화 상자를 엽니다.

2. 암호를 변경할 사용자 키를 선택합니다.

3. [등록 정보]를 클릭합니다. 사용자 키 속성 대화 상자가 나타납니다.

4. [일반] 탭을 클릭합니다.

5. [암호 변경]을 클릭합니다.

* 참고

“ 사용자 키 대화 상자 ”에서 사용자 키 내보내기, 가져오기, 이름 바꾸기, 삭제, 생성 등의 작업을 할 수 있습니다.

관련 정보

보안
사용자 키 대화 상자


사용자 키 대화 상자

Xshell 4 도움말 / 사용자 키 대화 상자
사용자 키 대화 상자

사용자 키 대화 상자는 사용자 키를 생성 및 관리할 수 있게 해줍니다. [도구] 메뉴의 [사용자 키 관리자]를 선택하여 열 수 있습니다.

가져오기

열기 대화 상자를 열어 사용자 키 파일을 선택하고 가져올 수 있습니다. 현재 Xshell 은 SSH1 프로토콜의 RSA 키와, OpenSSH SSH2 프로토콜의 RSA/DSA 키, SSH.COM 키 및 넷사랑컴퓨터 사용자 키 형식(*.pri)을 읽을 수 있습니다.

내보내기

저장 대화 상자를 열고 선택된 사용자 키 파일을 저장합니다. 내보내는 파일의 형식은 넷사랑 사용자 키 형식과 OpenSSH SSH2 형식입니다. 넷사랑컴퓨터 사용자 키 형식의 파일(*.pri)은 넷사랑컴퓨터에서 개발한 프로그램에서 사용할 수 있으며 타사의 응용프로그램에서는 사용할 수 없습니다.

삭제

선택된 사용자 키를 데이터베이스에서 삭제합니다.

이름 바꾸기

선택된 사용자 키의 이름을 바꿉니다. 키 이름은 파일 이름으로 유효한 것이어야 합니다.

등록 정보

사용자 키의 속성 정보를 보여줍니다. 종류, 길이, 손도장과 공개 키 등을 볼 수 있으며, 키 암호를 바꿀 수 있습니다.

생성

사용자 키 생성 마법사 를 엽니다.

관련 정보

공개 키 사용자 인증


호스트 키 관리

Xshell 4 도움말 / 호스트 키 관리
호스트 키 관리

호스트 키는 원격 호스트의 공개 키이며 사용자는 키의 손도장을 통해 호스트를 검증할 수 있습니다.

원격 호스트는 연결이 이루어질 때 자신의 공개 키를 Xshell에게 보냅니다. 처음으로 연결하는 호스트거나 호스트 키가 데이터베이스에 저장되어 있지 않으면, 연결할 때 SSH 보안 경고 대화 상자가 나타납니다. 호스트 키가 유효하고 신뢰할 수 있다면, 사용자는 호스트 키를 Xshell 호스트 키 데이터베이스에 저장합니다.

관련 정보

보안
SSH 보안 경고 대화 상자
호스트 키 대화 상자


SSH 보안 경고 대화 상자

Xshell 4 도움말 / SSH 보안 경고 대화 상자
SSH 보안 경고 대화 상자

SSH 보안 경고 대화 상자는 원격 호스트의 호스트 키가 호스트 키 데이터베이스에 저장되어 있지 않거나 원격 호스트 키와 저장되어 있는 호스트 키의 손도장이 다를 때 나타납니다.

한 번 수락

호스트 키를 이번 연결에만 받아들입니다. 호스트 키는 저장되지 않으며 다음 연결할 때 같은 대화 상자가 나타나게 됩니다. 서버의 호스트 키가 자주 바뀌거나 해당 서버에 자주 접속하지 않는 경우 유용합니다.

수락 및 저장

호스트 키를 저장하고 연결을 계속 진행합니다. 다음 연결할 때에는 SSH 보안 경고 대화 상자가 나타나지 않습니다. 손도장이 확실하고 이 호스트에 자주 접속하는 경우 유용합니다.

취소

호스트 키를 받아들이지 않고 연결을 취소합니다.

관련 정보

호스트 키 관리


호스트 키 대화 상자

Xshell 4 도움말 / 호스트 키 대화 상자
호스트 키 대화 상자

호스트 키 대화 상자는 접속이 허락된 호스트들에 대한 호스트 키를 관리할 수 있게 해줍니다. [도구] 메뉴의 [호스트 키 관리자]를 선택하여 열 수 있습니다.

가져오기

열기 대화 상자를 열어서 호스트 키를 가져옵니다. 가져온 호스트 키는 호스트 키 데이터베이스에 저장되어 호스트 키 대화 상자에 나타납니다. SECSH 공개 키 형식으로 저장된 파일을 가져올 수 있습니다.

내보내기

저장 대화 상자를 열어 선택된 호스트 키를 내보냅니다. 내보낸 키들은 SECSH의 공개 키 형식으로 저장되며 다른 프로그램에서도 사용할 수 있습니다.

제거

선택된 호스트 키를 데이터베이스에서 제거합니다.

보기

메모장으로 선택된 호스트 키 파일을 엽니다.

관련 정보

호스트 키 관리


터널링 서비스

Xshell 4 도움말 / 터널링 서비스
터널링 서비스

Xshell 은 신뢰할 수 없는 네트워크 환경을 통해 연결된 사용자의 PC와 다른 컴퓨터에 보안 터널을 생성하여 안전하게 데이터를 전송해 주는 TCP/IP 및 X11 포워딩 기능을 제공합니다.

관련 정보

TCP/IP 포트 포워딩
X11 포워딩
SOCKS4/5 동적 포트 포워딩
인스턴트 터널링


TCP/IP 포트 포워딩

Xshell 4 도움말 / TCP/IP 포트 포워딩
TCP/IP 포트 포워딩

암호화 터널을 통한 포트 포워딩 서비스를 이용하기 위해서는 각각의 응용 프로그램에 대한 포트 포워딩 규칙을 정의해야 합니다.

* 참고

Local 포워딩의 경우, 로컬 PC의 수신 대기 포트를 통한 접속을 대상 호스트의 특정 포트로 전달합니다.

Remote 포워딩의 경우, 원격 호스트의 수신 대기 포트를 통한 접속을 대상 호스트의 특정 포트로 전달합니다.

Dynamic 포워딩은 Local 포워딩과 동일한 방법으로 동작하지만 특정 대상 호스트를 정하지 않습니다. 참고로, Dynamic 포워딩은 SOCKS 프록시 프로토콜을 사용하며 SOCKS 프로토콜의 기본 포트 번호는 1080번입니다.

세션에 새 포트 포워딩 규칙을 추가하려면:

1. 세션 대화 상자를 엽니다.

2. 포트 포워딩 규칙을 편집할 세션을 선택합니다.

3. 표준 단추에서 [등록 정보]를 클릭합니다.

4. [범주]에서 [연결: SSH: 터널링]을 선택합니다.

5. [추가]를 클릭하여 포워딩 규칙 대화 상자를 엽니다.

6. [종류] 목록에서 연결의 종류를 선택합니다.

7. [원본 호스트]에 localhost 또는 IP 주소를 입력합니다.

8. [수신 대기 포트]에 포트 번호를 입력하거나 서비스 이름을 선택합니다.

9. [대상 호스트]에 서버 프로그램이 구동되고 있는 호스트의 이름이나 IP 주소를 입력하십시오.

10. [대상 포트]에 서버 프로그램이 대기하고 있는 포트 번호를 입력하십시오.

11. [설명]에 해당 포워딩 규칙에 대한 설명을 입력할 수 있습니다.

12. [확인]을 클릭합니다.

포워딩 규칙을 변경하려면:

1. 세션 대화 상자를 엽니다.

2. 포트 포워딩 규칙을 편집할 세션을 선택합니다.

3. 표준 단추에서 [등록 정보]를 클릭합니다.

4. [범주]에서 [연결: SSH: 터널링]을 선택합니다.

5. 변경하고자 하는 포워딩 규칙을 선택합니다.

6. [편집]을 클릭합니다.

포트 포워딩 규칙을 제거하려면:

1. 세션 대화 상자를 엽니다.

2. 포트 포워딩 규칙을 제거하고자 하는 세션을 선택합니다.

3. 표준 단추에서 [등록 정보]를 클릭합니다.

4. [범주]에서 [연결: SSH: 터널링]을 선택합니다.

5. 제거하고자 하는 포워딩 규칙을 선택합니다.

6. [제거]를 클릭합니다.

관련 정보

터널링 서비스


X11 포워딩

Xshell 4 도움말 / X11 포워딩
X11 포워딩

X11 포워딩은 TCP/IP 포트 포워딩의 특별한 경우입니다. X11 연결은 원격 호스트에서 사용자 PC의 X 서버 프로그램으로 성립되므로 이메일이나 텔넷과 같은 다른 클라이언트 프로그램과 반대의 경우라 할 수 있습니다. X11 포워딩을 이용하면 복잡한 포트 포워딩 설정 없이 원격의 X11 응용 프로그램들을 안전한 암호화 터널을 통해 사용자 PC에서 사용할 수 있습니다.

X11 포워딩 서비스를 사용하기 위해서는 Xshell 과 SSH 서버 모두를 설정해야 합니다.

Xshell에서 X11 포워딩을 활성화하려면:

1. 세션 대화 상자를 엽니다.

2. X11 포워딩을 활성화하고자 하는 세션을 선택합니다.

3. 표준 단추에서 [등록 정보]를 클릭합니다.

4. [범주]에서 [연결: SSH: 터널링]을 선택합니다.

5. [X11 연결을 다음으로 전달합니다]를 선택합니다.

6. 만약 사용자의 PC에 Xmanager®가 설치되어 있다면, [Xmanager]를 선택합니다.
만약 다른 PC X 서버를 사용한다면 [X DISPLAY]를 선택하고 적절한 값을 입력합니다.

7. [확인]을 클릭합니다.

* 참고

Xmanager 의 경우, X DISPLAY 옵션을 Xshell 이 자동으로 찾습니다.. 다른 PC X 서버 프로그램은 사용자가 직접 설정을 해야 합니다. 만약 PC X 서버가 TCP 6000번 포트를 사용하고 있다면, DISPLAY는 “localhost:0.0”으로 설정합니다.

OpenSSH 서버에서 X11 포워딩을 활성화하려면:

1. /etc/ssh/sshd_config 파일을 엽니다.

2. X11Forwarding 옵션의 값을 아래와 같이 설정합니다:
X11Forwarding             yes

3. SSH 서버를 다시 시작합니다.

ssh.com 서버에서 X11 포워딩을 활성화하려면:

1. /etc/ssh2/sshd2_config 파일을 엽니다.

2. AllowX11Forwarding 옵션의 값을 아래와 같이 설정합니다:
AllowX11Forwarding        yes

3. SSH 서버를 다시 시작합니다.

관련 정보

터널링 서비스


SOCKS4/5 동적 포트 포워딩

Xshell 4 도움말 / SOCKS4/5 동적 포트 포워딩
SOCKS4/5 동적 포트 포워딩

동적 포트 포워딩은 로컬 네트워크에 있는 연결을 SSH 서버로 전달하는 포워딩 방법 중 하나로, 전달될 대상 호스트와 포트가 SOCKS 프로토콜에 의해 자동으로 결정되는 방식입니다. 동적 포트 포워딩을 사용하면 Xshell을 SOCKS 프록시 서버로 사용할 수 있게 됩니다.

세션에 새 동적 포트 포워딩 규칙을 추가하려면:

1. 세션 대화 상자를 엽니다.

2. 포트 포워딩 규칙을 편집할 세션을 선택합니다.

3. 표준 단추에서 [등록 정보]를 클릭합니다.

4. [범주]에서 [연결: SSH: 터널링]을 선택합니다.

5. [추가]를 클릭하여 포워딩 규칙 대화 상자를 엽니다.

6. [종류] 목록에서 Dynamic (SOCKS4/5)을 선택합니다.

7. [수신 대기 포트]에 포트 번호를 입력하거나 서비스 이름을 선택합니다. SOCKS 프록시 서버의 기본 포트는 1080번입니다.

8. [확인]을 클릭합니다.

* 참고

동적 포트 포워딩의 경우에는 대상 호스트와 포트를 입력할 필요가 없습니다..

관련 정보

터널링 서비스


인스턴트 터널링

Xshell 4 도움말 / 인스턴트 터널링
인스턴트 터널링

인스턴트 터널링 기능은 세션이 연결되어 있는 상태에서 포워딩 규칙을 추가, 제거, 일시 정지, 다시 시작할 수 있도록 해주는 기능입니다. 현재 세션의 터널링 상태는 터널링 창에서 확인할 수 있습니다. 터널링 창을 보이게 하려면 [보기] 메뉴에서 [터널링 창]을 선택하십시오

터널링 창에서 포트 포워딩 규칙을 추가하려면:

1. 터널링 창에서 [포워딩 규칙] 탭을 클릭합니다.

2. 목록에서 마우스 오른쪽 단추를 클릭합니다.

3. 메뉴에서 [추가]를 선택합니다. 포워딩 규칙 대화 상자가 나타납니다.

* 참고

새로 추가된 규칙은 저장하지 않는 한 현재 연결에만 적용되며 연결이 끝나면 제거됩니다.

터널링 창에서 포트 포워딩 규칙을 제거하려면:

1. 터널링 창에서 [포워딩 규칙] 탭을 클릭합니다.

2. [포워딩 규칙] 목록에서 지우고자 하는 규칙에서 마우스 오른쪽 단추를 클릭합니다.

3. 메뉴에서 [제거]를 선택합니다.

포트 포워딩 규칙을 일시 중단하려면:

1. 터널링 창에서 [포워딩 규칙] 탭을 클릭합니다.

2. [포워딩 규칙] 목록에서 일시 중단하려는 규칙에서 마우스 오른쪽 단추를 클릭합니다.

3. 메뉴에서 [일시 중단]를 선택합니다.

포트 포워딩 규칙을 다시 시작하려면:

1. 터널링 창에서 [포워딩 규칙] 탭을 클릭합니다.

2. [포워딩 규칙] 목록에서 다시 시작하고자 하는 규칙에서 마우스 오른쪽 단추를 클릭합니다.

3. 메뉴에서 [다시 시작]을 선택합니다.

* 참고

다시 시작은 이전에 일시 중단했던 규칙에만 실행할 수 있습니다.

관련 정보

터널링 서비스


터미널 창 작업

Xshell 4 도움말 / 터미널 창 작업
터미널 창 작업

Xshell 은 원격 호스트의 명령행 인터페이스와 로컬 프롬프트를 동시에 사용할 수 있게 하는 간결하면서도 강력한 터미널 창을 제공합니다. 또한 터미널 창은 복사하기와 붙여넣기, 문자열 찾기, 글꼴 및 색깔 바꾸기, 고급 터미널 옵션 등 다양하고 편리한 기능을 제공합니다.

관련 정보

복사하기와 붙여넣기
문자열 찾기
글꼴 바꾸기
글자 색과 배경 색 설정
커서 설정 변경하기
창 다루기
멀티 세션 다루기
빠른 명령 모음 설정
인코딩 변경
고급 터미널 옵션의 설정
레이아웃 관리


복사하기와 붙여넣기

Xshell 4 도움말 / 복사하기와 붙여넣기
복사하기와 붙여넣기

문자열을 선택하려면:

1. 다음 중 한 가지 방법을 선택합니다:

· 선택하고자 하는 영역의 시작 점에서 마우스 왼쪽 단추를 누릅니다. 단추를 누른 채 마우스를 움직여 선택하고자 하는 영역의 끝 점에서 마우스 단추를 놓습니다. 선택된 문자열은 반전된 색으로 표시됩니다.

· 선택하고자 하는 문자열의 시작 점에서 마우스 왼쪽 단추를 클릭합니다. 마우스를 움직여 선택하고자 하는 영역의 끝점으로 이동합니다. Shift 키를 누른 채 왼쪽 단추를 다시 한 번 누릅니다.

· 선택하려는 단어를 두 번 클릭 합니다. 두 번 클릭된 단어가 선택됩니다.

· 선택하려는 줄을 빠르게 세 번 클릭합니다. 해당 줄 전체가 선택됩니다.

칼럼 단위로 문자열을 선택하려면:

1. Alt 키를 누릅니다.

2. 선택하고자 하는 영역의 시작 점에서 마우스 왼쪽 단추를 누릅니다. 단추를 누른 채 마우스를 움직여서 선택하고자 하는 영역의 끝 점에서 마우스 단추를 놓습니다.

선택된 문자열을 Windows 클립보드로 복사하려면:

1. 복사할 문자열을 선택합니다.

2. 다음 중 한 가지 방법을 선택합니다:

· [스마트 선택] 단추를 클릭한 후 [복사]를 선택합니다.

· [편집] 메뉴에서 [복사]를 선택합니다.

· 표준 단추에서 [복사]를 클릭합니다.

· Ctrl+Insert 키를 누릅니다.

· 옵션에서 [선택한 텍스트를 자동으로 클립보드에 복사]를 설정하면 선택한 텍스트가 자동으로 복사됩니다.

선택된 문자열을 메모장으로 복사하려면:

1. 복사할 문자열을 선택합니다.

2. 다음 중 한 가지 방법을 선택합니다:

· [스마트 선택] 단추를 클릭한 후 [메모장으로]를 선택합니다.

· [편집] 메뉴에서 [메모장으로]를 가리킨 후 [선택 영역]을 선택합니다.

* 참고

선택된 문자열뿐 아니라 현재 화면이나 스크롤 버퍼를 복사할 수도 있습니다. 메모장 창은 복사된 텍스트와 함께 자동으로 나타나게 됩니다. 이 기능은 문자열을 클립보드에 복사하지 않습니다.

클립보드의 내용을 터미널 화면에 붙여넣으려면:

1. 다음 중 한 가지 방법을 선택하십시오:

  • [편집] 메뉴에서 [붙여넣기]를 선택합니다.
  • 표준 단추에서 [붙여넣기]를 클릭합니다.
  • Shift+Insert 키를 누릅니다.
  • 마우스 가운데 단추나 오른쪽 단추의 동작을 [클립보드의 내용을 붙여 넣습니다.]로 선택한 경우 해당 마우스 단추를 클릭합니다.

xterm 스타일의 복사하기 및 붙여넣기를 설정하려면:

1. 옵션 대화 상자를 엽니다.

2. [키보드와 마우스] 탭을 클릭합니다.

3. [마우스 - 가운데 단추]의 동작을 [클립보드의 내용을 붙여 넣습니다.]로 선택합니다.

4. [선택한 텍스트를 자동으로 클립보드에 복사]를 선택합니다.

5. [확인]을 클릭합니다.

* 참고

xterm 프로그램은 문자열을 선택할 때 클립보드로 복사하며, 가운데 단추를 누를 때 터미널 화면에 붙여넣습니다.

관련 정보

터미널 창 작업


문자열 찾기

Xshell 4 도움말 / 문자열 찾기
문자열 찾기

스크롤 버퍼를 특정 키워드나 정규식을 이용하여 검색할 수 있습니다.

키워드로 찾으려면:

1. [편집] 메뉴에서 [찾기]를 선택합니다.

2. 찾기 대화 상자에서 찾을 키워드를 입력합니다.

3. [다음 찾기]를 클릭합니다.

정규식으로 찾으려면:

1. [편집] 메뉴에서 [찾기]를 선택합니다.

2. 찾기 대화 상자에서 찾을 키워드를 입력합니다.

3. [정규식]을 선택합니다.

4. [다음 찾기]를 클릭합니다.

* 참고

정규식에 대한 자세한 정보는 “ 정규식 ” 섹션을 참조하십시오.

관련 정보

터미널 창 작업


글꼴 바꾸기

Xshell 4 도움말 / 글꼴 바꾸기
글꼴 바꾸기

터미널 화면은 그 특성상 행과 열에 맞추어 글자를 나타내야 하기 때문에 Xshell 에서는 고정 폭 글꼴만을 선택할 수 있습니다.

터미널 글꼴과 그 크기를 바꾸려면:

1. 다음 중 한 가지 방법을 선택합니다:

· 표준 단추에서 글꼴 아이콘을 클릭하여 원하는 글꼴과 크기를 선택합니다.

· 세션 등록 정보 대화 상자에서 [모양] 범주를 선택한 후 원하는 글꼴과 크기를 선택합니다.

강조 문자 표현 방법을 변경하려면:

1. 세션 등록 정보 대화 상자를 엽니다.

2. [범주]에서 [모양]을 선택합니다.

3. [강조 스타일] 영역에서 원하는 옵션을 선택합니다.

* 참고

강조 스타일은 강조 색, 굵은 글꼴 또는 강조 색과 굵은 글꼴 모두를 사용할 수 있습니다.

관련 정보

터미널 창 작업


글자 색과 배경 색 설정

Xshell 4 도움말 / 글자 색과 배경 색 설정
글자 색과 배경 색 설정

색 구성표에는 글자 색과 배경 색, ANSI 16색 등의 정보가 저장됩니다. Xshell은 사용 중 언제든지 색 구성표를 선택/변경할 수 있도록 해주며, 선택된 색 구성표는 바로 적용됩니다.

터미널 색을 바꾸려면:

1. 다음 중 한 가지 방법을 선택합니다:

· 표준 단추에서 [색 구성표]를 클릭하면 색 구성표 선택 대화 상자가 나타납니다. 대화 상자에서 원하는 색 구성표를 선택한 후 [확인]을 클릭합니다.

· 세션 등록 정보 대화 상자의 [범주]에서 [모양]을 선택한 후 [색 구성표] 목록에서 원하는 색 구성표를 선택한 후 [확인]을 클릭합니다.

* 참고

Xshell 은 몇 개의 기본 색 구성표를 제공합니다. 사용자는 기존의 색 구성표를 편집하거나 새로운 색 구성표를 만들 수 있습니다.

새로운 색 구성표를 만들려면:

1. 색 구성표 선택 대화 상자를 엽니다.

2. [새로 만들기]를 클릭합니다. 새로운 색 구성표가 목록에 추가됩니다.

3. 생성된 색 구성표를 선택합니다.

4. [편집]을 클릭합니다. 색 구성표 편집 대화 상자가 나타납니다.

색 구성표를 편집하려면:

1. 색 구성표 선택 대화 상자를 엽니다.

2. 편집하고자 하는 색 구성표를 선택합니다.

3. [편집]을 클릭합니다. 색 구성표 편집 대화 상자가 나타납니다.

4. [일반 텍스트]에는 일반 글자에 사용될 색을 선택합니다.

5. [굵은 텍스트]에는 굵은 글자에 사용될 색을 선택합니다. 일반적으로 굵은 글자의 색은 일반 글자보다 밝은 색을 사용합니다.

6. [ANSI 컬러]는 터미널에서 ANSI 컬러 코드를 표현하기 위해 사용되는 색입니다. 위쪽의 색들은 black, red, green, yellow, blue, magenta, cyan 및 white 의 일반 글자색이며, 아래쪽의 색들은 각각의 굵은 글자의 색입니다.

색 구성표를 내보내려면:

1. 색 구성표 선택 대화 상자를 엽니다.

2. 내보내고자 하는 색 구성표를 선택합니다.

3. [내보내기]를 클릭합니다. 저장 대화 상자가 나타납니다.

4. 폴더를 정하고 저장할 파일 이름을 입력합니다.

5. [저장]을 클릭합니다.

* 참고

내보낸 파일은 “.xcs” 라는 형식이며 Xshell 에서만 사용 가능합니다. 여러 개의 색 구성표가 한 개의 파일에 저장될 수 있습니다. 색 구성표의 이름도 파일에 함께 저장됩니다.

색 구성표를 가져오려면:

1. 색 구성표 선택 대화 상자를 엽니다.

2. [가져오기]를 클릭합니다. 열기 대화 상자가 나타납니다.

3. 가져오기 원하는 색 구성표 파일(.xcs)을 선택합니다.

4. [열기]를 클릭합니다.

관련 정보

터미널 창 작업


커서 설정 변경하기

Xshell 4 도움말 / 커서 설정 변경하기
커서 설정 변경하기

커서의 색을 변경하려면:

1. 세션 등록 정보 대화 상자를 엽니다.

2. [범주]에서 [모양]을 선택합니다.

3. [커서 색]의 값을 선택합니다.

4. [텍스트 색]의 값을 선택합니다.

5. [확인]을 클릭합니다.

커서의 깜박임 여부를 변경하려면:

1. 세션 등록 정보 대화 상자를 엽니다.

2. [범주]에서 [모양]을 선택합니다.

3. [깜박이는 커서 사용]을 선택하거나 선택 해제합니다.

4. [확인]을 클릭합니다.

커서의 깜박임 속도를 변경하려면:

1. 세션 등록 정보 대화 상자를 엽니다.

2. [범주]에서 [모양]을 선택합니다.

3. [깜박이는 커서 사용]을 선택합니다.

4. [속도]에 커서 깜박임 속도를 밀리초 단위로 입력합니다.

5. [확인]을 클릭합니다.

관련 정보

터미널 창 작업


창 다루기

Xshell 4 도움말 / 창 다루기
창 다루기

알림 영역으로 최소화하려면:

1. 옵션 대화 상자를 엽니다.

2. [고급] 탭을 클릭합니다.

3. [알림 영역으로 최소화]를 선택합니다.

4. [확인]을 클릭하여 변경 사항을 저장합니다.

시작 시 알림 영역으로 최소화하려면:

1. 옵션 대화 상자를 엽니다.

2. [고급] 탭을 클릭합니다.

3. [Xshell 시작 시 알림 영역으로 최소화]를 선택합니다.

4. [확인]을 클릭하여 변경 사항을 저장합니다.

모든 연결이 종료되었을 때 Xshell을 끝내려면:

1. 옵션 대화 상자를 엽니다.

2. [고급] 탭을 클릭합니다.

3. [모든 연결 종료 시 Xshell 끝내기]를 선택합니다.

4. [확인]을 클릭합니다.

연결 종료 시 로컬 셸로 빠져 나오려면:

1. 옵션 대화 상자를 엽니다.

2. [고급] 탭을 클릭합니다.

3. [연결 종료 시 로컬 셸로 복귀]을 선택합니다.

4. [확인]을 클릭합니다.

새로운 Xshell 창을 생성하려면:

1. [창] 메뉴에서 [새 창]을 선택합니다.

다른 Xshell 창으로 이동하려면:

1. [창] 메뉴에서 [다음] 혹은 [이전]을 선택합니다.

* 참고

Alt+Right와 Alt+Left 키를 통해 동일한 기능을 수행할 수 있습니다.

모든 Xshell 창을 동시에 종료하려면:

1. [창] 메뉴에서 [모두 닫기]를 선택합니다.

현재 창을 제외한 모든 Xshell 창을 종료하려면:

1. [창] 메뉴에서 [이 창을 제외하고 모두 닫기]를 선택합니다.

관련 정보

터미널 창 작업


멀티 세션 다루기

Xshell 4 도움말 / 멀티 세션 다루기
멀티 세션 다루기

멀티 세션 기능은 하나의 Xshell 창에서 다중 연결을 유지하며 세션 탭 이나 세션 표시줄 을 이용하여 세션을 이동하면서 작업할 수 있도록 해줍니다.

하나의 Xshell 창에서 여러 개의 세션을 열려면:

1. 옵션 대화 상자를 엽니다.

2. [고급] 탭을 클릭합니다.

3. [옵션] 영역에서 [하나의 Xshell 창에 여러 개의 세션 열기]를 선택합니다.

4. [확인]을 클릭하여 변경 사항을 저장합니다.

세션 탭에서 새로운 연결을 생성하려면:

1. 세션 탭 의 탭 추가 단추를 클릭합니다.

2. 세션 목록에서 하나를 선택합니다.
결과: 새로운 탭에 선택된 세션이 열립니다.

세션 표시줄에서 새로운 연결을 생성하려면:

1. 세션 표시줄 의 맨 왼쪽 아이콘을 클릭합니다.

2. 세션 목록에서 하나를 선택합니다.

결과: 새로운 탭에 선택된 세션이 열립니다.

* 참고

새로운 연결을 생성하려면 “ 연결 ”에서 설명하는 바와 같이 세션을 이용하거나 세션 없이 연결하는 방법을 사용해도 됩니다.

로컬 셸에서 명령어를 입력하여 원격 컴퓨터에 연결하려면:

1. 세션 탭 의 탭 추가 단추를 클릭하여 [로컬 셸]을 선택하거나 세션 탭 의 빈 공간을 두 번 클릭 하여 로컬 셸 세션을 생성합니다.

2. 명령행 프롬프트 상태에서 ssh, telnet, sftp 등의 명령을 이용하여 원격지 컴퓨터에 접속합니다. 자세한 명령줄 사용법을 위해서는 ‘?’를 입력합니다.

멀티 세션 연결에서 세션 간 이동하려면:

1. 세션 이동하려면 다음 중 한 가지 방법을 사용합니다.

· 세션 탭을 선택합니다.

· 세션 표시줄에 나열된 세션 이름을 선택합니다.

· Ctrl+Tab, Shift+Tab 또는 Ctrl+Shift+Tab을 이용합니다.

· Alt+세션 번호로 이동합니다.

새로운 Xshell 창에 세션 연결하려면:

1. [창] 메뉴의 [새 터미널]을 선택하거나 표준 단추의 [새 터미널]을 클릭합니다. 결과: 새로운 Xshell 창이 열리고 현재 연결된 세션과 같은 세션 정보로 연결을 시도합니다.

관련 정보

터미널 창 작업


빠른 명령 모음 설정

Xshell 4 도움말 / 빠른 명령 모음 설정
빠른 명령 모음 설정

자주 사용하는 문자열을 빠른 명령으로 지정하여 사용하면 반복되는 키보드 입력을 빠른 명령 클릭으로 대신할 수 있습니다. 빠른 명령 표시줄을 표시하려면 [보기] 메뉴의 [빠른 명령]을 체크하면 됩니다.

빠른 명령 모음을 추가하려면:

1. [도구] 메뉴에서 [빠른 명령 모음]을 선택합니다. 결과: 빠른 명령 모음 대화 상자가 나타납니다.

2. [새로 만들기]를 클릭합니다.

3. 새로운 빠른 명령 모음의 이름을 입력합니다.

* 참고

또한 빠른 명령 모음 대화 상자를 열기 위해서 빠른 명령 표시줄에서 [빠른 명령 모음] 단추를 클릭한 다음 목록에서 [찾아보기]를 선택합니다.

빠른 명령 표시줄에서 빠른 명령을 추가하려면:

1. 빠른 명령 표시줄에서 정의되지 않은 빠른 명령 단추을 클릭합니다.
또는 바로 가기 키(Ctrl+F1 등)를 누를 수도 있습니다.
결과: 빠른 명령 편집 대화 상자가 나타납니다.

2. [레이블]에 빠른 명령 이름을, [텍스트]에 자주 사용하는 명령이나 문자열을 입력합니다.

3. [확인]을 클릭합니다.

빠른 명령 모음에 빠른 명령을 추가하려면:

1. [도구] 메뉴에서 [빠른 명령 모음]을 선택합니다. 결과: 빠른 명령 모음 대화 상자가 나타납니다.

2. 빠른 명령을 추가할 빠른 명령 모음을 선택합니다.

3. [편집]을 클릭합니다. 결과: 빠른 명령 모음 편집 대화 상자가 나타납니다.

4. 빠른 명령을 선택한 후 [편집]을 클릭합니다. 결과: 빠른 명령 편집 대화 상자가 나타납니다.

5. [레이블]에 빠른 명령 이름을 [텍스트]에 자주 사용하는 명령이나 문자열을 입력합니다.

6. [확인]을 클릭합니다.

7. 빠른 명령을 더 추가하려면 4-6 과정을 반복합니다.

8. 빠른 명령 모음 편집 대화 상자에서 [확인]을 클릭합니다.

* 참고

또한 현재 빠른 명령 표시줄에 표시되는 빠른 명령 모음을 편집하려면 빠른 명령 표시줄에서 [빠른 명령 모음] 단추를 클릭한 다음 목록에서 [편집]을 선택하여 빠른 명령 모음 편집 대화 상자를 엽니다.

빠른 명령 모음 편집 대화 상자에서는 빠른 명령을 추가, 제거, 편집이 가능합니다. 또한 빠른 명령 표시줄에 표시되는 순서를 변경할 수 있습니다.

빠른 명령 표시줄에 다른 빠른 명령 모음을 표시하려면:

1. 빠른 명령 표시줄에서 [빠른 명령 모음] 단추를 클릭한 다음 목록에서 빠른 명령 모음을 선택합니다. 결과: 선택된 빠른 명령 모음의 빠른 명령들이 나열됩니다.

세션을 시작할 때 표시되는 빠른 명령 모음을 선택하려면:

1. 세션의 세션 등록 정보 대화 상자를 엽니다.

2. [범주]의 [고급]을 선택합니다.

3. 세션에서 사용할 빠른 명령 모음을 선택합니다.

4. [찾아보기]를 눌러 나오는 빠른 명령 모음 대화 상자에서 빠른 명령 모음을 변경하거나 새로 만들 수 있습니다.

5. [확인]을 클릭합니다.

관련 정보

터미널 창 작업


인코딩 변경

Xshell 4 도움말 / 인코딩 변경
인코딩 변경

기본적으로 Xshell 은 Windows 시스템의 사용자 기본 언어를 사용하게 됩니다. 사용자는 원격 호스트의 인코딩에 따라 Windows 시스템과 다른 다양한 인코딩을 선택하여 사용할 수 있습니다.

세션의 인코딩을 변경하려면:

1. 다음 중 한 가지 방법을 선택합니다:

· 표준 단추에서 [인코딩]을 클릭하고 사용하려는 인코딩을 선택합니다.

· 세션 등록 정보 대화 상자를 열어 [범주]의 [터미널]을 선택한 후 [인코딩] 목록에서 원하는 인코딩을 선택합니다.

2. UTF-8 인코딩 출력:

· 원격 컴퓨터가 유니코드(UTF-8)를 지원하고 UTF-8을 사용하도록 설정되어 있다면 인코딩을 ‘유니코드(UTF-8)’를 사용하여야 합니다. UTF-8 인코딩은 여러 언어의 문자 세트를 동시에 출력할 수 있습니다.

* 참고

선택된 인코딩을 바르게 표시하기 위해서는 해당 Windows 시스템에 선택된 인코딩의 언어팩이 설치되어 있어야 합니다.

인코딩 옵션은 키보드 입력 값을 바꾸지는 않으며 필요한 경우 Windows에서 제공하는 IME (Input Method Editor)를 적절히 설치해야 합니다.

관련 정보

터미널 창 작업


고급 터미널 옵션의 설정

Xshell 4 도움말 / 고급 터미널 옵션의 설정
고급 터미널 옵션의 설정

스크롤 버퍼의 크기를 변경하려면:

1. 세션 등록 정보 대화 상자를 엽니다.

2. [범주]에서 [터미널]을 선택합니다.

3. [스크롤 버퍼]에 사용하고자 하는 라인 수를 입력합니다.

4. [확인]을 클릭합니다.

* 참고

스크롤 버퍼의 크기는 0 ~ 2,147,483,647사이의 값입니다. 0은 스크롤 버퍼를 사용하지 않는다는 의미입니다.

터미널 종류를 변경하려면:

1. 세션 등록 정보 대화 상자를 엽니다.

2. [범주]에서 [터미널]을 선택합니다.

3. [터미널 종류]에서 터미널 종류를 선택합니다.

4. [확인]을 클릭합니다.

터미널 시작할 때의 크기를 변경하려면:

1. 세션 등록 정보 대화 상자를 엽니다.

2. [범주]에서 [터미널]을 선택합니다.

3. [에뮬레이션] 영역에서 [연결되면 다음 터미널 크기 사용]을 선택합니다.

4. [행]에 행 크기를 입력합니다.

5. [열]에 열 크기를 입력합니다.

6. [확인]을 클릭합니다.

키패드 모드를 변경하려면:

1. 세션 등록 정보 대화 상자를 엽니다.

2. [범주]에서 [터미널: VT 모드]을 선택합니다.

3. [초기 숫자 키패드 모드]에서 [일반] 또는 [응용 프로그램]을 선택합니다.

4. [확인]을 클릭합니다.

관련 정보

터미널 창 작업


레이아웃 관리

Xshell 4 도움말 / 레이아웃 관리
레이아웃 관리

레이아웃 관리 기능은 사용자의 작업 환경이나 기호에 따른 Xshell 창의 레이아웃을 저장할 수 있는 기능입니다. 레이아웃 관리 대화 상자에서 저장한 레이아웃을 삭제하거나 이름을 변경할 수 있습니다.

현재 Xshell 창의 레이아웃을 저장하려면:

1. [보기] 메뉴에서 [레이아웃]을 선택한 후 [다른 이름으로 저장]을 선택합니다.

2. 다른 이름으로 저장 대화 상자에서 [새 이름]을 입력합니다.

3. [확인]을 클릭합니다.

다른 레이아웃으로 Xshell 창을 변경하려면:

· [보기] 메뉴에서 [레이아웃]을 선택한 후 레이아웃 목록에서 하나를 선택합니다.

· Alt+L를 눌러 레이아웃 목록에서 하나를 선택합니다.

등록된 레이아웃 목록을 관리하려면:

1. [보기] 메뉴에서 [레이아웃]을 선택한 후 [관리]를 선택합니다.

2. 레이아웃 관리 대화 상자에서 레이아웃을 삭제하거나 이름을 변경합니다.

관련 정보

터미널 창 작업


옵션 설정

Xshell 4 도움말 / 옵션 설정
옵션 설정

옵션 대화 상자는 모든 세션에 적용되는 옵션을 설정할 수 있게 해줍니다. [도구] 메뉴의 [옵션]을 선택하여 열 수 있습니다.

관련 정보

세션 폴더 및 시작 세션
기록 지우기 및 연결 로그
키 매핑 설정
마우스 설정
투명도 설정
고급 옵션


세션 폴더 및 시작 세션

Xshell 4 도움말 / 세션 폴더 및 시작 세션
세션 폴더 및 시작 세션

Xshell 세션 폴더 경로를 변경할 수 있습니다. 세션 대화 상자에는 변경한 경로 아래의 모든 세션들이 표시됩니다. 네트워크 폴더를 선택하면 다른 사용자와 세션을 공유할 수 있습니다.

세션 폴더를 변경하려면:

1. 옵션 대화 상자를 엽니다.

2. [일반] 탭에서 [세션 폴더 경로]를 입력합니다.

시작할 때 열 세션을 등록하려면:

1. 옵션 대화 상자를 엽니다.

2. [일반] 탭에서 [시작할 때 열 세션] 목록 아래의 [추가]를 클릭합니다.

3. 열기 대화 상자에서 세션 파일을 선택합니다.

관련 정보

옵션 설정


기록 지우기 및 연결 로그

Xshell 4 도움말 / 기록 지우기 및 연결 로그
기록 지우기 및 연결 로그

기록 지우기 대화 상자에서는 주소 표시줄, 작성 창, 검색 키워드, 로컬 셸 그리고 연결 로그의 히스토리를 선택하여 삭제할 수 있습니다. 기록 설정 대화 상자에서는 연결 로그에 관한 설정이나 로그를 저장할 파일을 지정할 수 있습니다.

기록을 지우려면:

1. 옵션 대화 상자를 엽니다.

2. [일반] 탭에서 기록 [지우기]를 클릭합니다.

3. 기록 지우기 대화 상자에서 지울 내용을 선택합니다.

4. [지우기]를 클릭햡니다.

연결 로그를 저장하려면:

1. 옵션 대화 상자를 엽니다.

2. [일반] 탭에서 기록 [설정]을 클릭합니다.

3. 기록 설정 대화 상자에서 [연결 정보를 다음 파일에 기록합니다.]를 선택합니다.

4. 접속 서버, 접속 프로토콜, 접속 일시, 종료 일시 및 접속 시간에 대한 정보를 저장할 파일을 입력합니다.

관련 정보

옵션 설정


키 매핑 설정

Xshell 4 도움말 / 키 매핑 설정
키 매핑 설정

사용자 지정 키 매핑 대화 상자에서는 현재 설정된 바로 가기 키 조합을 확인할 수 있으며 사용자가 키 조합을 추가, 삭제, 편집할 수 있습니다.

키 매핑을 변경하려면:

1. 옵션 대화 상자를 엽니다.

2. [키보드와 마우스] 탭을 클릭합니다.

3. [키 매핑]의 [편집]을 클릭합니다. 결과: 사용자 지정 키 매핑 대화 상자가 나타납니다.

4. [현재 키 설정] 목록에서 변경하려는 키 조합을 선택한 후 [편집]을 클릭합니다. 결과: 편집 대화 상자가 나타납니다.

5. [종류]의 메뉴, 문자열 보내기, 스크립트 실행, 응용 프로그램 시작 중 하나를 선택합니다.

6. [동작]에 선택한 종류별 메뉴나 문자열을 입력합니다.

7. [확인]을 클릭합니다.

관련 정보

옵션 설정


마우스 설정

Xshell 4 도움말 / 마우스 설정
마우스 설정

마우스의 가운데와 오른쪽 단추의 동작을 각각 선택할 수 있습니다. 또한 두 번 클릭으로 단어를 선택할 때 사용될 구분 기호를 지정할 수 있습니다.

마우스 단추의 동작을 변경하려면:

1. 옵션 대화 상자를 엽니다.

2. [키보드와 마우스] 탭에서 마우스 가운데 단추의 기능 중 하나를 선택합니다.

· 아무것도 하지 않습니다.

· 팝업 메뉴를 엽니다.

· 클립보드의 내용을 붙여 넣습니다.(기본값)

· 등록 정보 창을 엽니다.

3. 오른쪽 단추의 기능 중 하나를 선택합니다. 오른쪽 단추의 기본 기능은 [팝업 메뉴를 엽니다.]입니다.

두 번 클릭 선택 시 구분 기호를 변경하려면:

1. 옵션 대화 상자를 엽니다.

2. [키보드와 마우스] 탭의 [선택] 영역에서 단어를 선택할 때 사용할 구분 기호를 입력합니다.

관련 정보

옵션 설정


투명도 설정

Xshell 4 도움말 / 투명도 설정
투명도 설정

Xshell은 창의 투명도 설정 기능을 제공합니다.

창이 투명하게 보이도록 설정하려면:

1. [보기] 메뉴의 [투명하게]를 선택합니다.

2. 옵션 대화 상자를 엽니다.

3. [보기] 탭에서 투명도를 설정합니다.

4. [불투명도] 값을 설정합니다. 불투명도 값이 작을수록 Xshell 창이 투명해집니다.

5. [마우스를 창 위에 놓으면 불투명하게 표시] 옵션을 선택하면 Xshell 창을 투명하게 보기로 설정된 경우에도 마우스가 창 위에 위치하는 동안은 Xshell 창을 불투명하게 표시합니다.

6. [투명할 때 항상 위에 표시] 옵션을 선택하면 Xshell 창을 투명하게 사용하는 동안 모든 창 위에 표시합니다.

관련 정보

옵션 설정


고급 옵션

Xshell 4 도움말 / 고급 옵션
고급 옵션

고급 옵션은 옵션 대화 상자의 [고급] 탭에서 설정할 수 있는 옵션들입니다.

ESC 키를 누르면 영문 입력으로 전환

vi, vim 등과 같은 일부 응용프로그램에서 한글을 입력하다가 명령 모드로 가기 위해 ESC 키를 누른 경우 자동으로 영문 입력 상태로 전환됩니다.

벨 사용 안 함

벨소리를 사용하지 않도록 설정합니다.

쉬운 복사, 파일 다운로드를 위한 스마트 선택 단추 사용

터미널 영역을 마우스로 선택 시 스마트 선택 단추를 보이거나 안 보이게 설정합니다.

알림 영역으로 최소화

Xshell이 최소화될 때 알림 영역으로 최소화하게 됩니다.

전체 화면 모드에서 세션 탭 표시

전체 화면 모드에서 세션 탭을 표시합니다.

전체 화면 모드에서 스크롤바 표시

전체 화면 모드에서 스크롤바를 표시합니다.

현재 창 크기로 계단식 창 배열

[창] 메뉴에서 계단식 배열을 선택하면 현재 Xshell 창 크기로 배열됩니다.

Windows 시작 시 Xshell 실행

Windows 시작 시 Xshell을 자동으로 구동합니다.

Xshell 시작 시 알림 영역으로 최소화

Xshell이 시작할 때 알림 영역으로 최소화 됩니다.

Xshell 시작 시 세션 대화 상자 열기

Xshell이 시작할 때 세션 대화 상자를 엽니다.

메뉴 액세스에 Alt 키 사용

Alt 키를 누르면 메뉴를 열 수 있습니다.

하나의 Xshell 창에 여러 개의 세션 열기

하나의 Xshell 창에 여러 개의 세션이 열리도록 합니다. 세션 탭과 세션 표시줄을 이용하여 세션 간에 이동할 수 있습니다.

Xshell 종료 시 연결 끊을지 확인

프로그램 종료 시 연결 중인 세션의 종료 여부를 묻습니다.

세션 종료 시 연결 끊을지 확인

세션 종료 시 연결을 끊을지 여부를 묻습니다.

연결 종료 시 로컬 셸로 복귀

연결 종료 시 로컬 셸 상태로 세션 탭이 유지됩니다. 로컬 셸 세션에서는 터미널 화면에 Xshell 프롬프트가 나타나며, open, telnet, ssh, ping 등과 같은 로컬 명령어를 실행할 수 있습니다. 명령어 목록을 보려면 Xshell 프롬프트에서 help 또는 ?를 실행하십시오.

모든 연결 종료 시 Xshell 끝내기

모든 세션 연결이 종료되면 Xshell 프로그램을 종료합니다.

관련 정보

옵션 설정


파일 전송

Xshell 4 도움말 / 파일 전송
파일 전송

Xshell 은 SFTP와 ZMODEM 프로토콜을 이용하여 파일을 보내거나 받을 수 있도록 해줍니다.

관련 정보

SFTP를 이용한 파일 전송
ZMODEM을 이용한 파일 전송
Xftp와 연동한 파일 전송


SFTP를 이용한 파일 전송

Xshell 4 도움말 / SFTP를 이용한 파일 전송
SFTP를 이용한 파일 전송

SFTP는 SSH 기반의 파일 전송 프로토콜로서 ZMODEM과 비교하여 보다 안전하고 빠른 파일 전송을 지원합니다.

SFTP로 파일을 받으려면:

1. 로컬 프롬프트에서 sftp 명령으로 파일을 받으려는 호스트에 접속합니다.
Xshell:\> sftp hostname

2. sftp 프롬프트에서 get 명령으로 원하는 파일을 받습니다.
sftp:/home/user21> get filename

SFTP로 파일을 보내려면:

1. 로컬 프롬프트에서 sftp 명령으로 파일을 보내려는 호스트에 접속합니다.
Xshell:\> sftp hostname

2. sftp 프롬프트에서 put 명령으로 원하는 파일을 보냅니다.
sftp:/home/user21> put filename

관련 정보

파일 전송


ZMODEM을 이용한 파일 전송

Xshell 4 도움말 / ZMODEM을 이용한 파일 전송
ZMODEM을 이용한 파일 전송

ZMODEM을 통해 전송 받은 파일들은 사용자가 지정한 폴더에 저장되며, 받을 때마다 다른 폴더를 사용자가 지정할 수도 있습니다.

ZMODEM으로 파일을 받으려면:

1. 다음과 같은 명령을 원격 호스트의 프롬프트에서 실행합니다:
$ sz file1 file2 …

* 참고

세션 등록 정보의 [자동으로 ZMODEM 활성화] 옵션이 설정된 경우, 파일 받기가 자동으로 진행되므로 아래 2번과 3번 과정은 생략할 수 있습니다.

2. [파일] 메뉴에서 [전송]을 가리킵니다.

3. [ZMODEM으로 받기]를 선택합니다.

* 참고

만약 원격 호스트에 sz 명령이 존재하지 않을 경우 사용자가 직접 설치해야 합니다. 대부분의 경우 그와 유사한 명령이 존재합니다.

터미널에서 ZMODEM으로 파일을 받으려면:

1. Xshell 터미널 창에서 다운로드할 파일명을 선택합니다.
결과: 스마트 선택 단추가 선택된 파일명 주변에 나타납니다.

2. 스마트 선택 단추를 클릭합니다.

3. [ZMODEM으로 다운로드]를 선택합니다.

ZMODEM으로 파일을 보내려면:

1. 다음과 같은 명령을 원격 프롬프트에서 실행합니다:
$ rz

* 참고

세션 등록 정보의 [자동으로 ZMODEM 활성화] 옵션이 설정된 경우, 파일 보내기가 자동으로 진행되므로 아래 2번과 3번 과정은 생략할 수 있습니다.

2. [파일] 메뉴에서 [전송]을 가리킵니다.

3. [ZMODEM으로 보내기]를 선택합니다.

4. 보낼 파일을 선택합니다.

5. 만약 ASCII 형식으로 보내기 원한다면 [파일을 ASCII로 보냄]을 선택합니다.

6. [열기]를 클릭합니다.

끌어서 놓기를 이용하여 ZMODEM으로 파일을 보내려면:

1. 업로드하려는 Windows 파일을 선택합니다.

2. 파일을 끌어 Xshell 터미널 창에 놓습니다.
결과: 파일 전송이 자동으로 진행됩니다.

기본 파일 저장 폴더를 변경하려면:

1. 세션 등록 정보 대화 상자를 엽니다.

2. [범주]에서 [ZMODEM]을 선택합니다.

3. [수신 폴더] 영역 안에서 [다음 다운로드 경로를 사용함]을 선택합니다.

4. [다운로드 경로]의 […]를 클릭하여 폴더 찾아보기 대화 상자를 연 후 받은 파일들을 저장할 폴더를 선택합니다.

5. [확인]을 클릭합니다.

받은 파일을 열람하려면:

1. 세션 등록 정보 대화 상자를 엽니다.

2. [범주]에서 [ZMODEM]을 선택합니다.

3. [수신 폴더] 영역 안의 [열기]를 클릭합니다.

관련 정보

파일 전송


Xftp와 연동한 파일 전송

Xshell 4 도움말 / Xftp와 연동한 파일 전송
Xftp와 연동한 파일 전송

Xshell은 ㈜넷사랑컴퓨터의 파일 전송 프로그램인 Xftp와 연동하여 현재 Xshell로 접속 중인 호스트에 빠르고 쉽게 FTP/SFTP 연결을 할 수 있게 해 줍니다.

Xshell이 연결 중인 호스트에 Xftp 연결 생성하기:

1. Xshell로 파일을 전송하려는 호스트에 접속합니다.

2. [창] 메뉴에서 [새 파일 전송]을 선택합니다. 또는 표준 단추에서 [새 파일 전송]을 클릭합니다.

* 참고

Xshell이 사용하는 프로토콜이 SSH인 경우 Xftp는 SFTP 연결을 시도하며, 그 밖에 TELNET, RLOGIN 등의 프로토콜인 경우 FTP를 사용하여 연결합니다.

관련 정보

파일 전송


세션 로깅과 추적

Xshell 4 도움말 / 세션 로깅과 추적
세션 로깅과 추적

Xshell 의 로그 기능을 이용하면 세션을 통해 주고 받은 모든 문자를 파일로 남길 수 있습니다. 또한, 디버깅 목적으로 추적 기능을 이용할 수도 있습니다.

관련 정보

세션 로깅
세션 추적


세션 로깅

Xshell 4 도움말 / 세션 로깅
세션 로깅

문자열만을 로깅하려면:

1. [파일] 메뉴에서 [로그]를 가리킵니다.

2. [시작]을 선택합니다. 다른 이름으로 저장 대화 상자가 나타납니다.

3. 로그 데이터가 저장될 파일 이름을 입력합니다.

4. [일반 텍스트 뿐 아니라 터미널 코드도 기록]의 선택을 해제합니다.

5. [저장]을 클릭합니다.

* 주의

로깅은 세션이 끝날 때까지 계속됩니다. 세션을 끝내지 않고 로깅을 중단하려면, [파일] 메뉴의 [로그]에서 [중지]를 선택하십시오.

문자열과 터미널 코드를 함께 로깅하려면:

1. [파일] 메뉴에서 [로그]를 가리킵니다.

2. [시작]을 선택합니다. 다른 이름으로 저장 대화 상자가 나타납니다.

3. 로그 데이터가 저장될 파일 이름을 입력합니다.

4. [일반 텍스트 뿐 아니라 터미널 코드도 기록]을 선택합니다.

5. [저장]을 클릭합니다.

세션 연결 시 로깅을 시작하려면:

1. 세션 등록 정보 대화 상자를 엽니다.

2. [범주]에서 [로깅]을 선택합니다.

3. [연결 시 로깅 시작]을 선택합니다.

4. 로그를 저장할 폴더 또는 파일명을 지정할 수 있습니다.

5. [확인]을 클릭합니다.

관련 정보

세션 로깅과 추적


세션 추적

Xshell 4 도움말 / 세션 추적
세션 추적

추적 옵션으로 원격 호스트와 주고 받는 프로토콜 제어 데이터를 추적할 수 있습니다.

SSH 프로토콜의 경우에는 알고리즘 교환과 사용자 인증의 세부 사항을 터미널 화면에 출력할 수 있으며, TELNET 프로토콜의 경우에는 다양한 옵션 교환을 추적할 수 있습니다. 이 기능은 원격 호스트에 연결할 때 문제가 발생한 경우에 유용하게 사용할 수 있습니다.

추적 기능을 켜거나 끄려면:

1. 세션 등록 정보 대화 상자를 엽니다.

2. [범주]에서 [추적]을 선택합니다.

3. 옵션들을 적절히 선택합니다.

4. [확인]을 클릭합니다.

관련 정보

세션 로깅과 추적


인쇄

Xshell 4 도움말 / 인쇄
인쇄

Xshell 은 터미널 창의 텍스트를 로컬 프린터에서 인쇄할 수 있는 기능을 제공합니다. Xshell은 터미널 창에서 사용되는 글꼴 및 컬러를 인쇄할 때에도 그대로 사용합니다. 또한 페이지 설정 대화 상자에서 인쇄될 용지의 여백을 설정할 수 있습니다.

용지의 크기와 방향을 설정하려면:

1. [파일] 메뉴에서 [페이지 설정]을 선택합니다.

2. 적절한 용지 크기와 방향을 선택합니다.

3. 여백을 입력합니다.

4. [확인]을 클릭하여 변경 사항을 저장합니다.

인쇄하려면:

1. [파일] 메뉴에서 [인쇄]를 선택합니다.

2. [이름] 목록에서 프린터를 선택합니다.

3. [확인]을 클릭합니다.


Xagent 사용

Xshell 4 도움말 / Xagent 사용
Xagent 사용

Xagent 는 SSH 인증 에이전트(authentication agent)입니다. Xagent는 공개 키 사용자 인증에 사용되는 사용자 키를 가지고 있다가 Xshell 에서 사용자 키가 필요한 경우에 Xshell 이 해당 키를 사용할 수 있게 해줍니다.

Xagent 는 Xshell 사용자 키의 모든 목록을 유지하며, 필요한 경우 사용자에게 키 암호 입력을 요청합니다. 사용자가 키 암호를 입력한 경우, Xagent는 사용자 키를 풀어서 메모리에 저장합니다. 따라서, Xagent를 사용하면, 사용자는 같은 키에 대해 한 번의 키 암호 입력으로 해당 키를 여러 번 사용할 수 있습니다.

Xagent 는 또한 SSH의 에이전트 포워딩 기능을 위한 SSH 인증 서버로 동작합니다. SSH 에이전트 포워딩 기능은 처음 접속한 서버에서 다른 서버로 접속을 할 경우에 필요합니다. 기본적으로 사용자 키는 사용자의 PC에만 저장되어 있어서 처음 접속한 서버에서 다른 서버로 접속을 시도하는 경우에는 그 키의 사용이 불가능합니다. SSH 에이전트 포워딩 기능은 원격 서버의 SSH 클라이언트 프로그램이 내 PC의 Xagent 가 관리하는 사용자 키를 사용할 수 있게 해줍니다.

* 참고

Xagent 를 실행하면 Xagent 아이콘이 알림 영역에 생성됩니다. Xagent 대화 상자를 닫아도 Xagent 는 종료되지 않고 계속 실행됩니다. Xagent를 종료하거나 Xagent 대화 상자를 열려면 알림 영역 아이콘 상의 메뉴를 이용합니다.

관련 정보

Xagent를 통해 서버에 접속하기
원격 호스트에서 Xagent의 사용자 키 사용하기


Xagent를 통해 서버에 접속하기

Xshell 4 도움말 / Xagent를 통해 서버에 접속하기
Xagent를 통해 서버에 접속하기

Xshell이 Xagent를 사용하도록 설정하려면:

1. 세션 등록 정보 대화 상자를 엽니다.

2. [범주]에서 [연결: SSH]을 선택합니다.

3. [암호 처리에 Xagent (SSH 에이전트)를 사용함]을 선택합니다.

4. [확인]을 클릭합니다.

Xagent를 통해 SSH 서버에 접속하려면:

1. Xagent 를 사용하도록 Xshell 을 설정합니다.

2. Xagent 가 실행 중이 아닌 경우 Xagent 를 실행합니다.

3. SSH 서버에 접속합니다.
이 때, SSH 서버는 공개 키 사용자 인증을 지원해야 하고, 사용할 사용자 키의 공개 키 부분이 서버에 등록되어 있어야 합니다.

4. 사용자 키 암호 대화 상자가 나타납니다. 선택된 사용자 키의 암호를 입력합니다.

* 참고

연결: SSH 설정에서 [Xagent 자동 시작]을 선택한 경우 2번 과정을 생략할 수 있습니다. 사용자 키 암호 대화 상자는 선택된 키의 상태가 Close일 때만 나타납니다. 사용자 키의 상태는 Xagent 의 사용자 키 목록에서 확인할 수 있습니다.

관련 정보

Xagent 사용


원격 호스트에서 Xagent의 사용자 키 사용하기

Xshell 4 도움말 / 원격 호스트에서 Xagent의 사용자 키 사용하기
원격 호스트에서 Xagent의 사용자 키 사용하기

Xagent 를 사용하면 원격 호스트에 있는 ssh 클라이언트가 Xshell 이 사용하는 사용자 키 즉 Xagent 가 가지고 있는 사용자 키를 사용할 수 있습니다. 원격 호스트에서 Xagent 의 사용자 키를 사용하려면 Xshell 과 원격 호스트의 SSH 서버가 에이전트 포워딩 기능을 지원해야 합니다.

ssh.com 서버에서 에이전트 포워딩을 활성화하려면:

1. /etc/ssh2/sshd2_config 파일을 엽니다.

2. AllowAgentForwarding 옵션의 값을 아래와 같이 설정합니다:
AllowAgentForwarding      yes

3. SSH 서버를 다시 시작합니다.

* 참고

OpenSSH 서버는 no-agent-forwarding 옵션을 지정하지 않는 한 에이전트 포워딩 기능이 항상 활성화되어 있습니다.

Xagent의 키를 원격 호스트에서 이용하려면:

1. Xagent 를 사용하도록 Xshell 을 설정합니다.

2. Xagent 가 실행 중이 아닌 경우 Xagent 를 실행합니다.

3. SSH 서버에 접속하고 로그인합니다.

* 참고

서버가 에이전트 포워딩을 지원하면, 로그인 했을 때 에이전트 포워딩을 위한 환경변수(SSH_AUTH_SOCK 혹은 SSH2_AUTH_SOCK)들이 적절하게 설정됩니다.

4. 원격 서버에서 공개 키 인증을 하는 다른 서버로 접속합니다.

5. 사용자 키 암호 대화 상자가 나타나면 선택된 사용자 키의 암호를 입력합니다.

* 참고

[사용자 키 암호] 대화 상자는 선택된 키의 상태가 Close일 때만 나타납니다. 사용자 키의 상태는 Xagent 의 사용자 키 목록에서 확인할 수 있습니다.

관련 정보

Xagent 사용


스크립트 사용

Xshell 4 도움말 / 스크립트 사용
스크립트 사용

스크립트는 한꺼번에 실행할 명령들을 모아놓은 하나의 파일입니다. 반복된 작업들을 파일로 만들어 명령을 일일이 타이핑하지 않고 일괄적으로 실행할 수 있어 편리하며 Visual Basic 스크립트로 작성됩니다.

관련 정보

스크립트의 시작과 종료
스크립트 API


스크립트의 시작과 종료

Xshell 4 도움말 / 스크립트의 시작과 종료
스크립트의 시작과 종료

스크립트 파일 시작하려면:

1. [도구] 메뉴에서 [스크립트]를 가리킨 후 [실행]을 선택합니다.
결과: 열기 대화 상자가 나옵니다.

2. 스크립트 파일을 선택합니다.

3. [확인]을 클릭합니다.

스크립트 파일 실행 중 끝내기

1. [도구] 메뉴에서 [스크립트]를 가리킨 후 [취소]를 선택합니다.

관련 정보

스크립트 사용


스크립트 API

Xshell 4 도움말 / 스크립트 API
스크립트 API

Xshell은 다음 스크립트 API를 제공합니다. 이 API를 이용하면 반복적인 작업을 자동화하는데 사용할 수 있습니다.

관련 정보

스크립트 사용
xsh.Session
xsh.Screen
Script 예제


xsh.Session

Xshell 4 도움말 / xsh.Session
xsh.Session

다음 함수와 변수들은 Xshell 세션에서 사용할 수 있습니다. 이 함수와 변수를 사용하기 위해서는 xsh.Session과 함께 실행합니다 예를 들면 ‘Sleep’ 함수를 사용하고자 한다면 ‘xsh.Session.Sleep(1000)’과 같이 사용합니다.

Functions
반환값 | 함수 | 파라미터 | 설명
Void | OpenSession(LPCTSTR lpszSession) | lpszSession 문자열로서 Xshell 세션 경로이거나 Xshell이 사용하는 URL 형식입니다. | 세로운 세션이나 URL을 엽니다. 세션을 열기 위해서는 /s 옵션을 문자열의 맨 앞에 놓습니다. 예)A.xsh 세션을 열기 위해서는 ‘/s $PATH/A.xsh’를 사용합니다.
Void | CloseSession() |  | 현재 연결 중인 세션을 종료합니다.
Void | Sleep(long timeout) | Timeout 밀리초 단위의 시간 값. | 지정한 시간만큼 Xshell이 대기하도록 합니다.
Void | LogFilePath(LPCTSTR lpszNewFilePath) | lpszNewFilePath 경로를 포함하는 파일 이름. | 로그 파일을 지정합니다.
void | StartLog() |  | 세션에 대한 로그 기록을 시작합니다. 로그는 LogFilePath()에서 정한 경로에 저장합니다. 로그 파일 경로를 지정하지 않았다면 기본 경로를 사용합니다.
void | StopLog() |  | 로그 기록을 중지합니다.

변수
이름 | 종류 | 설명
Connected | BOOL | 현재 세션이 연결 중인지 여부.
LocalAddress | BSTR | 로컬 주소를 가져옵니다.
Path | BSTR | 현재 세션 파일의 경로를 가져옵니다.
RemoteAddress | BSTR | 리모트 주소를 가져옵니다.
RemotePort | long | 리모트 포트 번호를 가져옵니다.
Logging | BOOL | 현재 세션이 로그를 기록하고 있는지 확인합니다.

관련 정보

스크립트 API


xsh.Screen

Xshell 4 도움말 / xsh.Screen
xsh.Screen

다음 함수와 변수들은 Xshell의 터미널 화면을 다룰 때 사용할 수 있습니다. 이 함수와 변수를 사용하기 위해서는 xsh.Screen과 함께 실행합니다 예를 들면 ‘Clear()’ 함수를 사용하고자 한다면 ‘xsh.Session.Clear()’와 같이 사용합니다.

Functions
반환 값 | 함수 | 파라미터 | 설명
void | Clear() |  | 터미널 화면을 지웁니다.
void | Send(LPCTSTR lpszStrToSend) | lpszStrToSend 사용자가 보내고자 하는 문자열 | 터미널에 메시지를 보냅니다.
BSTR | Get(long nBegRow, long nBegCol, long nEndRow, long nEndCol) | nBegRow 터미널에서 줄의 시작 위치. nBegCol 터미널에서 열의 시작 위치. nEndRow 터미널에서 줄의 끝 위치. nEndCol 터미널에서 열의 끝 위치. | 터미널의 정해진 영역의 문자열을 읽어 그 값을 반환합니다.
void | WaitForString(LPCTSTR lpszString) | lpszString 터미널에 나타날 문자열. | 메시지를 기다립니다.
Long | WaitForStrings(VARIANT FAR* strArray, long nTimeout) | strArray 터미널에 나타날 문자열 nTimeout 기다릴 시간의 밀리초 값. 반환 값 발견한 문자의 숫자. | 타임 아웃이 발생하기 전까지 메시지를 기다립니다.
void | Synchronous(BOOL bSync) | bSync 1(True) : 화면 동기화를 합니다. 0(False) : 화면 동기화를 하지 않습니다. | 화면 동기화를 정합니다.

변수
이름 | 종류 | 설명
CurrentColumn | long | 현재 열을 반환합니다.
CurrentRow | long | 현재 줄을 반환합니다.
Columns | long | 터미널의 폭과 같은 열 수를 반환합니다.
Rows | long | 터미널의 높이와 같은 줄 수를 반환합니다.

관련 정보

스크립트 API


Script 예제

Xshell 4 도움말 / Script 예제
Script 예제

Script file

Sub Main

' *** Connect the session ***

xsh.Session.Open "ssh://192.168.1.17"

' "/s C:\Users\Administor\AppData\Roaming\NetSarang\Xshell\Sessions\example.xsh"

xsh.Screen.Synchronous = true

xsh.Screen.WaitForString "login: "

xsh.Screen.Send "username"

xsh.Screen.Send VbCr

xsh.Session.Sleep 100

xsh.Screen.WaitForString "Password: "

xsh.Screen.Send "password"

xsh.Screen.Send VbCr

xsh.Session.Sleep 100

' *** Wait for Prompt Message ***

xsh.Screen.WaitForString "username@password"

' *** Set File Format ***

Dim app, wb, ws

Set app = CreateObject("Excel.Application")

Set wb   = app.Workbooks.Add

set ws   = wb.Worksheets(1)

xsh.Session.LogFilePath = "c:\example.log"

xsh.Session.StartLog

Dim waitStrs

waitStrs = Array(Chr(10), "username@password") ' make wait message as array

Dim row, screenrow, readline, itmes

row = 1

' *** Send Command ***

xsh.Screen.Send "cat /etc/passwd"

xsh.Screen.Send VbCr

xsh.Session.Sleep 100

Dim result

' *** Read Data and Save it as an EXCEL File ***

Do

While true

        result = xsh.Screen.WaitForStrings(waitStrs, 1000)

        If result = 2 Then

               Exit Do

        End If

        screenrow = xsh.Screen.CurrentRow - 1

        readline  = xsh.Screen.Get(screenrow, 1, screenrow, 40)

        items     = Split(readline, ":", -1)

        ws.Cells(row,1).Value = items(0)

        ws.Cells(row,2).Value = items(2)

        row = row + 1

Wend

Loop

wb.SaveAs("C:\chart.xls")                    ' save file path

wb.Close

app.Quit

Set ws  = nothing

Set wb  = nothing

Set app = nothing

xsh.Screen.Synchronous = false

xsh.Session.StopLog

End Sub

관련 정보

스크립트 API


레퍼런스

Xshell 4 도움말 / 레퍼런스
레퍼런스

이 섹션은 Xshell 사용에 대한 레퍼런스 정보를 담고 있습니다.

관련 정보

표준 단추
주소 표시줄
Xshell 로컬 명령어
Xshell 명령줄 옵션
SFTP 명령어
정규식
미리 정의된 바로 가기 키


표준 단추

Xshell 4 도움말 / 표준 단추
표준 단추

Xshell은 자주 사용되는 작업과 명령들에 대한 표준 단추를 제공합니다.

아래는 표준 단추들에 대한 설명입니다.

단추 | 이름 | 설명
 | 새로 만들기 | 새 세션 등록 정보 대화 상자를 열어 새 세션을 생성합니다.
 | 열기 | 세션 대화 상자를 엽니다.
 | 연결 끊기 | 현재 세션의 연결을 끊습니다.
 | 다시 연결 | 현재 탭의 세션을 다시 연결합니다.
 | 등록 정보 | 현재 세션의 등록 정보를 보여줍니다. 세션이 열리지 않은 경우에는 기본 세션의 등록 정보를 보여줍니다.
 | 복사 | 선택영역을 클립보드로 복사합니다.
 | 붙여넣기 | 클립보드의 내용을 붙여넣습니다.
 | 찾기 | 찾기 대화 상자를 엽니다.
 | 인쇄 | 인쇄 대화 상자를 엽니다.
 | 색 구성표 | 색 구성표를 선택합니다.
 | 인코딩 | 출력 언어로 가능한 인코딩을 나열합니다.
 | 글꼴 | 사용 가능한 글꼴 이름과 크기를 나열합니다. 현재 열린 세션의 글꼴을 바꿀 수 있습니다. 각 세션의 글꼴을 변경하려면 세션 등록 정보 대화 상자에서 해당 세션의 글꼴을 선택할 수 있습니다.
toolbarnewterminal | 새 터미널 | 새로운 Xshell 창을 엽니다. 연결된 상태에서 이 단추를 클릭하면 해당 세션의 연결 정보를 사용하여 연결을 시도합니다.
toolbarfiletransfer | 새 파일 전송 | Xftp™가 설치된 경우 Xftp를 실행합니다. 연결된 상태에서 이 단추를 클릭하면 해당 세션의 연결 정보로 새로운 파일 전송 세션을 시작합니다. Xftp가 설치되어 있지 않으면 Xshell 자체의 파일 전송 세션을 시작합니다.
 | 전체 화면 | 전체 화면 모드로 전환합니다. Alt+Enter를 입력하면 일반 창 모드로 바뀝니다.
 | 화면 잠금 | 화면 잠금 모드로 전환합니다. 암호를 입력할 때까지 사용자 입력을 받아들이지 않습니다.
 | 키 매핑 | 사용자 지정 키 매핑 대화 상자를 엽니다.
 | 스크립트 | Xshell 스크립트 파일을 시작합니다.
 | 로깅 시작 | 로깅을 시작합니다.
 | 로깅 중지 | 로깅을 중지합니다.
cog | 옵션 | 옵션 대화 상자를 엽니다.
 | 사용자 키 관리자 | 사용자 키 대화 상자를 엽니다.
 | 호스트 키 관리자 | 호스트 키 대화 상자를 엽니다.
 | Xagent | Xagent 프로그램을 실행합니다.
 | Xactivator | Xactivator 프로그램을 실행합니다.
 | 도움말 | Xshell 도움말을 엽니다.

관련 정보

레퍼런스


주소 표시줄

Xshell 4 도움말 / 주소 표시줄
주소 표시줄

주소 표시줄의 문법은 다음과 같습니다:

        [protocol://][user[:password]@]hostname[:port][/]

사용 가능한 프로토콜은 ssh, sftp, telnet, rlogin 및 serial 입니다. 기본 프로토콜은 기본 세션에 선택된 프로토콜입니다. 프로토콜 별 기본 포트 번호는 아래와 같이 정의되어 있습니다:

· ssh:            22

· sftp:           22

· telnet:         23

· rlogin:         513

· ftp:            21

아래에서 몇 가지 예제를 보실 수 있습니다.

예제 | 설명
foobar.com | 기본 세션에 지정된 프로토콜과 포트 번호로 foobar.com 에 접속합니다.
ssh://kay@foobar.com/ | ssh 프로토콜로 foobar.com에 접속합니다. 사용자 계정은 kay이며 기본 포트 번호가 사용됩니다.
ssh://kay@foobar.com:12345/ | foobar.com의 12345번 포트에 ssh 프로토콜로 접속합니다. 사용자 계정은 kay입니다.
telnet://foobar.com/ | telnet 프로토콜을 통해 foobar.com에 접속합니다. 사용자 계정은 지정되지 않았고 기본 포트인 23번 포트에 접속됩니다.
rlogin://kay@foobar.com/ | rlogin 프로토콜로 foobar.com에 접속합니다. 사용자 계정은 kay이며 기본 포트인 513번 포트에 접속됩니다.
sftp://kay@foobar.com/ | sftp 프로토콜로 foobar.com에 접속합니다. 사용자 계정은 kay이며 기본 포트 번호가 사용됩니다.
ftp://foobar.com/test.zip | ftp 프로토콜로 foobar.com에 접속하여 test.zip 파일을 다운로드합니다.

관련 정보

레퍼런스


Xshell 로컬 명령어

Xshell 4 도움말 / Xshell 로컬 명령어
Xshell 로컬 명령어

Xshell 은 터미널 환경에 익숙한 고급 사용자들을 위한 로컬 명령어들을 제공합니다.

기본적으로 Xshell 프롬프트는 원격 호스트에 연결되지 않았을 때 터미널 화면에 나타납니다. 세션이 연결되었을 때는 “Ctrl+Alt+]”을 눌러 로컬 프롬프트로 빠져 나올 수 있습니다. 다시 원격 호스트 모드로 돌아가기 위해서는 “exit”을 입력하거나 “Ctrl+D”를 누르면 됩니다.

다음의 명령어들이 사용 가능합니다.

명령어 | 설명
help ? | 터미널 창에 명령어 목록을 표시
new | 새 세션 등록 정보 대화 상자 열기
open [session] | “session”이 지정된 경우 해당 세션에 연결, 지정 안된 경우 세션 대화 상자 열기
edit [session] | “session”이 지정된 경우 해당 세션의 세션 등록 정보 대화 상자를, 지정이 안된 경우 기본 세션의 세션 등록 정보 대화 상자 열기
list | 현재 작업 디렉토리의 사용 가능한 세션에 대한 정보와 디렉토리 목록을 보여줌
cd | 현재 작업 디렉토리를 바꿈
clear | 화면, 주소 바의 히스토리, 로컬 셸 명령 프롬프트의 명령 히스토리를 지움
exit quit | Xshell 세션을 종료하거나 원격 호스트로 돌아감
ssh [user@]host [port] | ssh 프로토콜로 연결
sftp [user@]host [port] | sftp 프로토콜로 연결
telnet [user@]host [port] | telnet 프로토콜로 연결
rlogin [user@]host [port] | rlogin 프로토콜로 연결
ftp [user@]host [port] | ftp 프로토콜로 연결
ipconfig | Windows의 ipconfig 명령을 실행
ping host | Windows의 ping 명령을 실행
tracert host | host까지의 패킷 경로를 보여줌.
netstat | Windows의 netstat 명령을 실행
nslookup | Windows의 nslookup 명령을 실행

관련 정보

레퍼런스


Xshell 명령줄 옵션

Xshell 4 도움말 / Xshell 명령줄 옵션
Xshell 명령줄 옵션

Xshell이 인식하는 명령줄 파라미터 옵션입니다. Windows의 콘솔 프로그램이나 다른 응용 프로그램에서 Xshell을 명령으로 실행할 경우 사용할 때 쓰일 수 있는 파라미터입니다.

옵션, 파라미터 | 설명
“세션 파일” | 해당 세션을 실행합니다. “세션 파일”은 경로를 포함할 수 있습니다.
-folder “세션 폴더” | 해당 폴더의 모든 세션을 실행합니다.
-url [protocol://][user[:password]@]host[:port] | 저장한 세션 파일이 아닌 URL을 직접 입력하여 접속합니다. 사용 가능한 프로토콜은 SSH, SFTP, TELNET, RLOGIN 그리고 FTP입니다. 프로토콜을 생략한 경우는 옵션 대화상자의 [일반] 탭에서 정한 기본 프로토콜을 사용합니다. 사용자(user), 암호(password)를 생략한 경우 이를 인증하기 위한 창이 나타납니다. 접속 포트(port)를 지정하지 않은 경우 접속 프로토콜의 기본 포트를 사용합니다.
-open | 세션 대화 상자를 엽니다.
-register | 제품 등록을 하기 위한 대화 상자를 엽니다.
-about | 제품의 버전, 라이선스 정보 등을 알 수 있는 Xshell 정보 대화 상자를 엽니다.
-prop “세션 파일” | 해당 세션의 세션 등록 정보 대화 상자를 엽니다. “세션 파일”은 경로를 포함할 수 있습니다.
-create “세션 파일” | 새로운 세션을 만듭니다.
-folder “세션 폴더” | “세션 폴더”에 있는 모든 세션을 실행합니다.
-newwin | 새로운 Xshell 창을 엽니다.
-newtab “탭 이름” | “탭 이름”으로 새로운 탭을 만듭니다.

예제:

Xshell “c:\users\zoo\AppData\Roaming\NetSarang\Xshell\Sessions\xdev.xsh”

xdev.xsh 세션 파일을 실행합니다.

Xshell -url foobar.com

foobar.com에 기본 프로토콜로 접속합니다.

Xshell -url ssh://foobar.com

foobar.com에 ssh로 접속합니다.

Xshell –url ssh://test:testpasswd@foobar.com

foobar.com에 ssh로접속합니다. 사용자 이름과 암호는 각각 “test”와 “testpasswd”입니다.

Xshell –url telnet://foobar.com:2300

foobar.com에 telnet 프로토콜을 사용, 2300번 포트로 접속합니다.

Xshell -newwin -url foobar.com

foobar.com에 기존 창의 세션 탭으로가 아닌 새로운 xshell 창을 실행하여 접속합니다.

* 참고

“-newwin” 옵션을 제외한 모든 옵션은 옵션 대화 상자의 [고급] 탭에서 [하나의 Xshell 창에 여러 개의 세션 열기]가 켜져 있는 경우 마지막 Xshell 창에서 실행하거나 탭으로 세션을 실행하도록 합니다. “-newwin” 옵션은 다른 옵션과 같이 사용할 수 있고 이 옵션으로 새로운 Xshell 창을 실행 합니다.

관련 정보

레퍼런스


SFTP 명령어

Xshell 4 도움말 / SFTP 명령어
SFTP 명령어

Xshell 은 터미널 환경에 익숙한 고급 사용자들을 위해 UNIX/Linux의 FTP와 비슷한 명령어들을 제공합니다. 각 명령어의 설명은 아래와 같으며, 자세한 사용법은 SFTP 프롬프트에서 help 명령을 통해 확인하시기 바랍니다.

명령어 | 설명
get file1 [file2] [file3] … | 원격 호스트의 지정된 파일을 로컬 호스트로 가져옵니다.
put file1 [file2] [file3] … | 로컬 호스트의 지정된 파일을 원격 호스트로 보냅니다.
mv path1 path2 rename path1 path2 | 특정 파일 또는 디렉터리를 다른 경로로 이동하거나 이름을 변경합니다.
mkdir directory | 원격 호스트에서 지정된 디렉터리를 생성합니다.
rmdir directory | 원격 호스트에서 지정된 디렉터리를 삭제합니다.
rm file | 원격 호스트에서 지정된 파일을 삭제합니다.
pwd | 원격 호스트의 작업 디렉터리를 표시합니다.
lpwd | 로컬 호스트의 작업 디렉터리를 표시합니다.
cd directory | 원격 호스트의 작업 디렉터리를 변경합니다.
lcd directory | 로컬 호스트의 작업 디렉터리를 변경합니다.
ls [directory] | 원격 호스트의 파일 목록을 보여줍니다.
lls [directory] | 로컬 호스트의 파일 목록을 보여줍니다.
explore [directory] | Windows 탐색기를 이용해 현재 (혹은 지정된) 디렉토리를 열람합니다.
help [command] | SFTP 명령어 목록 또는 지정된 명령어의 사용법을 보여줍니다.
bye exit quit | SFTP 연결을 종료합니다.

관련 정보

레퍼런스


정규식

Xshell 4 도움말 / 정규식
정규식

이 섹션에서는 찾기 대화 상자에서 사용되는 정규식에 대해 설명합니다.

관련 정보

레퍼런스
패턴 매치
문자 집합의 축약형
POSIX 문자 집합
예제


패턴 매치

Xshell 4 도움말 / 패턴 매치
패턴 매치
패턴 | 설명
. | 개행 문자를 제외한 한 문자
[abc] | a, b, c 중의 한 문자
[a-z] | a부터 z사이에 속해있는 한 문자
[^ac] | a와 c를 제외한 한 문자
(x) | x, 이 때 x는 정규식일 수 있음
x* | x가 0번 이상 반복됨, 이 때 x는 정규식일 수 있음
x+ | x가 1번 이상 반복됨, 이 때 x는 정규식일 수 있음
x{n,m} | x가 n번 이상 m번 이하로 반복됨, 이 때 x는 정규식일 수 있음
x{n} | x가 정확히 n번 반복됨, 이 때 x는 정규식일 수 있음
x{n,} | x가 n번 이상 반복됨, 이 때 x는 정규식일 수 있음
x|y | x 이거나 y, 이 때 x, y는 정규식일 수 있음
xy | xy, 이 때 x, y는 정규식일 수 있음
^ | 줄의 시작
\A | 줄의 시작
$ | 줄의 끝
\z | 줄의 끝
\Z | 줄의 끝
\< | 단어의 시작
\b | 단어의 시작
\> | 단어의 끝
\B | 단어의 끝

관련 정보

정규식


문자 집합의 축약형

Xshell 4 도움말 / 문자 집합의 축약형
문자 집합의 축약형
클래스 | 설명
\w | 단어를 구성하는 문자, [a-zA-Z0-9_]와 같음
\W | 단어를 구성하지 않는 문자, [^a-zA-Z0-9_]와 같음
\s | 공백문자
\S | 공백문자를 제외한 문자
\d | 숫자, [0-9]와 같음
\D | 숫자를 제외한 문자, [^0-9]와 같음

관련 정보

정규식


POSIX 문자 집합

Xshell 4 도움말 / POSIX 문자 집합
POSIX 문자 집합
클래스 | 설명
[:alnum:] | 알파벳과 숫자, [a-zA-Z0-9]와 같음
[:alpha:] | 알파벳, [a-zA-Z]와 같음
[:blank:] | 공백문자
[:cntrl:] | 제어문자
[:digit:] | 숫자, [0-9]와 같음
[:graph:] | 출력될 수 있는 문자 (공백문자 제외)
[:lower:] | 소문자, [a-z]와 같음
[:print:] | 제어문자가 아닌 문자
[:punct:] | 구두점
[:space:] | 공백문자
[:upper:] | 대문자, [A-Z]와 같음
[:xdigit:] | 16진수를 표기하는 데 사용되는 문자, [0-9a-fA-F]와 같음

관련 정보

정규식


예제

Xshell 4 도움말 / 예제
예제
표현식 | 설명
[0-9]+ | 숫자가 1번 이상 반복되는 패턴
(foo)|(bar) | "foo" 이거나 "bar"
\.html$ | ".html"로 끝나는 문자열
^\. | "." 으로 시작되는 문자열

관련 정보

정규식


미리 정의된 바로 가기 키

Xshell 4 도움말 / 미리 정의된 바로 가기 키
미리 정의된 바로 가기 키

아래의 목록은 Xshell 에 정의된 바로 가기 키들을 설명합니다.

바로 가기 키 | 설명
Alt + N | 파일 메뉴의 새로 만들기와 동일
Alt + O | 파일 메뉴의 열기와 동일
Alt + C | 파일 메뉴의 연결 끊기와 동일
Alt + Enter | 전체 화면 모드로 전환
Alt + D | 주소 표시줄로 키보드 포커스를 이동
Alt + L | 레이아웃 변경
Alt + 1~9 | 세션 탭 이동
Alt + Right | 창 메뉴의 다음과 동일
Alt + Left | 창 메뉴의 이전과 동일
Ctrl + D | 로컬 프롬프트에서 로컬 셸 종료
Ctrl + Alt + ] | 연결 중 로컬 프롬프트로 빠져 나가기
Ctrl + Alt + T | 창 메뉴의 새 터미널과 동일
Ctrl + Alt + F | 창 메뉴의 새 파일 전송과 동일
Ctrl + Tab | 하나의 Xshell 창에서 다음 세션으로 이동
Shift + Tab | 하나의 Xshell 창에서 최근 사용한 세션으로 이동
Shift + Home | 맨 위
Shift + End | 맨 아래
Shift + PgUp | 페이지 위로
Shift + PgDn | 페이지 아래로
Shift + Up Arrow | 위로 스크롤
Shift + Down Arrow | 아래로 스크롤

* 참고

메뉴의 바로 가기 키를 변경하려면 키 매핑 기능을 이용합니다. 사용자 지정 키 매핑 대화 상자에서는 사용자가 바로 가기 키의 키 조합을 변경할 수 있으며 메뉴, 문자열 보내기, 스크립트 실행, 프로그램 실행 등의 동작을 키 조합에 할당할 수 있습니다.

관련 정보

레퍼런스