Xshell 介紹

Xshell 4 Help / Xshell 介紹
Xshell 介紹

Xshell 為於 Windows 平台驅動的功能強大的 SSH, TELNET, RLOGIN終端機模擬軟體。Windows 使用者可以用 Xshell 容易且安全的連結到UNIX/Linux 主機。 SSH (Secure Shell) 通訊協定會提供加密及使用者驗證等功能，並可替代TELNET和RLOGIN等現有的通訊協定，以便讓使用者能在網路上安全執行連線。

See Also

主要功能
推薦規格及安裝
安裝及移除

Copyright© 2013 Netsarang Computer, Inc. All rights reserved.


主要功能

Xshell 4 Help / 主要功能
主要功能

這部分會描述Xshell的主要功能。

一般

l 支援SSH1, SSH2, SFTP, TELNET, RLOGIN及SERIAL通訊協定

l 支援Windows 2000/XP/2003/Vista/2008/7/8

l 支援OpenSSH 及 ssh.com 伺服器

l 設定多個使用者

l 保持連線選項

l SOCKS4/5, HTTP Proxy連線

l 支援多重工作階段 (工作階段標籤、工作階段列 )

l 使用者自訂按鍵對應

l VB 指令碼

l 新增連結列

l 中斷連線時自動重新連線

工作階段管理

l 新建及管理其他主機的工作階段檔案

l 支援開啟工作階段的工作階段對話方塊、網址列、本機提示、工作階段捷徑及連結列功能

l 提供快速連線的預設工作階段

l 同時連線到多重工作階段

l 網址列支援 URL 命令，並支援連線到未使用工作階段的遠端主機

l 用Xactivator工作階段連線

l 自動登入，自動輸入功能

l 工作階段對話方塊中資料夾及樹狀檢視

安全性

l RSA/DSA 公開金鑰、密碼及 Keyboard Interactive 使用者驗證方法

l RSA/DSA 新增金鑰精靈及匯入/匯出功能

l 用Xagent (SSH 使用者驗證代理程式)驗證使用者

l AES128/192/256、 3DES、 BLOWFISH、 CAST128、ARCFOUR 及RIJNDAEL 加密演算法

l SHA1、 SHA1-96、MD5、MD5-96 及 RIPEMD160 MAC演算法

l zlib 壓縮

l 主機金鑰管理對話方塊

l 使用者金鑰管理對話方塊

終端機

l 以Unicode為基礎的終端機緩衝區

l VT100、 VT220、 VT320、XTERM、LINUX、SCOANSI 及ANSI 終端機

l 多國語言輸出编碼 (UTF-8)

l 同時傳輸訊息到所有工作階段的撰寫列

l 可儲存到2,147,483,647行的捲動緩衝區

l 用規則運算式尋找字串

l 以欄位為單位選取文字

l 複製/貼上時支援 Multi-byte 字串

l 在終端機視窗連按兩下選取字組及指定分隔符號

l 連按三下滑鼠按鈕時選取一行

l 粗體字型及 ANSI 彩色碼

l Xterm 終端機滑鼠

l Xterm 256彩色模式

l Liunx Meta 鍵模擬

l 列印終端機螢幕

l 設定終端機視窗的行及邊界

l 按下ESC 鍵切換韓文->英文 (僅限於韓文Windows)

通道

l TCP/IP及 X11 轉寄

l 用SOCKS4/5的動態連接埠轉寄

l 用通道視窗可檢視目前啟動的轉寄頻道，而把新的轉寄規則新增到目前的工作階段

外觀

l 容易且功能強大的使用者介面

l 切換成使用者自訂的版面配置

l 可移動的工具列

l 色彩配置編輯/匯入/匯出

l 游標色彩變更及閃爍效果設定

l 用字型按鈕輕易變更字型

l 將經常使用的字串指定為快速命令

l 使用者可自訂工具列的標準按鈕

l 在狀態列顯示安全性-鎖定、選取工作階段、網路 up/down 流量內容

l 顯示為全螢幕 (Alt+Enter)

l 調整透明度的選項

本機命令語

l 針對進階使用者提供本地殼層提示

l open、ssh、 telnet、 rlogin 及 sftp、 ftp 等本機命令語

l ping、 ipconfig、 netstat 及nslookup等本機 Windows 命令語

l 遠端主機連線時匯出本機提示

互相相容性

l 與Xmanager聯動的 X11 轉寄

l 與Xagent程式聯動的代理程式轉寄

l 與Xftp聯動輕易連線到 FTP 網站

l 在記事本編輯捲動緩衝區

l 用功能表命令按順序選取Xshell視窗

檔案管理

l SFTP傳輸及接收

l ZMODEM 傳輸及接收

l ASCII 檔案傳輸

l 工作階段自動登入 (並儲存終端機碼)

l 版面設定及列印預覽

See Also

Xshell 介紹


推薦規格及安裝

Xshell 4 Help / 推薦規格及安裝
推薦規格及安裝
  • 處理器: Intel®元件互換機制
  • 電腦管理系統: Microsoft Windows® 2000 SP4以上
  • 儲存空間: 50MB 以上的剩餘空間
  • 網路: TCP/IP 網路
  • 程式: Internet Explorer® 6.0 以上

See Also

Xshell 介紹


安裝及移除

Xshell 4 Help / 安裝及移除
安裝及移除

該安裝程式使用InstallShield®製作，於安裝流程中可變更多種安裝選項。但於大部分情況下，只需按一下[下一步]即可。

透過Windows的標準新增/移除功能即可移除 Xmanager。執行控制台的[新增程式/移除程式]之後，在清單中選取移除 Xmanager或 Xmanager Enterprise。請特別留意，移除 Xmanager Enterprise時，Xmanager以外其他Xshell, Xftp, Xlpd等其他程式亦同時會被移除。

即使移除程式，使用者產生的登錄資訊、記錄檔及資料檔案均可保留。只要重新安裝，均可重新使用此資訊及檔案。若要刪除所有的登錄資訊和檔案，下列位置的登錄資訊和檔案會被全部刪除:

登錄資訊:

· \HKEY_CURRENT_USER\Software\NetSarang\Xmanager

· \HKEY_CURRENT_USER\Software\NetSarang\Xmanager Enterprise

檔案及資料夾:

· %APPDATA%\NetSarang\Xmanager

· %APPDATA%\NetSarang\Xmanager Enterprise

See Also

Xshell 介紹


啟動

Xshell 4 Help / 啟動
啟動

這裡將說明新增Telnet/Rlogin 或 SSH 工作階段的方法、及連線到 UNIX/Linux 主機的方法。Telnet 工作階段非常簡單。但SSH 工作階段，有時連線到伺服器之前需要把使用者金鑰註冊到伺服器。若需要註冊使用者金鑰，請參考"公開金鑰使用者驗證”。

See Also

新增工作階段
連線到遠端主機
結束Xshell


新增工作階段

Xshell 4 Help / 新增工作階段
新增工作階段

1. 在[檔案] 清單中選取[新增] 。會顯示新工作階段內容對話方塊。

圖表1: 新工作階段內容對話方塊

2. 在[名稱]輸入工作階段名稱。

3. 在[通訊協定]清單中選取適當的通訊協定。

4. 在[主機]輸入伺服器的主機名稱或 IP 位址。

5. 在[連接埠號碼]輸入遠端伺服器所使用的連接埠號碼。

6. 按一下[確定]。

See Also

啟動


連線到遠端主機

Xshell 4 Help / 連線到遠端主機
連線到遠端主機

接下來是連線到 SSH 工作階段的程序。若沒有新增的工作階段，請參考“新增工作階段”的部分。

1. 在[檔案] 清單中選取 [開啟]。

2. 在工作階段清單中選取要連線的工作階段並按一下[連線]後會顯示 SSH 使用者名稱對話方塊。

圖表2: SSH 使用者名稱對話方塊

3. 輸入使用者名稱並按一下[確定] 後會顯示 SSH 使用者驗證對話方塊。

圖表3: SSH 使用者驗證對話方塊

4. 若要嘗試 Password 驗證，在[密碼]處輸入密碼，然後按一下 [確定]。

5. 若要嘗試Public Key 驗證，首先在清單中選取使用者金鑰。將選取的使用者金鑰複雜密碼輸入在 [複雜密碼]處，然後按一下[確定]。

* 參考

若沒有使用者金鑰，請參考"公開金鑰使用者驗證”的部分。

6. 若要嘗試 Keyboard Interactive 驗證，按一下[確定]後回答連線中提示的問題。

See Also

啟動


結束Xshell

Xshell 4 Help / 結束Xshell
結束Xshell

若要中斷工作階段的連線，在終端機螢幕的提示打“exit” ，或者在[檔案] 清單中選取 [中斷連線] 。

* 參考

若在選取了連線終止時本地殼層還原選項的狀態下中斷連線的話，則會保持本地殼層狀態而不會變更工作階段標籤。本地殼層工作階段會將 Xshell 提示顯示在終端機螢幕上並可執行open、 telnet、 ssh、 ping等本機命令語。

若要結束 Xshell，在 [檔案] 清單中選取 [結束]。

See Also

啟動


工作階段管理

Xshell 4 Help / 工作階段管理
工作階段管理

工作階段是指擁有遠端主機連線相關設定的檔案。使用者建立工作階段，以便對於不同遠端主機設定不同選項。工作階段對話方塊將會顯示所有新工作階段，並有助於建立而編輯工作階段。

使用者不使用新工作階段即可直接連線到遠端電腦。Xshell有專為此可立即使用的預設工作階段提供專門支援安裝。

See Also

工作階段管理
工作階段內容
匯出
匯入


工作階段管理

Xshell 4 Help / 工作階段管理
工作階段管理

若要新增工作階段：

1. 開啟新增工作階段內容對話方塊。

2. 輸入連線內容。

3. 按一下[確定]。

若要開啟工作階段對話方塊:

· 在[檔案]功能表中選取[開啟]。

· 按一下標準按鈕[開啟]。

若要編輯工作階段：

1. 開啟工作階段對話方塊。

2. 選取要編輯的工作階段。

3. 在標準按鈕按一下[內容]。

4. 工作階段編輯完成後，按一下[確定]。

若要重新命名工作階段:

1. 開啟工作階段對話方塊。

2. 選取要重新命名的工作階段，然後按一下滑鼠右鍵。

3. 在功能表上選取[重新命名]。

* 參考

工作階段名稱須為有效檔案名稱。

若要以不同名稱複製工作階段

1. 開啟工作階段對話方塊。

2. 選取要以不同名稱複製的工作階段。

3. 在標準按鈕按一下[另存新檔]。

若要刪除工作階段：

1. 開啟工作階段對話方塊。

2. 選取要刪除的工作階段。

3. 在標準按鈕按一下[刪除]。

若要建立工作階段捷徑:

1. 開啟工作階段對話方塊。

2. 選取要建立捷徑的工作階段。

3. 在標準按鈕按一下[建立捷徑]。

4. 選取要儲存捷徑的資料夾。

5. 按一下[確定]。

若要變更預設工作階段的設定:

若要開啟預設工作階段的工作階段內容對話方塊，則要使用下列其中一個方法:

· 在本地殼層狀態，選取 [檔案]清單的 [內容]。

· 在主頁視窗的標準按鈕，按一下 [內容] 按鈕旁邊的箭號，然後在清單中選取[預設工作階段]。

* 參考

透過本機提示或網址列連線到ssh, telnet, rlogin, sftp時，均可使用此預設工作階段。

若本機提示要使用連線命令語，請參考“Xshell 本機命令語”。若使用網址列連線，請參考“網址列”的部分。

若要新增工作階段資料夾:

1. 開啟工作階段對話方塊。

2. 在標準按鈕按一下[新增]按鈕並於旁邊顯示出的清單上選取[資料夾]。

3. 輸入資料夾名稱。

若要工作階段檔案複製到其他電腦:

1. 開啟工作階段對話方塊。

2. 在標準按鈕按一下[開啟工作階段資料夾]。

3. 瀏覽並複製此工作階段檔案(*.xfp)或者透過電子郵件傳送至其他電腦。

4. 儲存工作階段檔案於以下的資料夾。"%APPDATA%\NetSarang\Xftp\Sessions"
"%APPDATA%\NetSarang\Xftp\Sessions"

See Also

工作階段管理


工作階段內容

Xshell 4 Help / 工作階段內容
工作階段內容

若要新增或編輯工作階段，開啟工作階段內容對話方塊。

若要開啟工作階段內容對話方塊:

· 在[檔案]功能表中選取[新增]。

· 在[檔案]功能表中選取[內容]。

· 按一下標準按鈕[內容]。

See Also

工作階段管理
連線
連線: 使用者驗證
連線: 使用者驗證: 登入提示
連線: 登入指令碼
連線: SSH
連線: SSH: 安全性
連線: SSH: 通道
連線: SSH: SFTP
連線: TELNET
連線: RLOGIN
連線: SERIAL
連線: PROXY
終端機
終端機: 鍵盤
終端機: VT 模式
終端機: 進階
外觀
外觀: 邊界
進階
進階: 追蹤
進階: 記錄
ZMODEM


連線

Xshell 4 Help / 連線
連線

連線設定可設定工作階段的連線相關內容。在大部份的情況下，使用者只要設定該部分就可以連線到遠端主機。

名稱

輸入此工作階段的專有名稱。因該名稱將為工作階段檔案的名稱，所以必須以有效字元組合而成。

通訊協定

選取要使用於連線至遠端電腦的通訊協定。可支援的通訊協定為SSH, SFTP, TELNET, RLOGIN 及 SERIAL。

主機

輸入遠端電腦的主機名稱或 IP 位址。

連接埠編號

輸入在上面所選取的通訊協定的連接埠編號。若在通訊協定清單上選取通訊協定，系統將自動輸入此通訊協定的預設連接埠編號。若遠端電腦使用不同連接埠編號，使用者必須直接輸入連接埠編號。SSH/SFTP、TELNET、RLOGIN通訊協定的預設值分別為22、23、513。

當工作階段連線時，傳送連線保持運作訊息

傳送連線保持運作訊息到遠端電腦。該功能最適用於不使用Xshell時意外中斷連線。於有些網路環境中，閘道器(Gateway) 或防火牆(Firewall) 系統會強制將一段時間沒有傳輸資料的連線斷線。

意外中斷連線時自動重新連線

在使用者沒有直接結束連線的情況下意外中斷連線時，會自動重新連線。

See Also

工作階段內容


連線: 使用者驗證

Xshell 4 Help / 連線: 使用者驗證
連線: 使用者驗證

使用者驗證設定可指定驗證方法和使用者名稱、密碼使用者金鑰。

方法

選取驗證方法。可選取 Password、Public Key、 Keyboard Interactive中之一。若SSH伺服器不支援所選取的驗證方法，下次連線時會再顯示詢問使用者驗證方法的對話方塊。

使用者名稱

輸入要登入的使用者名稱。使用者名稱為遠端電腦的登入帳戶。若此輸入方塊清空，下次連線時會再顯示詢問使用者名稱的對話方塊。

密碼

輸入遠端電腦使用者名稱的密碼。若此輸入方塊清空，連線中會顯示詢問使用者驗證的對話方塊。密碼將經加密而儲存於使用者電腦。若要大幅提升安全性，建議您清空此輸入方塊。

使用者金鑰

若於公開金鑰驗證已選取，則選取要使用的使用者金鑰。若此輸入方塊清空，連線中會顯示詢問使用者驗證的對話方塊。若於清單上沒有使用者金鑰，產生金鑰後，要到遠端SSH伺服器註冊。

複雜密碼

輸入所選取的使用者金鑰複雜密碼。輸入的金鑰複雜密碼將經加密而儲存於使用者電腦。若要大幅提升安全性，建議您清空此輸入方塊。

See Also

工作階段內容


連線: 使用者驗證: 登入提示

Xshell 4 Help / 連線: 使用者驗證: 登入提示
連線: 使用者驗證: 登入提示

若啟用TELNET 或 RLOGIN 通訊協定，Xshell需要識別伺服器的使用者名稱/密碼通訊協定以便自動執行登入程序。在一般情況下，直接使用預設值即可。

TELNET

輸入使用者名稱和密碼提示，以便讓TELNET 登入程序自動處理。空白文字也可使用為有效文字，因而要留加注意。

RLOGIN

輸入RLOGIN 通訊協定的密碼提示。按 rlogin 伺服器設定，有時不需要設定密碼。空白文字也可做為有效文字，因而要更加注意。

See Also

工作階段內容


連線: 登入指令碼

Xshell 4 Help / 連線: 登入指令碼
連線: 登入指令碼

登入指令碼設定可以定義自動輸入到終端機的命令語。成功登入到遠端伺服器之後，按顯示於清單上的順序，會一個一個執行命令語。若第一次登入後使用不同伺服器要登入，該功能會非常有用。

執行下列等待及傳送規則。

若要使用執行下列等待及傳送規則，則選取該選項。

新增

開啟等待及傳送規則對話方塊。編輯規則完成，爾後會新增到清單中。

編輯

開啟等待及傳送規則對話方塊，並編輯所選取的規則。

連線到工作階段時，執行指令碼。

連線到工作階段之後，就可以設定要執行的指令碼檔案。

See Also

工作階段內容


連線: SSH

Xshell 4 Help / 連線: SSH
連線: SSH

可以設定SSH 通訊協定的一般選項。

通訊協定版本

選取要使用的 SSH 通訊協定的版本。SSH2比SSH1更加安全，並提供多種功能。

使用 Xagent (SSH代理程式) 處理複雜密碼

僅限選取於使用Xagent。使用Xagent執行公開金鑰使用者驗證時，可節省要輸入使用者金鑰複雜密碼的麻煩。

Xagent自動啟動

需要時就可以自動啟動Xagent。若選取該選項使用Xagent的話，則使用者不必提前執行Xagent。

使用 ZLIB 壓縮

使用壓縮演算法是為壓縮了SSH連線的所有資料。若於網絡速度較緩慢的環境中使用壓縮功能，則可以提升速度。

不要配置終端機

若不要使用終端機，就可選取該選項。該功能最佳使用於只啟用Xshell的通道功能。

See Also

工作階段內容


連線: SSH: 安全性

Xshell 4 Help / 連線: SSH: 安全性
連線: SSH: 安全性

加密

加密演算法使用於加密透過網路傳輸的資訊。使用者在清單中可選取想要的加密演算法。若於清單上選取<Cipher List>，可嘗試多份演算法。要編輯<Cipher List>，按一下[編輯]即可。

MAC (訊息驗證碼)

MAC演算法是新增於SSH2，以便確認已傳送的網路資料的完整性並更加強化安全性。若在清單中選取<MAC List>，可嘗試使用多份演算法。要編輯<MAC List>，請按一下[編輯]。

See Also

工作階段內容


連線: SSH: 通道

Xshell 4 Help / 連線: SSH: 通道
連線: SSH: 通道

通道設定可設定 TCP/IP, Dynamic 及 X11 轉寄規則。在連線設定把SSH通訊協定選取為通訊協定時，該設定才可有效執行。

關於詳細的通道設定方法，請參考“通道服務”。

See Also

工作階段內容


連線: SSH: SFTP

Xshell 4 Help / 連線: SSH: SFTP
連線: SSH: SFTP

設定有關SFTP 通訊協定的選項。

啟動資料夾

透過SFTP 通訊協定並登錄成功，然後設定要啟動工作的本機及遠端資料夾。

See Also

工作階段內容


連線: TELNET

Xshell 4 Help / 連線: TELNET
連線: TELNET

設定有關TELNET 通訊協定的選項。

使用XDISPLOC Telnet 選項

使用XDISPLOC Telnet選項而登入時，將顯示(PC X 伺服器內容)轉寄到伺服器。若使用Xmanager 等 PC X 伺服器並使用該選項，可以方便使用者的電腦使用遠端伺服器的 X11 應用程式。

顯示

輸入登入時要轉寄的顯示。寄到伺服器之前，$PCADDR 關鍵字將自動轉換為 PC的 IP 位址。

See Also

工作階段內容


連線: RLOGIN

Xshell 4 Help / 連線: RLOGIN
連線: RLOGIN

設定有關RLOGIN 通訊協定的選項。

終端機速度

在rlogin 伺服器指定要轉寄的終端機速度。

See Also

工作階段內容


連線: SERIAL

Xshell 4 Help / 連線: SERIAL
連線: SERIAL

在SERIAL設定可設定 SERIAL 連線相關的選項。因為代替現有的終端機而使用PC連線，RS232C SERIAL 連線最適用於UNIX系統缺乏視訊卡或無法直接連結到主控台的情況。若要透過Xshell使用SERIAL 連線，首先在主機器統要安裝 SERIAL 介面。

關於詳細的SERIAL設定方法，請參考“SERIAL 連線”。

See Also

工作階段內容


連線: PROXY

Xshell 4 Help / 連線: PROXY
連線: PROXY

Proxy伺服器

選取使用於連線的Proxy伺服器設定。

關於Proxy設定的詳細內容，請參考“Proxy設定”。

See Also

工作階段內容


終端機

Xshell 4 Help / 終端機
終端機

在終端機設定部分可以設定終端機類型和其他終端機相關的選項。

終端機類型

選取要使用的終端機類型。Xshell會支援 VT100, VT102, VT220, VT320, ANSI, SCOANSI, LINUX 及 XTERM 終端機。

連線時使用下列終端機大小

想要指定該工作階段的終端機大小，即可選取該選項。此選項選取時，連線到工作階段時終端機大小將變更為水平和垂直數值。此選項未選取時，即使連線到工作階段也不會變更終端機大小。

行

輸入終端機的行寬。連線到工作階段時，終端機的大小就會調整。

行列

輸入終端機的列數。連線到工作階段時，終端機的大小就會調整。

捲動緩衝區

以行列為指定捲動緩衝區的大小。

將清除的螢幕推入捲軸緩衝區

即使被清除(clear)命令清除終端機工作螢幕，被清除的內容會留在捲動緩衝區，因而透過滑鼠捲動並可再顯示上一個螢幕。

編碼

選取終端機的輸出編碼。該數值為遠端伺服器所使用的語言。若選取預設語，Xshell會使用使用者Windows的預設編碼。該選項不會變更輸入數值。而若需要的話，則要即時安裝 Windows所提供的 IME (Input Method Editor)。

韓中日語言的模糊文字用寬文字處理

將韓中日語言的模糊文字用寬文字處理識別為寬文字。

See Also

工作階段內容


終端機: 鍵盤

Xshell 4 Help / 終端機: 鍵盤
終端機: 鍵盤

鍵盤設定可以設定使用者 PC的鍵盤轉寄到伺服器的字串。

功能鍵模擬

按各個終端機類型設定不同功能鍵。選取<預設值>時，Xshell按照“終端機”設定所指定的終端機類型會自動選取適當的功能鍵。

請指定其他選項的按鍵對應檔案.

若使用使用者所定義的按鍵所對應的檔案，依所按的各個功能鍵(F1~F20)可以直接指定要傳送到伺服器的字串。

Delete 鍵序列， Backspace 鍵序列

選取使用者按 Delete 鍵或 Backspace 鍵時要傳送的字串。

中繼(Meta)鍵模擬

為了使用Emacs 等 Meta 鍵的應用程式，可以設定 Meta 鍵模擬。

See Also

工作階段內容


終端機: VT 模式

Xshell 4 Help / 終端機: VT 模式
終端機: VT 模式

設定各個終端機模式的預設值。

Auto Wrap Mode (DECAWM)

啟動自動調換行列功能時，就可以啟用。

Origin Mode (DECOM)

啟用Origin Mode。啟用該選項會使方向鍵就以伺服器所指定的位置為準移動。

Reverse Video Mode (DECSCNM)

啟動Reverse Video Mode時，就可以啟用。啟用該選項會使螢幕的前景色彩和背景色彩反轉。

New Line Mode (NLM)

啟動New Line Mode時，就可以啟用。啟用該選項，按輸入鍵會同時傳送CR和LF。該選項未選取，輸入鍵會只傳送 CR。

Insert Mode (IRM)

啟動Insert Mode時，就可以啟用。啟用該選項會將伺服器傳送的字元插入到方向鍵位置，而不會刪除已存在的字串。

Echo Mode (SRM)

啟用該選項會將傳送到伺服器的字串直接輸出到螢幕上，然後傳送到伺服器。

初始方向鍵模式(DECCKM)

設定方向鍵模式的預設值。

初始數字鍵台模式(DECNKM)

按終端機類型設定功能鍵。

See Also

工作階段內容


終端機: 進階

Xshell 4 Help / 終端機: 進階
終端機: 進階

設定與終端機相關的進階選項。

在終端機中用 SHIFT 鍵限制滑鼠的使用

vi 等有些應用程式有把滑鼠按鈕或拖拉使用做為範圍變更、檔案選取、目錄移動等功能。此時，按住Shift 鍵並使用滑鼠的話，Xshell有可直接用滑鼠輸入進行文字選取等功能。

用背景色彩清除螢幕

清除螢幕時，不使用色彩配置所指定的背景色彩，而使用目前終端機的背景色彩。

用CR+LF接收LF

從伺服器接收 LF時，將在終端機螢幕上同時輸出 CR LF。

按機碼捲到最下方

輸入使用者鍵時，將終端機螢幕捲到最下方。

輸入/輸出終端機時捲到最下方

文字在終端機螢幕上輸出時，將終端機螢幕捲到最下方。

啟用破壞性BACKSPACE

按住Backspace鍵，就可以清除方向鍵左側的字元並移到此字元原本所在的位置上。

停用閃爍文字

閃爍文字不再閃爍，而顯示為靜態。

停用終端機標題變更

不變更Xshell的標提列上終端機標題。在大部份的情況下，標提列會按遠端電腦的要求顯示工作資料夾和主機名稱。

停用終端機列印功能

若從伺服器接收終端機列印要求，先不會列印而輸出在螢幕上。

停用交替終端機螢幕 (Alternate Screen) 切換

不做為Vi等一些應用程式的交替螢幕。若使用交替螢幕時，該應用程式結束，則同時會在終端機範圍切換為執行該應用程式之前的螢幕。

未接收處理終端機的變更要求(Disable terminal size change upon request)

忽略伺服器的終端機的大小變更要求。

See Also

工作階段內容


外觀

Xshell 4 Help / 外觀
外觀

外觀設定可以設定終端機視窗的色彩和字型。

色彩配置

選取在工作階段要使用的色彩。Xshell提供一些預設色彩配置，而使用者亦可新增色彩配置、或者在色彩配置對話方塊可編輯現有的色彩配置。

字型名稱

選取工作階段所使用的字型。只會列出固定寬字型。按標準按鈕的字型圖示也可以選取字型。

字型大小

選取想要的字型大小。

粗體文字

選取顯示粗體文字的方法。

方向鍵

指定方向鍵的色彩、外觀、閃爍效果。

See Also

工作階段內容


外觀: 邊界

Xshell 4 Help / 外觀: 邊界
外觀: 邊界

邊界設定可以設定Xshell終端機視窗的邊界及間距。

邊界

設定終端機視窗的邊界。

閒距

設定終端機視窗的行距和字元間距。

See Also

工作階段內容


進階

Xshell 4 Help / 進階
進階

進階設定可以設定快速命令組、追蹤、記錄選項。

快速命令組

可以設定使用於工作階段的預設快速命令組。啟動該工作階段時，所選取的預設快速命令組會顯示於快速命令列。

停用快速命令捷徑鍵 (Do not use Quick Command shortcut keys)

停用Ctrl+F1, Ctrl+F2 等鍵為快速命令捷徑，並將該鍵值傳送到伺服器。

See Also

工作階段內容


進階: 追蹤

Xshell 4 Help / 進階: 追蹤
進階: 追蹤

追蹤設定可以設定通訊協定追蹤選項。該功能最佳使用於解決特定問題。追蹤訊息會輸出到終端機螢幕上。

SH版本、演算法交換及使用者驗證

將版本交換、加密演算法、壓縮方法、伺服器及使用者驗證等資訊輸出到螢幕上。

SSH TCP/IP 及 X11 通道

將連接埠轉寄相關資訊輸出到螢幕上。

TELNET 選項模式

將Xshell和 telnet 伺服器之間的 TELNET 選項交換流程輸出到螢幕上。

See Also

工作階段內容


進階: 記錄

Xshell 4 Help / 進階: 記錄
進階: 記錄

記錄設定可以設定新增記錄相關的選項。

連線時開始記錄

工作階段將連線到遠端主機時，就會自動開始記錄。記錄方法就可以選取下列其中一項。

· 只記錄可列印的文字

· 記錄可列印的文字和終端機字碼

在記錄資料夾裡自動建立新檔案。

新增檔案到程式所預設指定的資料夾，並記錄訊息。檔案名稱將自動取得。

使用下列檔案。

按使用者所指定的格式，將記錄訊息儲存到使用者所指定的資料夾。

檔案路徑

指定記錄檔的路徑。建立檔案時， %n, %d, %t 均會自動轉換為名稱、日期、時間。

瀏覽伺服器按鈕([…])

開啟另存新檔對話方塊並選取要記錄記錄內容的檔案。

若指定的檔案已存在時覆寫。

若指定的檔案已存在，記錄內容會覆寫到該檔案。該選項未選取，在檔案名後會接上排序編號，以建立具有專有名稱的檔案。

開始工作階段記錄時詢問(&S)。

開始記錄時，開啟儲存對話方塊，以便讓使用者可選取留下記錄的檔案。

See Also

工作階段內容


ZMODEM

Xshell 4 Help / ZMODEM
ZMODEM

ZMODEM可以設定 ZMODEM 檔案傳輸相關的選項。

自動啟用ZMODEM(&A)

遠端 ZMODEM 程式開始傳送/接收時，就會自動執行傳送/接收。該選項未選取，則要在檔案清單的檔案傳輸中選取ZMODEM 接收/傳送而接收檔案。

下載前永遠詢問(&L)

每次下載時可以變更要接收的資料夾。

使用下列下載路徑(&D)

接收檔案時，不會詢問要儲存的資料夾並儲存到已指定的資料夾。存檔的檔案名稱與遠端檔案的名稱取為相同並儲存。若同名檔案已存在，會在檔案名後附加序號。

自動重新命名(&R)

若與從ZMODEM要接收的檔案相同的檔名已存在，則會自動變更檔案名稱。例如)變更前: abc.txt, 變更後: abc (2).txt

覆寫

若與從ZMODEM要接收的檔案相同的檔名已存在，則會自動覆寫現有的檔案。

See Also

工作階段內容


匯出

Xshell 4 Help / 匯出
匯出

從Xshell已匯出的工作階段會建立成一個工作階段表列檔案。若透過安裝Xshell的其他電腦匯入，該檔案不需要其他設定即可使用相同的工作階段。

若要匯出工作階段:

1. 在[檔案] 清單中選取 [匯出]。

2. 選取要儲存已匯出的工作階段的位置，而後按一下[下一步]。
結果: 會輸出工作階段的結果。

3. 按一下[完成]並結束匯出工作階段。

See Also

工作階段管理


匯入

Xshell 4 Help / 匯入
匯入

Xshell可以匯入從其他電腦匯出的工作階段。

若要匯入工作階段:

1. 在[檔案] 清單中選取 [匯入]。

2. 直接輸入從其他電腦匯出的工作階段表列檔案的儲存位置，或者按一下[…]按鈕選取工作階段表列檔案，然後按一下[下一步]。

3. 按一下[完成]而結束匯入工作階段。

See Also

工作階段管理


連線

Xshell 4 Help / 連線
連線

Xshell 會提供工作階段對話方塊、本機提示、網址列、連結列及工作階段捷徑等各式連線方法。

See Also

未經由工作階段連線
透過工作階段連線
SERIAL 連線
透過Xactivator連線
Proxy設定


未經由工作階段連線

Xshell 4 Help / 未經由工作階段連線
未經由工作階段連線

若要從本機提示連線:

1. 在本機提示上，請輸入下列命令之一:

· Xshell:\> telnet hostname

· Xshell:\> ssh hostname

· Xshell:\> rlogin hostname

* 參考

若遠端主機未使用預設連接埠號碼，則需要指定連接埠號碼。關於命令語的資訊，請參考“Xshell 本機命令語”。

若要透過網址列連線:

1. 在網址列上，請輸入下列命令之一:

· telnet://hostname

· ssh://hostname

· rlogin://hostname

2. 按Enter 鍵或按一下 [連線] 。

* 參考

在網址列上也可以輸入使用者名稱和連接埠號碼。關於更詳細的資訊，請參考“網址列”的部分。

See Also

連線


透過工作階段連線

Xshell 4 Help / 透過工作階段連線
透過工作階段連線

若要透過工作階段對話方塊連線:

1. 開啟工作階段對話方塊。

2. 選取要連線的工作階段。

3. 按一下[連線]。

* 參考

若已連線到遠端主機的話，為了新連線，會開啟新的索引標籤，或者執行新的 Xshell。

若要透過本機提示連線:

1.   在 Xshell 本機提示上，輸入下列命令。
Xshell:\> open session

若要透過捷徑連線:

1. 按兩下工作階段捷徑圖示。

* 參考

若要取得工作階段捷徑相關詳細資訊，請參考“工作階段管理”的部分。

See Also

連線


SERIAL 連線

Xshell 4 Help / SERIAL 連線
SERIAL 連線

RS232C SERIAL 連線最佳使用於UNIX 系統缺乏視訊卡或無法直接連結到主控台。若要透過Xshell使用SERIAL 連線，首先要在主機系統安裝 SERIAL 介面。

若要透過SERIAL連線:

1. 在[檔案] 清單中選取 [新增]。會顯示新增工作階段內容對話方塊。

2. 在[名稱]輸入工作階段名稱。

3. 在[通訊協定] 清單中選取 SERIAL。

4. 在[類別]中選取 [SERIAL]。

5. 在[Port]中選取連線到已安裝Xshell的 PC的RS232C 序列連接埠編號。

6. 在[Baud Rate]中選取通訊速度。 要設為與伺服器的數值一致。通常會使用 9600。

7. 在[Data Bits]中選取傳輸的資料位元。要設為與伺服器的數值一致。

8. 選取顯示傳送到[Stop Bits]的資料單位的後尾的位元數。依照伺服器設定選取。

9. [Parity]可以驗證傳輸資料是否有錯誤。按伺服器設定選取None, Odd, Even, Mark 及 Space中之一。

10. 按一下[確定]並新增工作階段。

11. 正如“透過工作階段連線”說明，透過新增的工作階段即可連線。

See Also

連線


透過Xactivator連線

Xshell 4 Help / 透過Xactivator連線
透過Xactivator連線

Xactivator會在通知區以圖示格式執行。若啟用Xactivator，則更加容易開啟新的Xshell視窗、方便啟動新的工作階段連線。還可以方便選取或關閉 Xshell視窗。

若要啟動Xactivator:

1. 在[工具] 清單中選取 [Xactivator執行]。執行Xactivator，而後會在通知區建立圖示。

若在Xactivator啟動新的工作階段連線:

1. 在Xactivator通知區圖示，按一下滑鼠右按鈕。

2. 在快顯清單，滑鼠放在[工作階段] 並把所有工作階段列出在子功能表上。

3. 選取要連線的工作階段。

See Also

連線


Proxy設定

Xshell 4 Help / Proxy設定
Proxy設定

Proxy伺服器於使用者的網路與要連線的外部網路之間做為中介角色的伺服器。

使用者可在Proxy清單對話方塊執行新增、編輯、移除Proxy伺服器。

若要新增Proxy伺服器:

1. 在工作階段內容對話方塊上 [連線: Proxy]的 [Proxy伺服器] ，按一下 [瀏覽]。

2. 按一下Proxy清單對話方塊中 [新增]。結果:會顯示Proxy清單對話方塊。

3. 輸入Proxy伺服器的名稱和Proxy伺服器的類型、主機資訊、使用者資訊。

4. 按一下[確定]並新增。

See Also

連線


安全性

Xshell 4 Help / 安全性
安全性

Xshell提供公開金鑰使用者驗證。

在Xshell所建立的主機金鑰和使用者金鑰資料庫，同時可以使用於Xmanager和Xftp程式。因而只要一次建立公開金鑰，就不再需其他設定程序即可使用所有程式。

See Also

公開金鑰使用者驗證
主機金鑰管理


公開金鑰使用者驗證

Xshell 4 Help / 公開金鑰使用者驗證
公開金鑰使用者驗證

為了啟用公開金鑰使用者驗證，使用者要產生以公開金鑰和秘密金鑰為一組的使用者金鑰。進行驗證公開金鑰時，Xshell 使用秘密金鑰新建使用者名稱，而SSH伺服器使用公開金鑰並檢查其簽名。

使用者金鑰均可產生於SSH 伺服器和 Xshell 兩邊。若產生在伺服器那邊，使用者透過 Xshell的匯入功能將秘密金鑰登錄在Xshell 為秘密金鑰所設的儲存裝置。若產生在 Xshell 上，使用者要將公開金鑰登錄在伺服器。

若要產生使用者金鑰:

1. 在[工具列]功能表中選取 [新使用者金鑰精靈]。

2. 按照新使用者金鑰精靈的指示，產生使用者金鑰。

* 參考

產生金鑰在最後一個階段中，公開金鑰可以登入在伺服器。其登錄方法會因伺服器類型而有所不同。

* SSH1: 將公開金鑰複製到$HOME/.ssh/authorized_keys 檔案中。為了刪除設定檔案和可寫入目錄的權限，要以輸入下列命令語的方式來執行。

$ cd
$ chmod go-w . .ssh .ssh/authorized_keys

* SSH2-OpenSSH: OpenSSH 伺服器均使用下列格式。將公開金鑰複製到 $HOME/.ssh/authorized_keys2檔案中。為了刪除設定檔案和可寫入目錄的權限，要以輸入下列命令語的方式來執行。
$ cd
$ chmod go-w . .ssh .ssh/authorized_keys2

* SSH2-IETF SECSH: 一些商用SSH伺服器使用與ssh.com伺服器相同的下列格式。將公開金鑰以如mypublickey.pu專有名稱儲存，並複製到$HOME/.ssh2目錄。然後將在 $HOME/.ssh2/authorization檔案新增下列 :
Key mypublickey.pub
為了刪除設定檔案和可寫入目錄的權限，要以輸入下列命令語的方式來執行。
$ cd
$ chmod go-w . .ssh2
$ chmod go-w .ssh2/authorization .ssh2/mypublickey.pub

若要在伺服器上登錄公開金鑰:

1. 在[工具]功能表上選取 [使用者金鑰管理員]，並開啟使用者金鑰對話方塊。

2. 選取要登錄的使用者金鑰。

3. 按一下[內容]時，會顯示使用者金鑰內容對話方塊。

4. 按一下[公開金鑰]標籤。

5. 在[公開金鑰格式]清單選取適當的格式。

6. 按一下[另存新檔]或複製金鑰內容，然後按照上面的公開金鑰註冊方法在伺服器上登錄。

若要變更使用者金鑰複雜密碼:

1. 開啟使用者金鑰對話方塊。

2. 選取要變更的使用者金鑰。

3. 按一下[內容]時，會顯示使用者金鑰內容對話方塊。

4. 按一下[一般] 標籤。

5. 按一下[變更複雜密碼] 。

* 參考

在”使用者金鑰對話方塊"上可以執行使用者金鑰匯出、匯入、重新命名、刪除、產生等工作。

See Also

安全性
使用者金鑰對話方塊


使用者金鑰對話方塊

Xshell 4 Help / 使用者金鑰對話方塊
使用者金鑰對話方塊

使用者金鑰對話方塊可讓使用者產生並管理使用者金鑰。在 [工具]功能表上選取 [使用者金鑰管理員]以開啟。

匯入

透過開啟開啟對話方塊，可選取使用者金鑰檔案並可匯入。目前 Xshell 可讀取SSH1通訊協定的 RSA 金鑰、OpenSSH SSH2 通訊協定的 RSA/DSA 金鑰、SSH.COM及NetSarang 使用者金鑰格式。

匯出

開啟存檔對話方塊並儲存所選取的使用者金鑰檔案。要匯出的檔案格式為NetSarang 使用者金鑰格式和OpenSSH SSH2格式。NetSarang 使用者金鑰格式檔案僅限於NetSarang Computer所製作的程式使用，而於其他公司的應用程式上無法使用。

刪除

在資料庫中刪除所選取的使用者金鑰。

重新命名

變更所選取的使用者金鑰名稱。金鑰名稱僅限使用有效的檔案名稱。

內容

顯示出使用者金鑰的屬性內容。使用者在此可瀏覽類型、長度、憑證指紋及公開金鑰，並可變更金鑰複雜密碼。

產生

開啟新使用者金鑰精靈。

See Also

公開金鑰使用者驗證


主機金鑰管理

Xshell 4 Help / 主機金鑰管理
主機金鑰管理

以主機金鑰做為遠端主機的公開金鑰，而使用者可使用金鑰的憑證指紋驗證主機。連線時，遠端主機將自己的公開金鑰傳送到 Xshell。若是第一次連線到的主機或未儲存於資料庫的主機金鑰，連線時會顯示 SSH 安全警告對話方塊。若是有效且可信任的主機金鑰，使用者將此主機金鑰儲存到 Xshell 主機資料庫。

See Also

安全性
SSH 安全警告對話方塊
主機金鑰對話方塊


SSH 安全警告對話方塊

Xshell 4 Help / SSH 安全警告對話方塊
SSH 安全警告對話方塊

SSH 安全警告對話方塊為在遠端主機的主機金鑰未在資料庫中儲存，或者遠端主機金鑰與已儲存的主機金鑰的憑證指紋不相同時，則會顯示安全警告對話方塊。

接受一次

主機金鑰只接受這一次連線。因此主機金鑰不被儲存，並於下一次連線時會顯示相同的對話方塊。經常變更主機金鑰或者不常連線到此伺服器時適用。

接受及儲存

儲存主機金鑰並進行連線。下一次連線時不再顯示SSH 安全警告對話方塊。使用確定的憑證指紋，或者經常連線到此伺服器時適用。

取消

不接受主機金鑰並取消連線。

See Also

主機金鑰管理


主機金鑰對話方塊

Xshell 4 Help / 主機金鑰對話方塊
主機金鑰對話方塊

主機金鑰對話方塊可讓使用者管理允許連線的主機的主機金鑰。在[工具] 功能表上選取 [主機金鑰管理員]並可開啟。

匯入

開啟 開啟對話方塊並匯入主機金鑰。已匯入的主機金鑰儲存在主機金鑰資料庫中並會顯示於主機金鑰對話方塊上。可匯入以SECSH 公開金鑰格式儲存的檔案。

匯出

開啟儲存對話方塊並匯出所選取的主機金鑰。已匯出的金鑰會以SECSH的公開金鑰格式儲存並可使用於其他程式。

刪除

在資料庫中刪除所選取的主機金鑰。

瀏覽

用記事簿開啟所選取的主機金鑰檔案。

See Also

主機金鑰管理


通道服務

Xshell 4 Help / 通道服務
通道服務

Xshell 提供TCP/IP 及 X11 轉寄功能。該功能是把安全性通道建立在於不信任的網路環境進行連線的使用者 PC和其他電腦，以便更加安全傳輸資料。

See Also

TCP/IP 連接埠轉寄
X11 轉寄
SOCKS4/5 動態連接埠轉寄
立即通道


TCP/IP 連接埠轉寄

Xshell 4 Help / TCP/IP 連接埠轉寄
TCP/IP 連接埠轉寄

為了使用藉由加密通道的連接埠轉寄服務，針對各個應用程式需要定義連接埠轉際規則。

* 參考

若是Local 轉寄，則會把透過本機PC的聆聽連接埠的連線轉寄到目的地主控件的指定連接埠。

若是Remote 轉寄，則把透過聆聽連接埠的主機連線，會轉寄到目的地主控件的指定連接埠。在大部分的情況下，這時目的地主控件為‘localhost’。

若是Dynamic 轉寄，轉寄方法為與 Local 轉寄相同，但不會設成指定目的主機。另外，Dynamic 轉寄會使用 SOCKS Proxy伺服器，SOCKS 通訊協定的預設連接埠號碼為 1080號。

若要把新的連接埠轉寄規則新增到工作階段:

1. 開啟工作階段對話方塊。

2. 選取要編輯連接埠轉寄規則的工作階段。

3. 按一下標準按鈕按中 [內容] 。

4. 在[類別]中選取 [連線: SSH: 通道]。

5. 按一下[新增]並開啟轉寄規則對話方塊。

6. 選取[類型] 清單中選取連線類型。

7. 在[來源主機]輸入 localhost 或 IP 位址。

8. 在[聆聽連接埠]輸入連接埠號碼，或者選取服務名稱。

9. 在[目的地主控件]輸入驅動中伺服器程式的主機名稱或IP 位址。

10. 在[目的連接埠]輸入伺服程式等候的連接埠號碼。

11. 在[描述]處可輸入該轉寄規則相關說明。

12. 按一下[確定]。

若要變更轉寄規則:

1. 開啟工作階段對話方塊。

2. 選取要編輯連接埠轉寄規則的工作階段。

3. 按一下標準按鈕的 [內容]。

4. 在[類別]中選取 [連線: SSH: 通道]。

5. 選取要變更的轉寄規則。

6. 按一下[編輯]。

若要移除連接埠轉寄規則:

1. 開啟工作階段對話方塊。

2. 選取要移除連接埠轉寄規則的工作階段。

3. 按一下標準按鈕中 [內容]。

4. 在[類別]中選取 [連線: SSH: 通道]。

5. 選取要移除的連接埠轉寄規則。

6. 按一下[移除]。

See Also

通道服務


X11 轉寄

Xshell 4 Help / X11 轉寄
X11 轉寄

X11 轉寄為 TCP/IP 連接埠轉寄的特例。PC X 伺服器程式可使用X11 通訊協定，並透過遠端主機連線到使用者 PC，因而與電子郵件或TELNET等其他用戶端程式是剛好相反的情形。而若使用X11 轉寄，沒有複雜的連接埠轉寄設定而且經由具安全性的加密通道，即可在使用者PC啟用X11應用程式。

若要啟用X11 轉寄服務，則均要設定 Xshell 和SSH伺服器。

若於Xshell啟用 X11 轉寄:

1. 開啟工作階段對話方塊。

2. 選取要啟動X11 轉寄的工作階段。

3. 按一下標準按鈕中 [內容]。

4. 在[類別]中選取 [連線: SSH: 通道]。

5. 選取[轉寄X11連線到。]。

6. 若Xmanager®已安裝在使用者的PC，則選取[Xmanager]。
若要使用其他 PC X 伺服器，則選取 [X DISPLAY]並輸入適當的DISPLAY。

7. 按一下[確定]。

* 參考

若是Xmanager，Xshell 會自動尋找X DISPLAY 選項。要使用其他 PC X 伺服器程式的話，使用者要自己設定。若 PC X 伺服器正使用 TCP 6000號連接埠，DISPLAY要設定為“localhost:0.0”。

若在OpenSSH 伺服器要啟用 X11 轉寄:

1. 開啟/etc/ssh/sshd_config檔案。

2. 將X11Forwarding 選項值設定如下:
X11Forwarding             yes

3. 重新啟動SSH 伺服器。

若在ssh.com 伺服器要啟用 X11 轉寄:

1. 開啟/etc/ssh2/sshd2_config檔案。

2. 將AllowX11Forwarding 選項值設定如下:
AllowX11Forwarding        yes

3. 重新啟動SSH 伺服器。

See Also

通道服務


SOCKS4/5 動態連接埠轉寄

Xshell 4 Help / SOCKS4/5 動態連接埠轉寄
SOCKS4/5 動態連接埠轉寄

動態連接埠轉寄為將本機網路的連線轉寄到 SSH 伺服器的轉寄方法之一，同樣也是要轉寄到的目的地主控件和連接埠由SOCKS 通訊協定自動指定的方式。啟用動態連接埠轉寄的話，使用者即可使用Xshell為SOCKSProxy伺服器。

若要把新的動態連接埠轉寄規則新增到工作階段:

1. 開啟工作階段對話方塊。

2. 選取要編輯連接埠轉寄規則的工作階段。

3. 按一下標準按鈕中 [內容] 。

4. 在[類別]中選取 [連線: SSH: 通道] 。

5. 按一下[新增]並開啟轉寄規則對話方塊。

6. 在[類型] 清單中選取 Dynamic (SOCKS4/5) 。

7. 在[聆聽連接埠]中輸入連接埠號碼，或者選取服務名稱。SOCKS Proxy伺服器的預設連接埠為 1080號。

8. 按一下[確定]。

* 參考

動態連接埠轉寄不需要輸入目的地主控件和連接埠。

See Also

通道服務


立即通道

Xshell 4 Help / 立即通道
立即通道

在工作階段連線的情況之下，立即通道功能會提供轉寄規則新增、移除、擱置、重新啟動等選項功能。現在工作階段的通道狀態可在 Xshell 終端機視窗下方的通道視窗確認。若要顯示通道窗格，請選取於 [檢視] 清單的 [通道窗格]。

若要在通道窗格新增連接埠轉寄規則:

1. 在通道窗格上按一下[轉寄規則] 標籤。

2. 在清單中按一下滑鼠右按鈕。

3. 在清單中選取[新增]。會顯示轉寄規則對話方塊。

* 參考

若未儲存新增規則，該規則僅限適用於現在的連線，並且連線結束後就會被移除。

若要在通道窗格移除連接埠轉寄規則:

1. 在通道窗格按一下[轉寄規則] 標籤。

2. 在[轉寄規則] 清單中對想要移除的規則，按一下滑鼠右按鈕。

3. 在清單中選取 [移除] 。

若要擱置連接埠轉寄規則:

1. 在通道窗格按一下[轉寄規則] 標籤。

2. 在[轉寄規則] 清單中對想要擱置的規則，按一下滑鼠右按鈕。

3. 在清單中選取 [移除] 。

若要重新啟動接埠轉寄規則:

1. 在通道窗格按一下 [轉寄規則] 標籤。

2. 在[轉寄規則] 清單中對想要重新啟動的規則，按一下滑鼠右按鈕。

3. 在清單中選取 [重新啟動] 。

* 參考

重新啟動僅限執行於上次擱置的規則。

See Also

通道服務


終端機視窗工作

Xshell 4 Help / 終端機視窗工作
終端機視窗工作

Xshell提供簡單且強大的終端機視窗，以便讓使用者能夠同時啟用遠端主機的命令行介面和本機提示。而終端機視窗還提供複製和貼上、尋找字串、變更字型及色彩、進階終端機選項等多樣且方便的功能。

See Also

複製和貼上
尋找字串
變更字型
設定文字色彩和背景色彩
變更游標設定
Xshell 視窗操作
操作多重工作階段
設定快速命令組
變更編碼
設定進階終端機選項
管理版面配置


複製和貼上

Xshell 4 Help / 複製和貼上
複製和貼上

若要選取字串:

1. 選取使用下列方法之一:

· 在欲選取的範圍開頭按一下滑鼠左鍵。按住了左鍵，同時將滑鼠游標移動到選取範圍的終點並放開滑鼠按鈕。該選取的字串會以反轉的顏色顯示。

· 在欲選取的範圍開頭按一下滑鼠左鍵。將滑鼠游標移動到選取範圍的終點，並放開滑鼠按鈕。該選取的字串會以反轉的顏色顯示。按住了Shift鍵，同時再按一下左鍵。

· 連按兩下欲選取的字組會選取按兩下的字組。

· 快速連按三下欲選取的行會選取該行。

若要以欄位為單位選取字串:

1. 按下Alt鍵。

2. 在欲選取的範圍開頭按一下滑鼠左鍵。按住了左鍵，同時將滑鼠游標移動到選取範圍的終點並放開滑鼠按鈕。

若要把複製選取的字串複製到Windows簡貼簿 :

1. 選取要複製的字串。

2. 選取使用下列方法之一:

· 按一下[智慧性選取]按鈕，然後選取 [複製] 。

· 在[編輯] 清單中選取 [複製] 。

· 按一下標準按鈕的 [複製] 。

· 按下Ctrl+Insert 鍵。

· 若在選項設為 [將選定的文字自動複製到剪貼簿] ，則會自動複製選取的文字。

若要把選取的字串複製到記事本:

1. 取要複製的字串。

2. 選取使用下列方法之一:

· 按一下[智慧性選取] 按鈕，然後選取 [記事本] 。

· 在[編輯] 清單上點選 [記事本] ，然後選取 [選取內容] 。

* 參考

除了所選取的字串以外，還可以複製現在的螢幕或捲動緩衝區。則會同時顯示記事本視窗和複製到的文字。該功能不會把字串複製到剪貼簿。

若要把剪貼簿的內容貼在終端機螢幕上:

1. 選取使用下列方法之一:

  • 在[編輯] 清單中選取 [貼上] 。
  • 按一下標準按鈕的 [貼上] 。
  • 按下Shift+Insert鍵。
  • 若把滑鼠中間按鈕或右按鈕動作設為[插入剪貼簿的內容。] ，則按一下該滑鼠按鈕。

若要設為xterm 樣式的複製及貼上:

1. 開啟選項對話方塊。

2. 按一下[鍵盤和滑鼠] 標籤。

3. [滑鼠 – 中間按鈕 ]的動作選為 [插入剪貼簿的內容。] 。

4. 選取[將選定的文字自動複製到剪貼簿] 。

5. 按一下[確定] 。

* 參考

xterm 程式選取字串時，先複製到剪貼簿，而按下中間按鈕貼在終端機螢幕上。

See Also

終端機視窗工作


尋找字串

Xshell 4 Help / 尋找字串
尋找字串

捲動緩衝區可使用指定關鍵字或規則演算式搜尋。

若要用關鍵字搜尋:

1. 在[編輯]清單中選取 [尋找] 。

2. 要尋找的關鍵字輸入在尋找對話方塊上。

3. 按一下[尋找下一個] 。

若要用規則演算式搜尋:

1. 在[編輯] 清單中選取 [尋找] 。

2. 要尋找關鍵字輸入在尋找對話方塊上。

3. 選取[規則演算式] 。

4. 按一下[尋找下一個] 。

* 參考

關於規則演算式的詳細資訊，請參考“規則運算式”的部分。

See Also

終端機視窗工作


變更字型

Xshell 4 Help / 變更字型
變更字型

終端機螢幕要針對行和列顯示字元，因而Xshell只能選取固定寬度字型。

若要變更終端機字型和該大小:

1. 選取使用下列方法之一:

· 按一下標準按鈕的字型圖示選取想要的字型和大小。

· 在工作階段內容對話方塊選取 [外觀] 類別，然後選取想要的字型和大小。

若要變更粗體文字表現方法:

1. 開啟工作階段內容對話方塊。

2. 在[類別]中選取 [外觀] 。

3. 在[粗體文字] 範圍選取想要的選項。

* 參考

粗體文字均可使用粗體色彩、粗體字型、粗體色彩和粗體字型等選項。

See Also

終端機視窗工作


設定文字色彩和背景色彩

Xshell 4 Help / 設定文字色彩和背景色彩
設定文字色彩和背景色彩

色彩配置會儲存文字色彩、背景色彩、 ANSI 16色等資訊。Xshell讓使用者隨時都能選取/變更色彩配置，而即時適用所選取的色彩配置。

若要變更終端機色彩:

1. 選取使用下列方法之一:

· 按一下標準按鈕的[色彩配置]就會顯示色彩配置對話方塊。在該對話方塊中選取想要的色彩配置，然後按一下 [確定] 。

· 在工作階段內容對話方塊的 [類別]中選取 [外觀] ，然後在 [色彩配置]清單中選取色彩配置，而後再按一下 [確定] 。

* 參考

Xshell會提供幾種不同預設色彩配置。使用者可以編輯現有色彩配置或新增色彩配置。

若要新增色彩配置:

1. 開啟色彩配置對話方塊。

2. 按一下[新增] 。新的色彩配置會新增到清單上。

3. 選取新增的色彩配置。

4. 按一下[編輯] 。會顯示編輯色彩配置對話方塊。

若要編輯色彩配置:

1. 開啟色彩配置對話方塊。

2. 選取想要編輯的色彩配置。

3. 按一下[編輯] 。會顯示編輯色彩配置對話方塊。

4. [一般文字]選取為一般文字所使用的色彩。

5. [粗體文字]選取為粗體文字所使用的色彩。粗體文字通常比一般文字使用更高亮的色彩。

6. 為了表現出ANSI 彩色碼，終端機就會使用[ANSI 彩色]的色彩。上方色彩為black、red、green、yellow、blue、magenta、cyan及white等一般文字色彩，則下方色彩顯示為各個粗體文字的色彩。

若要匯出色彩配置:

1. 開啟色彩配置對話方塊。

2. 選取想要匯出的色彩配置。

3. 按一下[匯出] 。會顯示儲存對話方塊。

4. 指定資料夾並輸入要儲存的檔案名稱。

5. 按一下[確定] 。

* 參考

匯出的檔案設為“.xcs”格式，並僅限使用於Xshell。多個色彩配置可儲存到同一件檔案裡。同時色彩配置的名稱也會儲存到檔案裡。

若要匯入色彩配置:

1. 開啟色彩配置對話方塊。

2. 按一下[匯入] 。會顯示開啟對話方塊。

3. 選取想要匯入的色彩配置檔案(.xcs) 。

4. 按一下[開啟] 。

See Also

終端機視窗工作


變更游標設定

Xshell 4 Help / 變更游標設定
變更游標設定

若要變更游標色彩:

1. 開啟工作階段內容對話方塊。

2. 選取[類別]中 [外觀] 。

3. 選取[游標色彩]的數值。

4. 選取[文字色彩]的數值。

5. 按一下[確定] 。

若要變更是否使用閃爍游標:

1. 開啟工作階段內容對話方塊。

2. 選取[類別]中 [外觀] 。

3. 選取或解除[使用閃爍游標] 。

4. 按一下[確定] 。

若要變更游標的閃爍速度:

1. 開啟工作階段內容對話方塊。

2. 選取[類別]中 [外觀] 。

3. 選取[使用閃爍游標] 。

4. [速度]的游標速度以毫秒為單位輸入值。

5. 按一下[確定] 。

See Also

終端機視窗工作


Xshell 視窗操作

Xshell 4 Help / Xshell 視窗操作
Xshell 視窗操作

若要最小化到系統匣:

1. 開啟選項對話方塊。

2. 按一下[進階] 標籤。

3. 選取[最小化到系統匣] 。

4. 按一下[確定]並儲存變更事項。

若要啟動時最小化到系統匣:

1. 開啟選項對話方塊。

2. 按一下[進階]標籤。

3. 選取[啟動Xshell時最小化到系統匣] 。

4. 按一下[確定]並儲存變更事項。

若要關閉所有連線時結束Xshell:

1. 開啟選項對話方塊。

2. 按一下[進階] 標籤。

3. [關閉所有連線時結束Xshell] 。

4. 按一下[確定] 。

若要連線終止時原到本地殼層:

1. 開啟選項對話方塊。

2. 按一下[進階]標籤。

3. 選取[連線終止時本地殼層還原] 。

4. 按一下[確定] 。

若要新增 Xshell 視窗:

1. 在[視窗] 清單中選取 [新視窗] 。

若要移動到其他Xshell 視窗:

1. 在[視窗] 清單中選取 [下一個] 或 [上一個] 。

* 參考

透過Alt+Right和 Alt+Left 鍵也能執行同樣的功能。

若要同時關閉所有 Xshell 視窗:

1. 在[視窗]清單中選取 [全部關閉] 。

若要關閉本視窗以外的所有Xshell視窗:

1. 在[視窗] 清單中選取[關閉本視窗以外的所有視窗] 。

See Also

終端機視窗工作


操作多重工作階段

Xshell 4 Help / 操作多重工作階段
操作多重工作階段

多重工作階段會保持在單行Xshell視窗上開啟多份工作階段，而於多個工作階段中讓使用者能以工作階段標籤或工作階段列移動工作。

若要在單行Xshell視窗上開啟多份工作階段:

1. 開啟選項對話方塊。

2. 按一下[進階] 標籤。

3. 在[選項] 範圍中選取 [在單行Xshell視窗上開啟多份工作階段] 。

4. 按一下[確定]並儲存該變更事項。

若要在工作階段標籤新增連線:

1. 按一下工作階段標籤的新增標籤按鈕。

2. 在工作階段清單中選取其中之一。
結果: 在新的標籤會開啟所選取的工作階段。

若在在工作階段列新增連線:

1. 按一下位於工作階段列最左邊的圖示。

2. 在工作階段清單中選取其中之一。

結果: 在新的標籤會開啟所選取的工作階段。

* 參考

若要新增連線，正如“連線”部分的說明可以啟用工作階段連線，或也可停用工作階段連線。

若要在本地殼層輸入命令語而連線到遠端電腦:

1. 按一下工作階段標籤的新增標籤而按鈕選取[本地殼層]，或者連按兩下工作階段標籤的餘空間而建立本地殼層工作階段。

2. 在設為命令行提示狀態下，透過 ssh, telnet, sftp 等命令連線到遠端電腦。若想要取得有關命令列的詳細使用方法，則輸入‘?’ 。

若要設為多重工作階段連線而在工作階段之間移動:

1. 若要在工作階段之間移動，則選取使用下列方法之一。

· 選取工作階段標籤。

· 選取工作階段列所列出的工作階段名稱。

· 使用Ctrl+Tab, Shift+Tab 或 Ctrl+Shift+Tab。

· 移到Alt+工作階段號碼。

若要工作階段連線到新的 Xshell 視窗:

1. 選取[視窗] 清單中 [新增終端機] ，或者按一下標準按鈕的 [新增終端機] 。結果: 會開啟新增Xshell 視窗，而透過與現在連線的工作階段相同的工作階段內容嘗試連線。

See Also

終端機視窗工作


設定快速命令組

Xshell 4 Help / 設定快速命令組
設定快速命令組

將經常使用的字串指定使用為快速命令，以便減少重複輸入鍵盤的麻煩並取代為按下快速命令的簡單操作。若要顯示快速命令列，只要打勾 [檢視] 清單中 [快速命令]即可。

若要新增快速命令組:

1. 在[工具]清單中選取 [快速命令組] 。結果: 會顯示快速命令組對話方塊。

2. 按一下[新增] 。

3. 輸入新增快速命令組的名稱。

* 參考

為了開啟快速命令組對話方塊，使用者也可以在快速命令列按一下 [快速命令組] 按鈕，然後在清單中選取 [瀏覽] 。

若要在快速命令列新增快速命令:

1. 在快速命令列按一下尚未定義的快速命令按鈕。
或者按下快速鍵(Ctrl+F1 等) 。
結果: 會顯示編輯快速命令對話方塊。

2. 在[標籤]輸入快速命令名稱，而在[文字]輸入常用的命令或字串。

3. 按一下[確定] 。

若要在快速命令組新增快速命令:

1. 在[工具] 清單中選取 [快速命令組] 。結果: 會顯示快速命令組對話方塊。

2. 選取要新增快速命令的快速命令組。

3. 按一下[編輯] 。結果:會顯示編輯快速命令組對話方塊。

4. 選取快速命令，然後按一下 [編輯] 。結果: 會顯示編輯快速命令對話方塊。

5. 在[標籤]輸入快速命令名稱，而在 [文字]輸入常用的命令或字串。

6. 按一下[確定] 。

7. 若要新增更多快速命令，則要重複 4-6 步驟。

8. 在編輯快速命令組對話方塊，按一下 [確定] 。

* 參考

另外，若要編輯顯示在現在快速命令列的快速命令組，先按一下快速命令列中 [快速命令組] 按鈕，而後在清單中選取 [編輯]並開啟編輯快速命令組對話方塊。

在編輯快速命令組對話方塊，使用者可以新增、移除、編輯快速命令。還可以變更顯示在快速命令列的排序。

若要在快速命令列上顯示其他快速命令組:

1. 在快速命令列按一下 [快速命令組] 按鈕，然後在清單中選取快速命令組。結果: 會列出所選取的快速命令組的快速命令。

若要選取啟動工作階段時顯示的快速命令組:

1. 開啟工作階段的工作階段內容對話方塊。

2. 選取[類別]的 [進階] 。

3. 選取要在工作階段所使用的快速命令組。

4. 按下[瀏覽]就會顯示快速命令組對話方塊，在此處可以便更或新增快速命令組。

5. 按一下[確定] 。

See Also

終端機視窗工作


變更編碼

Xshell 4 Help / 變更編碼
變更編碼

Xshell通常會使用Windows 系統的使用者預設語言。按遠端主機的編碼，使用者也可以選取使用與 Windows 系統不同的多種編碼。

若要變更工作階段的編碼:

1. 選取使用下列方法之一:

· 按一下標準按鈕中 [編碼] 並選取要使用的編碼。

· 開啟工作階段內容對話方塊而選取 [類別]的 [終端機] ，然後在 [編碼] 清單中選取想要的編碼。

2. 輸出UTF-8 編碼:

· 若遠端電腦設為支援Unicode(UTF-8)並使用 UTF-8，則要使用‘Unicode (UTF-8)’編碼。 UTF-8 編碼可同時輸出多種語言的字元集合。

* 參考

若要正確的顯示選取的編碼的話，先要安裝此Windows系統所選取的編碼的語言套件。

這時編碼選項不會變更鍵盤輸入值，但若需要的話，則要適當的安裝 Windows所提供的 IME (Input Method Editor) 。

See Also

終端機視窗工作


設定進階終端機選項

Xshell 4 Help / 設定進階終端機選項
設定進階終端機選項

若要變更捲動緩衝區的大小:

1. 開啟工作階段內容對話方塊。

2. 在[類別]中選取 [終端機] 。

3. 在[捲動緩衝區]輸入要使用的列數。

4. 按一下[確定] 。

* 參考

捲動緩衝區的大小為 0 ~ 2,147,483,647之間值。 0是指停用捲動緩衝區。

若要變更終端機類型:

1. 開啟工作階段內容對話方塊。

2. 在[類別]中選取 [終端機] 。

3. 在[終端機類型]中選取終端機類型。

4. 按一下[確定] 。

若要變更啟動終端機啟動時的大小:

1. 開啟工作階段內容對話方塊。

2. 在[類別]中選取 [終端機] 。

3. 在[模擬] 範圍中選取 [連線時使用下列終端機大小] 。

4. 在[列]處輸入列大小。

5. 在[欄]處輸入欄大小。

6. 按一下[確定] 。

若要變更鍵台模式:

1. 開啟工作階段內容對話方塊。

2. 在[類別]中選取 [終端機: VT 模式] 。

3. 在[初始數字鍵台模式]中選取 [一般] 或 [應用程式] 。

4. 按一下[確定] 。

See Also

終端機視窗工作


管理版面配置

Xshell 4 Help / 管理版面配置
管理版面配置

管理版面配置功能是指按使用者的工作環境或喜好可另存Xshell視窗的版面配置的功能。使用者可把已儲存的版面配置於管理版面配置對話方塊刪除或變更名稱。

若要儲存現在 Xshell 視窗的版面配置:

1. 在[檢視] 清單中選取[版面配置] ，而後儲存 [另存新檔] 。

2. 用其他名稱在儲存對話方塊輸入 [新名稱] 。

3. 按一下[確定] 。

若要以其他版面配置變更 Xshell 視窗:

· 在[檢視] 清單中選取 [版面配置] 後在版面配置清單中選取其中一個。

· 按下Alt+L並於版面配置清單中選取其中一個。

若要管理已註冊的版面配置清單:

1. 在[檢視] 清單中選取 [版面配置] ，然後選取 [管理] 。

2. 在管理版面配置對話方塊刪除版面配置或者變更名稱。

See Also

終端機視窗工作


設定選項

Xshell 4 Help / 設定選項
設定選項

選項對話方塊可設定適用於所有工作階段的選項。選取[工具] 清單中 [選項]可開啟選項對話方塊。

See Also

工作階段資料夾及啟動工作階段
清除記錄及連線記錄
設定按鍵對應
設定滑鼠
設定透明度
進階選項


工作階段資料夾及啟動工作階段

Xshell 4 Help / 工作階段資料夾及啟動工作階段
工作階段資料夾及啟動工作階段

使用者可以變更Xshell　工作階段資料夾路徑。工作階段對話方塊會顯示變更的路徑下方的所有工作階段。若選取網路資料夾，則可與其他使用者共用工作階段。

若要變更工作階段資料夾:

1. 開啟選項對話方塊。

2. 在[一般] 標籤輸入 [工作階段資料夾路徑] 。

若要註冊啟動時要開啟的工作階段:

1. 開啟選項對話方塊。

2. 在[一般] 標籤按一下 [啟動時要開啟的工作階段] 清單下方的 [新增] 。

3. 在開啟對話方塊中選取工作階段檔案。

See Also

設定選項


清除記錄及連線記錄

Xshell 4 Help / 清除記錄及連線記錄
清除記錄及連線記錄

在清除記錄對話方塊可以選取並刪除網址列、撰寫視窗、搜尋關鍵字、本地殼層及連線記錄的歷程。在設定記錄對話方塊可以指定連線記錄相關的設定或要儲存記錄的檔案。

若要清除記錄:

1. 開啟選項對話方塊。

2. 在[一般] 標籤按一下記錄 [清除] 。

3. 在記錄清除對話方塊中選取要清除的內容。

4. 按一下[清除] 。

若要儲存連線記錄:

1. 開啟選項對話方塊。

2. 在[一般] 標籤按一下記錄 [設定] 。

3. 在設定記錄對話方塊中選取 [將連線詳細資訊記錄到下列檔案。] 。

4. 輸入要儲存連線伺服器、連線通訊協定、連線日期、結數日期及連線時間相關內容的檔案。

See Also

設定選項


設定按鍵對應

Xshell 4 Help / 設定按鍵對應
設定按鍵對應

在使用者自訂按鍵對應對話方塊，使用者可確認現在設定的快速鍵組合，並可新增、刪除、編輯按鍵組合。

若要變更按鍵對應:

1. 開啟選項對話方塊。

2. 按一下[鍵盤和滑鼠] 標籤。

3. 按一下[按鍵對應]的 [編輯] 。結果: 會顯示使用者自訂按鍵對應對話方塊。

4. 在[設定現在索引] 清單中選取要變更的按鍵組合，然後按一下 [編輯] 。結果: 會顯示編輯對話方塊。

5. 在[類型]的功能表、傳送字串、執行指令碼、啟動應用程式中選取其中一個。

6. 在[動作]輸入選取的各個類別功能表或字串。

7. 按一下[確定] 。

See Also

設定選項


設定滑鼠

Xshell 4 Help / 設定滑鼠
設定滑鼠

可分別選取滑鼠中間和右按鈕的各個動作。而且可指定連按兩下選取時使用的分隔符號。

若要變更滑鼠按鈕的動作:

1. 開啟選項對話方塊。

2. 在[鍵盤和滑鼠] 標籤中選取一個滑鼠中間按鈕的功能。

· 不會執行任何動作。

· 開啟快顯功能表。

· 貼上剪貼簿的內容。(預設值)

· 開啟內容視窗。

3. 在右按鈕功能中選取其中一個。右按鈕的預設功能設為 [開啟快顯功能表。] 。

若要變更連按兩下選取十使用的分隔符號:

1. 開啟選項對話方塊。

2. 在[鍵盤和滑鼠] 標籤中 [選取] 範圍輸入選取字組時使用的分隔符號。

See Also

設定選項


設定透明度

Xshell 4 Help / 設定透明度
設定透明度

Xshell提供透明度設定功能。

若要視窗設定為透明顯示:

1. 在[檢視] 功能表中選取 [透明] 。

2. 開啟選項對話方塊。

3. 在[檢視] 標籤設定透明度。

4. 設定[不透名度]值。若要設定Xshell視窗透明度，則不透名度值越小會越透明。

5. 若選取[滑鼠移過在視窗上時顯示不透明]選項，即使Xshell 視窗設為透明顯示，滑鼠位置於視窗中會將Xshell視窗顯示為不透明。

6. 若選取[透明時最上層顯示] 選項，則在使用Xshell視窗為透明時會顯示於所有視窗的最上層。

See Also

設定選項


進階選項

Xshell 4 Help / 進階選項
進階選項

進階選項是指在選項對話方塊中 [進階] 標籤可設定的一些選項。

按下ESC鍵切換到英文輸入

在vi, vim 等一些應用程式輸入韓文時，想要移動到命令模式而按下ESC鍵後會自動切換到韓文輸入狀態。

停用鈴聲

設為停用鈴聲。

使用智慧型選取按鈕為了簡單複製及下載檔案

用滑鼠選取終端機範圍時，智慧型選取按鈕可設為顯示或隱藏。

最小化到系統匣

Xshell可設定為最小化到系統匣。

在全螢幕模式上顯示工作階段標籤

在全螢幕模式上會顯示工作階段標籤。

在全螢幕模式上顯示捲軸

在全螢幕模式上會顯示捲軸。

按目前視窗大小重疊顯示

若在[視窗] 清單中選取重疊顯示，則會按目前Xshell視窗大小重疊顯示。

開始Windows 時執行 Xshell

開始Windows 時，會自動驅動Xshell。

啟動Xshell時最小化到系統匣

啟動Xshell時會顯示為最小化到系統匣。

Xshell啟動時開啟工作階段對話方塊

Xshell啟動時會開啟工作階段對話。

在功能表存取中使用Alt鍵

按下Alt鍵就可以開啟功能表。

在單行Xshell視窗上開啟多份工作階段

在單行Xshell視窗上開啟多份工作階段。透過工作階段標籤和工作階段列就可以於工作階段之間移動。

Xshell結束時確認是否中斷連線

程式結束時會確認是否中斷連線中的工作階段。

工作階段終止時確認是否中斷連線

工作階段終止時會確認是否中斷連線。

連線終止時本地殼層還原

連線終止時會保持連線為本地殼層狀態。在本地殼層工作階段中終端機螢幕會顯示Xshell提示，還可以用, open、telnet、ssh、ping等本機命令語執行。要檢視命令語清單的話，請在Xshell提示執行help 或　? 。

關閉所有連線時結束Xshell

關閉所有連線時會結束Xshell。

See Also

設定選項


傳輸檔案

Xshell 4 Help / 傳輸檔案
傳輸檔案

用 SFTP和 ZMODEM，Xshell有助於使用者可傳輸或接收檔案。

See Also

用SFTP傳輸檔案
用ZMODEM傳輸檔案
與Xftp聯動的檔案傳輸


用SFTP傳輸檔案

Xshell 4 Help / 用SFTP傳輸檔案
用SFTP傳輸檔案

SFTP是指以SSH 為基礎的檔案傳輸通訊協定，而且會支援比ZMODEM更加安全且快速的檔案傳輸。

若要用SFTP接收檔案:

1. 在本機提示連線到透過sftp命令要接收檔案的主機。
Xshell:\> sftp hostname

2. 在sftp提示用 get命令接收想要接收的檔案。
sftp:/home/user21> get filename

若要用SFTP傳輸檔案:

1. 在本機提示連線到用sftp命令傳輸檔案的主機。
Xshell:\> sftp hostname

2. 在sftp提示用put命令傳輸想要傳輸的檔案。
sftp:/home/user21> put filename

See Also

傳輸檔案


用ZMODEM傳輸檔案

Xshell 4 Help / 用ZMODEM傳輸檔案
用ZMODEM傳輸檔案

用ZMODEM接收的檔案會儲存在使用者所指定的資料夾。每當接收檔案時，使用者還可以指定其他想要接收檔案的資料夾。

若要用ZMODEM接收檔案:

1. 在遠端主機的提示執行如下命令:
$ sz file1 file2 …

2. 在[檔案] 清單上點選 [傳輸] 。

3. 選取[用ZMODEM接收] 。

* 參考

若於遠端主機未存在sz命令，則使用者要直接安裝該命令。在大部分的情快之下，會存在與它類似的命令。

若要在終端機用 ZMODEM接收檔案:

1. 在Xshell終端機視窗選取要下載的檔案名稱。
結果: 在已選取的檔案名稱旁邊周圍會顯示智慧型選取按鈕。

2. 按一下智慧型選取按鈕。

3. 選取[用ZMODEM下載] 。

若要用ZMODEM傳輸檔案:

1. 在遠端提示執行如下命令:
$ rz

2. 在[檔案] 清單指向 [傳輸] 。

3. 選取[用ZMODEM傳輸] 。

4. 選取要傳輸的檔案。

5. 若要將檔案傳送到ASCII 格式，則選取 [將檔案傳送到 ASCII] 。

6. 按一下[開啟] 。

若要用拖放將檔案傳輸到ZMODEM:

1. 選取要上傳的 Windows 檔案。

2. 將檔案拖放到Xshell終端機視窗。
結果: 檔案傳輸會自動執行。

若要變更預儲存預設檔案的資料夾:

1. 開啟工作階段內容對話方塊。

2. 在[類別]中選取[ZMODEM] 。

3. 在[接收資料夾] 範圍中選取 [使用下列下載路徑] 。

4. 開啟瀏覽資料夾對話方塊，然後選取要儲存已接收的檔案的資料夾。

5. 按一下[確定] 。

若要閱覽已接收的檔案:

1. 開啟工作階段內容對話方塊。

2. 在[類別]中選取 [ZMODEM] 。

3. 按一下[接收資料夾] 範圍中 [開啟] 。

See Also

傳輸檔案


與Xftp聯動的檔案傳輸

Xshell 4 Help / 與Xftp聯動的檔案傳輸
與Xftp聯動的檔案傳輸

Xshell會與(株) NetSarang Computer所開發的檔案傳輸程式－Xftp聯動，以便讓目前連結到Xshell的主機能夠容易而快速的執行FTP/SFTP連線。

若要於Xshell所連線的主機中建立 Xftp 連線:

1. 用Xshell連線到要傳輸檔案的主機。

2. 在[視窗] 清單中選取 [新增檔案傳輸] 。或者按一下標準按鈕中 [新增檔案傳輸] 。

* 參考

若Xshell使用 SSH通訊協定，Xftp會嘗試SFTP 連線。另外，若使用的是TELNET、RLOGIN 等通訊協定，則會使用 FTP連線。

See Also

傳輸檔案


工作階段記錄和追蹤

Xshell 4 Help / 工作階段記錄和追蹤
工作階段記錄和追蹤

使用Xshell的記錄功能即可保留用工作階段接收和傳輸的所有字元為檔案。追蹤功能還使用為偵錯目的。

See Also

工作階段記錄
工作階段追蹤


工作階段記錄

Xshell 4 Help / 工作階段記錄
工作階段記錄

若只要記錄字串:

1. 在[檔案] 清單點選 [記錄] 。

2. 選取[開始] 。會顯示另存新檔對話方塊。

3. 輸入要儲存記錄資料的檔案名稱。

4. 選取並解除[記錄一般文字還和終端機字碼]選項。

5. 按一下[儲存] 。

* 注意

記錄動作會持續執行到工作階段結束為止。若要保持工作階段並停止記錄動作，在 [檔案]清單的 [記錄]中選取[停止] 。

若要同時記錄字串和終端機編碼:

1. 在[檔案] 清單點選 [記錄] 。

2. 選取[開始] 。會顯示另存新檔對話方塊。

3. 輸入要儲存記錄資料夾的檔案名稱。

4. 選取[記錄一般文字還和終端機字碼] 。

5. 按一下[儲存] 。

若要連線時開始記錄:

1. 開啟工作階段內容對話方塊。

2. 在[類別]中選取 [記錄] 。

3. 選取[連線時開始記錄] 。

4. 可自訂要儲存記錄的資料夾或檔案名稱。

5. 按一下[確定] 。

See Also

工作階段記錄和追蹤


工作階段追蹤

Xshell 4 Help / 工作階段追蹤
工作階段追蹤

透過追蹤選項，使用者就可以追蹤與遠端主機接收傳輸的通訊協定控制資料。

若是SSH通訊協定，則會把演算法交換及使用者驗證相關詳細內容輸出到螢幕上。若是TELNET 通訊協定，則可以追蹤各樣選項的交換。該功能最佳使用於連線到遠端主機時發生錯誤時。

若要關閉或開啟追蹤功能:

1. 開啟工作階段內容對話方塊。

2. 在[類別]中選取 [追蹤] 。

3. 選取適當選項。

4. 按一下[確定] 。

See Also

工作階段記錄和追蹤


列印

Xshell 4 Help / 列印
列印

Xshell提供把終端機視窗的文字列印到本機印表機的功能。Xshell還可直接用列印終端機所使用的字型及彩色。而在頁設定對話方塊中可以設定列印用紙的邊界。

若要設定用紙的大小和列印方向:

1. 在[檔案] 清單中選取 [頁設定] 。

2. 選取適當的用紙大小和方向。

3. 輸入邊界。

4. 按一下[確定]並儲存變更內容。

若要列印:

1. 在[檔案] 清單中選取 [列印] 。

2. 在[名稱] 清單中選取印表機。

3. 按一下[確定] 。


Xagent 使用

Xshell 4 Help / Xagent 使用
Xagent 使用

Xagent是指SSH 驗證代理程式(authentication agent)。Xagent會保管使用於公開金鑰使用者驗證的使用者金鑰。當Xshell需要用使用者金鑰時，Xagent讓Xshell能夠使用該金鑰。

Xagent會保存Xshell使用者金鑰的所有清單，若需要的話，則會向使用者要求輸入金鑰複雜密碼。若使用者輸入金鑰複雜密碼，Xagent會解鎖金鑰並儲存到記憶體。所以若使用Xagent，使用者只要一次輸入金鑰複雜密碼，就可以多次使用該金鑰。

另外，Xagent啟用為SSH驗證伺服器，因而可以執行 SSH代理程式轉寄功能。從第一次連線的伺服器要連線到其他伺服器時，則需要SSH 代理程式轉寄功能。使用者金鑰通常只儲存於使用者的 PC，而若從第一次連線的伺服器要連線到其他伺服器的話，則不可使用該金鑰。 SSH 代理程式會讓遠端伺服器的 SSH 用戶端程式能使用我方 PC的Xagent所管理的使用者金鑰。

* 參考

若使用Xagent，Xagent圖示會建立在系統匣。關閉Xagent對話方塊，而可保持連線執行Xagent。若要結束Xagent或開啟Xagent對話方塊，則使用系統匣圖示上方的功能表。

See Also

用Xagent連線到伺服器
在遠端主機使用 Xagent的使用者金鑰


用Xagent連線到伺服器

Xshell 4 Help / 用Xagent連線到伺服器
用Xagent連線到伺服器

若要設定為Xshell使用 Xagent:

1. 開啟工作階段內容對話方塊。

2. 在[類別]中選取 [連線: SSH] 。

3. 選取[使用 Xagent (SSH代理程式) 於處理複雜密碼] 。

4. 按一下[確定] 。

若要用Xagent連線到 SSH 伺服器:

1. 將Xagent設定為使用Xshell。

2. 若在停用Xagent，則要啟用執行Xagent。

3. 連線到SSH 伺服器。
這時 SSH 伺服器要支援公開金鑰使用者驗證，而先要把要使用的使用者金鑰的公開金鑰部分註冊到伺服器。

4. 會顯示複雜密碼對話方塊。輸入已選取的使用者金鑰的複雜密碼。

* 參考

連線: 若SSH 設定選取 [Xagent 自動啟動] ，則可省略第 2號程序。若以選取的金鑰的狀態設為Close，才會顯示複雜密碼對話方塊。在Xagent的使用者金鑰清單中就可以確認使用者金鑰的狀態。

See Also

Xagent 使用


在遠端主機使用 Xagent的使用者金鑰

Xshell 4 Help / 在遠端主機使用 Xagent的使用者金鑰
在遠端主機使用 Xagent的使用者金鑰

啟用Xagent的話，位於遠端主機的ssh 用戶端也可以使用Xshell所使用的使用者金鑰，也就是所謂Xagent擁有的使用者金鑰。若要在遠端主機使用Xagent的使用者金鑰，則Xshell和遠端主機的 SSH 伺服器要支援代理程式轉寄功能。

若要在ssh.com 伺服器啟用代理程式轉寄功能:

1. 開啟/etc/ssh2/sshd2_config檔案。

2. 將AllowAgentForwarding 選項值設定如下:
AllowAgentForwarding      yes

3. 重新啟動SSH 伺服器。

* 參考

除非指定no-agent-forwarding 選項，OpenSSH 伺服器永遠會啟用該代理程式轉寄功能。

若要在遠端主機使用Xagent的金鑰:

1. 將Xshell設定為啟用Xagent。

2. 首先要設為執行Xagent。

3. 連線到SSH 伺服器並登入。

* 參考

只要伺服器代理程式支援轉寄功能的話，登入時就會適當設定為代理程式轉寄所需的環境參數(SSH_AUTH_SOCK 或者 SSH2_AUTH_SOCK) 。

4. 從遠端伺服器連線到執行公開金鑰驗證的其他伺服器。

5. 若顯示複雜密碼對話方塊，則輸入選取的使用者金鑰的複雜密碼。

* 參考

若已選取的金鑰的狀態設為Close，才會顯示[複雜密碼]對話方塊。在Xagent的使用者金鑰清單中就可以確認使用者金鑰的狀態。

See Also

Xagent 使用


使用指令碼

Xshell 4 Help / 使用指令碼
使用指令碼

指令碼是指將所有要執行的命令匯集在一起的一個檔案。將重複執行的工作整合在一個檔案，不必打每一條命令且方便批次執行。該撰寫為 Visual Basic指令碼。

See Also

指令碼的啟用和結束
指令碼 API


指令碼的啟用和結束

Xshell 4 Help / 指令碼的啟用和結束
指令碼的啟用和結束

若要開始指令碼檔案:

1. 在[工具]清單中點選 [指令碼] ，然後選取 [執行] 。
結果: 會顯示開啟對話方塊。

2. 選取指令碼檔案。

3. 按一下[確定] 。

結束執行中指令碼檔案

1. 在[工具] 清單點選 [指令碼] ，然後選取 [取消] 。

See Also

使用指令碼


指令碼 API

Xshell 4 Help / 指令碼 API
指令碼 API

Xshell會提供下列 API。使用該 API有助於自動處理要重複執行的工作。

See Also

使用指令碼
xsh.Session
xsh.Screen
Script 例子


xsh.Session

Xshell 4 Help / xsh.Session
xsh.Session

下列函數和參數可使用於Xshell工作階段。若要使用這些函數和參數，則要與 xsh.Session同時執行。例如，想要使用‘sleep’函數的話，就與‘xsh.Session.sleep(1000)’同時使用。

Functions
傳回值 | 函數 | 參數 | 描述
Void | OpenSession(LPCTSTR lpszSession) | lpszSession 做為字串， Xshell 工作階段路徑或 Xshell所使用的 URL 格式。 | 開啟新工作階段或URL。 為了開啟工作階段，把 /s 選項放在字串的最前面。例子)要開啟A.xsh 工作階段就使用‘/s $PATH/A.xsh’。
Void | CloseSession() |  | 結束正在連線的工作階段。
Void | Sleep(long timeout) | Timeout 以毫秒為單位的時間值。 | 讓 Xshell等候所指定的時間。
Void | LogFilePath(LPCTSTR lpszNewFilePath) | lpszNewFilePath 包含路徑的檔案名稱。 | 指定記錄檔案。
void | StartLog() |  | 開始執行有關工作階段的記錄。把記錄儲存到LogFilePath()所設成的路徑。若未指定記錄檔案路徑，則要使用預設路徑。
void | StopLog() |  | 停止記錄。

參數
名稱 | 類型 | 描述
Connected | BOOL | 目前工作階段是否在連線。
LocalAddress | BSTR | 匯入本機網址。
Path | BSTR | 匯入目前工作階段檔案的路徑。
RemoteAddress | BSTR | 匯入遠端網址。
RemotePort | long | 匯入遠端連接埠號碼。
Logging | BOOL | 確認目前工作階段是否在記錄。

See Also

指令碼 API


xsh.Screen

Xshell 4 Help / xsh.Screen
xsh.Screen

操作Xshell的終端機螢幕時就可以使用下列函數和參數。若要使用該函數和參數，則要與 xsh.Screen同時執行。例如，若要使用‘Clear()’函數，則要與‘xsh.Session.Clear()’同時使用。

Functions
傳回值 | 函數 | 參數 | 描述
void | Clear() |  | 清除終端機螢幕。
void | Send(LPCTSTR lpszStrToSend) | lpszStrToSend 使用者想要傳送的字串。 | 將訊息傳送到終端機。
BSTR | Get(long nBegRow, long nBegCol, long nEndRow, long nEndCol) | nBegRow 於終端機中列的起點。 nBegCol 於終端機中欄位的起點。 nEndRow 於終端機中列的終點。 nEndCol 於終端機中欄位的終點。 | 於終端機設定範圍的字串，而傳回此值。
void | WaitForString(LPCTSTR lpszString) | lpszString 將在終端機顯示的字串。 | 等後訊息。
Long | WaitForStrings(VARIANT FAR* strArray, long nTimeout) | strArray 將在終端機顯示的字串。 nTimeout 等候時間的毫秒值。 傳回值 發現到的字元數字。 | 等候訊息到發生超時之前為止。
void | Synchronous(BOOL bSync) | bSync 1(True): 執行螢幕同步處理。 0(False) : 未執行螢幕同步處理。 | 決定是否執行螢幕同步處理。

參數
名稱 | 類行 | 描述
CurrentColumn | long | 傳回目前的欄位。
CurrentRow | long | 傳回目前的列。
Columns | long | 傳回與終端機的寬度相同的欄位數。
Rows | long | 傳回與終端機的高度相同的列數。

See Also

指令碼 API


Script 例子

Xshell 4 Help / Script 例子
Script 例子

Script file

Sub Main

' *** Connect the session ***

xsh.Session.Open "ssh://192.168.1.17"

' "/s C:\Users\Administor\AppData\Roaming\NetSarang\Xshell\Sessions\example.xsh"

xsh.Screen.Synchronous = true

xsh.Screen.WaitForString "login: "

xsh.Screen.Send "username"

xsh.Screen.Send VbCr

xsh.Session.Sleep 100

xsh.Screen.WaitForString "Password: "

xsh.Screen.Send "password"

xsh.Screen.Send VbCr

xsh.Session.Sleep 100

' *** Wait for Prompt Message ***

xsh.Screen.WaitForString "username@password"

' *** Set File Format ***

Dim app, wb, ws

Set app = CreateObject("Excel.Application")

Set wb   = app.Workbooks.Add

set ws   = wb.Worksheets(1)

xsh.Session.LogFilePath = "c:\example.log"

xsh.Session.StartLog

Dim waitStrs

waitStrs = Array(Chr(10), "username@password")' make wait message as array

Dim row, screenrow, readline, itmes

row = 1

' *** Send Command ***

xsh.Screen.Send "cat /etc/passwd"

xsh.Screen.Send VbCr

xsh.Session.Sleep 100

Dim result

' *** Read Data and Save it as an EXCEL File ***

Do

While true

        result = xsh.Screen.WaitForStrings(waitStrs, 1000)

        If result = 2 Then

               Exit Do

        End If

        screenrow = xsh.Screen.CurrentRow - 1

        readline  = xsh.Screen.Get(screenrow, 1, screenrow, 40)

        items     = Split(readline, ":", -1)

        ws.Cells(row,1).Value = items(0)

        ws.Cells(row,2).Value = items(2)

        row = row + 1

Wend

Loop

wb.SaveAs("C:\chart.xls")                    ' save file path

wb.Close

app.Quit

Set ws  = nothing

Set wb  = nothing

Set app = nothing

xsh.Screen.Synchronous = false

xsh.Session.StopLog

End Sub

See Also

指令碼 API


參考

Xshell 4 Help / 參考
參考

該部分包含有關Xshell使用的參考內容。

See Also

標準按鈕
網址列
Xshell 本機命令語
Xshell 命令行選項
SFTP 命令語
規則運算式
已定義的快速鍵


標準按鈕

Xshell 4 Help / 標準按鈕
標準按鈕

針對經常使用的工作和命令，Xshell會提供標準按鈕。

下列描述為標準按鈕相關的說明。

按鈕 | 名稱 | 描述
 | 新增 | 開啟新增工作階段內容對話方塊新增工作階段。
 | 開啟 | 開啟工作階段對話方塊。
 | 中斷連線 | 中斷目前工作階段的連線。
 | 重新連線 | 重新連線目前標籤的工作階段。
 | 內容 | 顯示目前工作階段的內容。若無法開啟工作階段，則會顯示預設工作階段的內容。
 | 複製 | 用剪貼簿複製所選取的範圍。
 | 貼上 | 貼上剪貼簿的內容。
 | 尋找 | 開啟尋找對話方塊。
 | 列印 | 開啟列印對話方塊。
 | 色彩配置 | 選取色彩配置。
 | 編碼 | 列出可使用為輸出語言的編碼。
 | 字型 | 列出可使用的字型和大小。還可變更目前啟用的工作階段的字型。若要變更各個工作階段的字型，則在工作階段內容對話方塊可選取該工作階段的字型。
toolbarnewterminal | 新增終端機 | 開啟新的Xshell 視窗。若連線時按一下該按鈕，則會用該工作階段的連線內容嘗試連線。
toolbarfiletransfer | 新增檔案傳輸 | 若已安裝Xftp™，就可以執行Xftp。若連線時按一下該按鈕，則會用該工作階段的連線內容開始新增檔案傳輸。若未安裝Xftp，則會開始Xshell本身的檔案傳輸工作階段。
 | 全螢幕 | 切換為全螢幕模式。若輸入 Alt+Enter，則會切換成一般視窗模式。
 | 鎖定螢幕 | 切換成鎖定螢幕。不會接收使用者輸入直到輸入密碼為止。
 | 按鍵對應 | 開啟使用者自訂的按鍵對應對話方塊。
 | 指令碼 | 啟用Xshell指令碼檔案。
 | 開始記錄 | 開始記錄。
 | 停止記錄 | 停止記錄。
cog | 選項 | 開啟選項對話方塊。
 | 使用者金鑰管理員 | 開啟使用者金鑰對話方塊。
 | 主機金鑰管理員 | 開啟主機金鑰對話方塊。
 | Xagent | 執行 Xagent 程式。
 | Xactivator | 執行 Xactivator 程式。
 | 說明 | 開啟Xshell說明。

See Also

參考


網址列

Xshell 4 Help / 網址列
網址列

網址列的語法如下:

        [protocol://][user[:password]@]hostname[:port][/]

可使用的通訊協定為ssh, sftp, telnet, rlogin及serial。預設通訊協定是指預設工作階段所選取的通訊協定。各個通訊協定的預設連接埠號碼定義如下:

  • ssh:            22
  • sftp:           22
  • telnet:         23
  • rlogin:         513
  • ftp:            21

可參考下列幾個例題。

例題 | 描述
foobar.com | 用於預設工作階段自訂的通訊協定和連接埠號碼連線到 foobar.com 。
ssh://kay@foobar.com/ | 用ssh 通訊協定連線到 foobar.com。使用者帳戶為 kay，並使用預設連接埠號碼。
ssh://kay@foobar.com:12345/ | 用ssh 通訊協定連線到foobar.com的12345號連接埠。使用者帳戶為 kay。
telnet://foobar.com/ | 用telnet 通訊協定連線到 foobar.com。未指定使用者帳戶，而會連線到23號預設連接埠。
rlogin://kay@foobar.com/ | 用rlogin通訊協定連線到 foobar.com。使用者帳戶為 kay，而會連線到 513號預設連接埠。
sftp://kay@foobar.com/ | 用sftp 通訊協定連線到 foobar.com。使用者帳戶為 kay，而會使用預設連接埠號碼。
ftp://foobar.com/test.zip | 用ftp 通訊協定連線到foobar.com並下載test.zip 。

See Also

參考


Xshell 本機命令語

Xshell 4 Help / Xshell 本機命令語
Xshell 本機命令語

針對熟知終端機環境的進階使用者，Xshell會提供本機命令語。

通常未連線到遠端主機時，Xshell提示會顯示在終端機螢幕上。連線到工作階段時，按下“Ctrl+Alt+]”就可以匯出本機提示。若要重新切換為遠端主機模式，則輸入“exit”或按下“Ctrl+D”即可。

可使用下列命令語。

命令語 | 描述
Help ? | 在終端機視窗顯示命令清單
New | 開啟新增工作階段內容
open [session] | 若已指定“session”則連線到該工作階段、若未指定則開啟工作階段對話方塊
edit [session] | 若已指定“session”則開啟該工作階段的工作階段內容對話方塊、若未指定則開啟預設工作階段的工作階段內容對話方塊
List | 顯示目前工作目錄中可使用的工作階段相關內容和目錄清單
Cd | 轉換目前工作目錄
Clear | 清除螢幕、網址列記錄、本地殼層命令提示的命令記錄
Exit Quit | 結束Xshell工作階段或回到遠端主機
ssh [user@]host [port] | 用ssh 通訊協定連線
sftp [user@]host [port] | 用sftp 通訊協定連線
telnet [user@]host [port] | 用telnet 通訊協定
rlogin [user@]host [port] | 用rlogin 通訊協定
ftp [user@]host [port] | 用ftp 通訊協定
ipconfig | 執行Windows的ipconfig命令
ping host | 執行Windows的ping命令
tracert host | 顯示連線到host的封包路徑。
Netstat | 執行Windows的netstat命令
Nslookup | 執行Windows的 nslookup 命令

See Also

參考


Xshell 命令行選項

Xshell 4 Help / Xshell 命令行選項
Xshell 命令行選項

是指Xshell可識別的命令行參數選項。這些參數可以從Windows控制台程序或其他應用程序執行時使用。

選項, 參數 | 描述
“工作階段檔案” | 執行該工作階段。“工作階段檔案”可包含路徑。
-folder “工作階段資料夾” | 執行該資料夾的所有工作階段。
-url [protocol://][user[:password]@]host[:port] | 不使用已儲存的工作階段檔案，而直接輸入 URL連線。可使用的通訊協定為 SSH, SFTP, TELNET, RLOGIN 及 FTP。 若要省略通訊協定，則要使用選項對話方塊的 [一般] 標籤所指定的預設通訊協定。 若省略使用者(user), 密碼(password)，則會顯示驗證視窗。 若未指定連線連接埠(port)，則會使用連線通訊協定的預設連接埠。
-open | 開啟工作階段對話方塊。
-register | 開啟相關的對話方塊註冊產品。
-about | 開啟可查明產品的版本、使用權內容等的Xshell內容對話方塊。
-prop “工作階段檔案” | 開啟該工作階段的工作階段內容對話方塊。“工作階段檔案”會包含路徑。
-create “工作階段檔案” | 新增工作階段。
-folder “工作階段資料夾” | 執行所有“工作階段資料夾”裡的工作階段。
-newwin | 開啟新的Xshell視窗。
-newtab “標籤名稱” | 用“標籤名稱”新增標籤。

例題:

Xshell “c:\users\zoo\AppData\Roaming\NetSarang\Xshell\Sessions\xdev.xsh”

執行xdev.xsh 工作階段檔案。

Xshell -url foobar.com

用預設通訊協定連線到foobar.com。

Xshell -url ssh://foobar.com

用ssh連線到foobar.com。

Xshell –url ssh://test:testpasswd@foobar.com

用ssh連線到foobar.com。使用者名稱和密碼分別為“test”和“testpasswd” 。

Xshell –url telnet://foobar.com:2300 foobar.com

用telnet 通訊協定和2300號連接埠連線到

Xshell -newwin -url foobar.com

執行新的xshell 視窗連線到foobar.com。而不使用現有視窗的工作階段標籤。

* 參考

除了“-newwin”選項之外的所有選項，若於選項對話方塊的 [進階] 標籤中開啟[在單行Xshell視窗上開啟多份工作階段]，則要執行最後一個Xshell 視窗。或者用標籤執行工作階段。“-newwin”選項可與其他選項同時使用，還可以用該選項執行新的Xshell視窗。

See Also

參考


SFTP 命令語

Xshell 4 Help / SFTP 命令語
SFTP 命令語

針對熟知終端機環境的進階使用者，Xshell會提供與 UNIX/Linux的 FTP類似的命令語。各個命令語的描述如下，若要更詳細的使用方法，請到SFTP 提示並透過 help 命令確認。

命令語 | 描述
getfile1 [file2] [file3] … | 將遠端主機的指定檔案匯入到本機主機。
putfile1 [file2] [file3] … | 將本機主機的指定檔案傳輸到遠端主機。
mv path1path2 renamepath1path2 | 將特定檔案或目錄移至其他路徑或者變更名稱。
mkdirdirectory | 在遠端主機建立指定的目錄。
rmdir directory | 將於遠端主機指定的目錄刪除。
rmfile | 將於遠端主機指定的檔案刪除。
pwd | 顯示遠端主機的工作目錄。
lpwd | 顯示本機主機的工作目錄。
cddirectory | 變更遠端主機的工作目錄。
lcddirectory | 變更本機主機的工作目錄。
ls [directory] | 顯示遠端主機的檔案目錄。
lls[directory] | 顯示本機主機的檔案目錄。
explore [directory] | 透過Windows 檔案總管閱覽目前 (或者已指定的) 目錄。
help [command] | 顯示SFTP 命令語目錄或指定命令語的使用方法。
bye exit quit | 結束SFTP 連線。

See Also

參考


規則運算式

Xshell 4 Help / 規則運算式
規則運算式

該部分會描述尋找對話方塊所使用的規則運算式。

See Also

參考
模式對應
字元組合的縮簡
POSIX 字元組合
例題


模式對應

Xshell 4 Help / 模式對應
模式對應
模式 | 描述
. | 新行字元以外的一個字元
[abc] | a, b, c 中一個字元
[a-z] | 屬於a至z之間的一個字元
[^ac] | a和 c以外的一個字元
(x) | x, 這時 x可能是規則運算式
x* | 0次以上重複x , 這時 x可能是規則運算式
x+ | 1次以上重複x, 這時 x可能是規則運算式
x{n,m} | ｎ次以上但ｍ次以下重複x, 這時 x可能是規則運算式
x{n} | 剛好n次重複x, 這時 x可能是規則運算式
x{n,} | ｎ次以上重複x, 這時 x可能是規則運算式
x|y | x 或者 y, 這時 x, y可能是規則運算式
xy | xy, 這時 x, y可能是規則運算式
^ | 行的起點
\A | 行的起點
$ | 行的終點
\z | 行的終點
\Z | 行的終點
\< | 字組的開始
\b | 字組的開始
\> | 字組的結束
\B | 字組的結束

See Also

規則運算式


字元組合的縮簡

Xshell 4 Help / 字元組合的縮簡
字元組合的縮簡
類別 | 描述
\w | 組成字組的字元, 與[a-zA-Z0-9_]相同
\W | 未組成字組的字元, 與[^a-zA-Z0-9_]相同
\s | 空白字元
\S | 空白字元以外的字元
\d | 數字,與[0-9]相同
\D | 數字以外的字元,與[^0-9]相同

See Also

規則運算式


POSIX 字元組合

Xshell 4 Help / POSIX 字元組合
POSIX 字元組合
類別 | 描述
[:alnum:] | 英文字母和數字,與[a-zA-Z0-9]相同
[:alpha:] | 英文字母,與[a-zA-Z]相同
[:blank:] | 空白字元
[:cntrl:] | 控制字元
[:digit:] | 數字,與[0-9]相同
[:graph:] | 可輸出的字元 (空白字元以外)
[:lower:] | 小寫,與[a-z]相同
[:print:] | 控制字元以外的字元
[:punct:] | 標點符號
[:space:] | 空白字元
[:upper:] | 大寫,與[A-Z]相同
[:xdigit:] | 顯示16進位數時使用的字元,與[0-9a-fA-F]相同

See Also

規則運算式


例題

Xshell 4 Help / 例題
例題
正規表現式 | 描述
[0-9]+ | 1次以上重複數字的模式
(foo)|(bar) | "foo" 或者 "bar"
\.html$ | 以".html"結束的字串
^\. | 以"." 開始的字串

See Also

規則運算式


已定義的快速鍵

Xshell 4 Help / 已定義的快速鍵
已定義的快速鍵

下列目錄會描述於Xshell已定義的快速鍵。

快速鍵 | 描述
Alt + N | 與新增檔案清單相同
Alt + O | 與開啟檔案清單相同
Alt + C | 與中斷連線檔案清單相同
Alt + Enter | 切換為全螢幕模式
Alt + D | 將鍵盤焦距移至網址列
Alt + L | 變更版面配置
Alt + 1~9 | 移動工作階段標籤
Alt + Right | 與視窗清單中下一個相同
Alt + Left | 與視窗清單中上一個相同
Ctrl + D | 在本機提示結束本地殼層
Ctrl + Alt + ] | 連線中匯出到本機提示
Ctrl + Alt + T | 與視窗清單中新增終端機相同
Ctrl + Alt + F | 與視窗清單中新增檔案傳輸相同
Ctrl + Tab | 從一個Xshell視窗移至下一個工作階段
Shift + Tab | 從一個Xshell視窗移至最近使用的工作階段
Shift + Home | 最上方
Shift + End | 最下方
Shift + PgUp | 向上翻頁
Shift + PgDn | 向下翻頁
Shift + Up Arrow | 向上捲動
Shift + Down Arrow | 向下捲動

* 參考

若要變更功能表的快速鍵，則利用按鍵對應功能。在使用者自訂按鍵對應對話方塊，使用者就可以變更快速鍵的按鍵組合。還可以把功能表、傳輸字串、執行指令碼、執行程式等動作配置到按鍵組合。

See Also

參考